Безопасный режим server 2020: Как загрузить Windows в Безопасном режиме? (Safe Mode)

Содержание

Как загрузить Windows в Безопасном режиме? (Safe Mode)

  • Внимание. Восстановление баз 1С7, 1C8 и Mssql после атаки шифровальщика, подробности и отзывы читайте в профильной теме.

JavaScript отключён. Чтобы полноценно использовать наш сайт, включите JavaScript в своём браузере.

Вы используете устаревший браузер. Этот и другие сайты могут отображаться в нём некорректно.
Вам необходимо обновить браузер или попробовать использовать другой.
Статус
В этой теме нельзя размещать новые ответы.
akok

Команда форума

Администратор

Способ №1

  1. Извлеките все гибкие диски, компакт-диски и DVD-диски, отключите внешние накопители.
  2. Перезагрузите или включите компьютер.
  3. До появления эмблемы загрузки Windows, нажмите на клавишу «
    F8
    «, чтобы на экране появилось меню дополнительных вариантов загрузки. Если вы не успели нажать клавишу «F8» и уже появился логотип Windows, то нужно дождаться появления приглашения Windows для входа в систему, завершить работу и перезагрузить компьютер.
  4. Теперь передвигаемся с помощью клавиш вверх/вниз и, остановившись на надписи «Safe Mode«(Безопасный режим), нажимаем клавишу «Enter» для начала загрузки.
  5. Для загрузки вашего компьютера в Обычном режиме перезагрузите компьютер.

 

Последнее редактирование модератором:

akok

Команда форума

Администратор

Способ №2


Внимание!!! В случае повреждения настроек безопасного режима, например вредоносными программами, загрузка в нормальном режиме будет невозможна, восстановить загрузку в нормальном режиме можно только при использовании средств восстановления (Консоль восстановления, Среда восстановления, LiveCD). Используйте данный метод только в случаях уверенности, что настройки безопасного режима не повреждены.
  1. Закройте все программы.
  2. Нажмите Пуск, потом выберите Выполнить или вызовите данное окно сочетанием клавиш Win-R
  3. Набирете команду msconfig в окне.
  4. Нажмите кнопку OK, запустится Настройка системы.
  5. Перейдите на вкладку «BOOT.INI«. (Или Загрузка в новых ОС) ​
  6. Поставьте отметку возле Парметра загрузки «SAFEBOOT» (Или Безопасный режим в новых ОС). После этого нажмите кнопку OK.

  7. Система отобразит сообщение, в котором говорится, что изменения вступят после перезагрузки. Нажмите кнопку Перезагрузка.
  8. После этого компьютер перезагрузится в Безопасном режиме.
  9. После того, как вы выполните все необходимые вам действия в Безопасном режиме повторите п.2-7, только в п.6 снимите галочку с пункта «/SAFEBOOT» (Безопасный режим) на вкладке «BOOT.INI» (Загрузка), вернитесь на вкладку «Общее» и поставьте отметку на пункте Обычный запуск — загрузка всех драйверов и запуск всех служб
    . Нажмите ОК, затем Перезагрузка
  10. После перезагрузки ваш компьютер загрузится в Обычном режиме.

 

Severnyj

Команда форума

Супер-Модератор

Ассоциация VN/VIP

Способ №3​


Внимание!!! В случае повреждения настроек безопасного режима, например вредоносными программами, загрузка в нормальном режиме будет невозможна, восстановить загрузку в нормальном режиме можно только при использовании средств восстановления (Консоль восстановления, Среда восстановления, LiveCD). Используйте данный метод только в случаях уверенности, что настройки безопасного режима не повреждены.

Внимание!!! Данный метод может использоваться только для ОС, загрузчик которых использует файл

boot.ini

  1. Включите с Свойствах папок отображение скрытых и системных файлов.
  2. Найдите в корне системного диска файл boot.ini, например C:\boot.ini
  3. Сделайте резервную копию данного файла
  4. Откройте данный файл в блокноте и отредактируйте следующим образом (изменения выделены голубым полужирным шрифтом):

    Было:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=»Microsoft Windows XP Professional» /fastdetect


    Стало:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]

    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=»Microsoft Windows XP Professional» /fastdetect /safeboot:minimal

  5. Сохраните изменения и перезагрузите компьютер.
  6. После перезагрузки системы будет загружена в Безопасном режиме.
  7. Для возврата в Нормальный режим восстановите файл boot.ini из резервной копии и перезагрузите компьютер.

 

Последнее редактирование:

Severnyj

Команда форума

Супер-Модератор

Ассоциация VN/VIP

Как перезагрузить Windows 8 в безопасном режиме
  1. На экране выбора пользователей и ввода пароля, либо в Правом боковом меню нажмите клавишу выключения компьютера с зажатой на клавиатуре клавишей Shift и выберите пункт Перезагрузка
  2. На следующем экране выбираем пункт Диагностика
  3. На следующем экране выбираем пункт Дополнительные параметры
  4. На следующем экране выбираем пункт Параметры загрузки
  5. На следующем экране нажмите кнопку Перезагрузить
  6. После перезагрузки на экране меню параметров загрузки выберите соответствеющий пункт, в нашем случае — это 4) Включить безопасный режим — соответственно нажимаем клавишу F4. (Или F5, если хелпер попросил проверить работу сети в безопасном режиме)
  7. После нажатия соответствующей клавиши, система загрузится в Безопасном режиме, для возврата в нормальный режим просто перезагрузите компьютер.

Также загрузить Windows 8 в Безопасном режиме можно Способом №2, описанным выше в этой теме.

Ссылки по теме:

 

Последнее редактирование модератором:

Severnyj

Команда форума

Супер-Модератор

Ассоциация VN/VIP

Как запустить Windows 10 в безопасном режиме?
  1. Выберите в меню Пуск значок Параметры

  2. Нажмите на значок Обновление и безопасность
  3. Выберите пункт меню Восстановление и нажмите кнопку Перезагрузить сейчас
  4. Выберите пункт Поиск и устранение неисправностей
  5. На следующем экране выберите Дополнительные параметры
  6. На следующем экране выберите Параметры загрузки
  7. На следующем экране нажмите кнопку Перезагрузить
  8. После перезагрузки на экране меню параметров загрузки выберите соответствующий пункт, в нашем случае — это 4) Включить безопасный режим — соответственно нажимаем клавишу F4. (Или F5, если хелпер попросил проверить работу сети в безопасном режиме)
  9. После нажатия соответствующей клавиши, система загрузится в Безопасном режиме, для возврата в нормальный режим просто перезагрузите компьютер.

Также загрузить Windows 10 в Безопасном режиме можно Способом №2, описанным выше в этой теме.

 

Последнее редактирование модератором:

akok

Команда форума

Администратор

Windows 10


С раздела «Параметры»
  1. Нажмите сочетание клавиш Клавиша Windows Win+I на клавиатуре, чтобы открыть раздел «Параметры«. Если это не сработает, нажмите кнопку «
    Пуск
    » в левом нижнем углу экрана, затем выберите Параметры.
  2. Выберите Обновление и безопасность > Восстановление.
  3. В разделе Особые варианты загрузки выберите Перезагрузить сейчас.
  4. После перезагрузки компьютера на экране Выберите параметр выберите элементы Диагностика > Дополнительные параметры > Параметры загрузки > Перезапуск.
  5. После перезагрузки компьютера вы увидите список параметров. Нажмите клавиши 4 или F4, чтобы запустить компьютер в Безопасном режиме. Если вам будет нужен Интернет, выберите клавиши 5 или F5, чтобы войти в Безопасный режим с загрузкой сетевых драйверов.
С экрана входа
  1. Перезапустите компьютер. На экране входа удерживайте клавишу
    SHIFT
    , а затем выберите элементы Завершение работы Значок питания > Перезагрузка.
  2. После перезагрузки компьютера на экране Выберите параметр выберите элементы Диагностика > Дополнительные параметры > Параметры загрузки > Перезапуск.
  3. После перезагрузки компьютера вы увидите список параметров. Нажмите клавиши 4 или F4, чтобы запустить компьютер в Безопасном режиме. Если вам будет нужен Интернет, выберите клавиши 5 или F5, чтобы войти в Безопасный режим с загрузкой сетевых драйверов.
Sandor

 

Последнее редактирование:

Статус
В этой теме нельзя размещать новые ответы.

Как отключить безопасный режим Windows 10

Реклама

&nbsp windows | для начинающих

Некоторые пользователи сталкиваются с тем, что Windows 10 всегда запускается в безопасном режиме и здесь естественным будет желание выключить загрузку в безопасном режиме при входе в систему.

В этой инструкции 2 способа отключить безопасный режим загрузки Windows 10, если компьютер или ноутбук постоянно входит в него.

Отключение безопасного режима Windows 10 с помощью msconfig

Чаще всего проблема с постоянной загрузкой Windows 10 в безопасном режиме возникает после того, как пользователь включил его с помощью изменения параметров загрузки в утилите «Конфигурация системы» (msconfig, как описано в 5 способов запустить безопасный режим Windows 10). В этом случае и отключить его можно тем же способом:

  1. Нажмите клавиши Win+R на клавиатуре (Win — клавиша с эмблемой Windows), введите msconfig в окно «Выполнить» и нажмите Enter.
  2. В открывшемся окне перейдите на вкладку «Загрузка».
  3. Снимите отметку «Безопасный режим».
  4. Нажмите «Ок» и перезагрузите компьютер. Выполните это через Пуск — Кнопка питания — Перезагрузка (но не через Завершение работы и повторное включение, это может играть роль).

После этих простых действий Windows 10 должна перезагрузиться в обычном режиме, а безопасный режим сам по себе включаться не будет.

Однако, иногда оказывается так, что при входе в msconfig отметка «Безопасный режим» снята, тем не менее Windows 10 при каждой загрузке все равно запускается в безопасном режиме. В этом случае может помочь следующий метод.

Как выключить запуск в безопасном режиме с помощью командной строки и bcdedit.exe

Если предыдущий метод не сработал, попробуйте следующие шаги для отключения безопасного режима:

  1. Запустите командную строку от имени администратора: в Windows 10 для этого можно использовать поиск на панели задач — начните вводить «Командная строка», нажмите правой кнопкой мыши по найденному результату и выберите пункт «Запустить от имени администратора». Также можно нажать клавиши Win+R, ввести cmd и нажать Enter (при условии, что внизу окна будет указано «Это задание будет создано с правами администратора).
  2. В командной строке введите следующую команду:
    bcdedit /deletevalue {default} safeboot
    и нажмите Enter.
  3. Если по какой-то причине указанная команда не сработает, попробуйте следующий вариант этой же команды:
    bcdedit /deletevalue {current} safeboot
  4. Перезагрузите компьютер, используйте именно пункт «Перезагрузка» в меню Пуск.

После перезагрузки Windows 10 должна будет загрузиться в обычном рабочем режиме.

Видео инструкция

В случае, если после выполнения описанных выше шагов у вас остались вопросы, задавайте их в комментариях, я постараюсь помочь и подсказать решение.

А вдруг и это будет интересно:

Как попасть в безопасный режим Window 10, за минуту

Как попасть в безопасный режим Window 10-01

Всем привет сегодня хочу рассказать как попасть в безопасный режим Window 10. В безопасном режиме запуск Windows выполняется с использованием ограниченного набора файлов и драйверов. В безопасном режиме не производится запуск программ, загружаемых при запуске, и устанавливается только базовый набор драйверов, необходимый для запуска Windows, за счет этого, вы в большинстве случаев имеете возможность произвести ремонт операционной системы, будь то откат версии драйвера или лечение трояна.

Ранее я уже рассказывал Как попасть в безопасный режим Window 7 и Как попасть в безопасный режим в Windows 8/8.1 с выходом новой Windows 10 так же есть возможность попадания в данный режим. Существует уже как минимум 4 способа попадания в безопасный режим.

Как попасть в безопасный режим Window 10 с помощью msconfig

Открываем меню выполнить нажатием Win+R и вводим msconfig.

Как попасть в безопасный режим Window 10-02

Переходим на вкладку Загрузка и ставим галку Безопасный режим.

Как попасть в безопасный режим Window 10-03

перезагружаемся

Как попасть в безопасный режим Window 10-04

В результате мы в него попали и сможем произвести восстановление windows или вылечить его от вирусов.

Как попасть в безопасный режим Window 10 через меню пуск

Для этого открываем пуск и зажимаем кнопку Shift, щелкаем правым кликом по завершение работы и жмем перезагрузка.

В итоге после перезагрузки вы попадете в дополнительное меню загрузки. В окне выбора действий жмем Диагностика.

Далее Дополнительные параметры

Параметры загрузки

Перезагрузить

вы попадете в параметры загрузки, где с 4 пункта можно выбрать то что вам нужно.

Как попасть в безопасный режим Window 10 через параметры

Открываем пуск и щелкаем параметры

Выбираем стрелку снизу

Переходим в пункт Восстановление и жмем перезагрузка

перезагружаемся и попадаем в Меню выбор действий.

Как попасть в безопасный режим Window 10 через 

bcdedit

И, наконец, если не удается попасть даже на экран входа в систему, то есть и еще один способ, но вам потребуется загрузочная флешка или диск с Windows 10 (которые можно легко создать на другом компьютере). Загрузитесь с такого накопителя, а затем либо нажмите клавиши Shift + F10 (это откроет командную строку), либо после выбора языка, в окне с кнопкой «Установить» нажмите «Восстановление системы», затем Диагностика — Дополнительные параметры — Командная строка.

В командной строке введите (безопасный режим будет применен к ОС, загружаемой на вашем компьютере по умолчанию, на случай, если таких систем несколько):

  • bcdedit /set {default} safeboot minimal — для следующей загрузки в безопасном режиме.
  • bcdedit /set {default} safeboot network — для безопасного режима с поддержкой сети.

Если требуется запуск безопасного режима с поддержкой командной строки, используйте сначала первую из перечисленных выше команд, а затем: bcdedit /set {default} safebootalternateshell yes

После выполнения команд, закройте командную строку и перезагрузите компьютер, он автоматически загрузится в безопасном режиме.

В дальнейшем, чтобы включить обычный запуск компьютера, используйте в командной строке, запущенной от имени администратора (или же способом, описанным выше) команду: bcdedit /deletevalue {default} safeboot

Еще один вариант, но запускающий не сразу безопасный режим, а различные варианты загрузки, из которых можно выбрать, при этом применяет это ко всем совместимым ОС, установленным на компьютере. Запустите командную строку с диска восстановления или загрузочной флешки Windows 10, как это уже было описано, затем введите команду:

bcdedit /set {globalsettings} advancedoptions true

В дальнейшем, чтобы отключить особые варианты загрузки, используйте команду (можно из самой системы, используя командную строку от имени администратора):

bcdedit /deletevalue {globalsettings} advancedoptions

Вот так вот просто загрузиться в безопасной режиме Window 10.

Материал сайта pyatilistnik.org

Восстанавливаем Active Directory

Пока работает служба каталогов восстановить данные Active Directory на контроллере домена невозможно. Поэтому для восстановления Active Directory следует выполнить следующие действия.

  1.  Перезагрузите компьютер.

  2.  В загрузочном меню выберите Windows Server. Не нажимайте клавишу <Enter> и вместо нее нажмите клавишу <F8> для получения доступа к дополнительным параметрам загрузки:

OS Loader V5.0

Windows Server Advanced Options Menu
Please select an option:

Safe Mode
Safe Mode with Networking
Safe Mode with Command Prompt

Enable VGA Logging
Enable VGA Mode
Last Good Known Configuration
Directory Services Restore Mode (Windows NT domain controllers only)
Debugging mode

Use | and | to move the highlight to your choice.
Press Enter to choose.

  3.  Выберите вариант восстановления службы каталогов Directory Services Restore Mode (Windows Domain Controllers Only).

  4.  Нажмите клавишу <Enter>.

  5.  После возврата в загрузочное меню Windows Server нажмите клавишу <Enter>. В нижней части экрана красным цветом будет выделена строка “Directory Services Restore Mode (Windows Domain Controllers Only)”.

Затем система загрузится в специальный безопасный режим без запуска службы каталогов. Обратите внимание, что система не будет выполнять роль контроллера домена и такие функции, как аутентификация пользователей.

  1.  Откройте программу Архивация данных (Windows Backup).

  2.  Перескочите на вкладку Восстановление (Restore).

  3.  Укажите носитель с архивной копией и выберите команду Состояние системы (System State).

  4.  Кликните на кнопке Восстановить (Start Restore).

  5.  Кликните на кнопке OK.

После восстановления архивной копии перезагрузите компьютер в нормальном режиме работы, что позволит воспользоваться восстановленными данными. По завершению процесса восстановления компьютер может стать временно неработоспособным, причем некоторым системам требовалось до 30-ти минут для завершения процесса восстановления Active Directory.

Как загрузиться в безопасном режиме в Windows 8 или 10

Одним из наиболее распространенных шагов при устранении неполадок ПК является загрузка в безопасном режиме. Долгое время это можно было сделать нажатием клавиши F8, но все изменилось в Windows 8 и в режиме автоматического восстановления.

Тем не менее, Вы все равно можете войти в безопасный режим, он спрятан глубоко в опциях восстановления Windows 8 или 10. В то время как просто нажатие клавиши F8, как мы все знаем, загрузит Вас в автоматический режим восстановления, Вы все же можете вручную получить доступ к вариантам восстановления, нажав комбинацию клавиш Shift + F8. Этого можно добиться еще проще, просто удерживайте клавишу SHIFT и нажмите «Перезагрузка» на экране входа в систему или даже в Windows.

Примечание: Все это должно работать точно и в Windows 10 и в Windows 8.

Загрузка в безопасном режиме в Windows 8 или 10

Существует несколько способов войти в безопасный режим, и эти способы зависят от того, можете ли Вы загрузить компьютер или можете ли Вы войти в компьютер. Первый — самый простой.

Если Ваш компьютер загружается до экрана входа в систему
Если Вы можете загрузить ПК до экрана входа в систему, то можете удерживая клавишу SHIFT, нажать кнопку «Перезагрузка», чтобы перейти к экрану параметров устранения неполадок, где Вы можете включить безопасный режим. Продолжайте читать чтобы узнать подробнее.

Если Ваш компьютер не загружается, а у вас есть флэш-накопитель для восстановления
Если у вас есть доступ к другому компьютеру с той же версией Windows, то Вы можете создать USB-накопитель и загрузить компьютер с него, который откроет перед вами экраны восстановления и предоставит доступ к безопасному режиму (см. Раздел расширенных инструментов устранения неполадок ниже).

Если Вы не можете загрузиться до экрана входа в систему
Когда Ваш компьютер не может загрузиться до экрана входа в систему, то обычно показывается экран восстановления. Если Вы не видите этот экран, то можете попытаться удерживая клавишу SHIFT нажимать на клавишу F8, которая может загрузить Вас в новый расширенный «Режим восстановления», где Вы можете нажать кнопку дополнительных параметров восстановления.

Единственная проблема заключается в том, что многие ПК не позволяют это делать, особенно новые ПК.

Продолжайте читать следующий раздел.

Использование расширенных инструментов устранения неполадок для включения безопасного режима
Как только Вы перейдете на экран устранения неполадок, либо используя SHIFT + Перезагрузка на экране входа в систему, либо путем нажатия клавиши F8, используя флеш-накопитель для восстановления системы или просто нажав расширенные параметры восстановления, Вы будете на экране, где сможете выбрать Устранение неполадок на вашем ПК.

Вам нужно будет нажать кнопку «Диагностика».


Теперь выберите «Дополнительные параметры».


Теперь выберите параметр «Параметры загрузки».


Наконец нажмите кнопку «Перезагрузить».


Когда Ваш компьютер будет перезагружаться, Вы сможете загрузиться в безопасном режим на знакомом экране «Параметры загрузки».

Переход в безопасный режим из Windows 8 или 10

Есть второй вариант, однако он требует, чтобы Windows уже была загружена. Нажмите комбинацию клавиш Win + R и введите msconfig в поле запуска и нажмите Enter.


Перейдите на вкладку «Загрузка» и установите флажок «Безопасная загрузка».


Вы также можете выбрать тип безопасного режима, в котором хотите загрузиться:

  • Минимальная — нормальный безопасный режим.
  • Другая оболочка — безопасный режим с командной строкой.
  • Сеть — безопасный режим с сетью.

Параметр Active Directory относится к восстановлению сервера, который является контроллером домена для Вашей сети. После того, как Вы выбрали подходящий вариант, нажмите кнопку «ОК» и перезагрузите компьютер.


Вы автоматически загрузитесь в безопасном режиме.


Если Вы перезагрузите компьютер, то загрузитесь в безопасном режиме, чтобы отключить его снова запустите msconfig и снимите флажок «Безопасная загрузка», затем нажмите кнопку «ОК».


Наконец, перезагрузите компьютер.


Вот и все.

Записки IT-специалиста — ЖЖ

01:28 26.04.2020
Настраиваем IKEv2 VPN-сервер на роутерах Mikrotik с аутентификацией по сертификатам

Сейчас, когда многие настраивают VPN для работы удаленных сотрудников, выбор протокола становится как никогда актуальным. С одной стороны стоят поддерживаемые современными ОС протоколы PPTP и L2TP, которые имеют ряд существенных недостатков и ограничений, с другой OpenVPN, который всем хорош, но требует установки стороннего ПО. При этом как-то забывают о быстром и безопасном IKEv2, основанном на IPsec новом протоколе, также поддерживаемом всеми современными ОС.

Почему именно IKEv2? Данный протокол входит в группу протоколов IPsec и обеспечивает высокий уровень безопасности, включая аутентификацию клиента с использованием сертификата, а также проверку подлинности сервера клиентом, что исключает атаки типа «человек посередине». При поддержке аппаратного ускорения IPsec со стороны оборудования показывает хорошую скорость соединения относительно других типов VPN в RouterOS и весьма прост в настройке с клиентской стороны, не требует добавления маршрутов.

К недостаткам можно отнести достаточную сложность настройки серверной части, которая требует выполнения определенных условий и наличия базового объема знаний о работе IPsec. В данной статье мы не будем углубляться в теорию, сделав упор на практическую сторону вопроса, ограничившись краткими пояснениями необходимости тех или иных настроек.

Создание центра сертификации и выпуск сертификатов

Когда мы говорим об использовании сертификатов для аутентификации, то подразумеваем наличие инфраструктуры открытых ключей (PKI), образующей область доверия, за счет чего появляется возможность проверки подлинности любого субъекта инфраструктуры без привлечения третьих служб и списков пользователей. В основе PKI лежит центр сертификации — CA, выпускающий сертификаты и дающий возможность убедиться в их подлинности при помощи корневого публичного сертификата.

В нашем случае центр сертификации будет создан средствами RouterOS прямо на маршрутизаторе. Для этого перейдем в System — Certificate и выпустим корневой сертификат нашего CA.

Красным указаны обязательные к заполнению поля. Name — видимое имя сертификата и Common Name — имя субъекта, которому выдан сертификат, в нашем случае это ca. Key Size — размер ключа, ключи размером менее 2048 байт не считаются безопасными, Days Valid — время действия сертификата, в нашем случае 10 лет.

Выделенный зеленым блок не является обязательным, но мы советуем его заполнять, дабы в дальнейшем не пришлось угадывать, что это за сертификат и кому и кем он выдан.

Затем перейдем на закладку Key Usage и оставим только crl sign и key cert. sign, затем нажмем Apply, чтобы применить изменения, после чего подпишем сертификат. нажав кнопку Sign, в открывшемся окне укажем CA CRL Host, в качестве которого следует использовать один из IP-адресов роутера.

В терминале эти же действия можно выполнить командой:

/certificate 
add name=ca country="RU" state="31" locality="BEL" organization="Interface LLC" common-name="ca" key-size=2048 days-valid=3650 key-usage=crl-sign,key-cert-sign
sign ca ca-crl-host=192.168.103.1

Следующим шагом выпустим сертификат сервера. Обратите внимание, что сервер обязательно должен иметь выделенный IP адрес и, желательно, доменное имя. Последнее условие не является обязательным, но предпочтительно, так как позволит отвязаться от использования адреса и в случае изменения IP вам не придется перевыпускать сертификаты и менять настройки клиентских подключений.

Заполнение полей в целом повторяет предыдущий пример, за исключением Common Name и Subject Alt. Name. Здесь мы указываем IP-адрес или FQDN по которому клиенты будут подключаться к серверу. Если вы используете IP-адрес, то тип записи в поле Subject Alt. Name нужно сменить на IP.

Обратите внимание, если вы выпустили сертификат с указанием FQDN, а подключить клиента попытаетесь по IP-адресу, либо наоборот, то такое соединение окажется невозможным.

На закладке Key Usage укажем единственное значение tls server и подпишем наш сертификат закрытым ключом центра сертификации CA.

Эти же действия в терминале:

/certificate 
add name=vpn.interface31.lab country="RU" state="31" locality="BEL" organization="Interface LLC" common-name="vpn.interface31.lab" subject-alt-name=DNS:"vpn.interface31.lab" key-size=2048 days-valid=3650 key-usage=tls-server
sign vpn.interface31.lab ca="ca"

Теперь можно выпускать клиентские сертификаты, это можно сделать как сразу, так и потом. Никаких особых требований здесь нет, в качестве имени указывайте максимально понятное значение, скажем, ФИО сотрудника или наименование офиса. Потому как понять кому принадлежит сертификат с CN IvanovIA не составит особого труда, в отличие от какого-нибудь безликого client3. Также обратите внимание на опцию Days Valid, не следует выдавать клиентские сертификаты на большой срок.

В Key Usage также указываем единственное назначение сертификата — tls client и подписываем его закрытым ключом CA.

Команды для терминала:

/certificate 
add name=SmirnovaMV country="RU" state="31" locality="BEL" organization="Interface LLC" common-name="SmirnovaMV" key-size=2048 days-valid=365 key-usage=tls-client
sign SmirnovaMV ca="ca"

Для использования на клиентских устройствах сертификаты следует экспортировать, наиболее удобно использовать для этого формат PKCS12, который в одном файле содержит закрытый ключ клиента, его сертификат и корневой сертификат CA. Для этого выберите сертификат в списке и в меню правой кнопки мыши укажите действие Export. В поле Type укажите PKCS12, а в Export Passphrase следует указать пароль (не менее 8 символов), в противном случае закрытый ключ выгружен не будет.

Это же можно сделать командой:

/certificate
export-certificate SmirnovaMV type=pkcs12 export-passphrase=0123456789

Скачать экспортированные сертификаты можно из раздела Files.

Настройка IKEv2 VPN-сервера

Здесь мы вступаем в достаточно сложную область настройки IPsec, объем статьи не позволяет подробно останавливаться на назначении каждой настройки, поэтому если вы не уверены в своих действиях, то мы не рекомендуем отклоняться от указанных ниже настроек.

Перейдем в IP — IPsec — Profiles и создадим новый профиль, который задает параметры для установления соединения. Все параметры оставляем по умолчанию, кроме наименования, которому следует дать осмысленное имя.

Либо выполните команду в терминале:

/ip ipsec profile
add name=IKEv2

Затем перейдем на закладку Proposals — предложения, который содержит параметры криптографии предлагаемые для соглассования подключающимся клиентам. Создадим новое предложение, которое сформировано с учетом используемых современными ОС алгоритмов и изменение его состава может либо ослабить безопасность, либо сделать подключение некоторых клиентов невозможным.

Параметры по умолчанию нам не подойдут, поэтому в блоке Encr. Algorithms убираем 3des и добавляем aes-128-cbc, aes-192-cbc, aes-256-cbc.

В терминале достаточно простой команды:

/ip ipsec proposal
add name=IKEv2 pfs-group=none

Здесь мы сталкиваемся с одной особенностью: создаваемые через терминал и Winbox предложения содержат различный набор параметров. То, что создается в терминале полностью соответствует приведенным выше на скриншоте требованиям.

Для выдачи VPN-клиентам нам потребуется отдельный диапазон адресов, перейдем в IP — Pool и создадим новый пул, в нашем случае будет использован диапазон адресов 10.20.0.100 — 10.20.0.199:

Снова вернемся к настройкам IPsec и создадим конфигурацию, передаваемую клиенту для настройки его сетевых параметров, для этого перейдем на в IP — IPsec — Mode Configs. При создании новой конфигурации установим флаг Responder, в поле Address Pool укажем имя созданного нами пула, в поле Address Prefix Lenght укажем префикс адреса — 32, поле Split Include указываем подсети, запросы к которым следует направлять в туннель, здесь следует указать одну или несколько внутренних сетей, доступ к которым должны получать удаленные клиенты. В нашем случае это сеть условного офиса — 192.168.111.0/24. Наконец флаг System DNS предписывает клиенту использовать собственные DNS сервера.

Это же действие в терминале:

/ip ipsec mode-config
add address-pool=ikev2-pool address-prefix-length=32 name=IKEv2-cfg split-include=192.168.111.0/24

Если же вам нужно, чтобы клиенты использовали внутренние сервера имен, например, в Active Directory, то флаг System DNS следует снять и указать адреса требуемых DNS-серверов.

Команда для терминала будет выглядеть так:

/ip ipsec mode-config
add address-pool=ikev2-pool address-prefix-length=32 name=IKEv2-cfg split-include=192.168.111.0/24 static-dns=192.168.111.101,192.168.111.201 system-dns=no

На закладке Groups создадим новую группу, никаких настроек здесь нет, просто укажите уникальное имя:

/ip ipsec policy group
add name=ikev2-policies

Затем на закладке Policices создадим шаблон политики, которая будет указывать какой именно трафик будет подвергаться обработке IPsec и отправляться в туннель. В поле Src. Address оставляем 0.0.0.0/0, в поле Dst. Address указываем выделенный для VPN-сети диапазон: 10.20.0.0/24, устанавливаем флаг Template и указываем созданную нами ранее группу в поле Group.

На закладке Action в поле Proposal укажите созданный нами ранее набор предложений.

Эти же действия в терминале:

/ip ipsec policy
add dst-address=10.20.0.0/24 group=ikev2-policies proposal=IKEv2 src-address=0.0.0.0/0 template=yes

После чего перейдем в IP — IPsec — Peers создадим новый пир для приема подключений. Сразу установим флаг Passive, в поле Address указываем 0.0.0.0/24 (разрешаем подключаться из любого места), в поле Profile указываем созданный нами профиль, а в поле Exchange Mode укажем протокол обмена ключами — IKE2.

В терминале для получения аналогичного результата выполните:

/ip ipsec peer
add exchange-mode=ike2 name=IKEv2-peer passive=yes profile=IKEv2

На закладке Identities создадим новую настройку идентификации подключающихся клиентов. Здесь много настраиваемых полей и нужно быть предельно внимательными, чтобы ничего не упустить и не перепутать. В поле Peer — указываем созданный нами пир, Auth. Method — способ аутентификации — digital signature, Certificate — сертификат сервера. Policy Template Group — группа шаблонов политик — выбираем созданную нами группу, Mode Configuration — указываем созданную нами конфигурацию для клиентов, Generate Policy — port strict.

Команда для терминала:

/ip ipsec identity
add auth-method=digital-signature certificate=vpn.interface31.lab generate-policy=port-strict mode-config=IKEv2-cfg peer=IKEv2-peer policy-template-group=ikev2-policies

На этом настройка сервера завершена, осталось лишь добавить правила брандмауэра, разрешающие работу с ним. Для того, чтобы клиенты могли подключаться к серверу перейдем в IP — Firewall — Filter Rules и добавим правило: Chain — input, Protocol — udp, Dst. Port — 500, 4500, In. Interface — ваш внешний интерфейс (в нашем случае это ether1). Действие не указываем, так как по умолчанию применяется accept.

Для добавления правила в терминале:

/ip firewall filter
add action=accept chain=input dst-port=500,4500 in-interface=ether1 protocol=udp

Но это еще не все, чтобы VPN-клиенты могли получить доступ к внутренней сети, следует добавить еще одно правило. На закладке General укажите Chain — forward и Interface — внешний интерфейс, затем на Advanced: IPsec Policy — in:ipsec.

/ip firewall filter
add action=accept chain=forward in-interface=ether1 ipsec-policy=in,ipsec

Оба правила следует расположить выше, чем запрещающие в каждой из цепочек.

Настройка подключения клиента в Windows

Прежде всего импортируем сертификат, для этого можно просто выполнить двойной клик на файле сертификата, в открывшемся Мастере импорта в качестве Расположения хранилища укажите Локальный компьютер, остальные параметры принимаются по умолчанию.

Затем создадим новое подключение штатными инструментами. А качестве Типа VPN укажем IKEv2, а в качестве Типа данных для входаСертификат. Также обратите внимание, что в строка Имя или адрес сервера должно совпадать с Common Name сертификата сервера, в противном случае подключение установить не удастся.

После чего откроем свойства созданного подключения и перейдем на закладку Безопасность, где установим переключатель Проверка подлинности в положение Использовать сертификаты компьютеров.

Теперь можно подключаться, если все сделано правильно — подключение будет успешно. Проверим таблицу маршрутов:

Как видим, маршрут к нашей внутренней сети 192.168.111.0/24 был добавлен автоматически и никаких ручных настроек клиента не требуется.

Настройка подключения клиента в Linux

Точно также начнем с сертификата, но в данном случае нам потребуется немного больше действий. Будем считать, что сертификат находится в корневой директории пользователя, для которого мы настраиваем подключение. Все последующие команды также следует выполнять от его имени.

Перейдем в домашнюю директорию и создадим скрытую папку для хранения ключей и сертификатов:

cd ~
mkdir .ikev2

Теперь нам нужно экспортировать из PKCS12 файла корневой сертификат CA, а также ключ и сертификат пользователя. Начнем с корневого сертификата:

openssl pkcs12 -in cert_export_SmirnovaMV.p12 -out .ikev2/IKEv2_CA.crt -nodes -nokeys -cacerts 

Затем экспортируем сертификат клиента:

openssl pkcs12 -in cert_export_SmirnovaMV.p12 -out .ikev2/SmirnovaMV.crt -nodes -nokeys

И его закрытый ключ. При экспорте закрытого ключа нас попросят установить для него пароль, минимальная длинна пароля 8 символов. Пропустить этот шаг нельзя.

openssl pkcs12 -in cert_export_SmirnovaMV.p12 -out .ikev2/SmirnovaMV.pass.key -nocerts

На каждом из этих этапов нам нужно будет вводить парольную фразу, указанную при экспорте сертификата пользователя на роутере.

И наконец уберем пароль с закрытого ключа пользователя:

openssl rsa -in .ikev2/SmirnovaMV.pass.key -out .ikev2/SmirnovaMV.key

Во время этого действия вы должны будете ввести пароль, который указали при создании ключа.

Для того, чтобы иметь возможность создавать VPN-подключения в графическом интерфейсе установим необходимый плагин для Network Manager:

sudo apt install network-manager-strongswan

После чего вам станут доступны настройки VPN IKEv2 соединения.

Настройки соединения достаточно просты. В секции Gateway указываем адрес сервера и путь к корневому сертификату CA. В секции Client устанавливаем Authentication: Certificate/private key и указываем пути к сертификату и закрытому ключу клиента. И в секции Option обязательно устанавливаем флаг Request an inner IP address. На этом настройка соединения окончена, можно подключаться.

Если мы после подключения проверим таблицу маршрутизации, то не обнаружим маршрута к офисной сети, но при этом она будет доступна:

Но никакой ошибки здесь нет. Просто Linux в данной ситуации поступает более правильно, вместо маршрута в системе создается соответствующая политика IPsec, которая направляет трафик к внутренней сети в туннель согласно тому, что мы указали в конфигурации клиента (Mode Configs) на роутере.

read more at Записки IT специалиста

Загрузка в безопасном режиме XP

Загрузка в безопасном режиме XP применяется в случаях неудачи при загрузке операционной системы, что означает значительные повреждения системных файлов Windows XP и реестра, случается это при установке неправильных драйверов и программ, а так же из-за вирусной активности. В Безопасном режиме операционная система загружает только основные системные службы и драйвера и если XP загружается в данном режиме, у нас появляется возможность отменить наши последние ошибочные действия работы на компьютере. Давайте рассмотрим в нашей статье все возможные способы восстановления Windows XP в безопасном режиме.

Загрузка в безопасном режиме XP

Прежде чем запускать Windows XP в Безопасном режиме стоит также попробовать Загрузку последней удачной конфигурации с работоспособными параметрами, ещё у нас на сайте есть много статей, которые смогут вам помочь, например: Не загружается Windows XP, Точка восстановления ХР, Восстановление системы через меню установки Windows XP. Что бы осуществить загрузку в безопасном режиме XP, при запуске компьютера нужно нажать несколько раз клавишу F-8 и вы зайдёте в меню дополнительных вариантов загрузки Windows XP. Входить нужно от лица Администратора.

В безопасном режиме Windows XP, можно попытаться удалить через меню Удаление и установка программ, программное обеспечение, которое вы устанавливали последним или пакеты драйверов мешающие по вашему мнению нормальной загрузке Windows XP. Лично я бы ещё выполнил проверку целостности системных файлов операционной системы, Пуск->Выполнить->cmd далее введите команду sfc /scannow, в большинстве подобных случаях вам понадобится установочный диск Windows XP.

Так же нужно убрать все программы из автозагрузки Пуск->Выполнить->mscconfig->Автозагрузка.

При использовании не просто безопасного режима, с загрузкой сетевых драйверов, вместе с основными драйверами Windows XP загрузятся драйвера на вашу сетевую карту и вы сможете выходить в интернет. Если после предпринятых действий загрузить Windows XP в нормальном режиме не удастся, вам нужно опять загрузиться в безопасный режим XP и запустить Восстановление системы, то есть попытаться откатится назад с помощью точки восстановления. Так же вам нужно знать, что в безопасном режиме не получиться создать точку восстановления, можно лишь использовать восстановление к более ранним настройкам компьютера. Пуск->Все программы->Стандартные Служебные->Восстановление системы.

Выбираем нужную точку и восстановления и восстанавливаемся.

Ну и напоследок, если в безопасный режим вам зайти не удастся, можете попытаться зайти в безопасный режим с поддержкой командной строки. Наберите explorer и попадёте в почти нормальный рабочий стол или можете вызвать средство Восстановления системы командой  

%systemroot%\system32\restore\rstrui.exe


Метки к статье: Windows XP Системные функции Восстановление Windows

Не удается загрузиться в нормальном режиме, и машина продолжает загружаться в безопасном режиме — Windows Server

  • 2 минуты на чтение

В этой статье

В этой статье описаны действия по устранению проблемы, при которой машины не могут загружаться в нормальном режиме и продолжают перезагружаться в безопасном режиме.

Исходная версия продукта: Windows 10 — все выпуски, Windows Server 2012 R2
Оригинальный номер базы знаний: 2543632

Симптомы

Машина не может загрузиться в нормальном режиме и продолжает перезапускаться в безопасном режиме.

Причина

Эта проблема возникает, когда опция SAFEBOOT отмечена в программе настройки системы на вкладке Boot .

Разрешение

Чтобы устранить проблему, выполните следующие действия:

Использование инструмента настройки системы в Windows 2003 / Windows XP:

Шаг 1: Закройте все программы, чтобы ничего не открывать, и они находятся на рабочем столе.

Шаг 2: Нажмите кнопку Start , а затем нажмите Run .

Шаг 3: В поле Run введите msconfig , как показано на изображении ниже.

Шаг 4: Нажмите кнопку OK , и запустится программа настройки системы . Затем вы увидите экран, похожий на изображение ниже.

Шаг 5: Щелкните вкладку BOOT.INI , выделенную красным полем на рисунке выше, и вы увидите экран, похожий на изображение ниже.

Шаг 6: Снимите отметку в поле / SAFEBOOT , обозначенном красным квадратом выше. Затем нажмите кнопку OK , а затем снова кнопку OK . Windows запросит перезагрузку. Нажмите кнопку Да , и теперь машина может загрузиться в нормальном режиме.

Примечание

Если выбрана опция / SAFEBOOT , вы заметите дополнительную запись в файле Boot.ini, как показано ниже.Если вы видите флажок для / SAFEBOOT, снимите флажок.

Несмотря на то, что этот документ в основном ориентирован на Windows 2003 Server и Windows XP, эта информация применима к Windows Vista, Windows Server 2008, Windows 7 и Windows Server 2008 R2.

В операционной системе под управлением Vista или более поздней версии может оказаться полезным средство командной строки редактора данных конфигурации загрузки (Bcdedit.exe):

Следующая команда удалит параметр / SAFEBOOT и поможет машине загрузиться в нормальный режим:

bcdedit / deletevalue {по умолчанию} safeboot

Откройте административную командную строку, чтобы выполнить команду выше bcdedit .Для получения подробной информации о командах и параметрах в командной строке введите bcdedit.exe /? команда.

Дополнительная информация

Редактор данных конфигурации загрузки Часто задаваемые вопросы

3 способа загрузки Windows Server 2012 в безопасном режиме

24 июля, 2016 по Admin Оставьте ответ »

Как перейти в безопасный режим в новых операционных системах Windows, таких как Windows 8, Windows 10 и Server 2012? Начиная с Windows 8, система загружается очень быстро, и время нажатия клавиши F8 для доступа к безопасному режиму составляет менее 200 миллисекунд, поэтому практически невозможно войти в безопасный режим, нажав F8 во время загрузки.

В этом руководстве мы покажем вам 3 эффективных способа загрузки Windows Server 2012 в безопасном режиме. Эти методы также должны работать с Windows 10 и Windows 8 / 8.1.

Метод 1. Загрузите Windows Server 2012 в безопасном режиме с помощью командной строки

  1. Нажмите клавиши Windows + X, чтобы открыть меню WinX, выберите « Командная строка (администратор) » из списка.

  2. Чтобы Windows отображала диспетчер загрузки Windows, введите следующую команду в командной строке и нажмите Enter.Вы получите подтверждение о том, что операция успешно завершена.

    bcdedit / set {bootmgr} displaybootmenu yes

    Если вы хотите прекратить отображение диспетчера загрузки Windows позже, выполните вместо этого следующую команду:
    bcdedit / set {bootmgr} displaybootmenu no

  3. Теперь перезагрузите компьютер, и вы увидите экран диспетчера загрузки Windows. Просто нажмите F8 , чтобы открыть дополнительные параметры загрузки.

  4. Выберите Safe Mode и нажмите Enter.Это откроет Windows Server 2012 в безопасном режиме.

Метод 2: загрузите Windows Server 2012 в безопасном режиме с помощью конфигурации системы

  1. Нажмите клавиши Windows + R, чтобы открыть окно «Выполнить». Введите msconfig и нажмите Enter.

  2. Откроется диалоговое окно «Конфигурация системы». На вкладке Boot отметьте опцию Safe boot и нажмите OK .

  3. Перезагрузите компьютер, и он автоматически загрузится в безопасном режиме.Если вы захотите остановить загрузку Windows в безопасном режиме в следующий раз, вам нужно снова открыть утилиту настройки системы (msconfig) и снять отметку с опции Safe boot .

Метод 3. Загрузите Windows Server 2012 в безопасном режиме с помощью приложения настроек

  1. Для начала вам нужно открыть панель настроек. Это можно сделать, наведя указатель мыши на правый верхний угол экрана или нажав клавишу Windows + I на клавиатуре.
  2. Удерживайте нажатой клавишу SHIFT на клавиатуре, затем щелкните значок Power и выберите Restart .

  3. Вам нужно будет нажать на опцию Устранение неполадок .

  4. Щелкните Параметры запуска .

  5. Щелкните Перезапустить .

  6. Компьютер автоматически загрузится до экрана Advanced Boot Options. Оттуда вы можете выбрать Safe Mode , чтобы запустить Windows Server 2012 в безопасном режиме.


Как загрузить компьютер в безопасном режиме с подключением к сети (Windows)

Windows 10

Чтобы загрузить компьютер с Windows 10 в безопасном режиме с загрузкой сетевых драйверов, вам необходимо сделать следующее:

  1. Нажмите кнопку Пуск или нажмите клавишу Windows на клавиатуре
  2. Нажмите Питание
  3. Удерживая SHIFT на клавиатуре, нажмите Перезагрузить
  4. Windows перезагрузится и предложит несколько разных параметров
  5. Выберите Устранение неполадок
  6. Выберите Дополнительные параметры
  7. Выберите Параметры запуска
  8. Нажмите Перезагрузите
  9. После перезагрузки Windows предложит несколько различных вариантов запуска.
  10. Выберите Safe Mode with Networking и нажмите Введите

Windows 8.1

Чтобы загрузить компьютер с Windows 8.1 в безопасном режиме с загрузкой сетевых драйверов, вам необходимо сделать следующее:

  1. Переход к рабочему столу на ПК с Windows 8.1
  2. Нажмите значок клавиатуры Windows 8 WINDOWS и клавишу « i » на клавиатуре одновременно или переместите мышь в правый верхний угол экрана, чтобы открыть панель Charms.
  3. Выберите Настройки
  4. Выберите значок Power , затем, удерживая нажатой клавишу SHIFT на клавиатуре, выберите Restart
  5. Ваш компьютер перезагрузится и загрузит расширенное меню запуска
  6. Выберите Устранение неполадок
  7. Выберите Дополнительные параметры
  8. Выберите Параметры запуска
  9. Нажмите Перезагрузите
  10. Нажмите клавишу F5 на клавиатуре, чтобы выбрать 5) Включить безопасный режим с поддержкой сети

Windows XP, Vista и Windows 7

Чтобы загрузить компьютер с Windows XP, Vista или Windows 7 в безопасном режиме с загрузкой сетевых драйверов, вам необходимо сделать следующее:

  1. Выключите компьютер
  2. Перезагрузите компьютер и сразу же начните нажимать клавишу F8 , расположенную на клавиатуре.Продолжайте нажимать F8 несколько раз, пока не появится меню загрузки
  3. Выберите Safe Mode with Networking из списка вариантов с помощью клавиш со стрелками на клавиатуре, а затем нажмите клавишу ENTER
  4. Войдите в свой компьютер, если будет предложено. После входа в систему вы заметите, что рабочий стол выглядит иначе, чем при загрузке компьютера в обычном режиме. Ваш дисплей может казаться увеличенным и нечетким, но это нормально в безопасном режиме; рабочий стол вернется в свое предыдущее состояние при выходе из безопасного режима

Когда вы будете готовы выйти из безопасного режима, просто перезагрузите компьютер.

2 способа загрузки сервера 2016 в режим сохранения

Уведомление о партнерской программе
Если вы покупаете продукт по некоторым ссылкам в этом сообщении, как партнер Amazon Itechguides.com зарабатывает на соответствующих покупках.

Введение

В этом руководстве демонстрируются 2 метода загрузки в безопасном режиме Server 2016:

  • Безопасный режим Server 2016 изнутри Windows
  • Безопасный режим Server 2016 из среды восстановления

Вот подробности для каждого метода.

Server 2016 Безопасный режим из Windows

Используйте этот метод, если вы все еще можете загрузиться и войти в Windows. Этот метод полезен, если вам нужно выполнить определенные задачи из безопасного режима.

Вот шаги:

  • Нажмите логотип Windows + клавишу R . Это откроет команду «Выполнить».
  • Введите команду «Выполнить» MSConfig и нажмите OK.
  • Когда откроется средство настройки системы Microsoft, щелкните вкладку Boot .Затем в Параметры загрузки установите флажок Безопасная загрузка и выберите Минимальный (по умолчанию). Когда закончите, нажмите Применить. Тогда хорошо.
  • Когда ваш сервер перезагрузится и вы войдете в систему, вы увидите, что теперь он находится в безопасном режиме.
  • По завершении работы в безопасном режиме снова откройте MSConfig, вкладку Boot и снимите флажок Safe boot . Щелкните ОК. Затем перезагрузите сервер в обычном режиме.

Внимание!
Если вы не вернете конфигурацию с помощью этой последней задачи, ваш компьютер продолжит загрузку в безопасном режиме!

Безопасный режим Server 2016 из среды восстановления

Второй способ загрузки в безопасном режиме Server 2016 — через среду восстановления.Используйте этот метод, если ваш сервер сломан и не может загрузиться.

Вот шаги:

  • На экране Advanced options выберите Startup Settings .
  • Когда откроется экран Startup Settings , щелкните Restart .
  • Ваш сервер перезагрузится и отобразит Advanced Boot Options .
  • Используйте клавиши со стрелками вверх / вниз, чтобы выбрать безопасный режим. Чтобы загрузить опцию, нажмите Enter на клавиатуре.Если вы не уверены, какой вариант выбрать, см. Мое объяснение каждого варианта ниже:
  1. Безопасный режим : это загружает Windows с минимальным набором драйверов и служб — используйте этот вариант, если у вас возникают проблемы с загрузкой Windows.
  2. Safe Mode with Networking : загружается в безопасном режиме, но теперь включает сетевые драйверы. Используйте эту опцию, если вам нужно выйти в Интернет или получить доступ к сетевому ресурсу.
  3. Безопасный режим с командной строкой : аналогично безопасному режиму, но вместо загрузки в графический интерфейс (вход в Windows) отображается командная строка.Используйте эту опцию, если вам нужно запустить команду для исправления Windows. Некоторые команды, которые могут быть полезны для исправления Windows: DISM, SFC, DISKPART.
  4. Последняя удачная конфигурация : Это очень полезный вариант загрузки. Используйте это, чтобы восстановить ваш сервер до последней известной чистой загрузки Windows. Этот метод полезен, если у вас появляется синий экран или сбой загрузки после обновления, установки нового программного обеспечения или драйвера устройства.

Чтобы узнать об остальных параметрах безопасного режима Windows Server 2016, щелкните Дополнительные параметры запуска (включая безопасный режим).

Заключение

В этом руководстве обсуждаются 2 варианта загрузки Windows Server 2016 в безопасном режиме. Надеюсь, вам удалось решить проблему с вашим сервером!

Если вам все еще требуется помощь, используйте форму «Оставить ответ», чтобы подробно описать возникшую у вас проблему. Одно сообщество читателей будет рада вам помочь!

Для получения дополнительных руководств по Windows Server 2016 посетите нашу страницу с инструкциями по Windows Server.

Загрузка Microsoft Windows Server в безопасном режиме и режиме восстановления служб каталогов с помощью Veeam Backup

При запуске Veeam Backup and Replication контроллер домена Microsoft Windows Server может загружаться в безопасном режиме и в режиме восстановления служб каталогов.

Около недели назад я загрузил Veeam Backup and Replication в свою тестовую среду. Это фантастический продукт, и он отлично работает, однако сегодня у меня возникла небольшая проблема с контроллером домена под управлением Windows Server 2016 Server Core.

Я проснулся от уведомления о том, что резервное копирование не удалось из-за проблемы со снимками VSS. Теперь я знаю, что VSS может быть немного придирчивым, поэтому я решил перезапустить гостевую виртуальную машину. После перезапуска она вернулась, была доступна для проверки связи и, похоже, работала нормально, однако резервное копирование продолжало давать сбой с новыми ошибками, журнал событий выглядел очень странно на сервере, и многие службы, которые были настроены на автоматический режим, не запускались. .

Этот конкретный сервер был установлен с использованием режима Server Core, поэтому он не имеет графического интерфейса пользователя и управляется через командную строку через RDP или с помощью утилит удаленного управления. Как только RDP подключился к серверу, я заметил логотип «Безопасный режим» на каждом углу дисплея, это было очень странно. Я снова перезапустил сервер, на этот раз вручную попытавшись запустить службы Active Directory вручную через services.msc.

Всего представлено:

 Код события: 16652
Источник: Directory-Services-SAM
Общее описание: Контроллер домена загружается в режиме восстановления служб каталогов.

Скриншот:

Контроллер домена загружается в режим восстановления служб каталогов.

Это меня удивило (и напугало меня в этом отношении). Я немедленно начал искать в Интернете, что могло вызвать это…

К моему облегчению, я прочитал множество сайтов, которые сообщают, что при запуске активного резервного копирования на гостевой виртуальной машине, которая является контроллером домена, Veeam временно активирует режим восстановления служб каталогов, поэтому в случае восстановления он загрузится в этот режим. автоматически.В моем случае переключатель не был изменен обратно во время сбоя резервного копирования.

Выполнение следующей команды в командной строке подтверждает, что для параметра safeboot установлено значение dsrepair enabled:

 bcdedit / v 

Чтобы отключить режим восстановления служб каталогов, введите в командной строке следующее:

 bcdedit / deletevalue safeboot 

Перезагрузите сервер, и проблема должна быть решена!

Как запустить Windows 10 в безопасном режиме? — Официальная поддержка Avira | База знаний и поддержка клиентов

Чтобы получить доступ к диспетчеру загрузки вашей системы, нажмите комбинацию клавиш Ctrl + F8 во время процесса запуска.Выберите желаемый безопасный режим, чтобы запустить компьютер.

Примечание
На компьютерах, которые быстро запускаются или которые оснащены быстрым SSD, может быть трудно нажать Ctrl + F8 точно в нужное время, чтобы поймать диалог. Поэтому для доступа к диспетчеру загрузки таким образом может потребоваться несколько попыток.

В качестве альтернативы безопасный режим также можно запустить непосредственно из Windows или с помощью служебной программы настройки системы Windows, описанной в следующем видео или в тексте ниже.

Запуск безопасного режима прямо из Windows

  1. Нажмите кнопку Windows → Питание.

  2. Удерживая нажатой клавишу переключения и нажмите Перезагрузка.

  3. Выберите опцию Устранение неполадок , а затем Дополнительные параметры.

  4. Перейдите в «Дополнительные параметры» и щелкните Параметры запуска.

  5. В разделе «Параметры запуска» нажмите Перезагрузить.

  6. Отображаются различные варианты загрузки.

    Соответствующими параметрами для загрузки в безопасном режиме являются числа, 4,5 или 6.
    Выберите вариант, нажав одну из цифровых или функциональных клавиш F4, F5 или F6

    4) Включить безопасный режим
    В этом режиме операционная система запускается с минимальным количеством установленных драйверов и используются только основные функции Windows.

    5) Включить безопасный режим с подключением к сети
    В этом режиме также запускаются сетевые драйверы.

    6) Включить безопасный режим с помощью командной строки
    В этом режиме операционная система запускается в текстовом режиме. Этот режим требует знания компьютерных команд и поэтому больше подходит для профессиональных пользователей.

  7. Windows 10 запускается в безопасном режиме.

Примечание
Вы можете сказать, что находитесь в безопасном режиме, поскольку слова «Безопасный режим» отображаются в четырех углах экрана.

Обновления

за ноябрь 2019 г. вызвали цикл перезагрузки Windows Server 2012

Введение

Некоторых отстающих, у которых все еще работают виртуальные машины Windows Server 2012, на прошлых выходных был неприятный сюрприз.Некоторые из них вошли в цикл загрузки. По-видимому, обновления ноября 2019 года вызвали цикл перезагрузки Windows Server 2012. Что ж, мы уже сталкивались с проблемами обновления раньше, как здесь, в публикации Quick Fix Publish: виртуальная машина не загружается после обновлений для Windows Server 2016 и Windows 10 за октябрь 2017 г. (KB4041691). Не нужно паниковать.

Симптомы

Не все виртуальные машины Windows Server 2012 были затронуты. Мы не обнаружили никаких проблем с Windows Server 2012 R2, 2016 или 2019. Что ж, симптом — это цикл перезагрузки, и ниже у меня есть последовательность того, как это выглядело визуально.

Перезапуск Пока все идет хорошо… Хорошо, этап 2 из 4… stlil кажется нормальным. Может быть, все еще в порядке… но нет, он запускается снова в бесконечном цикле.

Так что же вызвало этот цикл перезагрузки Windows Server 2012?

Исправить

Мы отключили виртуальные машины, на которых обновления за ноябрь 2019 г. вызвали цикл перезагрузки Windows Server 2012. Мы снова запустили их в «безопасном режиме», который успешно завершился. Наконец, мы выполнили обычную перезагрузку, и она тоже завершилась. Все обновления были применены с первого раза.Это было обновление стека обслуживания 2019-11 для Windows Server 2012 (KB4523208).

Мы вручную установили его через Центр обновления Windows, и это удалось.

При чтении информации об этом обновлении https://www.catalog.update.microsoft.com/ScopedViewInline.aspx?updateid=5fa2a68f-e7cd-43c7-a48a-5e080472cb77 указано, что оно должно быть установлено исключительно.

Может быть, это была основная причина. Он был развернут через WSUS с другими обновлениями за ноябрь 2019 года.

В общем, сейчас все хорошо.Напоминаю, что у нас есть как минимум 2 способа восстановить эти виртуальные машины. На случай, если мы не смогли их исправить. Знали хорошие резервные копии и способ их восстановить люди.

Заключение

Мы устранили проблему и полностью пропатчили эти серверы. Так что теперь все хорошо. За исключением того факта, что теперь их снова призвали как можно скорее отказаться от этой операционной системы.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *