Как установить нет фрамеворк 4 на виндовс 7: Как установить Microsoft .NET Framework 4.0 на Windows 7? и что это такое? | Info-Comp.ru

Содержание

Как установить Microsoft .NET Framework 4.0 на Windows 7? и что это такое? | Info-Comp.ru

Наверное, каждый пользователь операционной системы Windows сталкивался с таким понятием как Microsoft .NET Framework, но не каждый знает, что это такое, для чего он нужен, где его скачать и как его установить, поэтому сейчас мы рассмотрим все это и в качестве примера установим Microsoft .NET Framework 4.0 на Windows 7.

В дополнение ко всему прочему мы узнаем, что такое клиентский профиль Microsoft .NET Framework 4 и также рассмотрим процесс его установки.

Начнем мы конечно с основ, т.е. что такое Microsoft .NET Framework и для чего вообще он нужен?

Что такое Microsoft .NET Framework и для чего он нужен?

.NET Framework – это платформа, которая служит для создания и выполнения приложений и веб-служб. Разработчиком является компания Microsoft поэтому как не странно в большей степени .NET Framework создан и рассчитан на операционную систему Windows, но также есть проекты которые позволяют запускать программы .NET и в других операционных системах, например в Linux.

Основными компонентами .NET Framework являются среда выполнения (CLR) и библиотека классов, которая включает ADO.NET, ASP.NET, Windows Forms и Windows Presentation Foundation (WPF). Средой разработки в первую очередь выступает Microsoft Visual Studio, что и понятно, так как VS разработка тоже компании Microsoft, и в этом случае языками программирования выступают: C#, Visual Basic .NET, C++. Но так же, как было уже сказано выше, есть и независимые проекты, в которых можно писать программы под .NET Framework на других языках.

Для обычных пользователей, если говорить по-простому то Microsoft .NET Framework это всего лишь программа или компонент операционной системы, без которой программы или игры, написанные под .NET Framework просто не будут работать, даже не запустятся. Поэтому если кто сомневается, нужна ли программа Microsoft .NET Framework или нет, то ответ, конечно же, нужна, так как в современном мире огромное количество программ и игр, которые используют библиотеки .NET Framework. И если Вы до сих пор не столкнулись с программами или играми, которые требуют установки Microsoft .NET Framework то рано или поздно Вы с этим столкнетесь. А если говорить о том какую версию устанавливать то, конечно же, чем новей, тем лучше, для примера мы будем устанавливать версию 4.0, это, кстати, последняя версия .NET Framework которую можно установить на Windows XP, а на сегодняшний день доступна версия .NET Framework 4.5.2.

Примечание! Как видно из названия материала устанавливать Microsoft .NET Framework 4.0 мы будем на операционную систему Windows 7, кстати говоря, по умолчанию в ней уже установлен .NET Framework 3.5, в Windows 8 по умолчанию идет версия 4.0, а в Windows 8.1 уже 4.5. Поэтому если у Вас, например ОС Windows 8 то .NET Framework 4.0 устанавливать не нужно.

Прежде чем переходить к установке, давайте поговорим о так называемом Microsoft .NET Framework 4 Client Profile клиентском профиле .NET Framework 4.

Клиентский профиль .NET Framework 4

Клиентский профиль .NET Framework 4 — это некий поднабор компонентов .NET Framework 4, которые оптимизированы для клиентских приложений. Он включает в себя необходимый набор функций и компонентов, которых достаточно большинству клиентских приложений. Сюда входит Windows Presentation Foundation (WPF), Windows Forms, Windows Communication Foundation (WCF). Если говорить о том, что сюда не включено то это: ASP.NET, расширенный набор функций WCF, поставщик данных .NET Framework для Oracle и система MSBuild для компиляции, если Вам необходимы эти компоненты то нужно уже устанавливать полноценный .NET Framework 4. Как Вы, наверное, уже поняли клиентский профиль .NET Framework 4 это своего рода урезанная версия .NET Framework 4.

И теперь давайте перейдем к установке данных компонентов и начнем мы с Microsoft .NET Framework 4 Client Profile.

Примечание! Если Вы хотите сразу установить полноценный Microsoft .NET Framework 4.0, то клиентский профиль устанавливать не обязательно.

Установка Microsoft .NET Framework 4 Client Profile

И для того чтобы установить данный компонент необходимо, конечно же, его скачать, а это можно и лучше сделать с официального центра загрузки Microsoft.

Возможно два варианта установки это через веб установщик, т.е. мы, скачали небольшую по размеру программку и запустили ее, а она уже будет скачивать все необходимые компоненты и второй вариант так называемая автономная (классическая) установка при которой мы скачиваем полный пакет, а затем устанавливаем его. В принципе они ни чем не отличаются просто при первом варианте у нас на компьютере не останется своего рода дистрибутива, а при втором он у нас будет. При этом мы его сможем перенести и установить на компьютер, который не подключен к Интернету, в свою очередь веб установщик требует обязательного подключения к Интернету.

Я предлагаю клиентский профиль .NET Framework 4 установить с помощью веб установщика, а затем, когда мы будем рассматривать установку полноценного .NET Framework 4.0 использовать автономный установщик.

И так начнем.

Скачать клиентский профиль .NET Framework 4 (веб установщик) можно вот на этой странице.

Вы переходите на страницу и жмете «Скачать»

Затем Вам будет предложено отметить для загрузки дополнительные пакеты приложений, но так как в данном случае нам ничего больше не нужно мы просто жмем «Отказаться и продолжить» в правой части экрана

В итоге у Вас загрузится файл

dotNetFx40_Client_setup.exe, который нужно запустить.

И сразу после запуска нам необходимо согласиться с лицензионным соглашением, т.е. поставить галочку напротив «Я прочитал и принимаю условия лицензионного соглашения» и нажать «Установить».

Затем нам больше ничего не нужно делать мы просто ждем окончания загрузки и установки.

Установка займет не много времени всего минуты 3, после чего установщик скажет, что «Установка завершена», и мы жмем «Готово».

Как видите в установке клиентского профиля .NET Framework 4 нет ничего сложного как впрочем, и в установке самой платформы Microsoft .NET Framework 4, но это Вы сейчас сами и увидите.

Установка Microsoft .NET Framework 4.0

Для установки Microsoft .NET Framework 4.0 мы будем использовать автономный установщик. Скачать его можно вот здесь.

Также жмем «Скачать

» и если мы не хотим устанавливать что-то дополнительное, то жмем «Отказаться и продолжить»

У нас загрузится файл dotNetFx40_Full_x86_x64.exe мы его и запускаем. И также сначала соглашаемся с лицензионным соглашением, т.е. ставим галочку и жмем «Установить»

Затем начнется установка, которая также пройдет очень быстро.

Жмем «Готово».

Теперь на нашем компьютере установлен Microsoft .NET Framework 4.0 это, кстати, мы можем посмотреть в списке установленных программ, а именно

Панель управления->Программы и компоненты

Надеюсь, все было понятно. Удачи!

Нравится1Не нравится

Установка платформы .NET Framework в Windows 7 с пакетом обновления 1 (SP1)

  • Чтение занимает 2 мин

В этой статье

Для многих приложений, работающих в ОС Windows, требуется платформа .NET Framework.The .NET Framework is required to run many applications on Windows. Приведенные ниже инструкции помогут вам установить ее.You can use the following instructions to install it. Вы могли попасть на эту страницу после попытки запуска приложения и отображения следующего диалогового окна.You may have arrived on this page after trying to run an application and seeing the following dialog on your machine.

Эти инструкции помогут вам установить необходимые версии .NET Framework.These instructions will help you install the .NET Framework versions you need. .NET Framework 4.8 является самой новой версией.The .NET Framework 4.8 is the latest version. Она поддерживается в Windows 7 с пакетом обновления 1 (SP1) и Windows Server 2008 R2 и входит в состав обновления Windows 10 за май 2019 г.It is supported on Windows 7 SP1 and Windows Server 2008 R2 and is included with Windows 10 May 2019 Update.

.NET Framework 4.8.NET Framework 4.8

.NET Framework 4.8 можно использовать для запуска приложений, созданных для .NET Framework 4.0 или более поздней версии.The .NET Framework 4.8 can be used to run applications built for .NET Framework 4.0 or later.

.NET Framework 3,5.NET Framework 3.5

Платформа .NET Framework 3.5 входит в состав Windows 7.The .NET Framework 3.5 is included with Windows 7.

Платформа .NET Framework 3.5 поддерживает приложения, собранные для платформы .NET Framework версий с 1.0 по 3.5.The .NET Framework 3.5 supports apps built for .NET Framework 1.0 through 3.5.

СправкаHelp

Вы можете обратиться за помощью в корпорацию Майкрософт, если не можете определить правильную версию установленной платформы .NET Framework.You can contact Microsoft for help if you cannot get the correct version of the .NET Framework installed.

См. также разделSee also

Что делать, если .Net framework 4 не устанавливается на Windows 7

Благодаря «Майкрософт.Нет Фреймворк 4» возможно совместное функционирование различных типов программ, например, компьютерных игр в среде Виндовс. Однако не редки случаи возникновения сложностей у пользователей, когда не устанавливается NET Framework, и системой выводятся разные оповещения об ошибках. Ниже изложена инструкция с описанием всех этапов действий, которые необходимо выполнить, если NET Framework 4 не устанавливается на компьютере с Windows 7.

Ошибка при инсталляции

«Нет Фреймворк» является разработкой Майкрософт и инсталлируется в ПК вместе с Виндовс 7. Об этой платформе обычно пользователи ничего не знают, до момента необходимости запуска какой-нибудь несовместимой с системой программы. Но самостоятельная инсталляция четвертой версии платформы часто заканчивается неудачей.

Платформа более высокой модификации может быть установлена только при условии полной деинсталляции ранней версии, а также удаления всех «хвостов» старой программы.

«Майкрософт.Нет Фреймворк 4» уже давно не является последней модификацией, поэтому операционная система ее не воспринимает и выводит оповещения об ошибках при попытках ее установить. Обойти эту проблему можно временно деактивировав службу обновлений и полностью избавившись от старой версии платформы. Ниже приведено руководство с алгоритмом всех требуемых последовательных шагов, описывающих то, как все это правильно выполнить.

Удаление

К сожалению, не достаточна только простая деинсталляция через вкладку приложений и компонентов Виндовс в «Панели управления». Обязательно необходимо применение особых программ для очистки всех ключей и отметок в реестре ОС. Хорошо справляется с этой задачей приложение «iObit Uninstaller». Оно доступно для скачивания в интернете и обладает интуитивно понятным интерфейсом. Также отлично зарекомендовала себя программа «Dotnetfx cleanup tool». С целью применения этой утилиты следует выполнить следующие последовательные шаги:

  1. Скачать из глобальной сети архив этого ПО в формате «zip»;
  2. Затем распаковать и запустить «cleanup_tool.exe»;
  3. В отобразившемся меню щелкнуть «Да»;
  4. Дождаться появления окошка с перечнем утилит, в котором необходимо выделить «NET.Framework — все модификации»;
  5. Далее кликнуть «Очистить»;
  6. Подождать полного окончания процесса деинсталляции и перезапустить компьютер.

Процедура установки

Необходимо осуществить следующие действия:

  1. Далее в отобразившейся консоли напечатать «net stop WuAuServ»;
  2. Щелкнуть на «Ввод»;
  3. В графе поиска напечатать «cmd»;
  4. Кликнуть «Пуск»;
  5. Снова кликнуть «Ввод»;
  6. Затем через проводник войти в каталог «Windows»;
  7. Вызвать контекстное меню от папки «Software Distribution»;
  8. Кликнуть по строчке «Переименовать»;
  9. Задать новое имя «SDold» переименовываемой директории и нажать «Enter», чтобы изменения вступили в силу;
  10. Вновь запустить консоль и напечатать «net WuAuServ start»;
  11. Щелкнуть «Enter»;
  12. Теперь, после завершения всех вышеуказанных этапов, необходимо запустить установку «Net Framework 4»;

Примечание: с первой попытки может и не установиться.

Во время установки «Нет Фреймворк 4» иногда появляется сообщение об ошибке с рекомендацией перезапуска ПК. При этом требуется согласиться и перезапустить машину.

Затем вновь запустить инсталляцию платформы.

  1. Об успешном окончании процесса будет свидетельствовать окно с сообщением «Установка завершена»;
  2. Кликнуть кнопку «Готово».

Заключение

Несмотря на всю сложность процедуры, имея подробные инструкции с пошаговым описанием действий, каждый владелец компьютера способен без посторонней помощи решить проблему с появлением ошибок при инсталляции четвертого пакета от Майкрософт. После успешной ее установки уже не составит значительного труда произвести его обновление до последней конфигурации.

Не устанавливается .NET Framework 4: решение проблемы

Microsoft .NET Framework — специальный компонент, необходимый для работы многих приложений. Это программное обеспечение прекрасно совмещается с операционной системой Виндовс. Почему же тогда возникают ошибки? Давайте разбираться.

Скачать последнюю версию Microsoft .NET Framework

Почему может не устанавливаться Microsoft .NET Framework

Чаще всего эта проблема возникает при установке .NET Framework 4-й версии. Причин для этого может быть много.

Наличие уже установленной версии .NET Framework 4

Если у вас не устанавливается .NET Framework 4 в Windows 7, первое что нужно проверить, не установлена ли она в системе. Сделать это можно при помощи специальной утилиты ASoft .NET Version Detector. Скачать ее можно абсолютно бесплатно, на просторах интернета. Запускаем программу. После быстрой сканировки, в главном окне белым цветом выделены те версии, которые уже установлены на компьютере.

Можно конечно посмотреть информацию в списке установленных программ Windows, но там информация отображается не всегда корректно.

Компонент идет в комплекте с Виндовс

В разных версиях Windows в систему уже могут быть вшиты компоненты .NET Framework. Проверить это можно зайдя в «Удаление программы-Включение или отключение компонентов Виндовс». У меня например в Виндовс 7 Starter, зашита Microsoft .NET Framework 3.5, как видно на скриншоте.

Обновление Windows

В некоторых случаях .NET Framework не устанавливается, если Виндовс не получил важных обновлений. Поэтому необходимо зайти в «Пуск-Панель Управления-Центр обновлений-Проверка обновлений». Найденные обновления необходимо будет установить. После этого перегружаем компьютер и пробуем устанавливать .NET Framework.

Системные требования

Как и в любой другой программе, в Microsoft .NET Framework существуют системные требования компьютера для установки:

  • Наличие 512 Мб. свободной оперативной памяти;
  • Процессор с частотой 1Мгц;
  • 4.5 Гб. свободного места на жестком диске.
  • Теперь смотрим, соответствует ли наша система минимальным требованиям. Посмотреть это можно в свойствах компьютера.

    Microsoft .NET Framework был обновлен

    Еще одной популярной причиной, почему долго устанавливается .NET Framework 4 и более ранних версий, является его обновление. Я для примера обновил свой компонент до версии 4.5, а потом попытался установить 4-ю версию. У меня ничего не вышло. Я получил сообщение, что на компьютере установлена более новая версия и установка прервалась.

    Удаление различных версий Microsoft .NET Framework

    Очень часто, удаляя одну из версий .NET Framework, остальные начинают работать не корректно, с ошибками. А установка новых, вообще заканчивается неудачей. Поэтому, если вас постигла данная проблема, смело удаляйте весь Microsoft .NET Framework с компьютера и ставьте заново.

    Правильно удалить все версии можно с помощью утилиты .NET Framework Cleanup Tool. Установочный файл без проблем найдете в интернете.

    Выбираем «All version» и в жмем «Cleanup Now». Когда удаление окончиться перегружаем компьютер.

    Теперь можно приступать к установке Microsoft .NET Framework заново. Обязательно скачивайте дистрибутив с официального сайта.

    Не лицензионный Windows

    С учетом того, что .NET Framework как и Windows, продукт от компании Microsoft, то ломаная версия может быть причиной неполадок. Тут без комментариев. Вариант один — переустановка операционной системы.

    На этом все, надеюсь, что ваша проблема благополучно решилась

    Мы рады, что смогли помочь Вам в решении проблемы.
    Опишите, что у вас не получилось. Наши специалисты постараются ответить максимально быстро.
    Помогла ли вам эта статья?
    ДА НЕТ

    Что делать, если не устанавливается NET.Framework

    Для тех, кто хотя бы мало-мальски разбирается в программном обеспечении компьютера, абсолютно понятно, что в любом случае наступает время, когда возникает необходимость установить NET.Framework.

    С установкой и использованием NET.Framework у пользователей очень часто возникают проблемы

    Это совсем неудивительно, поскольку NET.Framework является платформой, на основе которой можно создавать, а затем впоследствии запускать некоторые приложения. Поскольку Microsoft является разработчиком такой платформы, то она рассчитана, безусловно, на Windows, хотя существует всё-таки возможность установить NET.Framework и на некоторые другие операционные системы, в число которых входит и Linux.

    К сожалению, установка платформы не всегда проходит успешно, пользователям приходится сталкиваться с серьёзными проблемами, когда возникают системные ошибки, по причине которых процесс инсталляции завершается внезапной неудачей.

    Конечно же, сразу возникает вопрос, почему не устанавливается Microsoft NET Framework 4. Получив ответ на этот вопрос, можно найти пути устранения проблемы.

    Проблемы установки платформы

    Неопытные пользователи, наслышанные о возможных ошибках, возникающих при инсталляции NET.Framework, желают узнать, можно ли обойтись без установки такого пакета на компьютер. В принципе, нет необходимости сразу же перегружать операционную систему всяческими дополнительными приложениями и программами, если пользователь в них не нуждается. Программисты рекомендуют инсталлировать только программное обеспечение, в котором непосредственно нуждается пользователь. Чрезмерная загрузка ОС ненужными программами провоцирует дефицит свободного пространства на жёстком диске, что ухудшает и работу системы, и её быстродействие.

    Кстати, Microsoft, изначально вложила в инсталляционный пакет Windows 7 загрузку NET.Framework. Кроме этого, загрузка платформы также может автоматически осуществиться, если у пользователя возникнет желание установить некоторые игровые приложения, поскольку и в этом случае разработчики игр, предвидят, что игра не будет запущена без такой платформы. Чтобы не утруждать пользователя дополнительными поисками, сразу в загрузочный файл игры внедряют и установку платформы.

    Встречающиеся ошибки

    Разобравшись в алгоритме инсталляции нового программного обеспечения, юзеры по аналогии приступают к установке NET.Framework на Windows 7. Выполняя последовательно все предлагаемые действия, пользователь обнадёживает себя, что всё пройдёт однозначно гладко, и вскоре платформа будет успешно установлена на Windows 7, после чего можно сразу приступить к загрузке и последующему запуску любимой игры.

    Однако в некоторых случаях возникает разочарование, поскольку приходится сталкиваться с тем, что даже при чётком следовании инструкции всё равно не устанавливается NET Framework 4 Windows 7, выдавая «грустное» сообщение на экран.

    Чаще всего причиной является конфликтная ситуация, возникающая в Windows 7.

    Компания Microsoft подтверждает, что проблема, в результате которой не устанавливается НЕТ Фреймворк 4 в Виндовс 7, действительно, связана с Центром обновления Windows.

    Безусловно, если возникает проблема, значит, находится и тот, кто старается найти пути её решения. Так и в этом случае, программисты уже нашли эффективные способы, позволяющие обойти возникающую ошибку, успешно установив NET.Framework на Windows 7.

    При этом нет необходимости совершать что-то невероятное, алгоритм устранения проблемы подробно расписан, поэтому его освоить сможет даже тот, кто не имеет достаточного практического опыта.

    Как установить NET.Framework

    «Не могу установить NET Framework» — фраза, которую приходится слышать от многих пользователей. Сочетание «не могу» просто заполонила тематические форумы. К счастью, существуют такие программисты, которые благодаря своим отличным знаниям и практическим умениям, умеют находить различные варианты устранения ошибок. К тому же, они не утаивают свои гениальные «находки», а с радостью делятся со всеми желающими, поэтому на форумах достаточно часто можно найти ценные советы, позволяющие решать проблемы даже абсолютным «чайникам».

    Алгоритм действий, ориентированный на установку платформы

    Чтобы установить NET.Framework на Windows 7, первоначально следует удалить предыдущие следы установки всех версий. Неопытным пользователям достаточно сложно проделать такие манипуляции, поскольку компания Microsoft достаточно плотно «переплела» системные папки с папками платформы. По этой причине предыдущая версия может очень сложно удаляться, или, вообще, нет возможности от неё «избавиться».

    Проигнорировать этот шаг тоже нельзя, поскольку в процессе новой инсталляции платформы на Windows 7, вновь может возникать ошибка.

    Чтобы весь процесс деинсталляции и последующей инсталляции был обеспечен успехом, важно следовать всем рекомендациям опытных пользователей. Прежде всего, рекомендуется загрузить файл dotnetfx_cleanup_tool.zip. Далее его следует открыть, а затем сразу же извлечь, поскольку он помещён в архив.

    В папке, в которой находятся все извлечённые файлы, необходимо найти файл cleanup_tool с расширением exe. Именно его следует запустить. Сразу же возникнет новое окно, в котором запрашивают разрешение на все последующие действия. Кликнув по кнопке «Да», пользователь соглашается со всем, поэтому программа продолжает выполнять все остальные действия.

    В определённый момент возникнет окно, в котором будет предложено право выбрать продукт Microsoft, который требуется удалить. Среди предлагаемого перечня есть строка «NET.Framework — все версии», выбрав её, остаётся нажать на кнопку «Очистить».

    Однако и такое приложение не всесильно, поскольку оно не сможет удалить NET.Framework 2.0, поскольку такая версия платформы определена разработчиками Microsoft в качестве неотъемлемой части операционной системы.

    После завершения очистки, компьютер нужно обязательно перезагрузить. Разработчики Microsoft выдвигают такие требования для многих важных процедур, связанных с процессами инсталляции и деинсталляции.

    После запуска операционной системы следует последовательно установить несколько версий Microsoft.NET.Framework. Первоначально версию 1.1, затем перейти к установке версии 3.5 и 3.0, далее вновь потребуется перезагрузка компьютера.

    В завершение остаётся включить Центр обновления Windows и уже после этого благополучно установить Microsoft.NET.Framework 4.

    Невзирая на то, что придётся потратить какое-то время на выполнение всех обозначенных действий, пользователь однозначно может гордиться полученным результатом. Новые знания, подкреплённые практическими навыками, всегда рассматриваются в качестве «золотого клада», который может пригодиться ещё много раз.

    Итак, установить платформу NET.Framework 4 на компьютер, невзирая на некоторые сложности, сможет каждый пользователь, если поверит в собственные силы и будет следовать рекомендациям опытных пользователей.

    Устранение неполадок заблокированных установок и удалений .NET Framework

    Удаление платформы Microsoft .NET Framework может вызвать неполадки в работе некоторых приложений.Uninstalling the Microsoft .NET Framework may cause some applications to cease to function. Обычно не рекомендуется удалять установленные версии .NET Framework, поскольку используемые приложения могут зависеть от конкретной версии .NET Framework.In general, you should not uninstall any versions of the .NET Framework that are installed on your computer, because an application you use may depend on a specific version of the .NET Framework. Дополнительные сведения см. в разделе .NET Framework для пользователей руководства Начало работы.For more information, see The .NET Framework for users in the Getting Started guide.
    .NET Framework 4.5.x/4.6.x/4.7.x (RUS) или более позднее обновление уже установлено на этом компьютере..NET Framework 4.5.x/4.6.x/4.7.x (ENU) or a later version is already installed on this computer. Никаких действий не требуется.No action necessary.

    Чтобы определить, какие версии платформы .NET Framework установлены в системе, см. статью Практическое руководство. Определение установленных версий платформы .NET Framework.To determine which versions of the .NET Framework are installed on a system, see How to: Determine Which .NET Framework Versions Are Installed.

    .NET Framework 4.5.x/4.6.x/4.7.x/4.8 (язык) требует наличия .NET Framework 4.5.x/4.6.x/4.7.x/4.8.The .NET Framework 4.5.x/4.6.x/4.7.x/4.8 (language) requires the .NET Framework 4.5.x/4.6.x/4.7.x/4.8. Установите.NET Framework 4.5.x/4.6.x/4.7.x/4.8 из Центра загрузки и повторно запустите программу установки.Please install the .NET Framework 4.5.x/4.6.x/4.7.x/4.8 from the Download Center and rerun Setup. Перед установкой языкового пакета необходимо установить английскую версию указанного выпуска .NET Framework.You must install the English version of the specified .NET Framework release before installing a language pack. Дополнительные сведения см. в разделе о языковых пакетах руководства по установке.For more information, see the section on To install language packs in the installation guide.
    Не удается установить .NET Framework 4.5.x/4.6.x/4.7.x/4.8.Cannot install the .NET Framework 4.5.x/4.6.x/4.7.x/4.8. Эта программа несовместима с другими приложениями на данном компьютере.Other applications on your computer are not compatible with this program.

    -или—or-

    Эта программа несовместима с другими приложениями на данном компьютере.Other applications on your computer are not compatible with this program.

    Скорее всего, на компьютере установлена предварительная или RC-версия .NET Framework.The most likely cause of this message is that a preview or RC version of the .NET Framework was installed. Удалите ее и снова запустите программу установки.Uninstall the preview or RC version and rerun Setup.
    .NET Framework 4.5.x/4.6.x/4.7.x/4.8. нельзя удалить, используя этот пакет..NET Framework 4.5.x/4.6.x/4.7.x/4.8 cannot be uninstalled using this package. Чтобы удалить .NET Framework 4.5.x/4.6.x/4.7.x/4.8. с компьютера, откройте панель управления, выберите Программы и компоненты, Просмотр установленных обновлений и «Обновление для Microsoft Windows» (KB2828152), а затем щелкните Удалить.To uninstall .NET Framework 4.5.x/4.6.x/4.7.x/4.8 from your computer, go to Control Panel, choose Programs and Features, choose View installed updates, select Update for Microsoft Windows (KB2828152) and then choose Uninstall. Устанавливаемый пакет не удаляет предварительную или RC-версию .NET Framework.The package you are installing doesn’t uninstall preview or RC releases of the .NET Framework.

    Удалите предварительную или RC-версию с помощью панели управления.Uninstall the preview or RC release from Control Panel.

    Не удается удалить .NET Framework 4.5.x/4.6.x/4.7.x/4.8.Cannot uninstall the .NET Framework 4.5.x/4.6.x/4.7.x/4.8. От этой программы зависят другие приложения на данном компьютере.Other applications on your computer are dependent on this program. Обычно не рекомендуется удалять установленные версии .NET Framework, поскольку используемые приложения могут зависеть от конкретной версии .NET Framework.In general, you shouldn’t uninstall any versions of the .NET Framework from your computer, because an application you use may depend on a specific version of the .NET Framework. Дополнительные сведения см. в разделе .NET Framework для пользователей руководства Начало работы.For more information, see The .NET Framework for users in the Getting Started guide.
    Распространяемый пакет .NET Framework 4.5.x/4.6.x/4.7.x/4.8. неприменим для этой операционной системы.The .NET Framework 4.5.x/4.6.x/4.7.x/4.8 redistributable does not apply to this operating system. Скачайте .NET Framework 4.5.x/4.6.x/4.7.x/4.8 для своей операционной системы на странице загрузки .NET Framework.Please download the .NET Framework 4.5.x/4.6.x/4.7.x/4.8 for your operating system from the .NET Framework download page. Возможно, вы пытаетесь установить .NET Framework 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2 или 4.8 на платформу, которая не поддерживается, или выбрали пакет установки, в котором отсутствуют компоненты для некоторых операционных систем.You may be trying to install .NET Framework 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2, or 4.8 on a platform that isn’t supported, or you have chosen the installation package that does not include the components for all supported operating systems. Повторите установку с помощью автономного установщика (для 4.5.1, для 4.5.2, для 4.6, для 4.6.1, для 4.6.2, для 4.7), для 4.7.1, для 4.7.2 или для 4.8.Run the installation again by using the offline installer (for 4.5.1, for 4.5.2, for 4.6, for 4.6.1, for 4.6.2, for 4.7), for 4.7.1, for 4.7.2, or for 4.8. Дополнительные сведения см. в руководстве по установке и в требованиях к системе для поддерживаемых операционных систем.For more information, see the installation guide and system requirements for supported operating systems.
    Перед установкой продукта необходимо установить обновление, соответствующее KB<number>.The update corresponding to KB<number> needs to be installed before you can install this product. Перед установкой .NET Framework требуется установить обновление KB.Installation of the .NET Framework requires that a KB update be installed before installing the .NET Framework. Установите обновление, а затем повторно начните установку .NET Framework.Install the update, and then begin the .NET Framework installation again.

    Например, для установки обновленных версий .NET Framework в ОС Windows 8.1, Windows RT 8.1 и Windows Server 2012 R2 необходимо установить обновление, соответствующее KB2919355.For example, installation of updated versions of the .NET Framework on Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2 requires that the update corresponding to KB 2919355 be installed.

    В настоящее время на компьютере установлены основные серверные компоненты операционной системы Windows Server 2008.Your computer is currently running a Server Core installation of the Windows Server 2008 operating system. Для установки .NET Framework 4.5.x требуется более поздний выпуск операционной системы.The .NET Framework 4.5.x requires a later release of the operating system. Установите Windows Server 2008 R2 с пакетом обновления 1 (SP1) или более поздней версии и перезапустите программу установки .NET Framework 4.5.x.Please install Windows Server 2008 R2 SP1 or higher and rerun .NET Framework 4.5.x setup. .NET Framework 4.5.1 b 4.5.2 поддерживается в роли Server Core с Windows Server 2008 R2 с пакетом обновления 1 (SP1) или более поздней версии.The .NET Framework 4.5.1 and 4.5.2 are supported in the Server Core role with Windows Server 2008 R2 SP1 or later. См. раздел Требования к системе.See System Requirements.
    У вас недостаточно прав для завершения этой операции для всех пользователей данного компьютера.You do not have sufficient privileges to complete this operation for all users of this computer. Войдите в систему как администратор и перезапустите операцию Установка.Log on as an administrator and rerun Setup. Для установки .NET Framework требуются права администратора.You must be an administrator on the computer to install the .NET Framework.
    Невозможно продолжить установку, поскольку другая установка требует перезагрузки компьютера.Setup cannot continue because a previous installation requires your computer to be restarted. Перезагрузите свой компьютер и перезапустите программу установки.Please restart your computer and rerun Setup. Перезагрузка иногда требуется для завершения установки.A restart is sometimes required to fully complete an installation. Выполните инструкции по перезагрузке компьютера и снова запустите программу установки.Follow the instructions to restart your computer and rerun Setup.

    В редких случаях может быть предложено несколько раз перезагрузить компьютер, если ОС Windows обнаружила несколько отсутствующих обновлений и перезапускается для установки следующего обновления в очереди.In rare cases, you may be asked to restart your system more than once if Windows has detected a number of missing updates and is restarting to install the next update in the queue.

    Не удается установить .NET Framework в режиме совместимости программ..NET Framework Setup cannot be run in Program Compatibility Mode. См. подробнее о проблемах с совместимостью программ далее в этой статье.See the Program Compatibility Issues section later in this article.
    Не удалось установить .NET Framework 4.5.x/4.6.x/4.7.x/4.8., так как хранилище компонентов повреждено..NET Framework 4.5.x/4.6.x/4.7.x/4.8 has not been installed because the component store has been corrupted. Дополнительные сведения см. в статье Исправление ошибок Центра обновления Windows с помощью системы DISM или средства проверки готовности системы к обновлению.See Fix Windows Update errors by using the DISM or System Update Readiness tool for more information.
    Не удается запустить программу установки, поскольку на этом компьютере недоступен установщик Windows.Setup cannot run because the Windows Installer Service is not available on this computer. См. статью Ошибка «Не удалось получить доступ к службе установщика Windows » при попытке установить программу в Windows 7 или Windows Vista на веб-сайте службы поддержки Майкрософт.See «The Windows Installer Service Could Not Be Accessed» error when you try to install a program in Windows 7 or Windows Vista on the Microsoft Support website.
    Программа установки может работать ненадлежащим образом, поскольку на компьютере недоступна служба Центра обновления Windows.Setup may not run properly because the Windows Update Service is not available on this computer. Вместо службы Центра обновления Microsoft Windows могут использоваться службы Windows Server Update Services (WSUS).The computer may be configured to use Windows Server Update Services (WSUS) instead of Microsoft Windows Update. Дополнительные сведения см в разделе с кодом ошибки 0x800F0906 в ошибке установки платформы .NET Framework 3.5: 0x800F0906, 0x800F081F, 0x800F0907.For more information, see the section for error code 0x800F0906 in .NET Framework 3.5 installation error: 0x800F0906, 0x800F081F, 0x800F0907.

    См. также статью Получение последней версии агента Центра обновления Windows на веб-сайте службы поддержки Майкрософт.Also see How to update the Windows Update Agent to the latest version on the Microsoft Support website.

    Программа установки может работать ненадлежащим образом, поскольку на компьютере недоступна фоновая интеллектуальная служба передачи данных (BITS).Setup may not run properly because the Background Intelligent Transfer Service (BITS) is not available on this computer. См. раздел об обновлении, позволяющем исправить сбой фоновой интеллектуальной службы передачи данных (BTIS) на компьютере с ОС Windows Vista на веб-сайте службы поддержки Майкрософт.See An update is available to fix a Background Intelligent Transfer Service (BITS) crash on a Windows Vista-based computer on the Microsoft Support website.
    Программа установки может работать неправильно, поскольку обновление Windows обнаружило ошибку и отображает код ошибки 0x80070643 или 0x643.Setup may not run properly because Windows update encountered an error and displayed error code 0x80070643 or 0x643. См. статью об ошибке установки обновления .NET Framework с кодом 0x80070643 или 0x643 на веб-сайте службы поддержки Майкрософт.See .NET Framework update installation error: «0x80070643» or «0x643» on the Microsoft Support website.
    .NET Framework 4.5.x/4.6.x/4.7.x/4.8. уже существует в этой операционной системе.The .NET Framework 4.5.x/4.6.x/4.7.x/4.8 is already a part of this operating system. Устанавливать распространяемый пакет .NET Framework 4.5.x/4.6.x/4.7.x/4.8. не нужно.You do not need to install the .NET Framework 4.5.x/4.6.x/4.7.x/4.8 redistributable. Никаких действий не требуется.No action.

    Чтобы определить, какие версии платформы .NET Framework установлены в системе, см. статью Практическое руководство. Определение установленных версий платформы .NET Framework.To determine which versions of the .NET Framework are installed on a system, see How to: Determine Which .NET Framework Versions Are Installed. Список поддерживаемых операционных систем см. в разделе Требования к системе.See System Requirements for supported operating systems.

    .NET Framework 4.5.x/4.6.x/4.7.x/4.8. не поддерживается в этой операционной системе.The .NET Framework 4.5.x/4.6.x/4.7.x/4.8 is not supported on this operating system. Список поддерживаемых операционных систем см. в разделе Требования к системе.See System Requirements for supported operating systems.

    Для неудачных установок платформы .NET Framework в Windows 7 это сообщение обычно указывает на то, что не установлен пакет обновления 1 (SP1) для Windows 7.For failed installations of the .NET Framework on Windows 7, this message typically indicates that Windows 7 SP1 is not installed. В системах Windows 7 платформе .NET Framework требуется пакет обновления 1 (SP1) для Windows 7.On Windows 7 systems, the .NET Framework requires Windows 7 SP1. Если вы используете Windows 7 и еще не установили пакет обновления 1 (SP1), это необходимо сделать перед установкой платформы .NET Framework.If you are on Windows 7 and have not yet installed Service Pack 1, you will need to do so before installing the .NET Framework. Сведения об установке Windows 7 с пакетом обновления 1 (SP1) см. в разделе Сведения об установке Windows 7 с пакетом обновления 1 (SP1).For information on installing Windows 7 SP1, see Learn how to install Windows 7 Service Pack 1 (SP1).

    На компьютере установлена версия Server Core операционной системы Windows Server 2008.Your computer is currently running a Server Core installation of Windows Server 2008 operating system. Для работы .NET Framework 4.5.x требуется полный выпуск операционной системы или Server Core 2008 R2 с пакетом обновления 1 (SP1).The .NET Framework 4.5.x requires a full release of the operating system or Server Core 2008 R2 SP1. Установите полную версию Windows Server 2008 с пакетом обновления 2 (SP2), Windows Server 2008 R2 с пакетом обновления 1 (SP1) или Server Core 2008 R2 с пакетом обновления 1 (SP1) и перезапустите программу установки .NET Framework 4.5.x.Please install the full version of Windows Server 2008 SP2 or Windows Server 2008 R2 SP1 or Server Core 2008 R2 SP1 and rerun .NET Framework 4.5.x Setup. .NET Framework поддерживается в роли Server Core с Windows Server 2008 R2 с пакетом обновления 1 (SP1) или более поздней версии.The .NET Framework is supported in the Server Core role with Windows Server 2008 R2 SP1 or later. См. раздел Требования к системе.See System Requirements.
    .NET Framework 4.5.x уже входит в состав операционной системы, но пока этот компонент отключен (только для Windows Server 2012).The .NET Framework 4.5.x is already a part of this operating system but is currently turned off (Windows Server 2012 only). Чтобы включить платформу .NET Framework 4.5.x, используйте раздел Включение или отключение компонентов Windows на панели управления.Use Turn Windows features on or off in the Control Panel to turn on .NET Framework 4.5.x.
    Для этой программы установки требуется компьютер с процессором x86.This setup program requires an x86 computer. Ее нельзя запускать на компьютерах с процессорами x64 или IA64.It cannot be installed on x64 or IA64 computers. См. раздел Требования к системе.See System Requirements.
    Для этой программы установки требуется компьютер с процессором x64 или x86.This setup program requires x64 or x86 computer. Ее невозможно установить на компьютер с процессором IA64.It cannot be installed on IA64 computers. См. раздел Требования к системе.See System Requirements.

    Установка платформы .NET Framework в Windows 8

    • Чтение занимает 2 мин

    В этой статье

    Для многих приложений, работающих в ОС Windows, требуется платформа .NET Framework.The .NET Framework is required to run many applications on Windows. Приведенные ниже инструкции помогут вам установить ее.You can use the following instructions to install it. Вы могли попасть на эту страницу после попытки запуска приложения и отображения следующего диалогового окна.You may have arrived on this page after trying to run an application and seeing the following dialog on your machine.

    Эти инструкции помогут вам установить необходимые версии .NET Framework.These instructions will help you install the .NET Framework versions you need. .NET Framework 4.8 является самой новой версией.The .NET Framework 4.8 is the latest version. Она поддерживается в Windows Server 2012, но не в Windows 8.It is supported on Windows Server 2012 but is not supported on Windows 8. Она входит в состав обновления Windows 10 за май 2019 г.It is included with the Windows 10 May 2019 Update).

    .NET Framework 4.8.NET Framework 4.8

    .NET Framework 4.8 поддерживается в Windows Server 2012.The .NET Framework 4.8 is supported on Windows Server 2012. Она не поддерживается в Windows 8.It is not supported on Windows 8.

    .NET Framework 4.8 можно использовать для запуска приложений, созданных для .NET Framework 4.0 или более поздней версии.The .NET Framework 4.8 can be used to run applications built for .NET Framework 4.0 or later.

    .NET Framework 4.6.NET Framework 4.6

    .NET Framework 4.6 является последней поддерживаемой версией платформы .NET Framework в Windows 8.The .NET Framework 4.6 is the latest supported .NET Framework version on Windows 8.

    Платформа .NET Framework 4.6 поддерживает приложения, созданные для платформы .NET Framework версий с 4.0 по 4.6.The .NET Framework 4.6 supports apps built for .NET Framework 4.0 through 4.6.

    .NET Framework 3,5.NET Framework 3.5

    Следуйте инструкциям по установке .NET Framework 3.5 в Windows 8 и 10.Follow the instructions to install the .NET Framework 3.5 on Windows 8 and 10.

    Платформа .NET Framework 3.5 поддерживает приложения, собранные для платформы .NET Framework версий с 1.0 по 3.5.The .NET Framework 3.5 supports apps built for .NET Framework 1.0 through 3.5.

    СправкаHelp

    Вы можете обратиться за помощью в корпорацию Майкрософт, если не можете определить правильную версию установленной платформы .NET Framework.You can contact Microsoft for help if you cannot get the correct version of the .NET Framework installed.

    См. также разделSee also

    Устранение неполадок при заблокированных установках и удалениях .NET Framework

    • 8 минут на чтение

    В этой статье

    При запуске веб-программы или автономной программы установки .NET Framework 4.5 или более поздних версий вы можете столкнуться с проблемой, которая препятствует или блокирует установку.NET Framework. В следующей таблице перечислены возможные проблемы с блокировкой и приведены ссылки на информацию об устранении неполадок.

    В Windows 8 и более поздних версиях .NET Framework является компонентом операционной системы и не может быть удален независимо. Обновления .NET Framework отображаются на вкладке «Установленные обновления » приложения «Программы и компоненты панели управления». Для операционных систем, в которых .NET Framework не предустановлена, .NET Framework отображается на вкладке Удаление или изменение программы (или на вкладке «Установка и удаление программ» ) приложения «Программа и компоненты» на панели управления. .Для получения информации о версиях Windows, на которых предустановлена ​​.NET Framework, см. Системные требования.

    Важно

    Поскольку версии .NET Framework 4.x являются обновлениями на месте, вы не можете установить более раннюю версию .NET Framework 4.x в системе, в которой уже установлена ​​более поздняя версия. Например, в системе с Windows 10 Fall Creators Update нельзя установить .NET Framework 4.6.2, поскольку .NET Framework 4.7.1 предустановлен вместе с операционной системой.

    Вы можете определить, какие версии .NET Framework установлены в системе. Дополнительные сведения см. В разделе Как определить, какие версии .NET Framework установлены.

    В этой таблице 4.5.x относится к .NET Framework 4.5 и его точечным выпускам, 4.5.1 и 4.5.2, 4.6.x относится к .NET Framework 4.6 и его точечным выпускам, 4.6.1 и 4.6. 2, 4.7.x относится к .NET Framework 4.7 и его точечным выпускам, 4.7.1 и 4.7.2, а 4.8 относится к .NET Framework 4.8.

    Сообщение о блокировке Для получения дополнительной информации или решения проблемы
    Удаление Microsoft.NET Framework может привести к прекращению работы некоторых приложений. Как правило, не следует удалять какие-либо версии .NET Framework, установленные на вашем компьютере, поскольку используемое вами приложение может зависеть от конкретной версии .NET Framework. Дополнительные сведения см. В разделе «.NET Framework для пользователей» в руководстве по началу работы с .
    .NET Framework 4.5.x / 4.6.x / 4.7.x (ENU) или более поздняя версия уже установлена ​​на этом компьютере. Никаких действий не требуется.

    Чтобы определить, какие версии .NET Framework установлены в системе, см. Раздел Практическое руководство. Определение установленных версий .NET Framework.

    Для .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 (, язык ) требуется .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8. Установите .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 из центра загрузки и повторно запустите программу установки. Перед установкой языкового пакета необходимо установить английскую версию указанного выпуска .NET Framework.Дополнительные сведения см. В разделе «Установка языковых пакетов» в руководстве по установке.
    Не удается установить .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8. Другие приложения на вашем компьютере несовместимы с этой программой.

    -или-

    Другие приложения на вашем компьютере несовместимы с этой программой.

    Наиболее вероятная причина появления этого сообщения заключается в том, что была установлена ​​предварительная версия или версия RC .NET Framework. Удалите предварительную версию или версию RC и повторно запустите программу установки.
    .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 нельзя удалить с помощью этого пакета. Чтобы удалить .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 со своего компьютера, перейдите в панель управления , выберите «Программы и компоненты» , выберите Просмотреть установленные обновления , выберите «Обновление для Microsoft Windows» (KB2828152 ), а затем выберите Удалить . Устанавливаемый вами пакет не удаляет предварительную версию или выпуски RC .NET Framework.

    Удалите предварительную версию или выпуск RC из Панели управления.

    Не удается удалить .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8. Другие приложения на вашем компьютере зависят от этой программы. Как правило, вам не следует удалять какие-либо версии .NET Framework с вашего компьютера, поскольку используемое вами приложение может зависеть от конкретной версии .NET Framework. Дополнительные сведения см. В разделе «.NET Framework для пользователей» в руководстве по началу работы с .
    .NET Framework 4.Распространяемый пакет 5.x / 4.6.x / 4.7.x / 4.8 не распространяется на эту операционную систему. Загрузите .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 для своей операционной системы со страницы загрузки .NET Framework. Возможно, вы пытаетесь установить .NET Framework 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2 или 4.8 на платформе, которая не поддерживается, или вы выбрали установочный пакет, который не включает компоненты для всех поддерживаемых операционных систем. Снова запустите установку с помощью автономного установщика (для версии 4.5.1, для 4.5.2, для 4.6, для 4.6.1, для 4.6.2, для 4.7), для 4.7.1, для 4.7.2 или для 4.8. Для получения дополнительной информации см. Руководство по установке и системные требования для поддерживаемых операционных систем.
    Необходимо установить обновление, соответствующее KB < number >, прежде чем вы сможете установить этот продукт. Для установки .NET Framework необходимо установить обновление KB перед установкой .NET Framework. Установите обновление, а затем запустите.NET Framework снова.

    Например, для установки обновленных версий .NET Framework в Windows 8.1, Windows RT 8.1 и Windows Server 2012 R2 необходимо установить обновление, соответствующее KB 2919355.

    На вашем компьютере в настоящее время выполняется установка Server Core операционной системы Windows Server 2008. Для .NET Framework 4.5.x требуется более поздняя версия операционной системы. Установите Windows Server 2008 R2 SP1 или выше и перезапустите.NET Framework 4.5.x. .NET Framework 4.5.1 и 4.5.2 поддерживаются в роли Server Core с Windows Server 2008 R2 SP1 или более поздней версии. См. Системные требования.
    У вас недостаточно прав для выполнения этой операции для всех пользователей этого компьютера. Войдите в систему как администратор и повторно запустите Setup . Для установки .NET Framework вы должны быть администратором компьютера.
    Невозможно продолжить установку, поскольку предыдущая установка требует перезагрузки компьютера.Перезагрузите компьютер и перезапустите программу установки. Иногда для полного завершения установки требуется перезагрузка. Следуйте инструкциям, чтобы перезагрузить компьютер и повторно запустить программу установки.

    В редких случаях вас могут попросить перезагрузить систему более одного раза, если Windows обнаружила несколько отсутствующих обновлений и перезагружается для установки следующего обновления в очереди.

    Установка .NET Framework не может быть запущена в режиме совместимости программ. См. Раздел «Проблемы совместимости программ» далее в этой статье.
    .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 не установлена, поскольку хранилище компонентов повреждено. Дополнительные сведения см. В разделе Исправление ошибок Центра обновления Windows с помощью DISM или средства проверки готовности к обновлению системы.
    Не удается запустить программу установки, поскольку на этом компьютере недоступна служба установщика Windows. См. Ошибку «Не удалось получить доступ к службе установщика Windows» при попытке установить программу в Windows 7 или Windows Vista на веб-сайте поддержки Microsoft.
    Программа установки может работать некорректно, поскольку на этом компьютере недоступна служба обновления Windows. Компьютер может быть настроен для использования служб Windows Server Update Services (WSUS) вместо Microsoft Windows Update. Дополнительные сведения см. В разделе с кодом ошибки 0x800F0906 в ошибке установки .NET Framework 3.5: 0x800F0906, 0x800F081F, 0x800F0907.

    См. Также раздел Как обновить агент Центра обновления Windows до последней версии на веб-сайте поддержки Microsoft.

    Программа установки может работать некорректно, так как фоновая интеллектуальная служба передачи (BITS) недоступна на этом компьютере. См. Доступно обновление для устранения сбоя фоновой интеллектуальной службы передачи (BITS) на компьютере под управлением Windows Vista на веб-сайте поддержки Microsoft.
    Программа установки может работать некорректно, так как Центр обновления Windows обнаружил ошибку и отобразил код ошибки 0x80070643 или 0x643. См. Раздел Ошибка установки обновления .NET Framework: «0x80070643» или «0x643» на веб-сайте поддержки Microsoft.
    .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 уже является частью этой операционной системы. Вам не нужно устанавливать распространяемый пакет .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8. Нет действий.

    Чтобы определить, какие версии .NET Framework установлены в системе, см. Раздел Практическое руководство. Определение установленных версий .NET Framework. См. Системные требования для поддерживаемых операционных систем.

    .NET Framework 4.5.x / 4.6.x / 4.7.x / 4.8 не поддерживается в этой операционной системе. См. Системные требования для поддерживаемых операционных систем.

    При неудачной установке .NET Framework в Windows 7 это сообщение обычно означает, что Windows 7 SP1 не установлен. В системах Windows 7 для .NET Framework требуется Windows 7 SP1. Если вы работаете в Windows 7 и еще не установили пакет обновления 1, вам необходимо сделать это перед установкой .NET Framework. Для получения информации об установке Windows 7 SP1 см. Узнайте, как установить Windows 7 Service Pack 1 (SP1).

    На вашем компьютере в настоящее время выполняется установка Server Core операционной системы Windows Server 2008. Для .NET Framework 4.5.x требуется полная версия операционной системы или Server Core 2008 R2 SP1. Установите полную версию Windows Server 2008 SP2 или Windows Server 2008 R2 SP1 или Server Core 2008 R2 SP1 и повторно запустите установку .NET Framework 4.5.x. .NET Framework поддерживается в роли Server Core с Windows Server 2008 R2 SP1 или более поздней версии.См. Системные требования.
    .NET Framework 4.5.x уже является частью этой операционной системы, но в настоящее время отключен (только для Windows Server 2012). Использование Включение и выключение функций Windows на панели управления для включения .NET Framework 4.5.x.
    Для этой программы установки требуется компьютер x86. Его нельзя установить на компьютеры x64 или IA64. См. Системные требования.
    Для этой программы установки требуется компьютер x64 или x86.Его нельзя установить на компьютерах IA64. См. Системные требования.

    Проблемы совместимости программ

    Установка .NET Framework 4.5 или его точечных выпусков завершается ошибкой с кодом 1603 или блокируется при работе в режиме совместимости программ Windows. Помощник по совместимости программ указывает, что платформа .NET Framework могла быть установлена ​​неправильно, и предлагает переустановить ее, используя рекомендуемый параметр (режим совместимости программ).Режим совместимости программ также мог быть установлен помощником по совместимости программ при ранее неудачных или отмененных попытках запустить программу установки .NET Framework.

    Установщик .NET Framework не может работать в режиме совместимости программ. Чтобы решить эту проблему блокировки, необходимо использовать редактор реестра, чтобы убедиться, что параметр режима совместимости не включен для всей системы:

    1. Нажмите кнопку Start , а затем выберите Run .

    2. В диалоговом окне Выполнить введите «regedit», а затем выберите ОК .

    3. В редакторе реестра перейдите к следующим подразделам:

      • HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ AppCompatFlags \ Compatibility Assistant \ Persisted

      • HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ AppCompatFlags \ Layers

    4. В столбце «Имя» найдите загружаемые имена .NET Framework 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 или 4.7.2 в зависимости от версии. вы устанавливаете и удалите эти записи.Названия загружаемых файлов см. В статье Установка .NET Framework для разработчиков.

    5. Перезапустите установщик .NET Framework для версий 4.5, 4.5.1, 4.5.2 или 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 или 4.7.2.

    См. Также

    .

    Установите .NET Framework 3.5 в Windows 10, 8.1, 8

    • 2 минуты на чтение

    В этой статье

    Вам может потребоваться .NET Framework 3.5 для запуска приложения в Windows 10, Windows 8.1 и Windows 8. Вы также можете использовать эти инструкции для более ранних версий Windows.

    Загрузите автономный установщик

    The.Автономный установщик .NET Framework 3.5 SP1 доступен на странице загрузки .NET Framework 3.5 SP1 и доступен для версий Windows до Windows 10.

    Установить .NET Framework 3.5 по запросу

    Вы можете увидеть следующее диалоговое окно конфигурации, если попытаетесь запустить приложение, для которого требуется .NET Framework 3.5. Выберите Установить эту функцию , чтобы включить .NET Framework 3.5. Для этого варианта требуется подключение к Интернету.

    Почему появляется это всплывающее окно?

    The.NET Framework создана Microsoft и предоставляет среду для запуска приложений. Доступны разные версии. Многие компании разрабатывают свои приложения для работы с .NET Framework, и эти приложения нацелены на конкретную версию. Если вы видите это всплывающее окно, вы пытаетесь запустить приложение, для которого требуется .NET Framework версии 3.5, но эта версия не установлена ​​в вашей системе.

    Включите .NET Framework 3.5 на панели управления

    Вы можете включить .NET Framework 3.5 через Панель управления Windows. Для этого варианта требуется подключение к Интернету.

    1. Нажмите клавишу Windows на клавиатуре, введите «Компоненты Windows» и нажмите Enter. Откроется диалоговое окно Включение или отключение компонентов Windows .

    2. Установите флажок .NET Framework 3.5 (включает .NET 2.0 и 3.0) , выберите OK и перезагрузите компьютер, если будет предложено.

      Вам не нужно выбирать дочерние элементы для Windows Communication Foundation (WCF) HTTP-активации и Windows Communication Foundation (WCF) Non-HTTP Activation , если вы не разработчик или администратор сервера, которому требуется эта функция.

    Устранение неполадок при установке .NET Framework 3.5

    Во время установки может возникнуть ошибка 0x800f0906, 0x800f0907, 0x800f081f или 0x800F0922; в этом случае обратитесь к ошибке установки .NET Framework 3.5: 0x800f0906, 0x800f0907 или 0x800f081f, чтобы узнать, как решить эти проблемы.

    Если вы по-прежнему не можете решить проблему с установкой или у вас нет подключения к Интернету, вы можете попробовать установить его с установочного носителя Windows.Дополнительные сведения см. В разделе Развертывание .NET Framework 3.5 с помощью обслуживания образов развертывания и управления ими (DISM). Если у вас нет установочного носителя, см. Раздел Создание установочного носителя для Windows.

    Предупреждение

    Если вы не полагаетесь на Центр обновления Windows как на источник для установки .NET Framework 3.5, вы должны убедиться, что строго используете источники той же соответствующей версии операционной системы Windows. Использование исходного пути, который не соответствует той же версии Windows, не предотвратит несовпадение версии.NET Framework 3.5 от установки. Однако это приведет к тому, что система окажется в неподдерживаемом и неработающем состоянии.

    .

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *