Разное

Настройка mikrotik multicast: Настройка IPTV от Ростелеком на роутерах MikroTik / Хабр

Настройка IPTV от Ростелеком на роутерах MikroTik / Хабр

В свое время когда я купил роутер MikroTik, передо мной кроме базовой настройки инета встала задача обеспечить работу IPTV, до того момента у меня был установленный Ростелекомом D-link. Сама базовая настройка инета на микротике заняла у меня примерно 10 минут, а вот с IPTV пришлось повозиться. Все мануалы прочитанные мной тогда не учитывали многих моментов, до которых я дошел расковыряв настройки многострадального D-link-а и без которых работать в данной схеме ТВ нормально не будет. В этой статье я хочу обозначить полученную мной универсальную инструкцию в данной ситуации.

В первую очередь обновим прошивку до последней. Подключаемся к нашему роутеру через Winbox, идем в [System]->[Packages] -> [Check for updates]. Если вышла более новая версия Routeros чем установлена у вас на девайсе, жмем Download & Install после чего новая версия будет скачана и маршрутизатор уйдет в перезагрузку.

После выполнения данных действий идем сюда и выбираем пакеты которые нужно загрузить для вашего устройства, в моем случае это haP series и выбираю я extra packages для текущей версии (6.43.4 на момент написания статьи).

Будет скачан архив из которого нужно будет распаковать файл multicast, открыть в winbox пункт files и перетащить распакованный нами файл прямо туда. После чего необходимо перезагрузить наш маршрутизатор ( идем в [System]->[Reboot]).

После перезагрузки в разделе Routing должен появиться пункт IGMP Proxy, если этого не произошло проверяем прошлые шаги — нужный ли пакет мы ставили ( для того ли девайса скачали, версии прошивки). В случае успеха идем дальше.

В IGMP Proxy на первой вкладке щелкаем знак [+] для создания так называемого Upstream. В пункте interface выбираем порт куда у нас вставлен шнур от провайдера, даже в случае если вы у вас используется PPPoE соединение выбираем именно физический порт, это очень важный момент. Помечаем галочку Upstream и в Alternative Subnets выставляем 0.0.0.0/0 и жмем Ок. Создаем второе правило для Downstream. В interface выбираем All, галочку upstream не ставим, больше никаких действий тут не требуется, просто жмем ок и все.

Следующим шагом будет настройка файрвола. Идем в [IP]->[Firewall] и [+], cоздаем новое правило Chain->forward, protocol->udp, In interface-> ether1 (порт, в который подключен кабель провайдера). Action->accept.

Создаем второе правило для IGMP. Цепочка также остается forward, protocol-> igmp, In interface-> ether1, Action->accept. Перетаскиваем созданные правила выше запрещающих.

Далее нужно блокировать прохождение мультикаст — траффика в беспроводную сеть. Идем в [Bridge] ->вкладка Filters -> [+]. Выбираем цепочку Output, out. Interface -> wlan1 то есть нашу нужную беспроводную сеть. На вкладке Advanced в packet type выбираем multicast а на вкладке Action назначаем действие drop, то есть запрет. Не забываем нажать ок чтобы сохранить настройки.

И тут пожалуй настает самый важный момент, если у вас интернет подключение идет через PPPoE, то необходимо на физический интерфейс куда подключен кабель от провайдера добавить айпишник 1.0.0.1 с маской 30 бит. В этом кстати, и заключалась проблема когда я первый раз настраивал микротик, без этого айпишника ничего не работало, а то что именно его нужно вбить я выяснил открыв настройки D-link-а. Идем в [IP]->[Adresses] и [+] и добавляем следующие настройки. В случае если используется прямое подключение без поднятия каких-либо тоннелей ( называют — IPoE), то предыдущих действий будет достаточно и данный пункт пропускаем.

Обращаю внимание на очень важный момент, после всех проделанных действий необходимо перезагрузить приставку если она была у вас включена и уже потом проверять результат настроек. В случае возникновения проблем в первую очередь советую проверить правила в файрволе.

У оператора может также быть задействована схема с использованием VLAN, в таком случае нужно на порту в который у вас подключен шнур от провайдера создать саб-интерфейс с vlan-ом передающим iptv, выяснить его номер можно попробовать через техподдержку. Идем в [interfaces]->[VLAN] и нажимаем [+] для создания нового, указываем его имя, оно не принципиально и нужно нам для удобства администрирования, VLAN ID же нужно указывать тот который дает провайдер, к примеру возьмем 234 и в interface порт в который подключен кабель провайдера. Жмем ОК.

Затем создаем новый бридж и добавляем туда созданный VLAN и порт в который подключена ваша приставка, предварительно этот порт нужно удалить из другого бриджа если он в каком либо задействован.

В свойствах самого бриджа рекомендую выставить STP в none при возникновении проблем.

В принципе я описал достаточно подробную инструкцию по данной теме. На этом все. Если есть какие либо вопросы и замечания пишите в комменты, готов ответить.

Настройка IPTV на Mikrotik

Для того что бы показывали каналы на IPTV приставке подключенной к Mikrotik требуется установить расширенный пакет multicast. 

Заходим на официальный сайт Mikrotik и скачиваем Extra packages для нашей версии прошивки (в нашем случае это 6.40.5)

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

 

Далее подключаемся к нашему устройству через Winbox, открываем Files.

Распаковываем скаченный архив и перетаскиваем пакет multicast-6.40.5-mipsbe.npk в Files.

Перезагружаем наше устройство (System -> Reboot)

После этого в разделе Routing у нас появилось меню IGMP Proxy, заходим в него и нажимаем +

В поле Interface выбираем WAN порт по которому к нам приходит интернет.

В поле Alternative Subnets указываем подсеть с которой идет вещание  IPTV. Обычно это 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16, так же можно попробовать указать 0.0.0.0/0, но лучше уточнить у поставщика услуг.

Так же ставим галочку Upstream и нажимаем OK.

 

Далее еще раз нажимаем

В разделе Interface указываем порт к которому подключена приставка или интерфейс локальной сети (в нашем случае это bridge1) и нажимаем OK.

Далее заходим в Settings 

и ставим галочку Quick Liave для быстрого переключениями между каналами.

 

 Настраиваем Firewall.

Переходим в IP -> Firewall и создадим 3 правила:

1. На вкладке General выбираем:

Chain: input

Protocol: 2 (igmp)

In. Interface: ether1 (ether1 — интерфейс на который приходит интернет)

 

На вкладе Action выбираем: accept

2. На вкладке General выбираем:

Chain: input

Protocol: 17 (udp)

Dst. Port: 1234 (Порт по которому по умолчанию передается IPTV)

In. Interface: ether1 (ether1 — интерфейс на который приходит интернет)

На вкладе Action выбираем: accept

 

3. На вкладке General выбираем:

Chain: forward

Protocol: 17 (udp)

Dst. Port: 1234 (Порт по которому по умолчанию передается IPTV)

На вкладе Action выбираем: accept

 

Далее эти правила нужно поставить выше запрещающих

После этого на приставке должны показывать каналы.

 

Если приставка или другое устройство подключено по Wi-Fi — нужно выполнить еще одну настройку:

Заходим в Wireless -> Interfaces -> wlan1 заходим на вкладку Wireless и нажимаем Advanced Mode.

Параметр WMM Support ставим enabled для включения поддержки Wi-Fi multimedia

А так же параметр Multicast Helper ставим full для  отправки мультикаст пакетов по MAC адресам клиентам.

Все, на этом настройка IPTV на MikroTik завершена.

 

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

Принимаем несколько multicast IPTV источников на MikroTik

Статья участвует в Конкурсе статей по настройке оборудования Mikrotik с операционной системой RouterOS

Очень часто в сетях крупых и не очень ISP ходит бесплатное и не очень IPTV в виде multicast потоков. Все мы знаем, что настройка IPTV сводится буквально к двум конфигурационным строкам одного из пакетов (multicast):

/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add interface=ether2

Но как быть в случае, если два и более провайдеров предоставляют вам IPTV? На ум приходит, конечно же, Bridge, но решение кажется не уместным в силу того, что два WAN будут объединены, что может негативно сказаться на вашей безопасности и, в частных случаях, может привести к авариям на сетях ISP, если вы такой не один. Что же, давайте попробуем решить этот вопрос.

Для начала, конечно же, создадим «брижд», здесь подразумевается, что ether1 и ether2 — это два аплинка (ISP1 и ISP2), предоставляющие нам услуги multicast IPTV.

/interface bridge add bridge=Bridge-WANandIPTV
/interface bridge port add interface=ether1 bridge=Bridge-WANandIPTV
/interface bridge port add interface=ether2 bridge=Bridge-WANandIPTV

Теперь нам надо разделить, какие группы от кого получать. Предположим, от  ISP2 мы хотим только 234.5.2.0/24, а от ISP1.

Примечание: узнать адресацию групп и качество вещание на них у конкретных ISP можно сперва проверив каждого отдельного оператора по плейлистам, предоставляемым публично.

/interface bridge filter
add action=accept chain=output dst-address=234.5.2.0/24 ip-protocol=igmp mac-protocol=ip out-interface=ether2
add action=drop chain=output ip-protocol=igmp mac-protocol=ip out-interface=ether2

Помните, мы говорили, что можем навредить обоим ISP (ISP1 и ISP2), если просто объединим порты в «бридж». Представьте, у ISP1 и ISP2 схемы исполнена в виде «VLAN на дом». Один широковещательный домен на доме у каждого из операторов. Мы соединили ISP1 и ISP2. Ничего страшного в начале не произошло, но… Появился еще один пользователь в вашем многоквартирном доме, который произвел аналогичные действия, например, поставив перед роутером простенький неуправляемый свитч. Вот в этот момент возникнет петля. Мы не знаем, как устроена сеть у ISP1 и ISP2, но давайте не будем участвовать в «вакханалии» вместе с неуправляемыми свитчами других пользователей, что бы оба оператора не заблокировали порты к нам. Для этого мы добавим еще одно правило в фильтрации бриджа, запрещающее обмен между портами.

/interface bridge filter
add action=drop chain=forward in-bridge=Bridge-WANandIPTV out-bridge=Bridge-WANandIPTV

Вернемся к настройке IGMP-Proxy, вместо аплинка ether1 мы используем бридж, а даунлинком у нас будет ether3. Но прежде, чем мы перейдем к непосредственной настройке IGMP, не стоит забывать, что для работы нам потребуется по IP адресу (любому) на аплинке и даунлинке, хоть /32. Давайте так и сделаем.

/ip address add interface=Bridge-WANandIPTV address=10.10.10.1/32
/ip address add interface=ether3 address=10.10.10.2/32

Непосредственно, настройка самого IGMP-Proxy. Старая конфигурация нам более не потребуется.

/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=Bridge-WANandIPTV upstream=yes
add interface=ether3

Отлично!

На этом этапе IPTV полностью должно работать. Но у нас осталась главная проблема, это — интернет. Ведь, мы заменили ether1 и ether2 одним бриджом. А, следовательно, теперь все общение с операторами должно происходить через Bridge-WANandIPTV. Предположим, ISP2 дает услугу по PPPoE, а ether1 через L2TP.

Тогда правка конфигурации в отношении PPPoE клиента должна выглядеть следующим образом:

/interface pppoe-client set 0 interface=Bridge-WANandIPTV

Таким образом, мы заставили pppoe-client ходить не через ether2, а через Bridge-WANandIPTV.

Что касается L2TP, то правка здесь будет сводиться к переводу IP для внутренней маршрутизации с ether1 на Bridge-WANandIPTV.

/ip address set [find where interface=ether1] interface=Bridge-WANandIPTV

Заключение

Как мы видим, схема приобрела законченный вид и в нее можно добавлять необходимое количество аплинков. При этом транспортные сети операторов не будут страдать от петель и подобных проблем. Для любителей «перфекционизма» также осталось пространство для деятельности. Например, можно опять же в фильтре бриджа запретить хождение PPPoE пакетов на других операторов, что бы спать спокойно и не думать о краже паролей от вашего соединения. А также, с помощью вышеуказанного фильтра можно произвести еще ряд дополнительных действий по усилению вашей собственной защиты, но об этом уже в следующей статье.

Участник конкурса Александр

Просьба всем кто читает статьи, участвующие в конкурсе, ставить оценки.

Данный информационный материал был создан, подготовлен и размещен специалистами ООО «ЛАНМАРТ» и является собственностью администрации проекта www.lanmart.ru. Любое использование и размещение данного материала на других ресурсах допускается только при наличии прямой ссылки на первоисточник.

multicast в wireless-сетях — Чтобы не забыть

Кратко: если у вас роутер mikrotik и вы хотите использовать udp-multicast в беспроводной сети, то надо включить опцию multicast helper в настройках интерфейса. Если этого не сделать, то пакеты будут теряться. А дальше мы посмотрим как можно диагностировать подобную ситуацию.

Обновил я свой роутер до mikrotik (оказалась очень удобная штука). В моей локальной сети для всяких разных iot был настроен zeroconfig по собственному мануалу. И тут что-то пошло не так.

Выражалось это все тем, что мультикаст с запросом адреса есть, а мультикаст-ответа нет. При этом машина, которой этот запрос предназначался, отвечала. Или ответ приходил, но спустя пол минуты или больше.

Мы можем эту итуацию наблюдать на скриншоте wireshark ниже.Рассмотрим на примере хоста diskstation.local.

На нем я смотрел в tcpdump и видел, что ответ есть.

# tcpdump port mdns
...
18:04:29.405838 IP6 fe80::e3de:bf6f:105e:ad4d.mdns > ff02::fb.mdns: 0 [2q] A (QM)? diskstation.local. AAAA (QM)? diskstation.local. (41)
18:04:29.405885 IP 192.168.88.252.mdns > 224.0.0.251.mdns: 0 [2q] A (QM)? diskstation.local. AAAA (QM)? diskstation.local. (41)
18:04:29.406152 IP6 fe80::211:32ff:fe80:3eb5.mdns > ff02::fb.mdns: 0*- [0q] 1/0/0 (Cache flush) AAAA fe80::211:32ff:fe80:3eb5 (57)
18:04:29.406388 IP diskstation.lan.mdns > 224.0.0.251.mdns: 0*- [0q] 2/0/0 (Cache flush) AAAA fe80::211:32ff:fe80:3eb5, (Cache flush) A 192.168.88.250 (73)

Интернеты не смотгли дать вразумительного ответа почему так происходит. Была лишь одна зацепка — это разбор проблем с вещанием iptv. И именно там я встретил заметку о том, что гоже было бы включить multicast helper в настройках интерфейса wifi (предварительно нажать advanced settings).

Понравилось это:

Нравится Загрузка…

Похожее

Mikrotik настройка IP-TV — Компьютер для Всех

«Mikrotik настройка IP-TV «. Для того чтоб настроить IP-TV на маршрутизаторе Mikrotik, необходимо включить пакет multicast. , Если пакет уже установлен, то в консоли маршрутизатора в который вы зашли  через Winbox или Web-интерфейс, в разделе Routing, будет доступен пункт Igmp-Proxy.
Итак начнем:

Mikrotik настройка IP-TV


 

Теперь на Mikrotik требуется установить quick-leave в положение yes. это позволит ускорить переключение между каналами. Очень полезная вещь и мы  сбережем свои нервные клетки и не разочаруемся в нашем девайсе. Далее нам требуется

MikroTik

Настройка роутера Mikrotik

Через утилиту winbox

Скачать данную утилиту возможно с сайта https://mikrotik.com/download

Ссылка на скачивание расположена в самом низу страницы.

При запуске утилиты, возможно подключиться по IP или MAC адресу. Для этого нажимает … и выбираем устройство, затем нажимаем Connect.

  1. L2TP

Заходим на роутер. В открывшимся окне заходим в IP -> DHCP Client.

Сначала выбираем необходимый нам интерфейс (WAN порт. По умолчанию ether1). Нажимаем на него 2 раза, открывается меню настройки DHCP Client’а. Нам необходимо в строке “Add Default Route” Выбрать значение “Special classless”. После этого нажимаем применить (Apply) и Renew, что бы роутер обновил маршруты. Закрываем открытые вкладки.

 

 Создаем L2TP подключение. Для этого заходим в вкладку PPP. Нажимаем «+» и выбираем “L2TP Client”.

                     

После того как откоется окно настроек нового интерфеса необходимо зайти во вторую вкладку «Dial Out». В данной вкладке необходимо прописать:

  1. Сервер для подключения (172.16.0.1),
  2. Имя и пароль для авторизации по L2TP,
  3. Включить добавление маршрутов, пункт «Add Default Route».

Заходим в настройки DNS (IP -> DNS).

Нам необходимо прописать DNS сервер для работы интернета. Прописываем 94.230.128.3 и 94.230.129.3. Жмем «ОК».

 

Настраиваем NAT. Заходим в настройки Firewall (IP -> Firewall). Выбираем вкладку NAT. И добавляем правило (жмем на «+»).

 

  1. Для начала необходимо выбрать «Out. Interface». Выбираем ранее созданное L2TP подключение.

 

Затем переходим на вкладку Action и выбираем тип «masquerade». Жмем «ОК». У нас должен появиться интернет.

 

После настройки роутера необходимо обновить его ПО.

Открываем System -> Packeges

Для обновления роутера необходимо нажать кнопку “Check For Updates”. Далее появиться следующее окно.

Нам отображается информация о том, что есть свежая версия ПО (текущая версия 6.15, свежая 6.32.3).

Возможно просто скачать (Download) или скачать и сразу обновить (Download & Upgrade). Mikrotik обновится при следующей перезагрузке и разница лишь в том, когда эта перезагрузка произойдет. При нажатии “Download & Upgrade” MikroTik уйдет на перезагрузку сразу после скачивания файлов.

  1. Настройка WiFI

Для настройки WiFi зайдите в меню Quick Set. Необходимые нам параметры «Network Name» — это имя WiFi сети (SSID) и «WiFI Password». После того как настройки будут произведены необходимо нажать «ОК» в правом вернем углу.

 

  1. IPTV

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast. Для этого выполните следующее:

  1. Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download
  2. Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии. Как это сделать можно прочитать в инструкции «Как прошить роутер.docx»;
  3. Нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;

 

  1. Распакуйте скаченный архив с дополнительными пакетами;
  2. Откройте в Winbox меню Files;
  3. Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npkв Winbox окно File List.

 

  1. Перезагрузите роутер через меню System — Rebootили через терминал командой system reboot.

После перезагрузки в меню System — Packages должен появиться модуль multicast.

 

Настройка IGMP Proxy

Откройте меню Routing — IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV.

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров: 10.0.0.0/8.

После ввода параметров нажмите кнопку OK.

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV.

В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK.  В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

 

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

 

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте меню New Terminal

 

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment=»Allow IGMP» disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=input comment=»IPTV UDP incoming» disabled=no dst-port=1234 in-interface=ether1 protocol=udp

/ip firewall filter add action=accept chain=forward comment=»IPTV UDP forwarding» disabled=no dst-port=1234 protocol=udp

ether1 — это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

После этого откройте меню IP — Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

                                                                                                                                                                                                                                          

Для работы IPTV через WiFI необходимо сделать следующее.

  1. Откройте меню Wireless.
  2. Зайдём в Interface и откроем настройки беспроводного адаптера wlan Перейдём в профессиональный режим настройки Advanced Mode.
  3. Перейдем на вкладку «Wireless». В данной вкладке необходимо включить функцию «WMM» (выбрать значение enable). Нажимаем «ОК».

Настройка IPTV на MikroTik ( IPTV + MikroTik + Beeline ) / MikroTik / Howitmake.ru

Собственно решил поделиться наработкой.
Думаю этот вариант настройки, который прост, до безобразия, подойдет для настройки iptv и у других провайдеров.
Нет необходимости ставить дополнительные пакеты для нормальной работы multicast трафика, нет необходимости настраивать правила для фаерволла, нашей приставке будет присвоен IP адрес локальной сети провайдера и доступа из интернета не будет, так что необходимость в фильтрации пакетов, совершенно, отпадает. Отдельно я просканировал IP адрес приставки, сканер, открытых портов не нашел.
На форуме beeline, по поводу этого способа настройки, написано много несусветной околесицы из серии, «Зачем светить MAC адрес в интернете?! Могут залезть» — занавес… Господа ну почитайте мат.часть хоть немного, прежде чем писать глупости!
Суть его сводится вот к чему, мы создаем мост из 2х интерфейсов
ether1 — который смотрел в сеть beeline
ether2 — к которому подключен сетевой кабель идущий от приставки ( в моем случае ether5 )

Заходим в раздел Bridge и создаем мост, назовем его bridge-to-beeline

Теперь выкидываем интерфейс ether5 из моста dridge1-lan и добавляем его в bridge-to-beeline

Чтобы было понятно за что этот интерфейс отвечает, я назвал его ether5-iptv


Аналогичным образом поступаем с интерфейсом ether1, к которому у нас подключен кабель от провайдера.

Таким образом, у нас должен получиться сетевой мост dbridge-to-beeline, в который входит 2 интерфейса:

1) ether1

2) ether5-iptv

В результате, приставка будет получать IP адрес из сети провайдера, пакеты к ней будут идти без ограничений не попадая на фаерволл.

Нам остается перенастроить DHCP-client переходим в IP->DHCP client и в настройках клиента меняем интерфейс ether1 на bridge-to-beeline

Меняем параметры маршрутизации пакетов из локальной сети в сеть провайдера, на фаерволле, теперь выходным интерфейсом у нас будет не ether1, а наш новый сетевой мост bridge-to-beeline переходим в IP -> Firewall и меняем правило маршрутизации пакетов из локальной сети.

Применительно к Beeline

Пробуем зайти на любой сайт и нас выкидывает на форму авторизации beeline, это происходит по тому что у нас изменился MAC адрес оборудования, он был сгенерирован при создании моста bridge-to-beeline вводим логин/пароль и в течении 10 мин, интернет у нас начинает работать.

Нам остается подключить приставку к порту 5 и смотреть ТВ как обычно.

Косаемо нагрузки на систему, загрузка процессора роутера не превышает 40%, согласно системы мониторинга Zabbix( да роутер у меня мониторится), так что запас ресурсов позволяет еще навешать функционала на эту железку.

На этом я закончу.

Другие статьи об оборудовании Mikrotik можно посмотреть в на этой странице

Принимаем несколько источников многоадресного IPTV на MikroTik

Статья участвует в Конкурсе статей по настройке оборудования Mikrotik с операционной системой RouterOS

Очень часто в сетях крупных и не очень ISP ходит бесплатно и не очень IPTV в виде multicast потоков. Все мы знаем, что настройка IPTV сводится к двум конфигурационным строкам одного из пакетов ( многоадресной передачи ):

/ интерфейс igmp-proxy маршрутизации
добавить альтернативные подсети = 0.0.0.0 / 0 interface = ether1 upstream = yes
add interface = ether2

Но как быть в случае, если два и более провайдеров предоставляют вам IPTV ? На ум приходит, конечно же, Bridge , но кажется не уместным решением того, что два WAN будут объединены, что может негативно сказаться на вашей безопасности и, в частных случаях, может привести к аварии на сетях ISP , если вы такой не один. Что же, давайте попробуем решить этот вопрос.

Для начала, конечно же, создадим « брижд », здесь подразумевается, что ether1 и ether2 — это два аплинка ( ISP1 и ISP2 ), предоставляющие нам услуги многоадресной передачи IPTV .

/ interface bridge add bridge = Bridge-WANandIPTV
/ interface bridge port add interface = ether1 bridge = Bridge-WANandIPTV
/ interface bridge port add interface = ether2 bridge = Bridge-WANandIPTV

Теперь нам надо Разделить, какие группы от кого получать.Предположим, от ISP2 мы хотим только 234.5.2.0/24 , а от ISP1 .

Примечание: узнать адрес и качество вещания на них отдельных ISP можно заказать для каждого отдельного оператора по плейлистам, предоставленным публично.

/ interface bridge filter
add action = accept chain = output dst-address = 234.5.2.0 / 24 ip-protocol = igmp mac-protocol = ip out-interface = ether2
add action = drop chain = output ip-protocol = igmp mac-protocol = ip out-interface = ether2

Помните, мы говорили, что можем навредить обоим ISP ( ISP1 и ISP2 ), если просто объединим порты в «бридж».Представьте, у ISP1 и ISP2 схемы исполнена в виде « VLAN на дом». Один широковещательный домен на доме у каждого из операторов. Мы соединили ISP1 и ISP2 . Ничего страшного в начале не произошло, но … Появился еще один пользователь в вашем многоквартирном доме, который произвел аналогичные действия, например, поставив перед роутером простенький неуправляемый свитч. Вот в этот момент возникнет петля. Мы не знаем, как устроена сеть у ISP1 и ISP2 , но давайте не будем участвовать в «вакханалии» вместе с неуправляемыми свитчами других пользователей, что бы оба оператора не заблокировали порты к нам.Для этого мы добавим еще одно правило в фильтрации бриджа, запрещающее обмен между портами.

/ interface bridge filter
add action = drop chain = forward in-bridge = Bridge-WANandIPTV out-bridge = Bridge-WANandIPTV

Вернемся к настройке IGMP-Proxy , вместо аплинка ether1 мы используем бридж, а даунлинком у нас будет ether3 . Но прежде, чем мы перейдем к непосредственной настройке IGMP , не стоит забывать, что для работы нам потребуется по IP адресу (любому) на аплинке и даунлинке, хоть /32 .Давайте так и сделаем.

/ ip address add interface = Bridge-WANandIPTV address = 10.10.10.1 / 32
/ ip address add interface = ether3 address = 10.10.10.2 / 32

Непосредственно, настройка самого IGMP-Proxy . Старая конфигурация нам более не потребуется.

/ роутинг igmp-proxy interface
add alternate-subnets = 0.0.0.0 / 0 interface = Bridge-WANandIPTV upstream = yes
add interface = ether3

Отлично!

На этом этапе IPTV полностью должно работать.Но у нас осталась главная проблема, это — интернет. Ведь мы заменили ether1 и ether2 одним бриджом. А, следовательно, теперь должно быть все общение с операторами происходить через Bridge-WANandIPTV . Предположим, ISP2 дает услугу по PPPoE , а ether1 через L2TP.

Тогда правка конфигурации в отношении PPPoE клиента должна выглядеть следующим образом:

/ interface pppoe-client set 0 interface = Bridge-WANandIPTV

Таким образом, мы заставили pppoe-client и не через ether2 , а через Bridge-WANandIPTV .

Что касается L2TP , здесь будет сводиться к переводу IP для внутренней маршрутизации с ether1 на Bridge-WANandIPTV.

/ набор IP-адресов [найти где interface = ether1] interface = Bridge-WANandIPTV

Заключение

Как мы видим, схема приобрела законченный вид и в нее можно добавить необходимое количество аплинков. При этом транспортные сети не будут страдать от петель и подобных проблем.Для любителей «перфекционизма» также осталось пространство для деятельности. Например, можно опять же в фильтре бриджа запретить хождение пакетов PPPoE на других операторов, что бы спокойно спать о краже паролей от вашего соединения. А также с помощью вышеуказанного фильтра может быть усилен ряд действий по вашей собственной статье.

Участник конкурса Александр

Просьба всем кто читает статьи, участвующие в конкурсе, ставить оценку.

Информационный материал был создан, подготовлен и размещен специалистами ООО «ЛАНМАРТ» и является собственностью администрации проекта www.lanmart.ru. Любое использование данного материала на других ресурсах только при наличии ссылки на первоисточник.

.

мультикаст в беспроводных сетях — Чтобы не забыть

Кратко: если у вас роутер mikrotik и вы хотите использовать udp-multicast в беспроводной сети, то надо включить опцию multicast helper в настройках интерфейса. Если этого не сделать, то пакеты будут теряться. А дальше мы посмотрим как можно диагностировать подобную ситуацию.

Обновил я свой роутер до mikrotik (оказалась очень удобная штука). В моей сети для всяких разных iot был настроен zeroconfig по собственному мануалу.И тут что-то пошло не так.

Выражалось это все тем, что мультикаст с запросом адреса есть, а мультикаст-ответа нет. При этом машина, которой этот запрос предназначался, отвечала. Или ответ приходил, но спустя пол минуты или больше.

Мы можем эту итурировать на скриншоте wirehark ниже.Рассмотрим пример хоста diskstation.local.

На нем я смотрел в tcpdump и видел, что ответ есть.

 # порт tcpdump mdns
...
18: 04: 29.405838 IP6 fe80 :: e3de: bf6f: 105e: ad4d.mdns> ff02 :: fb.mdns: 0 [2q] A (QM)? diskstation.local. AAAA (QM)? diskstation.local. (41)
18: 04: 29.405885 IP 192.168.88.252.mdns> 224.0.0.251.mdns: 0 [2q] A (QM)? diskstation.local. AAAA (QM)? diskstation.local. (41)
18: 04: 29.406152 IP6 fe80 :: 211: 32ff: fe80: 3eb5.mdns> ff02 :: fb.mdns: 0 * - [0q] 1/0/0 (очистка кеша) AAAA fe80 :: 211: 32ff: fe80 : 3eb5 (57)
18: 04: 29.406388 IP diskstation.lan.mdns> 224.0.0.251.mdns: 0 * - [0q] 2/0/0 (очистка кеша) AAAA fe80 :: 211: 32ff: fe80: 3eb5, (очистка кеша) A 192.168.88.250 (73) 

Интернеты не смотгли дать вразумительного ответа почему так происходит. Была лишь одна зацепка — это разбор проблем с вещанием iptv. И там я встретил заметку о том, что гоже было бы включить помощник многоадресной рассылки в настройках интерфейса Wi-Fi (нажмите расширенные настройки).

Понравилось это:

Нравится Загрузка …

Похожее

.

Настройка IPTV от Ростелеком на роутерах MikroTik / Хабр

В свое время, когда я купил роутер MikroTik, передо мной, кроме установленной установки, встала задача обеспечить работу IPTV, до того момента у меня был установленный Ростелекомом D-link. Сама базовая настройка инета на микротике заняла у меня примерно 10 минут, а вот с IPTV пришлось повозиться. Все мануалы, прочитанные мной, не учитывают многих моментов, до которых я дошел расковыряв многострадального D-link-а и без которых работать в данной схеме ТВ нормально не будет.В этой статье я хочу обозначить полученную мной универсальную инструкцию в данной ситуации.

В первую очередь обновим прошивку до последней. Подключаемся к нашей роутеру через Winbox, идем в [Система] -> [Пакеты] -> [Проверить обновления]. Если вышла более новая версия Routeros чем установлена ​​у вас на девайсе, жмем Загрузить и установить после чего новая версия будет скачана и маршрутизатор уйдет в перезагрузку.

После выполнения данных действий идем сюда и выбираем пакеты, которые нужно загрузить для вашего устройства, в моем случае это серия haP и выбираю дополнительные пакеты для текущей версии (6.43.4 на момент написания статьи).

Будет скачан архив из которого нужно будет распаковать файл многоадресной рассылки, открыть в winbox пункт файлы и перетащить распакованный файл прямо туда. После чего необходимо перезагрузить наш маршрутизатор (идем в [System] -> [Reboot]).

После перезагрузки в разделе «Маршрутизация» должен появиться пункт прокси-сервера IGMP, если этого не произошло, проверяем прошлые шаги — нужный пакет мы ставили (для того ли девайса скачали, версии прошивки).В случае успеха идем дальше.

В прокси-сервере IGMP на первой вкладке щелкаем знак [+] для создания так называемого восходящего потока. В интерфейсе выбирается порт, куда у нас вставлен шнур от провайдера, даже если вы у вас используется соединение PPPoE, выбирая именно физический порт, это очень важный момент. Помечаем галочку Upstream и в альтернативных подсетях выставляем 0.0.0.0/0 и жмем Ок. Создаем второе правило для Downstream. В интерфейсе выбираем All, галочку вверх не ставим, больше никаких действий тут не требуется, просто жмем ок и все.

Следующим шагом будет настройка файрвола. Идем в [IP] -> [Межсетевой экран] и [+], cоздаем новое правило Цепочка-> пересылка, протокол-> UDP, В интерфейсе-> ether1 (порт, в который подключен кабель провайдера). Действие-> принять.

Создаем второе правило для IGMP. Цепочка также остается forward, protocol-> igmp, In interface-> ether1, Action-> accept. Перетаскиваем созданные правила выше запрещающих.

Далее нужно блокировать прохождение мультикаст — траффика в беспроводную сеть.Идем в [Bridge] -> вкладка Filters -> [+]. Выбираем цепочку Вывод, вых. Интерфейс -> wlan1 то есть нашу нужную беспроводную сеть. На вкладке Расширенный тип пакета выбираем многоадресную рассылку а на вкладке Действие назначаем действие drop, то есть запрет. Не забываем нажать ок, чтобы сохранить настройки.

И тут пожалуй настает самый важный момент, если у вас подключение к Интернету идет через PPPoE, то необходимо на физический интерфейс, куда подключается кабель от провайдера добавить айпишник 1.0.0.1 с маской 30 бит. В этом кстати, и ничего заключалась проблема, когда я первый раз настраивал микротик, без этого айпишника не работало, а то что именно его нужно вбить я пробил открывал D-линк-а. Идем в [IP] -> [Адреса] и [+] и добавляем следующие настройки. В случае если используется прямое подключение без поднятия каких-либо туннелей (называют — IPoE).

Обращаю внимание на очень важный момент, после всех проделанных действий необходимо перезагрузить приставку, если она была у вас включена и уже потом проверять результат настроек.В случае возникновения проблем в первую очередь советую проверить правила в файрволе.

У оператора может также быть задействована схема с использованием VLAN, в таком случае нужно на порту у вас подключенный шнур от провайдера создать интерфейс с vlan-ом передающим iptv, выяснить его номер можно попробовать через техподдержку. Идем в [интерфейсы] -> [VLAN] и нажимаем [+] для создания нового, указываем его имя, не принципиально и нужно указать оно для удобства администрирования, VLAN ID же нужно указать тот который дает провайдер, к примеру возьмем 234 и в интерфейсе порт в который подключен кабель провайдера.Жмем ОК.

Затем создайте новый бридж и добавленный созданный порт, который подключен к вашей приставке, и этот порт нужно удалить из другого бриджа, если он в каком либо задействованном состоянии.

В свойствах самого бриджа рекомендую выставить STP в отсутствие при возникновении проблем.

В принципе я описал подробную инструкцию по данной теме. На этом все. Если есть какие либо вопросы и замечания пишите в комменты, готов ответить.

.

Настройка IPTV на MikroTik (IPTV + MikroTik + Beeline) / MikroTik / Howitmake.ru

Собственно решил поделиться наработкой.
Думаю этот вариант, который прост, до безобразия, подойдет для настройки iptv и у других провайдеров.
Нет необходимости ставить дополнительные пакеты для нормальной работы многоадресного трафика, нет необходимости настраивать правила для фаерволла, нашего приставки будет IP адрес локальной сети провайдера и доступа из интернета не будет, так что необходимость в фильтрации пакетов, совершенно, отпадает.Отдельно я просканировал IP-адрес приставки, сканер, портов не нашел.
На форуме beeline, по поводу этого способа настройки, написано много несусветной околесицы из серии, «Зачем светить MAC адрес в интернете ?! Могут залезть »- занавес… Господа ну почитайте мат.часть хоть немного, чем писать глупости!
Суть его сводится вот к чему, мы создаем мост из 2х интерфейсов
ether1 — который смотрел в сеть билайн
ether2 — к которому подключен сетевой кабель идущий от приставки (в случае ether5)

Заходим в раздел Bridge и создаем мост, назовем его bridge-to-beeline

выкидываем интерфейс ether5 из моста dridge1-lan и добавляем его в мост-к-билайн
Чтобы было понятно, что этот интерфейс отвечает, я назвал его ether5-iptv

Аналогичным образом поступаем с интерфейсом ether1 , к которому у нас подключен кабель от провайдера.
Таким образом, у нас должен получиться сетевой мост dbridge-to-beeline , в который входит 2 интерфейс:
1) эфир1
2) ether5-iptv

В результате приставка будет получать IP-адрес из сети провайдера, пакеты к ней будут идти без ограничений не попадая на фаерволл.

Нам остается перенастроить DHCP-клиент переходим в IP-> DHCP client и в настройках клиента меняем интерфейс ether1 на bridge-to-beeline

Меняем параметры настройки пакетов из сети в сети провайдера, на Переходим к IP -> Межсетевой экран и меняем правила маршрутизации пакетов из локальной сети.

Применительно к Beeline

Пробуем зайти на любой сайт и нас выкидывает форму авторизации beeline, чтобы мы изменили MAC-адрес оборудования, он был сгенерирован при создании моста между мостом и Beeline вводим логин / пароль и в течении 10 мин, интернет у нас начинает работать.

Нам остается подключить приставку к порту 5 и смотреть ТВ как обычно.
Косаемо нагрузки на систему, загрузка процессора роутера не превышает 40%, согласно системе мониторинга Zabbix (да роутер у меня мониторится), так что запас ресурсов позволяет навешать функционала на эту железку.
На этом я закончу.
Другие статьи об оборудовании Mikrotik можно посмотреть на этой странице

.

Добавить комментарий

Ваш адрес email не будет опубликован.