Usb mikrotik: Подключение USB накопителя к роутеру MikroTik и расшаривание ресурсов

Содержание

Подключение USB накопителя к роутеру MikroTik и расшаривание ресурсов

Форматирование USB накопителя

MikroTik поддерживает свою файловую систему, поэтому USB флешку сначала необходимо отформатировать, чтобы роутер мог с ней работать.

Внимание! При форматировании все данные будут удалены с USB накопителя, поэтому предварительно сохраните необходимые файлы на компьютер.

Подключите USB flash к роутеру и выполните форматирование:

Откройте меню System — Stores

Перейдите на вкладку Disks

Выберите в списке ваш накопитель, обычно usb1

Нажмите кнопку Format Drive:

В появившемся окне нажмите Yes.


После этого в столбцеStatus появится надписьformatting…, т.е. роутер выполняет форматирование и нужно дождаться его завершения. При большой емкости накопителя, процесс форматирования может занять не одну минуту, поэтому будьте терпеливы.

После успешного форматирования в столбцеStatus будет написано ready и слева указан общий объем флешки Total Space и свободное место на ней Free Space

.

Откройте меню Files. В списке появилась наша флешка с именем usb1. Теперь можно перетягивать на нее файлы.

Расшаривание ресурсов с помощью Samba

Чтобы компьютеры могли заходить на USB flash по сети, настроим сервис Samba (SMB):

  • Откройте меню IP — SMB
  • Поставьте галочку Enabled
  • В поле Domain укажите название вашей рабочей группы
  • В поле Comment укажите имя роутера, которое будет отображаться в списке компьютеров рабочей группы;
  • Allow Guest- разрешить доступ гостевым пользователям;
  • Interfaces- с каких интерфейсов давать доступ к расшаренной папке. Оставим all- доступ со всех интерфейсов.

Нажмите кнопку Shares для добавления папки и выполните следующие настройки:

  • Нажмите синий плюсик, чтобы добавить новую папку.
  • В появившемся окне в поле Name укажите название папки.
  • В поле Directory укажите путь к папке, напримерusb1/files. Папку предварительно создавать не обязательно.
  • Max Sessions- количество пользователей, которые могут одновременно подключаться к расшаренной папке. Оставим это значение по умолчанию.
  • НажмитеOK.

После этого в списке появится новая расшаренная папка. Закрываем это окно.

Теперь настроим права пользователей. В окнеSMB Settingsнажмите кнопкуUsers.

Перед вами появится окно со списком пользователей. По умолчанию уже будет присутствовать гостевой пользовательguest. В столбцеRead Onlyстоит значениеyes— это значит, что гостевой пользователь имеет права только на чтение файлов в расшаренной папке. Создание и добавление файлов в расшаренную папку ему не доступно.

Чтобы дать гостевому пользователю права на запись, кликните двойным щелчком мыши на пользователе и зайдите в его настройки. Далее уберите галочку с

Read Onlyи нажмите кнопкуOK.

Также вы можете создать других пользователей и дать им пароли для доступа к расшаренной папке.

После настройки прав пользователей в окнеSMB Settingsнажмите кнопкуOK.

Проверим доступ к расшаренной папке. В Windows XP откройте на рабочем столе значокСетевое окружение.

В проводнике выберитеОтобразить компьютеры рабочей группыи в списке появится наш MikroTik.

Заходим в него и открываем нашу папкуshare.

Проверим можно ли создавать файлы в этой папке. Кликните правой кнопкой мыши по пустому месту, выберите в выпадающем менюСоздать — Папкуи введите любое имя.

После этого будет создана папка, а значит, у гостевого пользователя есть доступ на запись файлов в расшаренную папку.

Настройка FTP сервера MikroTik

Чтобы получить доступ к файлам на флешке из интернета, настроим FTP сервер на роутере Mikrotik:

1. Откройте меню IP — Services;

2. Выберите в списке ftp

3. Нажмите синюю галочку.

Проверим подключение по FTP. В браузере или в проводнике введите внутренний или внешний адрес роутера MikroTik, например ftp://192.168.88.1. В появившемся окне введите имя администратора и пароль.

Перед вами откроется список файлов на роутере MikroTik. Вы можете зайти в папкуusb1на флэшку.

Если вы не хотите давать другим пользователям имя и пароль администратора, можно создать другого пользователя с паролем.

Будьте осторожны! FTP сервер MikroTik дает всем пользователям права на запись файлов на сервер. К сожалению, дать права только на чтение нельзя.

Для создания нового пользователя выполните следующее:

1. Откройте меню System — Users.

2. Нажмите синий плюсик для добавления нового пользователя

3. В поле Nameвведите имя пользователя user.

4. В списке Group выберите группу пользователей, например read.

5. В поле Password введите пароль.

6. В поле Confirm Password повторите пароль.

7. Нажмите OK.

Перейдите на вкладкуGroupsи откройте параметры выбранной группы read.

Проверьте, чтобы стояла галочка ftp и нажмите OK.

Теперь открываем в браузере адрес роутера ftp://192.168.88.1, вводим имя пользователя user и пароль, нажимаем Входи получаем доступ к файлам по FTP.

Роутер Mikrotik и накопитель данных

Прочитано: 7 757

Сегодня я хочу рассмотреть все шаги, о том, как подключить USB носитель (Флешка,Съемный диск) к роутеру Mikrotik с целью с примеру организации FTP доступа, к конфигурационным файлам,бекапу настроек и многому всему что Вы захотите хранить на данном носителе.

В роли роутера в рамках этой заметки будет выступать: Mikrotik RB951Ui-2Hnd (обновлен до последнего состояния на момент написания данной заметки)

На заметку: носитель USB не должен содержать какую либо важную информацию перед тем как его подключим к роутеру, потому как после подключения он будет отформатирован, а данные на нем утеряны безвозвратно.

USB устройства поддерживаемые оборудованием

Mikrotik:

  • UPS
  • Ethernet Controllers
  • Flash Disk / Hard Disk Drives
  • HSDPA/EDGE/GPRS (3G) Modem

Так опознает моя система Ubuntu 12.04.5 Desktop amd64usb носитель на 8Gb

Dec 12 10:37:25 system kernel: [4214501.644227] scsi 28:0:0:0: Direct-Access JetFlash Transcend 8GB 1100 PQ: 0 ANSI: 6

Dec 12 10:37:25 system kernel: [4214501.645343] sd 28:0:0:0: Attached scsi generic sg2 type 0

Dec 12 10:37:25 system kernel: [4214501.647855] sd 28:0:0:0: [sdb] 15417344 512-byte logical blocks: (7.89 GB/7.35 GiB)

Dec 12 10:37:25 system kernel: [4214501.648873] sd 28:0:0:0: [sdb] Write Protect is off

Dec 12 10:37:25 system kernel: [4214501.648877] sd 28:0:0:0: [sdb] Mode Sense: 43 00 00 00

Dec 12 10:37:25 system kernel: [4214501.650200] sd 28:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA

Dec 12 10:37:25 system kernel: [4214501.657059] sdb: sdb1 sdb4

Dec 12 10:37:25 system kernel: [4214501.660936] sd 28:0:0:0: [sdb] Attached SCSI removable disk

[email protected]:~$ sudo fdisk /dev/sdb

Команда (m для справки): p

Диск /dev/sdb: 7893 МБ, 7893680128 байт

243 головок, 62 секторов/треков, 1023 цилиндров, всего 15417344 секторов

Units = секторы of 1 * 512 = 512 bytes

Размер сектора (логического/физического): 512 байт / 512 байт

I/O size (minimum/optimal): 512 bytes / 512 bytes

Идентификатор диска: 0x00000000

Удаляю все разделы и создаю один единственный (+7G) на usb носителе:

[email protected]:~$ sudo fdisk /dev/sdb

Форматирую данный usb носитель в файловую систему (либо ext3 & fat32)

[email protected]:~$ sudo mkfs.ext3 /dev/sdb1

[email protected]:~$ sudo partprobe

Подключаю следующий накопитель в роутер (данный роутер оборудован разъемом USB), запускаю winbox и подключаюсь с текущему роутеру, обычно по умолчанию носитель подключенный к роутеру winbox именуется, как Winbox — System — Disk

и обнаруживаю, что Mikrotik успешно определил подключенный носитель:

Если в данной вкладке Disk видите размер USB носителя, то тогда все хорошо, если же вместо размера обнаружите статус Invalid, то устройство USB Необходимо отформатировать, сделать это можно через выделив диск и нажав кнопку «Format Drive».

Теперь переходим на элемент настройки: winboxIP&DNSFiles и видим обнаруженный раздел USB носителя подготовленного на системе Ubuntu 12.04.5 Desktop amd64

Теперь на данный раздел disk3 можно копировать файлы/сохранять бекап настроек, т. е. Работать с USB носителем только в пределах устройства

Mikrotik.

Если же нужно к данному разделу предоставить доступ по сети, то для этих целей подойдет:

  • Расшарить папку с помощью SAMBA

Настраиваю сервис SAMBA: winbox — IP&MAC — IP — SMB

ставим галочку у пункта Enabled

В рабочее поле Domain: WORKGROUP вводим именование рабочей группы (домен указать нельзя, не поддерживается)

Comment: Samba FileServer Часть описания которая будет видна всем при отображении списка компьютеров в создаваемой рабочей группе, к примеру на Windows 7 это посмотреть можно будет так:

Allow Guests: ставим галочку, если доступ нужен будет по учетной записью гостя, т. е. Без пароля.

Intefaces: указываем интерфейс на котором определена связь с компьютерами рабочей группы. У меня интерфейс ether2 смотрит в локальную сеть (но можно также указать All — т. е. Доступен ресурс на всех сетевых интерфейсах)

Теперь когда файловый сервис поднят, нужно добавить каталоги, для этого нажимаем кнопку Shares — Add (нажимаем плюсик) и создаем каталог и предопределяем количество пользователей которые смогут одновременно общаться с ним:

Name: shara — указываем название папки

Directory: disk3/shara — путь к папке (где disk3 берем из шага: winbox — IP&DNS — Files)

Max Sessions: 7 — количество одновременных соединений к расшаренной папке

По окончании создания нажимаем Apply & OK, а если нужны еще каталоги то процесс идентичный выше рассмотренному.

Ниже подробное рассмотрение каждой возможности доступа по сети к USB носителю:

Теперь нужно создать пользователей которые будут иметь доступ к данному расшаренному ресурсу, для этого в окне: SMB Settings нажимаем кнопку Users — Add (нажимаем плюсик), добавляем пользователей.

По умолчанию присутствует учетная запись гостевого пользователя (guest) без пароля с правами только чтение (установлена галочка Read Only), записывать прав нет (дать возможность записывать — нужно снять данную галочку Read Only).

  • Создаю пользователя:
  • Name: ekzorchik
  • Password: [email protected]
  • Read Only: снимаю галочку

По окончании создания нажимаем Apply & OK

В итоге получаем диск и имеющиеся каталоги:

Теперь продемонстрирую примеры подключения к созданной выше расшаренной папки USB носителя, предварительно определив IP адрес на устройстве Mikrotik текущей сети: winbox — IP&MAC — IP — Address, в моем случае адрес: 10.7.8.140/24

Если данный Mikrotik с адресом 10.7.8.140 внесен в DNS, то обращение с Windows 7 к нему возможно по DNS-имени, если же нет, то тогда:

Пуск — Мой Компьютер и в строке адреса: \\10.7.8.140

После нажатия на кнопку OK (в случае правильно указания идентификационных данных) произойдет переход на файловый ресурс поднятый на Mikrotik где будут отображены созданные каталоги: backup & shara, pub — это дефолтный каталог.

Перейдя в любой из них, к примеру backup можно создавать/изменять/удалять — такие уж у пользователя (созданного) права доступа.

Также можно подключить данный Mikrotik и через командную строку на определенную букву диска:

C:\Users\Admin>net use X: \\10.7.8.140\shara /user:workgroup\ekzorchik [email protected]

Команда выполнена успешно.

Удалить подключенный ресурс Mikrotik:

C:\Users\Admin>net use X: /delete /y

X: успешно удален.

Под Ubuntu 12.04.5 Desktop amd64 (рабочий стол Gnome Classic) подключение будет выглядеть следующим образом:

Приложения — Стандартные — Терминал

[email protected]:~$ smbtree -N (или [email protected]:~$ smbtree -N)

WORKGROUP

\\W7X86

\\VW-PC

\\Samba FileServe Samba FileServer — вот мой Mikrotik

\\MikroTik Samba FileServer — вот мой Mikrotik

\\MONITORING

\\ALIGNER-PC

[email protected]:~$ sudo apt-get install smbfs -y

[email protected]:~$ sudo smbclient -U ekzorchik \\\\10.7.8.140\\shara [email protected]

Domain=[WORKGROUP] OS=[Unix] Server=[MikrotikSMB]

smb: \> ls

. D 4096 Sat Dec 12 11:49:24 2015

.. D 4096 Sat Dec 12 11:49:41 2015

36734 blocks of size 4096. 39224 blocks available

smb: \> mkdir file

smb: \> pwd

Current directory is \\10.7.8.140\shara\

или через GUI:

Переход — Компьютер — Обзор сети (Сеть) — Нахожу в обнаруженном именование устройства Mikrotik (по умолчанию: winbox — IP&DNS — System — Identify) или же: Переход — Компьютер — Обзор сети (Сеть) — Сеть Windows — WORKGROUP — щелкаю по нему левой кнопкой мыши два раза и идентифицируюсь и вот они доступные мне ресурсы.

Теперь рассмотрю доступ по сети к USB носителю через FTP сервис (к примеру можно выставить сервис в интернет):

winbox — IP&DNS — IP — Service — находим FTP (если выделен серым цветом, то значит сервис выключен, выделяю его и нажимаю «на Галочку» тем самым включив его).

Если обратиться по URL-адресу: ftp://10.7.8.140{IP&DNS адрес Микротика) и пока авторизоваться можно только по учетной записью admin (дефолтная учетная запись суперпользователя на микротике с пустым паролем), то произойдет вход на FTP ресурс, где будет доступны все файлы которые присутствует на встроенной памяти так и подключенный USB ресурс (в моем случае идет именование disk3). Оставлять данный административный доступ можно, но вот предоставлять его кому бы то ни было слишком рискованно, а потому создам пользователя и группу с правами только для ftp подключения:

windows — IP&DNS — System — Users, во вкладке Group — Add (добавляем/создаем) —

Name: FTPWrite

Policies: Отмечаем ftp (т. е. Данная роль только для взаимодействия с сервисом FTP)

Skin: профиль безопасности

По окончании создания нажимаем Apply & OK и переходим на вкладку UsersAdd (Создаем):

Name: ekzorchik

Group: выбираю группу FTPWrite

Allowed Address: с каких адресов разрешено входить, пропускаю.

Password: задаю пароль — [email protected]

Confirm Password: — [email protected]

По окончании создания нажимаем Apply & OK

На заметку: поизучав возможности FTP сервиса пришел к выводу, что поднимаемый FTP сервис на Mikrotik всех создаваемых пользователей не ограничивает, а потому пользователи могут писать файлы, права на чтение отсутствуют напрочь.

На заметку: старайтесь не использовать пароль оканчивающийся на спец символ в виде собаки (@), т. к. консольные утилиты порой неправильно его воспринимают, придется экранировать, а это та еще проблема.

Чтобы под Ubuntu 12.04.5 Desktop amd64 подключить ftp ресурс микротика задействуем заметку

[email protected]:~$ sudo curlftpfs ftp://test:[email protected] /media/mikrotik -o allow_other

[email protected]:~$ ls -l /media/mikrotik/

итого 28

-rw-rw—- 1 root root 14183 янв. 2 2015 auto-before-reset.backup

drwxrwx— 5 root root 4096 дек. 12 08:49 disk3

drwxrwx— 1 root root 2048 дек. 12 08:28 pub

drwxrwx— 1 root root 2048 янв. 1 2015 skins

Если говорить из практики для чего может понадобится подключить USB носитель в виде флешки или переносного диска, то к примеру у меня на нем лежат бекапы конфигурационных файлов, прошивки, файлы наработок, вообще всего же не перечислить, каждый сам в этом случае определит для чего это ему может понадобиться. На этом я прощаюсь, заметка получилась объемная и практическая, до встречи, с уважением автор блога — Олло Александр.

Mikrotik и USB модем | Wi-Fi SYSTEM

Данная инструкция рассчитана на настройку нового Микротика с пустой конфигурацией.
Если Ваш Микротик уже содержит старые конфигурации, то необходимо их сбросить.
Как это сделать, можно посмотреть в инструкции по настройке (шаг 1-3).

Mikrotik с USB модемом удобно использовать в связке.

Где это может пригодиться? В местах, где нет проводного интернета.
Например, в труднодоступных и отдалённых местах или в транспорте.
В этой статье мы покажем, как настроить интернет на Микротике через USB модем.

При подключении USB модема автоматически появляется новый интерфейс ppp-out1  
Он по умолчанию выключен

Если зайти в свойства интерфейса и посмотреть информацию (кнопка Info справа в меню), то можно увидеть более подробные сведения:
Модель USB модема, ревизию, серийный номер, название оператора, режим работы (3G/LTE), уровень сигнала.

Если информация автоматически не появилась — нажмите в окне PPP info кнопку Start.
В некоторых моделях информация может быть недоступна, если интерфейс USB модема включен.

Чтобы появился интернет через подключенный USB модем, необходимо включить интерфейс:

/interface enable ppp-out1

После этого у Вас есть несколько вариантов настройки Микротика:

Вариант 1

Настроить интернет с открытым доступом для личного пользования.
Для этого достаточно скопировать следующий скрипт и вставить его в терминал Микротика

/ip dns set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/interface bridge add name=inet-bridge
/ip pool add name=inet-pool ranges=192.168.100.2-192.168.103.253
/ip dhcp-server add address-pool=inet-pool disabled=no interface=inet-bridge lease-time=12h name=inet-dhcp
/interface bridge port add bridge=inet-bridge interface=wlan1
/ip address add address=192.168.100.1/22 comment=»Internet network» interface=inet-bridge network=192.168.100.0
/ip dhcp-server network add address=192.168.100.0/22 comment=»Internet network» dns-server=8.8.8.8,208.67.222.222 gateway=192.168.100.1 netmask=22
/ip firewall nat add action=masquerade chain=srcnat comment=»masquerade Internet network» src-address=192.168.100.0/22
/interface wireless set wlan1 mode=ap-bridge ssid=WiFi_USB default-forwarding=no disabled=no

 

Вариант 2

Настроить интернет с авторизацией для публичных мест.
В этом случае достаточно скопировать готовый скрипт для Микротика из Личного кабинета.


Как это выглядит в жизни.

Один из примеров — использование Wi-Fi в автотранспорте.

Подключаем настроенный Микротик к автомобильному питанию. Мы использовали автомобильную зарядку на 12V.

В телефоне включили Wi-Fi и подключились к нашему Микротику.

Как видно — интернет появился. Скорость зависит от типа модема и качества связи в данной местности.


 

Подключение USB накопителя к MikroTik и настройка файлового сервера (SMB)

Не так давно я рассказывал о настройке USB модема на роутере MikroTik, но есть и другой вариант использования USB разъёма… подключив к нему флешку или жёсткий диск, можно довольно легко получить сетевой накопитель (SMB сервер) или настроить FTP-сервер.

Настройку Samba сервера покажу на примере RB951G-2HnD и внешнего HDD 2.5″ WD My Passport на 1Tb. Сразу оговорюсь что это не полноценная замена NAS — памяти и ресурсов тут в обрез, так что чудес производительности ждать не стоит (хотя на hAP AC2 работать будет заметно шустрее из-за более производительного процессора). Также не получится сделать из MikroTik DLNA-сервер или замену TimeCapsule, однако данного решения вполне хватит для хранения каких-то документов, дистрибутивов и организации совместного доступа к файлам для нескольких человек.

Настройка файлового сервера (SMB) на MikroTik

Для начала нам понадобится отформатировать подключенный диск или флешку в одну из двух поддерживаемых файловых систем ext3 или fat32. Лучше выбрать ext3 чтобы избежать ограничений на размер файлов (напомню, что максимально возможный размер файла для тома FAT32 — 4 ГБ).

Заходим в меню System->Disks и указав файловую систему ext3 нажимаем кнопку «Format Drive». Полагаю, не стоит лишний раз напоминать что все данные на диске будут утеряны.

Теперь можно приступать к настройке SMB сервера, для чего переходим в пункт меню IP->SMB и активируем сервис. Собственно, сервер уже работает и даже есть один расшаренный ресурс /pub. Его лучше сразу отключить нажав кнопку «Shares» и далее значок «D» (disable), так как это внутренняя флеш память устройства и имеет ограниченное количество циклов чтения/записи.

В настройках можно задать имя рабочей группы, разрешать (или нет) доступ гостевой учётной записи и отметить на каком интерфейсе будет доступен Samba сервер. По умолчанию стоит «ALL», то есть на всех, но я бы рекомендовал установить «bridge-local» для доступа только внутри локальной сети.

Кликнув по кнопке «Users» добавляем пользователей для доступа к расшаренным ресурсам (по умолчанию есть только гость с правами только на чтение, но можно разрешить и запись). К сожалению, ограничить доступ пользователей к определённым папкам не получится, как я уже и говорил это не полноценный NAS.

За создание сетевых ресурсов отвечает кнопка «Shares». Для того чтобы добавить новый ресурс достаточно кликнуть «Add new», задав имя ресурса и указал в качестве места расположения весь диск (/disk1) или отдельный каталог на нём (/disk1/dist). Отмечу только, что предварительно создавать директории на диске не нужно, они появятся автоматически.

Если потребуется, изменив значение параметра Max Sessions, можно установить количество одновременно подключенных клиентов. Пожалуй, это всё, что хотелось рассказать о файлового сервера (SMB) на MikroTik. Если остались вопросы или желаете дополнить, не ленитесь оставлять комментарии.

Подписывайтесь на канал Яндекс.Дзен и узнавайте первыми о новых материалах, опубликованных на сайте.

Если считаете статью полезной,
не ленитесь ставить лайки и делиться с друзьями.

Настройка Mikrotik для работы с 3G/LTE модемом любых сотовых операторов.

Последнее время скорости через мобильных операторов стали увеличиваться, стоимость ежемесячного платежа снижаться, поэтому кроме подключения одного стационарного компьютера или ноутбука, появилась возможность подключать к беспроводному интернету целые локальные сети. Естественно многих пугает сложность настройки, и они вместо микротика выбирают другое оборудование, которое используют в качестве 3G или LTE роутера, хотя на самом деле это не так, настройка производится за несколько минут.

Для начала определимся с моделью микротика, к которому будем подключать USB сотовый модем. Его можно подключать к роутерам серий RB751, RB951G, RB750UP, RB2011 и другим, кроме всего можно подключать и к антеннам серии SXT, либо OmniTIK, в которых так же имеется порт USB.

В нашем случае возьмем плату от роутера Mikrotik RB751G-2HnD, у которого есть USB порт, встроенный беспроводной адаптер и 5 гигабитных сетевых портов для подключения компьютеров.

Модем можно использовать любой, в нашем случае это HUAWEI E3276, который поддерживает работу в сетях сотовых операторов в режимах 3G и 4G/LTE.

Подключаем 3G модем HUAWEI к плате RB751G-2HnD в USB порт. При этом размещать плату можно либо внутри помещения (естественно поместив в родной корпус), компьютеры и другие устройства сети можно подключать непосредственно в свободные сетевые порты, либо разместить его на чердаке или на крыше в корпусе уличного исполнения, тогда питание производится через первый сетевой порт через кабель с максимальной длиной до 100 метров. В таком случае не требуется разрезать кабель от БП, прикручивать его к свободным жилам витой пары, как пришлось бы при использовании роутеров типа D-Link или TP-Link, которые не поддерживают питание PoE.

Кроме всего Mikrotik RB951G-2HnD имеет встроенный беспроводной адаптер, поэтому он может раздавать интернет через Wi-Fi сеть не только в доме, но и в машине или автобусе. Если подключить устройство к любому аккумулятору с напряжением от 10 и до 24 вольт (например от шуруповерта), можно использовать интернет от сотового оператора на пикнике в чистом поле или лесу, разместив приемный комплект на ближайшем высоком дереве.

Подключать и отключать модем можно на включенном устройстве, привязка осуществляется к модему, следовательно можно менять сим карту, устанавливая ее от любого оператора — МТС, Мегафон, Билайн, Теле2 и любых других, настройки оборудования изменять не потребуется.

При подключении модема появляется новый интерфейс ppp-out1, который по умолчанию отключен.

Соответственно если зайти в его свойства, нажать кнопку Info в меню справа, можно посмотреть уровень сигнала, название оператора и режим работы 3G/LTE. Если при открытии окошка в нем никакой информации нет, нужно нажать кнопку Start, после завершения просмотра данных, кнопку Stop. В зависимости от типа модема, получения информации о соединении может быть не доступно, если сам интерфейс модема включен и активен.

Соответственно что бы заработал интернет, достаточно включить интерфейс модема (нажав кнопку Enable), через некоторое время он установит соединение с оператором и появится доступ во всемирную паутину, что можно проверить, запустив пинг до любого узла.

В списке IP-адресов появляется адрес, который выдал модему сотовый оператор, соответственно в списке маршрутов появляется дефолтный маршрут в сторону оператора. Вручную ничего добавлять не нужно. То есть если взять любой, даже уже настроенный микротик, отключить основной канал и подключив USB модем, автоматически заработает доступ в интернет.

Осталось раздать интернет по кабелю, для этого заходим в меню Bridge, нажимаем на + и ничего не трогая сразу на Ok.

После чего на вкладке Ports так же нажатием на + добавляем все доступные сетевые порты ether1ether5, и при необходимости беспроводной адаптер, однако его настройку рассматривать не будем.

Для раздачи интернета подключенным устройствам нужно установить IP-адрес на бридж, для этого в меню IP->Addresses добавляем 192.168.0.1/24 и указываем интерфейс bridge1. При необходимости можно использовать и любые другие адреса.

Что бы интернет у подключенных устройств заработал, нужно настроить НАТ. Для этого в меню IP->Firewall заходим на вкладку NAT и создаем новое правило, где указываем src.address192.168.0.0/24 — для этой сети микротик будет транслировать запросы во внешнюю сеть.

На вкладке Action выбираем действие — masquerade. После чего нажимаем кнопку Ok, настройка НАТа завершена.

В соответствующем разделе файрвола появляется правило НАТ.

В заключение нужно разрешить работу встроенного DNS сервера, что бы он отвечал на запросы подключенных клиентов, для этого в меню IP->DNS достаточно поставить галочку Allow Remote Requests, и при необходимости указать другие адреса серверов, вместо тех, что выдает провайдер.

Если требуется, что бы подключенные компьютеры получали IP адреса автоматически, нужно настроить DHCP сервер, в меню IP->DHCP Server нужно нажать кнопку DHCP Setup и следовать сообщениям, появляющимся на экране.

Сначала следует указать на каком интерфейсе будет работать DHCP сервер, если сетевые порты объединены в бридж, то указывать отдельные интерфейсы уже нельзя. В нашем случае выбираем bridge1.

Сеть, для которой будет работать DHCP сервер микротик определяет автоматически по настройкам IP адреса, установленным на ранее указанном интерфейсе.

Адрес шлюза так же определяется автоматически.

А вот в настройках диапазона адресов для выдачи, можно изменить стандартные значения, что бы освободить часть подсети для установки IP-адресов вручную. Например указав диапазон 192.168.0.200-192.168.0.254, можно раздавать адреса, начиная с 200, а другие адреса можно устанавливать на оборудование статически, не опасаясь, что произойдут конфликты.

Одним из последних пунктов указываем адрес DNS сервера для выдачи, можно указать свой адрес роутера — 192.168.0.1, как он сам и предлагает, можно указать адрес стороннего сервера, например 8.8.8.8, но в этом случае через канал пойдут лишние запросы, поэтому использование локального сервера на роутере выгоднее.

В заключении указываем время аренды адресов, то есть то время, на которое выдается адрес компьютеру. Стандартно стоит 3 дня, можно поставить 10 минут, по истечении этого времени происходит повторный запрос на получение адреса, при этом сетевые соединения в эти моменты не обрываются. Длинную аренду обычно используют, когда подключено всего несколько компьютеров, если же к сети постоянно подключаются и отключаются различные устройства, короткая аренда позволяет уменьшить базу выданных адресов.

По завершении в разделе DHCP сервера появилась соответствующая запись.

Проверяем как работает сеть 3G от MegaFon. Модем показывает уровень сигнала -73дБм.

Запускаем тест на прием и получаем ровно 2 мегабита в секунду на передачу — как раз ограничение по тарифу.

На прием аналогично — ограничение ровно 2 мегабита по тарифу. При этом на прием график намного ровнее.

Теперь меняем сим карту на другую, с поддержкой LTE — модем сразу переключается в другой режим — Evolved 3G (LTE). Уровень сигнала так же увеличивается до -71дБм

Снова проверяем скорость — на передачу 5.8 мегабит.

На прием 9.4 мегабита. Вполне хватит для серфинга в интернете, просмотра видео и закачек файлов.

Настроить оборудование можно либо через винбокс, либо путем вставки команд в окно New Terminal, естественно предварительно нужно сбросить начальную конфигурацию.

Вот конфиг в текстовом виде произведенных выше настроек, его достаточно скопировать (возможно подкорректировав настройки адресов), и вставить на оборудование.

 

/interface bridge

add name=bridge1

/ip pool

add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridge1 lease-time=10m name=dhcp1

/interface bridge port

add bridge=bridge1 interface=ether5

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether2

/ip address

add address=192.168.0.1/24 interface=bridge1

/ip dhcp-server network

add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1

/ip dns

set allow-remote-requests=yes

/ip firewall nat

add action=masquerade chain=srcnat src-address=192.168.0.0/24

 

Теперь вы знаете, что настроить 3G/4G модем на микротике настолько просто, что пожалеете, что не настроили его раньше. Кроме всего можно подключить по USB любой сотовый телефон, и если он поддерживает работу в режиме модема, микротик так же получит доступ в сеть. При этом смена сим карты не повлияет на работоспособность, настройки изменять не потребуется.

MikroTik Routers and Wireless — Products: Woobm-USB

[BG] Bulgarian С настоящето, «Mikrotikls SIA», декларира, че Woobm-USB е в съответствие със съществените изисквания и другитеприложими разпоредби на Директива 2014/53/EC.
[CZ] Czech «Mikrotikls SIA» tímto prohlašuje, že Woobm-USB splňuje základní požadavky a všechna příslušná ustanoveni Směrnice 2014/53/ES.
[DK] Danish Undertegnede «Mikrotikls SIA» erklærer herved, at følgende udstyr Woobm-USB overholder de væsentlige krav og øvrige relevante krav i direktiv 2014/53/EF.
[DE] German Hiermit erklärt «Mikrotikls SIA», dass sich das Gerät Woobm-USB in Übereinstimmung mit den grundlegenden Anforderungen und den übrigen einschlägigen Bestimmungen der Richtlinie 2014/53/EG befindet.
[EE] Estonian Käesolevaga kinnitab «Mikrotikls SIA» seadme Woobm-USB vastavust direktiivi 2014/53/EÜ põhinõuetele ja nimetatud direktiivist tulenevatele teistele asjakohastele sätetele.
[GR] Greek ΜΕ ΤΗΝ ΠΑΡΟΥΣΑ Ο ΚΑΤΑΣΚΕΥΑΣΤΗΣ «Mikrotikls SIA» ΔΗΛΩΝΕΙ ΟΤΙ Woobm-USB ΣΥΜΜΟΡΦΩΝΕΤΑΙ ΠΡΟΣ ΤΙΣ ΟΥΣΙΩΔΕΙΣ ΑΠΑΙΤΗΣΕΙΣ ΚΑΙ ΤΙΣ ΛΟΙΠΕΣ ΣΧΕΤΙΚΕΣ ΔΙΑΤΑΞΕΙΣ ΤΗΣ ΟΔΗΓΙΑΣ 2014/53/ΕΚ
[EN] English Hereby, «Mikrotikls SIA», declares that this Woobm-USB is in compliance with the essential requirements and other relevant provisions of Directive 2014/53/EC.
[ES] Spanish Por la presente, «Mikrotikls SIA», declara que este Woobm-USB cumple con los requisitos esenciales y otras exigencias relevantes de la Directiva 2014/53/EC.
[IT] Italian Con la presente «Mikrotikls SIA» dichiara che questo Woobm-USB è conforme ai requisiti essenziali ed alle altre disposizioni pertinenti stabilite dalla direttiva 2014/53/CE.
[LV] Latvian Ar šo «Mikrotikls SIA» deklarē, ka Woobm-USB atbilst Direktīvas 2014/53/EK būtiskajām prasībām un citiem ar to saistītajiem noteikumiem.
[LT] Lithuanian Šiuo «Mikrotikls SIA» deklaruoja, kad šis Woobm-USB atitinka esminius reikalavimus ir kitas 2014/53/EB Direktyvos nuostatas
[HU] Hungarian A «Mikrotikls SIA» ezzennel kijelenti, hogy a Woobm-USB típusú beren-dezés teljesíti az alapvető követelményeket és más 2014/53/EK irányelvben meghatározott vonatkozó rendelkezéseket.
[NL] Dutch Hierbij verklaart «Mikrotikls SIA» dat het toestel l Woobm-USB in overeenstemming is met de essentiële eisen en de andere relevante bepalin-gen van richtlijn 2014/53/EG.
[PL] Polish Niniejszym «Mikrotikls SIA» deklaruje że Woobm-USB jest zgodny z zasadniczymi wymaganiami i innymi właściwymi postanowieniami Dyrektywy 2014/53/EC.
[PT] Portuguese Eu, «Mikrotikls SIA», declaro que o Woobm-USB cumpre os requisitos essenciais e outras provisões relevantes da Directiva 2014/53/EC.
[RO] Romanian Prin prezenta, «Mikrotikls SIA», declară că aparatul Woobm-USB este în conformitate cu cerinţele esenţiale şi cu alte prevederi pertinente ale Directivei 2014/53/CE..
[SK] Slovak «Mikrotikls SIA» týmto vyhlasuje, že Woobm-USB spĺňa základné požiadavky a všetky príslušné ustanovenia Smernice 2014/53/ES.
[SI] Slovenian «Mikrotikls SIA» izjavlja, da je ta Woobm-USB v skladu z bistvenimi zahtevami in drugimi relevantnimi določili direktive 2014/53/ES.
[FI] Finish «Mikrotikls SIA» vakuuttaa täten että Woobm-USB tyyppinen laite on direktiivin 2014/53/EY oleellisten vaatimusten ja sitä koskevien direktiivin muiden ehtojen mukainen.
[SE] Swedish Denna utrustning är i överensstämmelse med de väsentliga kraven och andra relevanta bestämmelser i direktiv 2014/53/EC.
[NO] Norwegian «Mikrotikls SIA», Erklærer herved at Woobm-USB er i samsvar med de grunnleggende krav og øvrige relevante krav i direktiv 2014/53/EF.

Как установить Mikrotik Router OS на USB флешку :: Настройка оборудования Mikrotik :: Настройка оборудования

Рейтинг

Оценка: 5Голосов: 1Комментарии: 3

Эта статья посвящена установке Mikrotik Router OS на USB флешку.

Рис.1. Mikrotik Router OS Netinstall. Получаем необходимые файлы.

Для установки Mikrotik Router OS на USB флешку понадобится утилита Netinstall и пакеты, которые нужно установить (ZIP file). Все необходимое можно получить по адресу: http://www.mikrotik.com/download.html.

Рис.2.  Mikrotik Router OS Netinstall.

Запускаем утилиту Netinstall и выбираем диск, на который будет происходить установка. Нажимаем кнопку Browse для выбора директории в которой находятся пакеты для установки Mikrotik Router OS.

Рис.3. Mikrotik Router OS Netinstall выбор директории.

Рис.4.  Mikrotik Router OS Netinstall, выбор пакетов и запуск установки.

После того, как мы указали директорию в которой расположены пакеты для установки, мы увидим список с названиями пакетов. Теперь выберем необходимые нам и нажмем install.

Рис.5.  Mikrotik Router OS Netinstall Installation completed.

Процесс установки не займет много времени. Об его окончании будет свидетельствовать надпись Installation completed.

Рис.6.  Netinstall Installation completed, содержимое флешки.

После завершения установки, флешка будет содержать пакеты для установки и другие файлы для окончательной установки Mikrotik Router OS на флешку.

Дальнейшая установка будет проходить без нашего участия. Нам необходимо только подключить флешку к компьютеру и дождаться окончательной установки.

Специально для ASP24.

Если Вы нашли ошибку в тексте, то выделите ее мышкой и нажмите Ctrl + Enter или нажмите здесь.

Большое спасибо за Вашу помощь! Мы скоро исправим ошибку!

Сообщение не было отправлено. Пожалуйста, попробуйте еще раз.

Сообщение об ошибке

Ошибка:

Ваш комментарий (не обязательно):

Да Отмена

Подключение USB-накопителя к роутеру MikroTik и расшаривание ресурсов

Форматирование USB-накопителя

MikroTik поддерживает свою файловую систему, поэтому USB-флешку сначала необходимо отформатировать, чтобы роутер мог с ней работать.

Внимание! При форматировании все данные будут удалены с USB-накопителя.

Подключите USB-флешку к роутеру и выполните форматирование:

Откройте меню Система — Магазины

Перейдите на вкладку Диски

Выберите в списке ваш накопитель, обычно usb1

Нажмите кнопку Форматировать диск:

Нажмите, появшемся, нажмите Да .


После этого в столбце Статус появится надпись форматирование … , т.е. роутер форматирование и нужно дождаться его завершения. При большой емкости, процесс форматирования может занять не одну минуту, поэтому будьте терпеливы.

После успешного форматирования в столбце Статус будет написано готов и слева указан общий объем флешки Общий объем и свободное место на ней Свободное пространство .

Откройте меню Файлы . В списке появилась наша флешка с именем usb1 . Теперь можно перетягивать на нее файлы.

Расшаривание ресурсов с помощью Samba

Чтобы компьютеры могли заходить на USB-флеш-память по сети, настроим сервис Samba (SMB):

  • Откройте меню IP — SMB
  • Поставьте галочку Включено
  • В поле Домен укажите название вашей рабочей группы
  • В поле укажите имя роутера, которое будет в списке компьютеров рабочей группы;
  • Разрешить гостю — разрешить доступ гостевым пользователям;
  • Интерфейсы — с каких интерфейсов предоставить доступ к расшаренной среде.Оставим all- доступ со всех интерфейсов.

Нажмите кнопку Shares для добавления папки и выполните следующие настройки:

  • Нажмите синийик, чтобы добавить новую папку.
  • В появившемся окне в поле Название укажите название папки.
  • В поле Directory укажите путь к папке, например ,usb1 / files. Папку создать не обязательно.
  • Max Sessions — количество пользователей, которые могут одновременно подключаться к расшаренной системе.Оставим это значение по умолчанию.
  • НажмитеOK.

После этого в списке появится новая расшаренная папка. Закрываем это окно.

Теперь настроим права пользователей. В окне Настройки SMB нажмите кнопку Пользователи .

Перед вами появится окно со списком пользователей. По умолчанию уже будет присутствовать гостевой пользователь гость . В столбце Только для чтения стоит значение да — это значит, что гостевой пользователь имеет права только на чтение файлов в расшаренной папке.Создание и добавление файлов в расшаренную папку ему не доступно.

Чтобы дать гостевому пользователю права на запись, кликните двойным щелчком мыши на пользователе и зайдите в его настройки. Далее уберите галочку с Только чтение и нажмите кнопку OK .

Также вы можете создать других пользователей и дать им пароли для доступа к расшаренной папке.

После настройки прав пользователей в окне Настройки SMB нажмите кнопку OK .

Проверим доступ к расшаренной папке. В Windows XP откройте на рабочем столе значок Сетевое окружение .

В проводнике Отобразить рабочую группу и в списке появится наш MikroTik.

Заходим в него и открываем нашу папку share .

Проверим можно ли создать файлы в этой папке. Нажмите правой кнопкой мыши по пустому месту, выберите в выпадающем меню Создать — Папку и введите любое имя.

После этого будет создана папка, а значит, у гостя есть доступ на запись файлов в расшаренную папку.

Настройка FTP сервера MikroTik

Чтобы получить доступ к файлу на флешке из интернета, настроим FTP сервер на роутере Mikrotik:

1. Откройте меню IP — Services ;

2. Выберите в списке ftp

3. Нажмите синюю галочку.

Проверим подключение по FTP.В браузере или в проводнике введите внутренний или внешний адрес роутера MikroTik, например ftp://192.168.88.1 . В появившемся введите имя администратора и пароль.

Перед вами откроется список файлов на роутере MikroTik. Вы можете зайти в папку usb1 на флэшку.

Если вы не хотите давать другим пользователям имя и пароль администратора, можно создать другого пользователя с паролем.

Будьте осторожны! FTP MikroTik предоставляет всем пользователям права на запись файлов на сервере.К сожалению, права дать только на чтение нельзя.

Для создания нового пользователя выполните следующее:

1. Откройте меню Система — Пользователи.

2. Нажмите синий плюсик для добавления нового пользователя

3. В поле Имявведите имя пользователя user.

4. В списке группы пользователей, например read.

5. В поле введите пароль.

6. В поле Подтвердите пароль из области пароль.

7. Нажмите OK.

Перейдите на вкладку Группы и откройте параметры выбранной группы , прочтите .

Проверьте, чтобы стояла галочка ftp и нажмите OK .

Теперь открываем в браузере адрес роутера ftp://192.168.88.1 , вводим имя пользователя , пользователь и пароль, нажимаем Входи получаем доступ к файлам по FTP.

.

Роутер Mikrotik и накопитель данных

Прочитано: 7 758

Сегодня я хочу рассмотреть все шаги, о том, как подключить USB носитель (Флешка, Съемный диск) к роутеру Mikrotik с целью с примером организации FTP доступа, к конфигурационным файлам, бекапу настроек и многому что всему. захотите на данном носителе.

В роли роутера в этой заметки будет выступать: Mikrotik RB951Ui-2Hnd (обновлен до последнего состояния на момент написания данной заметки)

На заметку: носитель USB не должен содержать какую-либо информацию перед тем как его подключим к роутеру, как после подключения он будет отформатирован, данные на нем утеряны безвозвратно.

USB устройство поддерживаемое оборудование Mikrotik :

  • ИБП
  • Контроллеры Ethernet
  • Флэш-диск / жесткие диски
  • HSDPA / EDGE / GPRS (3G) модем

Так опознает мою систему Ubuntu 12.04.5 Desktop amd64 usb носитель на 8Gb

12 декабря 10:37:25 ядро ​​системы: [4214501.644227] scsi 28: 0: 0: 0: JetFlash с прямым доступом Transcend 8GB 1100 PQ: 0 ANSI: 6

12 декабря 10:37:25 системное ядро: [4214501.645343] sd 28: 0: 0: 0: Присоединенный scsi generic sg2 type 0

12 декабря 10:37:25 системное ядро: [4214501.647855] sd 28: 0: 0: 0: [sdb] 15417344 512-байтовые логические блоки: (7,89 ГБ / 7,35 ГБ)

12 декабря 10:37:25 ядро ​​системы: [4214501.648873] sd 28: 0: 0: 0: [sdb] Защита от записи выключена

12 декабря 10:37:25 ядро ​​системы: [4214501.648877] sd 28: 0: 0: 0: [sdb] Mode Sense: 43 00 00 00

12 декабря 10:37:25 ядро ​​системы: [4214501.650200] sd 28: 0: 0: 0: [sdb] Запись в кэш: включена, чтение из кеша: включена, не поддерживает DPO или FUA

12 декабря 10:37:25 системное ядро: [4214501.657059] sdb: sdb1 sdb4

12 декабря 10:37:25 ядро ​​системы: [4214501.660936] sd 28: 0: 0: 0: [sdb] Прикрепленный съемный диск SCSI

aollo @ system: ~ $ sudo fdisk / dev / sdb

Команда (m для справки): p

Диск / dev / sdb: 7893 МБ, 7893680128 байт

243 головок, 62 секторов / треков, 1023 цилиндров, всего 15417344 секторов

единиц = секторы 1 * 512 = 512 байт

Размер сектора (логического / физического): 512 байт / 512 байт

Размер ввода / вывода (минимальный / оптимальный): 512 байт / 512 байт

Идентификатор диска: 0x00000000

Удаляю все разделы и создаю один единственный ( + 7G ) на usb носителе:

aollo @ system: ~ $ sudo fdisk / dev / sdb

Форматирую данный usb носитель в файловой системе (либо ext3 & fat32 )

aollo @ system: ~ $ sudo mkfs.ext3 / dev / sdb1

aollo @ system: ~ $ sudo partprobe

Подключаю следующий накопитель в роутер (данный роутер оборудован разъемом USB ), запускю winbox и подключаюсь с текущей роутеру, обычно по умолчанию носитель подключенный к роутеру winbox именуется, как Winbox — Система — Диск обнаруживается ииваю, что Mikrotik успешно определил подключенный носитель:

Если в данной вкладке Disk видите размер USB носителя, то тогда все хорошо, если же вместо размера обнаружите статус Invalid , то USB Необходимо отформатировать, сделать это можно через диск и эту кнопку « Format Драйв ».

Теперь переходим на элемент настройки: winbox IP & DNS Файлы и видимый раздел USB носителя подготовленного на системе Ubuntu 12.04.5 Desktop amd64

Теперь на данный раздел disk3 можно копировать файлы / укрепления бекап настроек, т. е. Работать с USB носителем только в пределах устройства Mikrotik .

Если же нужно к данному разделу предоставить доступ по сети, то для этих целей подойдет:

  • Расшарить папку с помощью SAMBA

Настраиваю сервис SAMBA: winbox — IP & MAC — IP — SMB

ставим галочку у пункта Включено

В рабочее поле Домен : WORKGROUP вводим именование рабочей группы (домен указать нельзя, не поддерживается)

Комментарий: Samba FileServer Часть описания будет видна всем при отображении списка компьютеров в создаваемой рабочей группе, к примеру на Windows 7 это посмотреть можно будет так:

Разрешить гостей: ставим галочку, если доступ нужен будет по учетной записи гостя, т.е. Без пароля.

Интерфейсы : указываем интерфейс на котором определена связь с компьютерами рабочей группы. У меня интерфейс ether2 смотрит в локальную сеть (но можно также указать All — т. Е. Доступен ресурс на всех сетевых интерфейсах)

Теперь когда файловый сервис поднят, нужно добавить кнопку акций — добавить (нажимаем плюсик) и создать каталог и предопределяем количество пользователей, которые могут одновременно общаться с ним:

Имя: shara — указываем название папки

Каталог: disk3 / shara — путь к папке (где disk3 берем из шага: winbox — IP и DNS — Файлы )

Max Sessions: 7 — количество одновременных соединений к расшаренной папке

По окончании создания нажимаем Применить и ОК , если нужны еще каталоги то процесс идентичный выше рассмотренному.

Ниже приводится подробное рассмотрение каждой возможности доступа по сети к USB носителю:

Теперь нужно создать пользователей, которые будут иметь доступ к данному расшаренному ресурсу, для этого в окне: Настройки SMB нажимаем кнопку Пользователи — добавьте (нажимаем плюсик), добавляем пользователей.

По умолчанию присутствует учетная запись визит пользователя ( guest ) без пароля с правами только чтение (установлена ​​галочка Только чтение ), записывать прав нет (дать возможность записывать — нужно снять систему галочку Только чтение ).

  • Создаю пользователя:
  • Наименование: Экзорчик
  • Пароль: 712mbddr @
  • Только чтение: снимаю галочку

По окончании создания нажимаем Apply & OK

В результате получаем диск и каталоги:

Теперь создаю пример подключения к созданной выше расшаренной папки USB носителя, созданного IP-адреса Mikrotik текущей сети: winbox — IP & MAC — IP — Address , в моем адресе: 10.7.8.140 / 24

Если данный Mikrotik с адресом 10.7.8.140 внесен в DNS , то обращение с Windows 7 к нему возможно по DNS -имени, если же нет, то тогда:

Пуск — Мой Компьютер и в строке адреса: \\ 10.7.8.140

После нажатия кнопки OK (в случае указания указанных данных) произойдет переход на файловый ресурс поднятый на Mikrotik , где будут отображены созданные каталоги: backup & shara, pub — это дефолтный каталог.

Перейдя в любой из них, к примеру резервная копия можно создать / попытаться / удалить — такие уж у пользователя (созданного) права доступа.

Также можно подключить данный Mikrotik и через командную строку на определенную букву диска:

C: \ Users \ Admin> net use X: \\ 10.7.8.140 \ shara / user: workgroup \ ekzorchik 712mbddr @

Команда выполнена успешно.

Удалить подключенный ресурс Mikrotik :

C: \ Users \ Admin> чистое использование X: / delete / y

X: успешно удален.

Под Ubuntu 12.04.5 Desktop amd64 (рабочий стол Gnome Classic ) подключение будет выглядеть следующим образом:

Приложения — Стандартные — Терминал

aollo @ system: ~ $ smbtree -N (или aollo @ system: ~ $ smbtree -N)

РАБОЧАЯ ГРУППА

\ W7X86

\ VW-PC

\\ Samba FileServe Samba FileServer — вот мой Mikrotik

\\ MikroTik Samba FileServer — вот мой Mikrotik

\ МОНИТОРИНГ

\ ALIGNER-PC

aollo @ system: ~ $ sudo apt-get install smbfs -y

aollo @ system: ~ $ sudo smbclient -U ekzorchik \\\\ 10.7.8.140 \\ shara 712mbddr @

Домен = [WORKGROUP] OS = [Unix] Server = [MikrotikSMB]

smb: \> ls

. D 4096 Сб 12 дек 11:49:24 2015

.. D 4096 Сб 12 дек 11:49:41 2015

36734 блока размером 4096. Доступно 39224 блока

smb: \> mkdir файл

smb: \> pwd

Текущий каталог \\ 10.7.8.140 \ shara \

или через GUI :

Переход — Компьютер — Обзор сети (Сеть) — Нахожу в обнаруженном именовании устройства Mikrotik (по умолчанию: winbox — IP & DNS — Система — Определить) или же: Переход — Компьютер — Обзор сети (Сеть) — Сеть Windows — WORKGROUP — щелкаю левой кнопкой мыши два раза и идентифицируюсь и вот они доступные мне ресурсы.

Теперь рассмотрю доступ по сети к USB носителю через FTP сервис (к примеру можно выставить сервис в интернет):

winbox — IP и DNS — IP — Сервис — находим FTP (если выделен серым цветом, то значит сервис выключен, выделяю его и нажимаю « на Галочку » тем включив его).

Если обратиться по URL-адресу : ftp://10.7.8.140 {IP & DNS адрес Микротика) и пока авторизоваться можно только по учетной записью admin (дефолтная учетная запись суперпользователя на микротике с пустым паром), то произойдет вход на FTP ресурс, где будет доступна все файлы, которые присутствуют на встроенной памяти так и подключенный USB ресурс (в моем случае идет именование disk3 ).Создайте пользователя и группу с правами только для ftp подключения:

windows — IP и DNS — Система — Пользователи , во вкладке Группа — Добавить (добавляем / создаем) —

Имя: FTPWrite

Политики: Отмечаем ftp (т. Е. Данная роль только для взаимодействия с сервисом FTP)

Кожа: профиль безопасности

По окончании создания нажимаем Применить и OK и переходим на вкладку Пользователи Добавить ( Создаем ):

Наименование: Экзорчик

Группа: выбираю группу FTPWrite

Разрешенный адрес: с каких разрешено входить, пропускаю.

Пароль: задаю пароль — 712mbddr @

Подтвердите пароль: — 712mbddr @

По окончании создания нажимаем Применить и ОК

На заметку: поизучав возможности FTP сервиса пришел к выводу, что поднимаемый FTP сервис на Mikrotik всех создаваемых пользователей не ограничивает, потому что пользователи могут писать файлы, права на чтение отсутствуют.

На заметку: старайтесь не использовать пароль оканчивающийся на спец символ в виде собаки (@), т.к. консольные утилиты порой неправильно его воспринимают, придется экранировать, а это та еще проблема.

Чтобы под Ubuntu 12.04.5 Desktop amd64 подключить ftp ресурс микротика задействуем заметку

aollo @ system: ~ $ sudo curlftpfs ftp: // test: [email protected] / media / mikrotik -o allow_other

aollo @ system: ~ $ ls -l / media / mikrotik /

итого 28

-rw-rw—- 1 корень корень 14183 янв.2 2015 auto-before-reset.backup

drwxrwx— 5 root root 4096 дек. 12 08:49 disk3

drwxrwx— 1 корень корень 2048 дек. 12 08:28 паб

drwxrwx— 1 корень корень 2048 янв. 1 2015 скинов

Если говорить из практики для чего может понадобится подключить USB носитель в виде флешки или переносного диска, то к примеру у меня на лежат бекапы конфигурационных файлов, прошивки, файлов наработок, вообще всего же не перечислить, сам в этом случае определит для чего это может понадобиться.На этом я прощаюсь, заметка получилась объемная и практическая, до встречи, с уважением автор блога — Олло Александр.

.

Подключение USB накопителя к MikroTik и настройка файлового сервера (SMB)

Не так давно я рассказывал о настройке USB-модема на роутере MikroTik, но есть и другой вариант использования USB-разъёма … подключив к нему флешку или жёсткий диск, можно довольно легко получить сетевой накопитель (SMB сервер) или настроить FTP-сервер.

Настройку Samba сервера покажу на примере RB951G-2HnD и внешний HDD 2.5 «WD My Passport на 1 Тб. Сразу оговорюсь, что это не полноценная замена NAS — памяти и ресурсов тут в обрез, так что чудес производительности ждать не стоит (хотя на hAP AC2 работать будет заметно шустрее из-за более производительного процессора).Также не получится сделать из MikroTik DLNA-сервер или замену TimeCapsule, однако данного решения вполне хватит для хранения каких-то документов, дистрибутивов и организации доступа к файлам для нескольких человек.

Настройка файлового сервера (SMB) на MikroTik

Для начала нам понадобится отформатировать подключенный диск или флешку в одну из двух поддерживаемых файловых систем ext3 или fat32. Лучше выбрать ext3, чтобы избежать ограничений на размер файлов (напомню, что максимально возможный размер для тома FAT32 — 4 ГБ).

Заходим в меню System-> Диски и указав файловую систему ext3 нажимаем кнопку «Format Drive». Полагаю, не стоит лишний раз напоминать что все данные на диске будут утеряны.

Теперь можно приступать к настройке SMB сервера, для чего переходим в пункт меню IP-> SMB и активируем сервис. Собственно, сервер уже работает и даже есть один расшаренный ресурс / pub. Его лучше сразу отключить кнопку «Shares» и далее значок «D» (отключить), так как это внутренняя флеш память устройства и имеет ограниченное количество циклов чтения / записи.

В настройках можно задать имя рабочей группы, разрешить (или нет) доступ гостевой учётной записи и отметить в каком интерфейсе будет доступен Samba сервер. По умолчанию стоит «ALL», то есть на всех, но я бы рекомендовал установить «bridge-local» для доступа только внутри локальной сети.

Кликнув по кнопке «Пользователи» добавляем пользователей для доступа к расшаренным ресурсам (по умолчанию есть только гость с правами только на чтение, но можно разрешить и запись).К сожалению, ограничить доступ пользователей к определенным папкам не получится, как я уже говорил, это не полноценный NAS.

За сетевые ресурсы отвечает кнопка «Shares». Для того, чтобы добавить новый ресурс достаточно кликнуть «Добавить новый», задав имя ресурса и указать в размещении весь диск (/ disk1) или отдельный каталог на нём (/ disk1 / dist). Отмечу только, что создать директорию на диске не нужно, они появятся автоматически.

Если потребуется, изменив значение параметра Max Sessions , можно установить количество одновременно подключенных клиентов.Пожалуй, это всё, что хотелось рассказать о файлового сервера (SMB) на MikroTik. Если остались вопросы или желаете дополнить, не ленитесь оставлять комментарии.

Подписывайтесь на канал Яндекс.Дзен и узнавайте первыми о новых материалах, опубликованных на сайте.

Если статью считаете полезной,
не ленитесь ставить лайки и делиться с друзьями.

.

Настройка интернета в загородном доме

Ранее я опубликовал статью о том, как маскировать траффик от yota с помощью openvpn и клиента на микротик. В нескольких человек попросили рассказать о всей схеме подключения, которую я использую. Схема у меня получилась нестандартная, все придумал или нагуглил сам по ходу решения проблем со связью. Решил поделиться c остальными, тема интересная и актуальная для многих.

Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую по программе, основанной на информации из официального курса , сертифицированный сетевой партнер MikroTik .Курс стоящий, все подробности читайте по ссылке.

Данная статья является частью единого цикла про Mikrotik.

Введение

В теплое время года, да и не только, летом просто чаще, я провожу много времени за городом в Подмосковье на даче. Там же и работаю. Для того, чтобы можно было нормально работать, нужен был стабильный интернет, которого долгое время у меня не было, и я откровенно страдал. Вынужден был для работы задерживаться в городе. Мой дом расположен в очень отдаленном и тихом участке, рядом с лесом, который является несомненным плюсом с точки зрения тишины и безлюдности, и в то же время минусом с точки зрения связи.

Непосредственно сотовая связь более ли менее нормально работает, разговаривать можно. А вот с интернетом была откровенная беда. Операторы ловятся все, но интернет «никакой». Еле-еле ловит 3г. Да и цены никогда не радовали. Чтобы нормально работать, мне нужно много трафика, платить за него по имеющимся тарифам не очень хотелось.

Все изменилось, когда я попробовал оператора Yota с ее безлимитным интернетом. Как только увидел, что мой дом вроде как находится в зоне охвата, решил купить для начала симку и проверить связь.У меня в смартфоне можно установить 2 симки, так что я ее стал использовать как вторую. Тарифы у ёты мне понравились тем, что нет роуминга по всей России, что очень удобно. Пользовался в смартфоне интернетом, когда уезжал за пределы домашнего региона.

С этим смартфоном я приехал на дачу и проверил связь. Чуда не произошло, так как ёта работает по тем же базовым станциям, что и мегафон, поэтому и связь такая же как у мегафона, практически никакая. Интернетом пользоваться было очень не удобно, постоянно обрывалась, хотя временами что-то получалось загрузить.В общем, я находился в зоне неуверенного приема 3г. Я решил проверить следующую штуку: залез на чердак и положил телефон в окна, выходит на сторону, где установлена ​​ближайшая базовая станция. Стал проверять связь и очень обрадовался. Она стала значительно лучше, интернет на самом телефоне работал сносно, иногда ловился lte сигнал.

Меня это очень воодушевило и я решил включить точку доступа на телефоне, оставить его на чердаке, а самому с другим этажа подключиться нотубком к точке и работать.Тут я впервые познакомился с ограничением Yota .

Ограничение Yota

Суть ограничения ёты в том, что у нее разные тарифные планы для разных устройств с разной стоимостью. У меня была симка с самым дешевым тарифом, который позволяет пользоваться интернетом на смартфоне. Если ты пытаешься со смартфоном раздавать другие устройства, то yota это определяет и выводит страничку с предупреждением о том, что на вашем тарифе это делать запрещено, но если вы хотите использовать интернет, то заплатите за это отдельно.

Я пошел в поиск смотреть, что есть на эту тему. Оказалась, что тема весьма популярна. Для обхода ограничения на тот момент достаточно было на компьютере установить TTL 65, если у вас смартфон на андроиде, и все. Суть в том, что на самом смартфоне TTL пакеты 64, если на компьютере будет 65, то из смартфона эти пакеты будут улетать с TTL 64 и ёта не будет о том, что вы кому-то раздаете интернет. Мне это помогло. Какое-то время я пользовался интернетом так.Но со врменем решил что-то изменить. Чтобы установить смартфон, мне надоело постоянно раздавать интернет и на другие устройства, смартфон разряжался от режима работы в качестве точки доступа. Аккумулятор у него достаточно мощный, на день работы мне хватало, но все равно не нравилась такая схема. Раздавать интернетавать на другие устройства, я кстати, научился. У меня был рутовый доступ на телефон. Я на него поставил софт, который уже на смарте изменял TTL всех пролетающих пакетов.

Нужно было решать вопрос с качеством связи. Тут я уже серьезно углубился в тему и стал подбирать решение под свою ситуацию.

Выбор антенны для усиления lte сигнала Yota

Почитал форумы на тему усиления сигнала, начал разбираться в антеннах. Надежду на успех давала информация о том, что если у вас хоть как-то сигнал ловится телефоном, то антенна поможет точно и будет значительно лучше. То есть улучшить уже имеющийся сигнал не проблема. Ппроблемы возникают в основном там, где сигнала с обычного телефона нет совсем.

В итоге я купил себе — антенна панельная направленная MIMO 3G / 4G LTE, 20 дБ (1900-2700 МГц) — http://450mhz.ru/antenna/?id=207. В комплекте у нее идут 5-ти метровые провода. Мне этого было достаточно, дополнительные провода не покупал. Но нужны были отдельные переходники, чтобы соединить эту антенну с usb модемом. Я купил вот эти — http://450mhz.ru/accessories/?id=91. Для креепления антенны к стене здания нужно купить отдельно кронштейн. Купил такой — http: // 450mhz.ru / аксессуары /? id = 215.

Устанавливать антенну для качественного приема необходимо в прямой видимости установки станции. Она не должна быть закрыта складками местности или другими зданиями. Толку от нее в этом случае будет мало. Мне повезло, мой дом достаточно высокий и с чердака вид на базовую станцию ​​ничем не перекрыт, как раз над сосдеской крышей проходит.

К сожалению, я не смог закрепить антенну на кронштейн. У меня просто нет возможности это сделать. Высота дома большая, сборные лестницы очень ненадежны на такой высоте.Работать инструментом на них невозможно, а тем более крепить антенну, она тяжелая. К тому же потом нужно ее правильно отрегулировать, проверить связь, повернуть, возожно несколько раз это проделать. Я не смог бы вызвать подъемник и установить с ним, но я не пошел на это, так как после того, как подъемник уедет, у меня не будет доступа к антенне вообще, я не смогу ее ни спозиционировать в случае надобности по-другому, ни проверить .

Нужно было либо собирать леса вдоль стен дома, либо на крыше как-то крепить.В общем, сложно. Я отделался малой кровью. Установил антенну на чердаке рядом с окном и направил на базовую станцию. Немного покрутил, повертел, понаклонял в разные стороны и выбрал оптимальное положение.

Этого оказалось достаточно для того, чтобы появился уверенный прием на нижней границе. То есть из 5-ти палок, у меня стабильно ловилась одна, иногда 2. Сигнал был стабильный, скорость 1-5 мегабит. Мне для работы этого достаточно. Да и для всего остального. Но хочется конечно больше.Думаю, сигнал будет еще лучше, если антенну вынести на улицу и установить таки на кроншейне повыше. Но пока не придумал, как это сделать.

Подбор usb модема для Yota

Антенну нужно было подключить к модему. По отзывам в интернете я выбрал, которая гарантированно работала с сим картами Yota. Это оказалось Huawei E3372 / 827F / M150-2 — 4G LTE / 3G USB http://450mhz.ru/USB_modem/?id=192. В магазине я купил уже прошитый под все московские операторы.Вставил сим карту ёты и сразу же все заработало при подключении модема к компьютеру. Или не сразу. Уже точно не помню, делал все больше года назад. Постараюсь воспроизвести всю последовательность своих действий. Скорее всего модем заработал каким-то другим оператором, на котором я проверял. Симка от ёты у меня была для смартфона, вряд ли она просто так заработает в usb модеме.

Я нашел в интернете более удобную прошивку для модема и перепрошил его, попутно заменив IMEI, взятый со старого сломанного телефона.Всю информацию по работе с модемом я нашел на форуме 4pda.ru. Попробовал поискать инструкции, по которому делал, но не нашел. Информации очень много, но именно то, что использовал я, мне не попалось. Поэтому опишу только последовательность дейтвий, которые выполнил. Вы сами ищите свежие инструкции для этого, их много, я только что смотрел, надо брать модем и пробовать. Мне уже не на чем проверять, рабочий модем не хочу дергать.

  1. Я прошил модем Huawei E3372 свежей прошивкой HiLink .
  2. Вроде бы отдельно установил какой-то более удобный веб-интерфейс, точно уже не помню.
  3. Сменил IMEI модема, взяв у старого телефона.
  4. Установил TTL fix. Он был в виде небольшого патча.

После этого я мог просто вставить симку yota, модем в компьютер или роутер пользоваться и интернетом. Первое время все было нормально, чем дальше, тем чаще я стал получать страницу от предупреждения об ограничении раздачи интернета. Стал читать информацию и понял, что только TTL фикса сталочоно.Ёта начала опеределять, кто пользуется интернетом по ресурсам, на которые осуществляется доступ. К примеру, если у вас симка для смартфона, вы идете на сервер обновлений Microsoft, или играете в онлайн-игру для ПК, очевидно, что вы интернет раздаете и вам нужно ограничить доступ.

Первое время было достаточно вносить изменения в файлы хостов на компьютерах, ограничивая доступ к ресурсам. Список ресурсов искал в интернете. Но со временем появлялись все чаще и чаще. К примеру, я заметил, что доступ в интернет сразу прекратил, как только я обновлял порты на freebsd в данной машине.Ко всему прочему, интернетом стали пользоваться другими устройствами — телефонами, планшетами. Настраивать списки ограничений на них всех было очень затруднительно или невозможно. Я стал решать вопрос кардинально. В итоге настроил openvpn клиент на роутере микротик и замаскировал весь трафик.

Я забежал немного вперед, не рассказав еще о подключении usb-модема к микротику.

Настройка usb модема с Yota на mikrotik

Антенна у нас есть, модем прошит под ёту и готов работать.Осталось его подключить к роутеру mikrotik и настроить раздачу интернета от yota. С помощью переходников подключаем антенну к модему и втыкаем его в mikrotik. У меня получилось вот так:

Мой микротик RB951G-2HnD с версией ОС 6.33.3 без проблем определил модем. Мне не пришлось ничего настраивать. В списке интерфейсов появился новый с названием lte1 :

Так как в прошивке HiLink уже встроенный сервер dhcp, в микротике необходимо запустить клиентский интерфейс dhcp на lteсе.Вы получите адрес из диапазона 192.168.8.0.

Дальше можете настроить микротик как вам захочется. Подробная информация по настройке микротиков есть в моей статье. Там все очень подробно и просто написано, есть видео.

На этом у меня все по моему интернету через yota в загороднем доме.

Заключение

Подведу итог того, что было сделано. По пунктам выстрою всю последовательность действий.

  1. Купил сим карту yota и убедился, что хоть какой-то сигнал ловится на даче.
  2. Купил usb модем и перепрошил его для работы в сети yota, заменил imei и установил ttl fix.
  3. Купил антенну для усиления сигнала 4g / lte, переходники и подключил ее к модему.
  4. Подключил модем к микротик, настроил раздачу интернета по wifi.
  5. Настроил клиент openvpn на микротике для маскировки интернет-трафика от ёты.

На текущий момент такая конфигурация успешно работает. Не сомневаюсь, что через некоторое время в придумают какую-то новую схему блокировки несанкционированной раздачи интернета с тарифов, не предназначенных для этого.Будем думать тогда, как поступать.

У меня уже есть идея, как можно преодолеть будущие блокировки от yota. Я даже думал уже сейчас ее использовать. Например, через ёту подключаться по rdp к другому компьютеру и работать на нем. На локальном компьютере отключить все соединения, кроме rdp к указанному адресу. Конечно, это не так удобно, да и с остальных устройств не получится выходить в интернет. Но это не очень страшно. Мне интернет нужен в основной для работы, а через rdp мне даже удобнее в некоторых случаях.Я использую готвое и настроенное рабочее окружение, которое доступно из любого места. Если интернет стабильный, то работать практически так же удобно, как и за локальным рабочим столом.

А все остальные пусть на природе отдыхают от своих гаджетов и интернета. Для здоровья полезно. Жду советов, комментариев, подсказок по написанному. Возможно кто-то предложит более простой и удобный вариант. Добавлю еще, когда уезжаю, забираю модем с собой и использую по мере надобности в Москве или где-нибудь еще.Очень удобно. Считаю это существенным плюсом моего решения. Оплаченный безлимитный интернет всегда со мной.

На всякий случай еще приведу ссылку на настройку бесшовного Wi-Fi роуминга на основе микротик. Тема актуальная как раз для загородного дома, так как бесшовность решения на основе микротиковского заглушки весьма условна и в энтерпрайзе не везде подойдет. А вот для домашнего использования в самый раз — бюджетно и просто.

Напоминаю, что статья является частью единого цикла про Mikrotik.

Онлайн курсы по Mikrotik

Если у вас есть желание научиться работать с роутерами микротик и стать специалистом в этой области, рекомендую пройти курсы по программе, основанной на информации из официального курса , сертифицированный сетевой партнер MikroTik . Выполнить следующие действия. Все подробности на сайте. Стоимость обучения весьма демократична, хорошая возможность получить новые знания в актуальной на сегодняшний день предметной области.Особенности курсов:
  • Знания, ориентированные на практику;
  • Реальные ситуации и задачи;
  • Лучшее из международных программ.
Помогла статья? Подписывайся на telegram канал автора
Анонсы всех статей, плюс много другой полезной и интересной информации, которая не попадает на сайт. .

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *