Mikrotik queues: Queues в RouterOS: Simple Queues MikroTik (часть 1)

Содержание

Queues в RouterOS: Simple Queues MikroTik (часть 1)

5. Практика Simple Queues

Для демонстрации настройки простых очередей рассмотрим пример на рисунке 5.1. Каждое из устройств на схеме является маршрутизатором, функционирующем на RouterOS. R1 и R2 являются потребителями трафика – на них будет запущен bandwidth-test по направлению к BT_server. На маршрутизаторе R_queue будет выполнена настройка простых очередей.


Рисунок 5.1 — Схема сети для рассмотрения практических примеров

Начальная конфигурация устройств:

R1:

R2:

BT_server:

R_queue:

5.1 Ограничение скорости для подсети

Выполним ограничение скорости для подсети 172.16.1.0/24 upload 10 Мбит/с, download 5 Мбит/с. Для этого на R_queue выполним команду /queue simple add target=172.16.1.0/24 max-limit=10M/5M, а на R1 и R2 запустим тестирование пропускной способности.

Конфигурация R_queue:


Рисунок 5.2 — Результаты тестирования downlink


Рисунок 5.3 — Результаты тестирования в направлении uplink

На рисунках 5.2 и 5.3 видно, что трафик потребителя R1 ограничен, в соответствии с задачей, ~10Мбит/~5Мбит, тогда как пропускная способность R2 ограничивается физическими возможностями порта.

5.2 Распределение общей полосы по приоритетам

В примере 5.1 был рассмотрен простейший способ ограничения скорости для определённой подсети. Такая реализация может быть использована в небольших сетях, либо как временное решение. На практике чаще пропускная способность канала должна быть разделена между несколькими потребителями в разных пропорциях.

Рассмотрим пример, в котором пропускная способность канала связи равна 10Мбит/с и должна быть поделена между двумя потребителями: первый потребитель ограничен 8 Мбит/с, второй — 5 Мбит/с. Поскольку суммарная пропускная способность выше полосы канала (8 Мбит/с+5 Мбит/с > 10 Мбит/с), то установим приоритет для второго потребителя.

Для этого создадим иерархию простых очередей: родительская очередь ограничена 10 Мбит/с, а дочерние — 8 и 5 Мбит/с соответственно, причём имеют разные приоритеты. Важно отметить, что target родительской очереди должен соответствовать target всех дочерних.

Конфигурация R_queue:


Рисунок 5.4 — Результаты тестирования в направлении downlink


Рисунок 5.5 — Результаты тестирования в направлении uplink

Пропускная способность канала распределяется в соответствии с приоритетами — сначала 5 Мбит/с выделяется R2, а потом оставшаяся полоса — R1. R2 не получает всю пропускную способность канала связи, т.к. выставлено ограничение max-limit=5M. При этом, если остановить потребление трафика на R2, R1 получит пропускную способность в соответствии с ограничениями — 8 Мбит/с:


Рисунок 5.6 — Результаты тестирования в направлении downlink


Рисунок 5.7 — Результаты тестирования в направлении uplink

5.3 Использование CIR и MIR при распределении пропускной способности

Недостатком решения, рассмотренного в примере 5.2, является то, что при отсутствии одного из потребителей, часть пропускной способности не используется, даже, если в ней есть потребность со стороны активного потребителя трафика. Так, например, при отсутствии трафика R1, R2 сможет использовать только 5 Мбит/с.

Решим эту задачу, задав значения CIR и MIR. Для обоих потребителей установим MIR равным 10 Мбит/с, а CIR — 2 Мбит/с. Приоритеты останутся теми же: приоритизация трафика второго потребителя будет выше.

Конфигурация R_queue:


Рисунок 5.8 — Результаты тестирования в направлении downlink


Рисунок 5.9 — Результаты тестирования в направлении uplink

Сначала пропускная способность распределяется в соответствии с CIR — по 2 Мбит/с, а затем, т.к. приоритет R2 выше, чем у R1, оставшаяся часть полосы канала предоставляется R2: 10Мбит — 2 Мбит -2 Мбит = 6 Мбит, т.е. итоговая пропускная способность R2 – 8 Мбит/с (2 Мбит/с от CIR + 6 Мбит/с при приоритетном распределении полосы канала). При этом, если отключить R2, то R1 начинает утилизировать всю доступную полосу:


Рисунок 5.10 — Результаты тестирования в направлении downlink


Рисунок 5.11 — Результаты тестирования в направлении uplink

Mikrotik настройка QUEUES TREE

Если обратиться к великому и могучему, то можно найти миллионы статей по настройке шейпирования на микротике. Но все они слишком уж тяжелые для понимания и монстрообразные. Все можно сделать намного проще. Но для начала расскажу, что это такое «Динамическое шейпирование» и почему его надо делать. Сам по себе динамический шейпинг это возможность в автоматическом режиме распределять скорость интернета между пользователями в зависимости от потребностей и загруженности канала Интернет.

Например у вас подключено к сети 2 компьютера, 1 телефон и 1 планшет. На компьютерах включен торрент, а вы пока решили посидеть в любом контактике или просто посмотреть на милых котиков в интернете. При обычном роутере все было бы весьма печально. Максимальнвая скорость была бы отдана торрентам, а вам достались бы сущие байты. Именно для предотвращения такой ситуации было придумано динамическое шейпированиескорости. Когда вы его правильно настроите, то заметите, что ситуация координально изменилась. Торрент качает, вы сидите в интернете и не испытваете проблем со скоростью. Ваш Mikrotik разрулил канал интернета таким образом, что бы каждый подключенный девайс не испытывал проблем. Красиво звучит, правда? Что же на практике? Queues Tree — именно тут и будут обрабатываться ваши скорости. Как настроите, так работать и будет.

Теперь переходим к практике. Я надеюсь вы уже умеете подключаться к вашему Mikrotik через утилиту Winbox, поэтому не буду рассказывать такие банальные вещи. И так, подключились. Переходим IP->Firewall->Address list. Тут нам необходимо создать адресный лист, который будет содержать внутреннюю подсеть. Именно ту, из которой ваши железки будут получать IP-адреса. Сделать это категорически просто. Жмем на синий плюсик, в поле Name пишем любое название. Оно лишь обзывает ваш адресный лист для лучшего понимания. В поле адрес пишем вашу подсеть. Я предполагаю, что вы не настраивали специальным образом DHCP и используете настройки по умолчанию. Тогда вводите такую строку: 192.168.88.0/24 и жмем ок.

Далее переходим в этом же окне на вкладку Mangle. Тут надо создать всего две записи. Жмем на плюсик, появляется окно добавления. На первой вкладке выбираем forward, в поле Dst.Address вписываем свою подсеть, например 192.168.88.0/24. Ввели? Отлично. Открываем вкладку Action. В поле Action выбираем mark packet, а в поле new packet mark пишем down. Ставим галочку passthrough. Все, жмем ок. Проделываем тоже самое еще раз с той лишь разницей, что меняем Dst.address на Src.address и в поле new packet пишем up. Все. Мы сделали 2 правила, которые будут маркировать весь трафик проходящий через ваш маршрутизатор. Это надо для того, что бы роутер понимал, какой трафик куда идет и как его надо балансировать. У вас должно получиться точно как на картинке, только подсеть и название листа ваши.

Все верно? Идем дальше. Большую часть мы уже сделали, настало время настроить балансировку и проверить ее работу. Слева в меню находим и открываем ссылку с названием Queues. В первую очередь нам необходимо создать тип очереди. Для этого переходим на вкладку Queues Types. Как всегда нам предстоит создать 2 типа очередей. Для входящего трафика и исходящего. Ничего сложного тут нет. Сделайте точно так же, как показано на картинке ниже.

Отлично, у вас есть очереди. Осталось только создать правила для их обработки. Это мы делаем на вкладке Queue Tree. Именно тут создается дерево с правилами обработки трафика. Если до того, как попасть в этот блог вы уже находили другие инструкции, то заметите, что у меня всего 4 правила. В отличии от других, которые делают 5, 6, 8 и более правил. Может оно хорошо для крупных сетей, где нужна специфика. Но для дома это слишком избыточно и просто не нужно.

Хорошо, делаем дальше. Для добавления правила опять жмем на уже полюбившиейся нам плюсик. В поле name пишем GLOBAL, тем самым мы будем понимать, что это правило самое главное. Родительское. Остальное оставляем как есть, ничего не меняем и жмем ОК.

Добавляем следующее. Жмем плюсик, в поле name пишем любое название, какое вам нравится. А вот в поле parent из выпадающего списка выбираем ранее созданное правило GLOBAL и жмем ок. Получаем очередь из двух правил. Осталось еще два. Добавляем еще одно, все тем же плюсиком. Стоит сказать, что оставшиеся два правила будут практически одинаковыми с небольшой разницей. Поэтому приводим их к виду, как показано на рисунках.

Сделали? Отлично. Теперь все подключенные к роутеру устройства получат скорость равную 2 Мегабита в секунду. Вы можете изменять значения в любую сторону, но не увлекайтесь. Как только ширина вашего интернет канала закончится, роутер выдаст всем скорость, которая указана в поле Limit at. Поэтому стоит делать скорость в пределах 5-7 Мегабит. Этого более чем достаточно для комфортного использования интернета.

Как видите, настройка mikrotik не сложная. Главное понять логику работу и вы сможете очень гибко управлять доступом в сеть и не только. В следующих статьях я расскажу подробнее о защите вашего роутера от атак из Интернета.

Поделиться в социальных сетях:

Настройка MikroTik. Использование Simple Queue для ограничения скорости.

В этой статье я опишу как можно настроить QoS на MikroTik для работы, скажем в небольшой корпоративной сети до 42 компьютеров. Предлагаемая ниже схема маркировки пакетов и шейпинга трафика позволяет получать хорошие задержки при практически полной загрузке канала интернета. Так же можно добиться довольно быстрого открытия страниц при скачке торрентов другими пользователями. Канал делится поровну между качающими в любой конкретный момент пользователями. В общем, это хорошо реализованая идея динамического шейпинга на микротик. Кроме того предлагается пиринговый трафик отделить от основного и шейпить по другому.

 

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

 

Для тех кто не хочет тратить своё дорогое время на изучение данного мануала предлагаем нашу платную помощь.

Отмаркируем пакеты пиринговых (гостевых) ресурсов byfly. Дабы упростить задачу воспользуемся терминалом, чтобы указать те адреса, которые мы будем считать пиринговыми: 


Откроем терминал и вставим туда команду:

ip firewall address-list

Далее вставим: 

add address=86.57.151.0/27 disabled=no list=Guest

add address=82.209.245.151 disabled=no list=Guest

add address=194.158.206.240 disabled=no list=Guest

add address=194.158.206.241 disabled=no list=Guest

add address=194.158.206.246 disabled=no list=Guest

add address=86.57.246.0/24 disabled=no list=Guest

add address=93.84.112.0/21 disabled=no list=Guest

add address=178.124.128.0/21 disabled=no list=Guest

add address=91.149.189.0/25 disabled=no list=Guest

add address=91.149.189.128/26 disabled=no list=Guest

add address=93.125.53.0/24 disabled=no list=Guest

add address=178.172.148.0/24 disabled=no list=Guest

add address=91.149.157.192/26 disabled=no list=Guest

add address=93.125.30.0/23 disabled=no list=Guest

add address=86.57.251.28 disabled=no list=Guest

add address=86.57.253.1 disabled=no list=Guest

add address=193.232.248.79 disabled=no list=Guest

add address=193.232.248.80 disabled=no list=Guest

add address=194.158.202.59 disabled=no list=Guest

add address=82.209.195.15 disabled=no list=Guest

add address=86.57.250.0/23 disabled=no list=Guest

add address=91.149.157.0/25 disabled=no list=Guest

add address=194.158.199.177 disabled=no list=Guest

add address=82.209.240.241 comment=DNS disabled=no list=Guest

add address=82.209.243.241 comment=DNS disabled=no list=Guest

В результате выполнения должно получится что-то подобное:


Отмаркируем соединения пользователей на пиринговые (гостевые) ресурсы. Для этого переходим на вкладку IP-Firewall-Mangle и нажимаем плюсик +:

На вкладке Advanced выберем список адресов Guest:

Выберем маркировку соединенений меткой guest-connection:

Создадим правило маркировки гостевых пакетов:

Чтобы исключить дальнейшую перемаркировку пакетов последующими правилами снимаем галочку с passthrough:

В результате получаем 2 правила маркировки гостевых соединений и пакетов:

Нажмём ещё раз плюсик, чтобы создать правило маркировки оставшихся пакетов, как идущих из интернета. Сначала маркируем все соединения:

Маркируем пакеты идущие через соединения internet-connection:

Получится четыре правила в Mangle:

Настроим Simple Queues для канала интернета в 6M/0.5M и скорость на ADSL порту 12M/0.8M. Настроим шедуллер для исходящего трафика. Будем его делить между пользователями поровну классифицируя согласно IP копьютеров в сети.

Так же настроим шедуллер для входящего трафика. Трафик классифицируем:

Создадим родительскую очередь All, через которую будет проходить весь трафик. Укажем сети, в которых находятся наши клиенты и ограничения скорости для них 10M/0.5M. Нужно указывать скорости, которые ниже на 15-25% чем скорости на ADSL порту, иначе возможно увеличение задержек и неправильная работа шейпера, при использовании канала на полную. Очередь All всегда должна быть под 0 номером в таблице.

Перейдём на вкладку Advanced и выберем пакеты, которые мы от маркировали в мангле метками «internet-packet«, «guest-packet«. Установим гарантированные скорости равными максимальным и включим для них ранее созданные шедуллеры «up-pcq» и «down-pcq»:

Создадим дочернюю очередь, к которой будет относится пиринговый «гостевой» трафик. Target Address – пишем сеть, в которой находятся клиенты, в нашем случае — 192.168.88.0/24. Чтобы всё хорошо работало, Max limit в квоте Guest должен быть немного меньше чем в квоте All. Очередь Guest должна быть под номером 1 в таблице.

Одно из условий правильной работы HTB шейпера: cумма гарантированных скоростей «limit-at» дочерних очередей должна быть меньше максимальной скорости «max-limit» родительской очереди. Установим 2m/64k гарантированной полосы на пиринговые ресурсы. Увеличим приоритет квоты Guest до 7, и выберем правильный шедуллер (Queue Type):

Создадим дочернюю по отношению к All очередь ByFly, по которой пойдёт интернет трафик. Из опыта скажу, что 10% канала 6m/512k придётся зарезервировать для нормальной работы шейпера. Это связано с особенностями устройства HTB деревьев и тем, что провайдер иногда может немного недодавать вам полосу. Кроме того, возможно дрожание в канале, если резервировать меньше. Итак, Max-limit устанавливаем 5400k/430k для нашего канала.

Укажите для очереди ByFly гарантированные скорости, тип шедуллера, родительскую очередь, приоритет и маркированные пакеты согласно скрину:

Создадим в очереди ByFly очередь для пользователя user1 c такими настройками:

  • максимальная скорость 5m/256k
  • IP адрес 192.168.88.254
  • имя квоты для него user1

Пакеты становящиеся в очередь: internet-packet.

Шедуллеры: up-pcq down-pcq.

Родительская очередь: ByFly.

Приоритет: 5.

Гарантированая полоса 128k/10k, выделяемая пользователю, позволит создать до 42 очередей в родителе ByFly для клиентских компьютеров (5400k/128k=42 очереди, 430k/10k=43 очереди).

После добавления пользователей дерево выглядеть будет так в порядке обработки очередей:

Или так, в порядке старшинства очередей:

Вариант настройки Queue Tree для динамичекого шейпинга трафика на Микротик.

Ещё вы можете у нас заказать платную настройку маршрутизатора и посмотреть цены на настройку

 

Освоить MikroTik Вы можете с помощью онлайн-куса «Настройка оборудования MikroTik». Курс содержит все темы, которые изучаются на официальном курсе MTCNA. Автор курса – официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с микротиками, и тем, кто еще их не держал в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

 

Cмотрите также:

Микротик ограничение скорости. Настройка приоритета трафика (QoS)

В статье подробно описано, как настроить на Микротике ограничение скорости по отдельному ip или на целую сеть, ограничение на интерфейсе и физическом порту. А также настройка приоритета трафика (QoS), для sip, tv и других сервисов. Все настройки будут производиться через программу winbox.

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если у Вас версия RouterOS выше 6.29, то перед настройкой шейпера убедитесь. что в firewall отключен fasttrack, эта технология позволяет увеличить производительность маршрутизатора, но если она включена, то шейпить скорость не получится. Заходим в меню   на вкладке Filter Rules,  ищем правило fasttrack connection. Если такое правило существует, то отключаем или удаляем его.

Ограничение скорости интернета на все ip адреса в подсети.

Предположим, провайдер предоставляет нам интернет канал 50 Мбит/сек. Стоит задача: для каждого пользователя ограничить канал до 5 Мбит/с.

Создадим  новый тип. Для этого заходим в меню Queue вкладка Queue Types. И нажимаем на кнопку «+» добавить.

Type Name – имя нового типа

Kind – тип, принимает следующие значения
bfifo – тип основанный на алгоритме First-In First-Out, Первый-пришел первый ушел, размер очереди определяется в байтах параметром queue size, если очередь переполнена, то остальные пакеты отбрасываются.
pfifoто же самое что и bfifo, только размер не в байтах, а в пакетах
mq pfifo тот же pfifo с поддержкой нескольких очередей
red — Random Early Drop — это механизм очередей, который пытается избежать перегрузки сети, контролируя средний размер очереди. Средний размер сравнивается с двумя порогами: минимальным (минимальным) и максимальным (максимальным) порогом. Если средний размер (avgq) меньше минимального порога, пакеты не отбрасываются. Когда средний размер очереди больше максимального порога, все входящие пакеты удаляются.
sfq — Stochastic Fairness Queuing (SFQ) обеспечивается хешированием и циклическими алгоритмами. Трафик может быть однозначно идентифицирован с помощью 4 параметров (src-адрес, dst-адрес, src-порт и dst-порт), поэтому эти параметры используются алгоритмом хэширования SFQ для классификации пакетов в один из 1024 возможных подпотоков. Затем алгоритм round-robin начнет распространять доступную пропускную

способность для всех подпотоков, причем каждый раунд дает байты трафика sfq-allot. Вся очередь SFQ может содержать 128 пакетов и доступно 1024 подпотока.
pcq – то же что sfq,  но с возможностью ограничить скорость потоков

Более подробно о типах можно прочитать здесь https://wiki.mikrotik.com/wiki/Manual:Queue#Kinds

Для ограничения ширины канала выбираем тип pcq, в поле Rate указываем значение скорости. В нашем случае 3M. Нам нужно ограничить 3 Мбит/c на вход и на выход, поэтому ставим галочки напротив Dst. Address и Src.Address. Если нам нужно не симметрично ограничить канал, скажем на загрузку 3Мбит/c, а на отдачу 5Мбит/c, то нужно создать два типа, на загрузку и на отдачу с соответствующими параметрами. Остальные поля оставляем как есть.

Остальные поля pcq типа

Limit — размер одного подпотока
Total limit — максимальное количество данных в во всех подпотоках
Burst Rate, Burst Threshold, Burst Time  — довольно интересные параметры, рассмотрим их более подробно.
Burst Rateдословно «взрыв скорости» если мы сделаем настройки как показаны на рисунке.

То это будет работать так: если пользователь допустим начнет закачку файла, то сначала канал  у него будут 10Мбит/c, параметр Burst Rate, и такая скорость будет в течении 3-х минут, параметр Burst Time, далее скорость вернется к значению Rate. Если пользователь не будет некоторое время скачивать и у него использование интернет канала опустится меньше 512 Кбит/c, значение Burst Threshold , то при следующем использовании интернета, первые 3 минуты пользователь будет пользоваться каналом со значением  Burst Rate. Это бывает очень полезно, скажем когда пользователи просто ходят по страницам в интернете, то скорость загрузки страниц у них будет 10 Мбит, а если они начнут качать большие файлы, то через три минуты скачивание будет всего 5 Мбит/c.
Поля раздела Classifer думаю понятны без объяснений, это адрес, порт источника и назначения, а также маски адресов. Более подробно о типе pcq читайте здесь https://wiki.mikrotik.com/wiki/Manual:Queues_-_PCQ.

Следующим шагом применим наши созданные правила. Заходим на вкладку Simple Queues и добавляем очередь.

Name – имя нашей очереди

Target – цель. Здесь прописываем нашу подсеть

Остальные поля не заполняем, если вы встречали статьи где нужно прописывать Max Limit, то могу сказать что это не обязательно, работать будет и с параметром unlimited. Далее переходим на вкладку advanced и выбираем в качестве Queue type. Созданные выше типы.

Нажимаем кнопку ОК. На этом настройки закончены. Теперь любой компьютер c ip адресом из подсети 192.168.7.0/24 будет ограничен шириной канала в 3Мбит/с.

Ограничение на интерфейсе

Для ограничения на порту зайдите на вкладку Interface Queue, выберите нужный интерфейс и примените к нему созданное выше правило.

В примере на порту eth6 будет применено ограничение в 3Мбит/с

Ограничение скорости с помощью маркировки пакетов и Queues Tree на всю сеть

Если нужно ограничить ширину канала на одну или несколько сетей, а также на отдельные ip адреса то этот можно сделать с помощью маркировки пакетов .

Заходим в меню IP-Firewall, вкладка Address Lists создаем новый адрес лист с нашей сетью.

Также в этот лист можно добавить и отдельные ip адреса, а не сеть, скажем если они идут не по порядку, допустим 192.168.7.11, 192.168.7.87, 192.168.7.199.

Далее переходим на вкладку Mangle , здесь добавляем два правила. На вкладке General, поле Chain выбираем forward

Переходим в advanced и в поле Src. Address List выбираем лист созданный на первом шаге

Идем на вкладку Action. Здесь в поле action выбираем маркировку пакетов mark packet и пишем как будем маркировать, например upload.

Аналогично создаем еще одно правило на download. Только уже будет Dst. Address List и маркировка download.

Нажимаем Ок. Теперь все пакеты идущие из сети 192.168.7.0/24 будут маркироваться как upload, а пакеты идущие в эту сеть как download.

Теперь идем в меню Queues, вкладка Queues tree и добавляем правило.

Name – имя

Parent выбираем global

Packet Marks выбираем маркировку созданную ранее upload

Limit AT гарантированная скорость, т.е если у нас скажем общий канал 10 Мбит/c и мы создаем две очереди с максимальной шириной канала по 10 Мбит. То если вторая очередь заняла скажем канал на 8 Мбит, то нашей остается всего 2 Мбит, параметром Limit AT мы указываем, что гарантируем канал в 5 Мбит. т.е если в нашей очереди начнут интенсивно использовать интернет, то приоритет у нашей очереди увеличится, а у второй очереди уменьшится и скорость поделится по 5 Мбит

Max Limit максимальная скорость. Это и есть наше ограничение скорости.

Нажимаем ОК и аналогично создаем очередь на загрузку

Если все сделали правильно, то мы увидим наши созданные queue и загрузку по ним.

Этот способ удобно использовать когда список сетей или адресов на ограничение часто меняется, тогда их просто можно добавлять или удалять в адресных листах. Если же адреса для ограничения меняются не часто, то удобнее использовать simple queus.

Simple Queues

Более простой способ ограничения скорости делается через вкладку Simple Queues. Заходим на эту вкладку нажимаем добавить

В поле name пишем имя в target нашу сеть. Max Limit ограничения на загрузку и на отдачу

Нажимаем ОК, На этом настройка завершена, теперь вся сеть 192 .168.7.0/24 ограничена в 10Мбит, про Burst Limit я писал выше, здесь это работает также. Если нам нужно ограничить скорость не на всю сеть, а на отдельный ip адрес, то просто в поле target прописываем этот ip.

Приоритезация трафика на Mikrotik

Если нужно настроить приоритизацию трафика на Mikrotik то это делается через параметр Priority в настройка Queues tree.

Или на вкладке Advanced в Simple Queues.

Приоритет принимает значение от 1 до 8. Чем меньше значение, тем выше приоритет, т.е очередь с priority 1 будет обрабатываться самой первой, а с 8 последней. Например если у вас есть сервер ip телефонии asterisk с ip 192.168.7.10, то для него лучше сделать настройки такие.

Если нам нужно настроить приоритет определенного типа трафика, например SIP, VoIP или IpTV не привязываясь к ip адресам. То сделать это можно с помощью Mangle и Queues Tree, как это сделать я писал выше, только маркируем пакеты не по ip а по протоколу и порту. Например для маркировки пакетов на порт 5060 будет выглядеть так.

Комбинируя выше указные способы можно очень гибко настроить шейпинг скорости и приоритет трафика. Также надо отметить что настройки в Queue Tree имеют больший приоритет чем в simple Queues.

Обучающий курс по настройке MikroTik

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Настройка Микротик — Queues Tree

Часто возникает ситуация, когда необходимо динамически распределить скорость между клиентами сети. Различные роутеры предлагают варианты настроек, но в этой статье мы поговорим о том, как сделать самую простую и эффективную настройку Queues Tree. Настройка Wi-Fi «Микротика» не так сложна как кажется на первый взгляд и вы в этом сами убедитесь на примере ниже.

Потребность в ограничении скорости может возникать по разным причинам, но цель всегда одна – предоставить комфортную среду для все пользователей сети. В микротике это решается включением Queues Tree.

Для того, что бы настроить микротик первым делом вам необходимо знать ширину вашего канала. Узнать это можно у провайдера, либо открыть любой измеритель скорости и посмотреть там. Мы советуем SpeedTest.

Итак, нам все известно, у нас стоит микротик и базово настроен. Что нам делать дальше? А дальше открываем IP->Firewall и переходим на вкладку Mangle. Здесь мы промаркируем пакеты всего трафика, который будет проходить через наш микротик. Это нужно для того, что бы в дальнейшем, когда появится разделение сетей и вам надо будет разным сетям выдать разную скорость, вы просто укажете это в маркировке. Но об этом расскажем позже.

Нажимаем на плюсик и добавляем правило:

На первой вкладке Generel мы указываем:

Chain forward – слушаем весь проходящий трафик.
Dst.Address – указываем свою подсеть, которой ограничиваем скорость.

Переходим на вкладку Action:

Action – выбираем mark packet, тем самым говоря микротику, что надо маркировать трафик.
New Packet Mark – указываем название как маркировать. Написать можно абсолютно все, но мы рекомендуем использовать понятные наименования. Потому что далее они нам понадобятся. Так же стоит обратить внимание, раз мы в поле Dst.Address указали подсеть, то трафик в данном случае будет считаться download.

После заполнения полей жмем ОК. И добавляем еще одно правило, аналогичное первому, только поле Dst.address заменяем на Src.Address и не забываем, что теперь трафик будет считаться upload

Переходим к настройке Queues Tree, оно же дерево очередей. Открываем Queues и идем на последнюю вкладку Queues Types. Нам необходимо добавить два типа очередей. Нажимаем плюсик и заполняем:

Type Name – название типа очереди. Опять же рекомендуем указывать upload и download, что бы не путаться в дальнейшем.
Kind – тип очереди. Нам нужен PCQ
Rate – ширина вашего канала.

Остальное можно не менять. Особое внимание обратите на галочку в поле Classifier. Если вы добавляете тип очереди для download трафика, то галочка должна стоять на Dst.Address, а для upload трафика Src.Address.

Теперь приступаем непосредственно к добавлению самих очередей. При настройке Queues Tree микротика для одной подсети создается две основных очереди, в которых и будет происходить обработка трафика. Так же эти очереди необходимо поместить в родительские. Если вы настраиваете шейпирование для одной подсети, то родитель будет один. Для примера я покажу и второго родителя для составления очередей для разных подсетей. Нажимаем плюсик и добавляем первого родителя, назовем его GLOBAL и больше ничего менять не будем. Опять жмем плюсик и добавляем второго родителя для одной подсети, называем его, например home, а в качестве Parent ставим нашего первого родителя GLOBAL. Пришло время добавить дерево для обработки трафика. Жмем плюсик и заполняем поля:

Name – down. Указываем, что данное правило будет обрабатывать скорость для download трафика.
Parent – указываем нашего второго родителя.
Packet Marks – указываем маркер пакетов, который настраивали ранее в Mangle для download.
Queue Type – выбираем тип дерева из тех, что добавили ранее.
Max Limit – указываем максимальную скорость, которую хотим выдать клиенту.

Добавляем второе дерево с аналогичными настройками для upload трафика. На этом все, настройка Queues Tree закончена. Теперь вы можете увидеть, как бегает трафик и как деревья его обрабатывают. Так же можно обратить внимание на то, что значок у деревьев может менять цвет зеленый, желтый и красный. Это означает канал свободный, почти заполнен и используется на максимум. Но не весь канал, а та ширина, что вы выдали клиенту и соответственно указание цветом говорит о том, что один клиент полностью потребил выделенную ему скорость.

MIKROTIK НАСТРОЙКА QUEUES TREE ЧАСТЬ ВТОРАЯ

И так, начинаем как всегда с маркировки трафика и адресных листов. Открываем IP->Firewall->Address List. Нажимаем плюсик и заполняем своими данными два поля Name и Address. Кстати, в поле Address лучше сразу указывайте подсеть. Так удобнее и не надо плодить кучу однотипных правил.

Добавили? Едем дальше. Теперь переходим на вкладку Mangle (IP->Firewall->Mangle). Здесь мы создаем два правила для входящего и исходящего трафика. Они будут практически идентичны друг другу. Жмем синий плюсик и заполняем поля для Download трафика:

  • General->Chain-> Forward
  • Advanced->Dst.Address List->Ваше название адресного листа, который мы сделали ранее.
  • Action->Action->mark packet
  • Action->New Packet Mark-> Назовите, как вам будет удобнее.

Теперь переходим к Upload трафику.
  • General->Chain-> Forward
  • Advanced->Src.Address List->Ваше название адресного листа, который мы сделали ранее.
  • Action->Action->mark packet
  • Action->New Packet Mark-> Назовите, как вам будет удобнее.

Для большей наглядности, вот как выглядят правила у меня:





Далее нам необходимо создать два типа очередей, которые будут обрабатывать наш трафик Queues->Queue Types. Здесь ничего сложного нет, поэтому просто приведу картинки, а вы сделайте так же.

Ну и наконец, создаем само дерево очередей для обработки трафика Queues->Queue Tree. Жмем плюсик и добавляем первое глобальное дерево:

  • Name – Любое название
  • Parent – global
  • Queue Type – default
  • Priority – 8
  • Max Limit – указываете ширину Вашего канала.

Жмем ОК. Добавляем следующее правило, но уже используя типы и манглы.
  • Name -> download
  • Parent -> выбираем название, которое сделали шагом выше.
  • Packet Marks -> Выбираем правило для download трафика, которое добавляли в IP->Firewall->Mangle
  • Queue Type -> выбираем тип очереди для download трафика
  • Priority – 8

Все, жмем ОК, правило добавлено. Теперь по аналогии делаем еще одно правило для upload трафика. Вот как выглядит у меня:

На этом, собственно, все. Теперь у Вас все должно работать.

Поделиться в социальных сетях:

Настройка mikrotik cloud core router ограничение скорости

Сегодня немного поговорим о настройке ограничении скорости на mikrotik cloud core router, а вообще отмечу что разницы в настройке будь это CCR или hab lite нет так как они работают на одной и тоже операционной системе RouterOS, то есть если вы раньше уже делали это на других моделях этой фирмы то и с этой прекрасно справитесь, но все же разберем некоторые примеры по работе shaper в микротике.

Если вы хотите углубить свои знания по работе с роутерами MikroTik, то наша команда рекомендует пройти курсы которые сделаны на основе MikroTik Certified Network Associate и расширены автором на основе опыта . Подробно читайте ниже.

Настройка queues mikrotik

В этой статье не будем глубоко погружаться в типы очередей (queue types) и больше времени уделим практике. Еще раз повторю что все что будет здесь показано актуально и для cloud core router и для любого другого микротока, работающего на RouterOS.  И так для настройки ограничений скорости по каким-либо критериям в микротике есть раздел Queues в нем есть две вкладки это «Simple Queues» и «Queue Tree».

В Simple Queues – или простые очереди, нельзя гибко приоритезировать трафик, в большинстве случаем используют этот тип очереди, так как он прост в настройке и дает достаточно большой функционал.

Queue Tree – или дерево очередей, это уже более высокий уровень здесь можно реализовать такие схемы как например, sip трафику отдать высокий приоритет, http чуть ниже а торрентам самый низкий. В таком случае если кто-то начнет качать фильмец через торрент и одновременно будут телефонные звонки – качество этих звонков не пострадает так как их пакеты будут обрабатываться в первую очередь.

Если у вас еще не куплен микротик и вы хотите заранее потренироваться в его настройке, разверните у себя на виртуальной машине eve-ng эмулятор и пробуйте все конфигурации на нем, также конечно стоит настроить Firewall так как вирусов и различных атак на просторах интернета полно.

Во вкладке Queue Types находятся алгоритмы обработки трафика такие как:

  • Bfifo
  • Pfifo
  • Sfq
  • Mq pfifo
  • Pcq

Скажу так в 95% случаем вы, да и все, кто доходит до настройки очередей использует PCQ.

Простыми словами если вы выбираете этот алгоритм в микротике, он поровну разделит скорость доступа в интернет между всеми участниками.

Например, создадим простою очередь на сеть 192.168.13.0\24 и выставим ограничения для нее в 10Mb\s.

В такой ситуации если два ПК начнут пользоваться интернетом, первый качать торрент второй просто серфить в интернете, то для второго все будет очень печально так как торрент съест все установленные нами 10Mb\s. Посмотрим на примере:

Без указания PCQ.

Как видим ПК 1 съедает почти весь трафик скачкой торрент файла и ПК 2 почти ничего не достаётся. А представим, что компьютеров в организации 100?! Тогда будет вообще очень плохо. Теперь поменяем всего два параметра во вкладке Advanced.

Для исходящего и входящего трафика поставим Queue Type pcq-upload-default и pcq-download-default и сымитируем такую-же ситуации для теста.

С указанием PCQ.

Видим, что скорость поделилась почти поровну, используйте это в своей практике.

Ограничение скорости по ip компьютера

Если нам надо некоторым компьютерам в рамках очереди LAN ограничить скорость еще, например компьютеру по ip 192.168.13.110 разрешить использовать только 1Mb\s но не ограничивая других. Для этого создаем еще одну очередь с этим ip адресом и указываем родителя очередь LAN, как показано на скриншоте ниже.

Так, например можно резать трафик «качкам» любящим покачать фильмы на работе, отлавливать их с помощью torch и под них создавать очередь.

В общем то данного функционала уже хватить для настройки ограничения скорости в mikrotik cloud core route как и в других роутерах на базе RouterOS.

В следующих статьях попробую подробно описать про типы очередей, queue Tree и так это все работает в связке.

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

Руководство

: Очередь — MikroTik Wiki

Применимо к RouterOS: v6.0 +

Подкатегории

Сводка

Очереди используются для ограничения и определения приоритета трафика:

  • ограничить скорость передачи данных для определенных IP-адресов, подсетей, протоколов, портов и других параметров
  • ограничить одноранговый трафик
  • отдавать предпочтение некоторым потокам пакетов над другими
  • настроить всплески трафика для более быстрого просмотра веб-страниц
  • применять разные ограничения в зависимости от времени
  • распределяет доступный трафик между пользователями поровну или в зависимости от загрузки канала.

Реализация очереди в MikroTik RouterOS основана на иерархическом ведре токенов (HTB).HTB позволяет создавать иерархическую структуру очередей и определять отношения между очередями.

В RouterOS эти иерархические структуры могут быть прикреплены в двух разных местах, диаграмма потока пакетов иллюстрирует цепочки ввода и постмаршрутизации.

Существует два разных способа настройки очередей в RouterOS:

  • / queue simple menu — предназначено для упрощения настройки простых повседневных задач постановки в очередь (таких как ограничение загрузки / выгрузки одного клиента, ограничение трафика p2p и т. Д.).
  • / дерево очереди меню — для реализации расширенных задач постановки в очередь (таких как глобальная политика приоритезации, ограничения групп пользователей). Требуются отмеченные потоки пакетов от объекта / ip firewall mangle .

Принципы ограничения скорости

Ограничение скорости используется для управления скоростью потока трафика, отправляемого или принимаемого через сетевой интерфейс. Отправляется трафик, скорость которого меньше или равна указанной скорости, тогда как трафик, который превышает скорость, отбрасывается или задерживается.

Ограничение скорости может быть выполнено двумя способами:

  1. отбросить все пакеты, превышающие предел скорости — ограничение скорости (дроппер или формирователь) (100% -ный ограничитель скорости при размере очереди = 0)
  2. задерживают пакеты, которые превышают заданный предел скорости в очереди и передают его, когда это возможно — выравнивание скорости (планировщик) » (100% выравнивание скорости при размере очереди = неограниченно)

На следующем рисунке объясняется разница между ограничение скорости и выравнивание скорости :

Как видите, в первом случае весь трафик превышает определенную скорость и отбрасывается.В другом случае трафик превышает определенную скорость и задерживается в очереди и передается позже, когда это возможно, но обратите внимание, что пакет может быть задержан только до тех пор, пока очередь не будет заполнена. Если в буфере очереди больше нет места, пакеты отбрасываются.

Для каждой очереди мы можем определить два ограничения скорости:

  • CIR (согласованная скорость передачи информации) — (ограничение в RouterOS) в худшем случае, поток получит этот объем трафика независимо от других потоков трафика.В любой момент времени пропускная способность не должна опускаться ниже установленной скорости.
  • MIR (максимальная скорость передачи информации) — ( max-limit в RouterOS) в лучшем случае, максимальная доступная скорость передачи данных для потока, если есть свободная часть полосы пропускания.

Простые очереди

Подменю: / простая очередь


Самый простой способ ограничить скорость передачи данных для определенных IP-адресов и / или подсетей — использовать простые очереди.

Вы также можете использовать простые очереди для создания расширенных приложений QoS.У них есть полезные интегрированные функции:

  • Организация очереди однорангового трафика
  • Применение правил очереди к выбранным временным интервалам
  • Приоритеты
  • Использование нескольких меток пакетов из / ip firewall mangle
  • Формирование (планирование) двунаправленного трафика (один лимит на общую выгрузку + скачивание)

Пример конфигурации

Предположим, у нас есть топология сети, подобная рис. 8.6, и мы хотим ограничить загрузку и выгрузку для частной сети (загрузка — 256 кбит / с, а загрузка — 512 кбит / с).

Добавьте простое правило очереди, которое ограничит трафик загрузки до 512 кбит / с и загрузку до 256 кбит / с для сети 10.1.1.0/24 , обслуживаемой интерфейсом Ether2 :

[admin @ MikroTik] / queue simple> add name = private target = 10.1.1.0 / 24 max-limit = 256K / 512K dst = ether2
 
В этом случае оператор работает правильно, даже если мы указываем только один из параметров: «target =» или «dst =» , потому что оба они определяют, где и для какого трафика будет реализована эта очередь.


Проверьте свою конфигурацию:

[admin @ Augsha] / queue simple> print

Флаги: X - отключено, I - недопустимо, D - динамическое
 0 name = "private" target = 10.1.1.0 / 24 dst-address = 0.0.0.0 / 0
      target = ether2 parent = none dst = "" приоритет = 8
      queue = default-small / default-small limit-at = 0/0 max-limit = 256k / 512k
      предел пакета = 0/0 порог пакета = 0/0 время пакета = 0 с / 0 с
      общая очередь = по умолчанию маленький
 

Параметр max-limit сокращает максимально доступную полосу пропускания.Значение max-limit = 256k / 512k означает, что клиенты из частных сетей получат максимум 512 кбит / с для загрузки и 256 кбит / с для загрузки. target позволяет определить исходные IP-адреса, к которым будет применяться правило очереди.

Возможно, вы хотите исключить сервер из ограничения, если это так, добавьте для него очередь без каких-либо ограничений (max-limit = 0/0, что означает отсутствие ограничений). Переместите это правило в начало списка, поскольку элементы в / queue simple выполняются по порядку один за другим, если маршрутизатор находит правило, удовлетворяющее определенному пакету, следующие правила не сравниваются:

[admin @ MikroTik] / queue simple> добавить name = server target = 10.1.1.1 / 32 max-limit = 0/0 интерфейс = ether2
 

Идентификаторы потока

  • target (множественный выбор: IP-адрес / маска сети): список диапазонов IP-адресов, которые будут ограничены этой очередью.
  • интерфейс (Имя интерфейса или все ): идентифицирует интерфейс, к которому подключена цель. Полезно, когда невозможно указать целевые адреса.

Примечание: Начиная с RouterOS v6, эти настройки объединены в опции target , где вы можете указать любой из вышеперечисленных. Цель следует рассматривать с точки зрения цели. Если вы хотите ограничить возможности загрузки ваших пользователей, установите «target upload».

Каждое из этих двух свойств может использоваться для определения направления целевой загрузки и загрузки.

Будьте осторожны при настройке обеих этих опций для одной и той же очереди — в случае, если они будут указывать на противоположные направления, очередь не будет работать.

Если не указано ни значение target , ни interface , очередь не сможет различать загрузку и загрузку и ограничит весь трафик дважды.

Другая недвижимость

  • имя (текст): уникальный идентификатор очереди, который может использоваться в качестве значения опции родительского для других очередей
    • и — ограничение трафика загрузки и выгрузки
    • загрузка — ограничить только трафик до цели
    • скачать — ограничить только трафик от цели
  • время ( ВРЕМЯ-ВРЕМЯ, вс, пн, вт, ср, чт, пт, сб ВРЕМЯ — местное время, названия всех дней не являются обязательными; по умолчанию: не установлено): позволяет указать время, когда очередь будет активной.Маршрутизатор должен иметь правильные настройки времени.
  • dst-address (IP-адрес / сетевая маска): позволяет выбрать только определенный поток (от целевого адреса до этого адреса назначения) для ограничения объясните, что является целевым и что такое dst и что загружается, а что нет
  • меток пакетов (разделенный запятыми список имен меток пакетов): позволяет использовать помеченные пакеты из / ip firewall mangle . Взгляните на диаграмму потока пакетов RouterOS. Пакеты необходимо отмечать перед простыми очередями (до global-in HTB queue), иначе ограничение загрузки целевого объекта не сработает.Единственная цепочка mangle до global-in — это prerouting .

HTB Свойства

  • родительский (Имя родительской простой очереди или нет ): назначает эту очередь как дочернюю очередь для выбранной цели {{{…}}}. Целевая очередь может быть HTB-очередью или любой другой ранее созданной простой очередью. Чтобы трафик достигал дочерних очередей, родительские очереди должны захватывать весь необходимый трафик.
  • приоритет (1..8): приоритет одной дочерней очереди над другой дочерней очередью.Не работает с родительскими очередями (если в очереди есть хотя бы один дочерний элемент). Один — самый высокий, восемь — самый низкий приоритет. Дочерняя очередь с более высоким приоритетом будет иметь шанс достичь своего максимального предела до того, как дочерняя очередь с более низким приоритетом. Приоритет не имеет отношения к очередям.
  • очередь ( ЧТО-ТО / ЧТО-ТО ): выберите тип очереди загрузки / выгрузки. Типы очередей могут быть созданы в / тип очереди .
  • limit-at (НОМЕР / НОМЕР ): нормальная скорость загрузки / выгрузки данных, которая гарантирована цели
  • max-limit (НОМЕР / НОМЕР ): максимальная скорость загрузки / выгрузки данных, которую может достичь цель, чтобы достичь того, что
  • burst-limit (НОМЕР / НОМЕР ): максимальная скорость передачи / выгрузки данных, которая может быть достигнута при активном пакете
  • пакетный интервал ( ВРЕМЯ / ВРЕМЯ ): период времени в секундах, за который рассчитывается средняя скорость загрузки / выгрузки данных.(Это НЕ время фактического всплеска)
  • burst-threshold (НОМЕР / НОМЕР ): когда средняя скорость передачи данных ниже этого значения — пакетная передача разрешена, как только средняя скорость передачи данных достигает этого значения — пакетная передача запрещается. (в основном это переключатель включения / выключения). Для оптимального поведения пакетов это значение должно быть выше limit-at и ниже max-limit value

И соответствующие параметры для global-total HTB queue:

  • total-queue ( ЧТО-ТО / ЧТО-ТО ): соответствует очереди
  • total-limit-at (НОМЕР / НОМЕР ): соответствует limit-at
  • total-max-limit (НОМЕР / НОМЕР ): соответствует max-limit
  • total-burst-limit (НОМЕР / НОМЕР ): соответствует burst-limit
  • общее время пакета ( ВРЕМЯ / ВРЕМЯ ): соответствует пакетному времени
  • total-burst-threshold (НОМЕР / НОМЕР ): соответствует burst-threshold

Хорошая практика предполагает, что:

Сумма детских предельных значений должна быть меньше или равна max-limit родительского.
max-limit каждого ребенка должно быть меньше max-limit родителя. Таким образом, вы оставите некоторый трафик для других дочерних очередей, и они смогут получать трафик, не борясь за него с другими дочерними очередями.

Статистика

  • скорость (только чтение / только чтение): средняя скорость передачи данных очереди в байтах в секунду
  • скорость передачи пакетов (только для чтения / только для чтения): средняя скорость передачи данных в очереди в пакетах в секунду
  • байта (только для чтения / только для чтения): количество байтов, обработанных этой очередью
  • пакетов (только для чтения / только для чтения): количество пакетов, обработанных этой очередью
  • байта в очереди (только для чтения / только для чтения): количество байтов, ожидающих в очереди
  • пакетов в очереди (только для чтения / только для чтения): количество пакетов, ожидающих в очереди
  • отброшено (только чтение / только чтение): количество отброшенных пакетов
  • заимствует (только для чтения / только для чтения): пакеты, прошедшие очередь с превышением предельного значения (и были неиспользованы и удалены из других очередей)
  • предоставляет (только для чтения / только для чтения): пакетов, прошедших очередь ниже своего «предельного» значения ИЛИ, если очередь является родительской — сумма всех заимствованных дочерних пакетов
  • pcq-queues (только для чтения / только для чтения): количество подпотоков PCQ, если тип очереди — PCQ

И соответствующие параметры для global-total HTB queue:

  • total-rate (только чтение): соответствует скорости
  • total-packet-rate (только чтение): соответствует пакетной скорости
  • total-bytes (только для чтения): соответствует байтам
  • total-packets (только чтение): соответствует пакетам
  • байтов в очереди (только для чтения): соответствует байтов в очереди
  • пакетов в очереди (только для чтения): соответствует пакетов в очереди
  • total-drop (только для чтения): соответствует удалено
  • total-lends (только чтение): соответствует lends
  • всего заимствований (только для чтения): соответствует заимствований
  • total-pcq-queues (только для чтения): соответствует pcq-queues

Queue Tree

Подменю: / дерево очереди


Дерево очередей создает только одну направленную очередь в одном из HTB.Это также единственный способ добавить очередь в отдельный интерфейс. Таким образом можно упростить конфигурирование — вам не нужны отдельные отметки для загрузки и выгрузки — только загрузка попадет в общедоступный интерфейс, а только загрузка попадет в частный интерфейс.

Дерево очередей не упорядочено — весь трафик проходит его вместе.

Узнайте больше о HTB и посмотрите примеры конфигурации.

Идентификаторы потока

  • имя (текст): уникальный идентификатор очереди, который может использоваться в качестве значения опции родительского для других очередей
  • меток пакетов (список, разделенный запятыми): позволяет использовать помеченные пакеты из / ip firewall mangle .Взгляните на эту диаграмму потока пакетов. Вам необходимо убедиться, что пакеты помечаются перед простыми очередями (до глобальной очереди HTB)

HTB Недвижимость

  • родительский (Имя или нет ): назначает эту очередь как дочернюю очередь для выбранной цели. Целевая очередь может быть HTB-очередью или любой другой ранее созданной очередью
  • .
  • приоритет (1..8): приоритет одной дочерней очереди над другой дочерней очередью. Не работает с родительскими очередями (если в очереди есть хотя бы один дочерний элемент).Один — самый высокий, восемь — самый низкий приоритет. Дочерняя очередь с более высоким приоритетом будет иметь шанс достичь своего максимального предела до того, как дочерняя очередь с более низким приоритетом. Приоритет не имеет отношения к очередям.
  • очередь ( НЕЧТО ): выберите тип очереди. Здесь можно создавать типы очередей
  • limit-at ( НОМЕР ): нормальная скорость передачи данных, которая гарантирована цели
  • max-limit ( НОМЕР ): максимальная скорость передачи данных, разрешенная для достижения цели
  • burst-limit ( НОМЕР ): максимальная скорость передачи данных, которая может быть достигнута при активном пакете
  • burst-time ( TIME ): период времени в секундах, за который рассчитывается средняя скорость передачи данных.(Это НЕ время фактического всплеска)
  • burst-threshold (НОМЕР ): когда средняя скорость передачи данных ниже этого значения — пакетная передача разрешена, как только средняя скорость передачи данных достигает этого значения — пакетная передача запрещается. (в основном это переключатель включения / выключения). Для оптимального поведения в пакетном режиме это значение должно быть выше limit-at value и ниже max-limit value

Statistics

Команда: / статистика печати дерева очереди

  • скорость (только чтение): средняя скорость передачи данных очереди в байтах в секунду
  • скорость передачи пакетов (только чтение): средняя скорость передачи данных в очереди в пакетах в секунду
  • байта (только для чтения): количество байтов, обработанных этой очередью
  • пакетов (только для чтения): количество пакетов, обработанных этой очередью
  • байтов в очереди (только для чтения): количество байтов, ожидающих в очереди
  • queued-packets (только для чтения): количество пакетов, ожидающих в очереди
  • отброшено (только для чтения): количество отброшенных пакетов
  • заимствует (только для чтения): пакеты, прошедшие очередь с превышением предельного значения (и были неиспользованы и удалены из других очередей)
  • предоставляет (только для чтения): пакетов, прошедших очередь ниже ее «предельного» значения ИЛИ, если очередь является родительской — сумма всех заимствованных дочерних пакетов
  • pcq-queues (только для чтения): количество подпотоков PCQ, если тип очереди — PCQ

Типы очередей

Подменю: / тип очереди


Это подменю перечисляет по умолчанию созданные типы очередей и позволяет добавлять новые, специфичные для пользователя.

По умолчанию RouterOS создает следующие предопределенные типы очередей:

[admin @ MikroTik] / тип очереди> печать
 0 name = "default" kind = pfifo pfifo-limit = 50

 1 name = "ethernet-default" kind = pfifo pfifo-limit = 50

 2 name = "wireless-default" kind = sfq sfq-perturb = 5 sfq-allot = 1514

 3 name = "synchronous-default" kind = красный красный-предел = 60 красный-мин-порог = 10 красный-максимум-порог = 50 красный-всплеск = 20
   красный-средний-пакет = 1000

 4 name = "hotspot-default" kind = sfq sfq-perturb = 5 sfq-allot = 1514

 5 name = "only-hardware-queue" kind = none

 6 name = "multi-queue-ethernet-default" kind = mq-pfifo mq-pfifo-limit = 50

 7 name = "default-small" kind = pfifo pfifo-limit = 10

 

Примечание: Начиная с v5.8 есть новый вид none и новая очередь по умолчанию only-hardware-queue . Для всех RouterBOARDS этот новый тип очереди будет установлен как очередь интерфейса по умолчанию

.

only-hardware-queue оставляет интерфейс только с кольцевым буфером дескриптора передачи hw, который сам по себе действует как очередь. Обычно не менее 100 пакетов могут быть поставлены в очередь для передачи в кольцевом буфере дескриптора передачи. Размер кольцевого буфера дескриптора передачи и количество пакетов, которые могут быть поставлены в очередь, различаются для разных типов MAC-адресов Ethernet.

Отсутствие программной очереди особенно выгодно в системах SMP, поскольку устраняет необходимость синхронизировать доступ к ней с разных процессоров / ядер, что является дорогостоящим.


multi-queue-ethernet-default может быть полезен в системах SMP с интерфейсами Ethernet, которые поддерживают несколько очередей передачи и имеют поддержку драйвера Linux для нескольких очередей передачи. Наличие одной программной очереди для каждой аппаратной очереди может сократить время, затрачиваемое на синхронизацию доступа к ним.

Примечание: , имеющий возможность установить only-hardware-queue, требует поддержки в драйвере Ethernet, поэтому он доступен только для некоторых интерфейсов Ethernet, которые чаще всего встречаются на RB.

Примечание. Улучшение по сравнению с only-hardware-queue и multi-queue-ethernet-default присутствует только тогда, когда нет записи «/ queue tree» с типичным интерфейсом в качестве родительского.

Виды

Типы очередей или алгоритмы организации очередей (планирования) описывают, какой пакет будет передан следующим в очереди.RouterOS поддерживает несколько алгоритмов организации очередей:

  • BFIFO, PFIFO, MQ PFIFO
  • КРАСНЫЙ
  • SFQ
  • PCQ
PFIFO, BFIFO и MQ PFIFO

Эти дисциплины организации очереди основаны на алгоритме FIFO (First-In First-Out). Разница между PFIFO и BFIFO заключается в том, что один измеряется в пакетах, а другой — в байтах.

Каждый пакет, который не может быть поставлен в очередь (если очередь заполнена), отбрасывается. Большие размеры очереди могут увеличить задержку, но лучше использовать канал.

В этих очередях используются параметры pfifo-limit и bfifo-limit .


mq-pfifo — это pfifo с поддержкой нескольких очередей передачи. Эта очередь полезна в системах SMP с интерфейсами Ethernet, которые поддерживают несколько очередей передачи и имеют поддержку драйвера Linux для нескольких очередей передачи.

mq-pfifo использует параметр mq-pfifo-limit .

КРАСНЫЙ

Random Early Drop — это механизм организации очередей, который пытается избежать перегрузки сети, контролируя средний размер очереди.Средний размер очереди сравнивается с двумя пороговыми значениями: минимальным (минимальное ) и максимальным (максимальное ) порогом. Если средний размер очереди (avg q ) меньше минимального порога, пакеты не отбрасываются. Когда средний размер очереди превышает максимальный порог, все входящие пакеты отбрасываются. Но если средний размер очереди находится между минимальным и максимальным пороговыми значениями, пакеты случайно отбрасываются с вероятностью P d , где вероятность является точной функцией среднего размера очереди: P d = P max (среднее q — min th ) / (max th — min th ).Если средняя очередь растет, вероятность отбрасывания входящих пакетов также растет. P max — коэффициент, который может регулировать резкость вероятности отбрасывания пакета, (в простейшем случае P max может быть равно 1. Диаграмма на рисунке 8.2. Показывает вероятность отбрасывания пакета в алгоритме RED.

SFQ

Стохастическая организация очереди по справедливости (SFQ) обеспечивается с помощью алгоритмов хеширования и циклического перебора. Поток трафика может быть однозначно идентифицирован с помощью 4 опций (src-address, dst-address, src-port и dst-port), поэтому эти параметры используются алгоритмом хеширования SFQ для классификации пакетов в один из 1024 возможных подпотоков.Затем алгоритм циклического перебора начнет распределять доступную полосу пропускания по всем подпотокам, на каждом цикле давая sfq-allot байтов трафика. Вся очередь SFQ может содержать 128 пакетов, и доступно 1024 подпотока.

SFQ

называется «стохастическим», потому что на самом деле он не выделяет очередь для каждого потока, у него есть алгоритм, который разделяет трафик по ограниченному количеству очередей (1024) с использованием алгоритма хеширования.

PCQ

Per Connection Queuing (PCQ) похож на SFQ, но имеет дополнительные функции.

Можно выбрать идентификаторы потока (из dst-address | dst-port | src-address | src-port). Например, если вы классифицируете потоки по src-адресу на локальном интерфейсе (интерфейс с вашими клиентами), каждый подпоток PCQ будет одной конкретной загрузкой клиента.
Можно назначить ограничение скорости для подпотоков с опцией pcq-rate . Если pcq-rate = 0, подпотоки разделят доступный трафик поровну.

Дополнительная информация и примеры PCQ доступны здесь.

Недвижимость

Свойства, начинающиеся с определенного имени типа очереди, применяются только к определенному типу. Например, все свойства, начинающиеся с pcq, применяются только к очереди kind = pcq .

Имущество Описание
bfifo-limit ( целое [1000..4294967295] ; по умолчанию: 15000 ) Максимальное количество байтов, которое может содержать очередь BFIFO.Применяется, если вид — bfifo.
kind ( bfifo | mq-pfifo | none | pcq | pfifo | red | sfq ; по умолчанию:) Вид определенного типа очереди. Подробнее >>
mq-pfifo-limit ( целое [1..4294967295] ; по умолчанию: 50 ) Ограничение PFIFO для нескольких очередей.
имя ( строка ; по умолчанию:) Описательное имя типа очереди
pcq-burst-rate ( целое [0..4294967295] ; По умолчанию: 0 ) Максимальная скорость передачи / выгрузки данных, которая может быть достигнута, пока разрешен пакет для подпотока
pcq-burst-threshold ( целое [0..4294967295] ; по умолчанию: 0 ) Это значение переключателя включения / выключения пакета
pcq-burst-time ( time ; по умолчанию: 10s ) Период времени в секундах, в течение которого вычисляется средняя скорость передачи данных.(Это НЕ время фактического всплеска)
pcq-classifier ( список src-адресов | dst-address | src-port | dst-port ; по умолчанию: «» ) Выбор идентификаторов подпотоков
pcq-dst-address-mask ( integer [0..32] | IPNetmask ; по умолчанию: 32 ) размер сети IPv4, которая будет использоваться в качестве идентификатора подпотока dst-адреса
pcq-dst-address6-mask ( целое [0..128] ; По умолчанию: 128 ) размер сети IPV6, которая будет использоваться как идентификатор подпотока dst-адреса
pcq-limit ( целое [1..4294967295] ; по умолчанию: 50 ) Размер очереди одного подпотока (в килобайтах)
pcq-rate ( целое [0..4294967295] ; по умолчанию: 0 ) Максимальная доступная скорость передачи данных каждого вспомогательного пара
pcq-src-address-mask ( целое [0..32] | IPNetmask ; По умолчанию: 32 ) размер сети IPv4, которая будет использоваться в качестве идентификатора подпотока src-address
pcq-src-address6-mask ( целое [0..128] ; по умолчанию: 128 ) размер сети IPV6, которая будет использоваться в качестве идентификатора подпотока src-address
pcq-total-limit ( целое [1..4294967295] ; по умолчанию: 2000 ) Максимальное количество байтов в очереди (в килобайтах) для всех подпотоков на один экземпляр PCQ.Обратите внимание, что каждая запись в дереве очереди имеет собственный экземпляр PCQ.
pfifo-limit ( целое [1..4294967295] ; по умолчанию: 50 ) Максимальное количество пакетов, которое может удерживать очередь PFIFO. Применяется, если вид — pfifo.
red-avg-packet ( целое [1..65535] ; по умолчанию: 1000 ) Используется RED для расчета среднего размера очереди (для преобразования пакетов в байты)
красная вспышка ( целое [0..4294967295] ; По умолчанию: 20 ) Количество пакетов, разрешенных для пачки пакетов, когда в очереди нет пакетов
красный предел ( целое [0..4294967295] ; по умолчанию: 60 ) КРАСНЫЙ предел очереди в пакетах
красный макс-порог ( целое [0..4294967295] ; по умолчанию: 50 ) Средний размер очереди, при котором вероятность маркировки пакетов самая высокая.
мин-красный порог ( целое [0..4294967295] ; по умолчанию: 10 ) Средний размер очереди в байтах.
sfq-allot ( целое [0..32767] ; по умолчанию: 1514 ) Количество данных в байтах, которое может быть отправлено за один цикл циклического перебора
sfq-perturb ( целое [0..4294967295] ; по умолчанию: 5 ) Как часто необходимо обновлять хэш-функцию

Очередь интерфейса

Подменю: / интерфейс очереди


Перед отправкой данных через интерфейс они обрабатываются очередью.Это подменю перечисляет все доступные интерфейсы в RouterOS и позволяет изменить тип очереди для конкретного интерфейса.

Примечание: Вы не можете добавлять новые интерфейсы в это меню. Список формируется автоматически.

Объекты

Имущество Описание
интерфейс ( строка ) Имя интерфейса, к которому применяется очередь. Параметр только для чтения.
очередь ( строка ; по умолчанию:) Тип очереди, назначенный конкретному интерфейсу.

[ Вверх | К содержанию ]

.

очередей — RouterOS — MikroTik

Очередь — это набор пакетов данных, коллективно ожидающих передачи сетевым устройством с использованием методологии заранее определенной структуры. Очередь работает почти по той же методологии, что и в банках или супермаркетах, где клиент обслуживается в соответствии с его прибытием.

Очереди используются для:

  • ограничения скорости передачи данных для определенных IP-адресов, подсетей, протоколов, портов и т. Д .;
  • ограничить одноранговый трафик;
  • приоритезация пакетов;
  • настроить пачки трафика для ускорения трафика;
  • применять разные временные ограничения;
  • распределяет доступный трафик между пользователями поровну или в зависимости от загрузки канала.

Реализация очереди в MikroTik RouterOS основана на Hierarchical Token Bucket (HTB).HTB позволяет создавать иерархическую структуру очередей и определять отношения между очередями. Эти иерархические структуры могут быть прикреплены в двух разных местах, диаграмма потока пакетов иллюстрирует как вход , так и цепочки постмаршрутизации .

Существует два разных способа настройки очередей в RouterOS:

  • / queue simple menu — разработано для упрощения настройки простых ежедневных задач постановки в очередь (таких как ограничение загрузки / выгрузки одного клиента, ограничение трафика p2p и т. Д. .).
  • / дерево очереди меню — для реализации расширенных задач постановки в очередь (таких как глобальная политика приоритизации, ограничения групп пользователей). Требуются отмеченные потоки пакетов от / ip firewall mangle объекта.

Принципы ограничения скорости

Ограничение скорости используется для управления скоростью потока трафика, отправляемого или принимаемого на сетевом интерфейсе. Отправляется трафик, скорость которого меньше или равна указанной скорости, тогда как трафик, который превышает скорость, отбрасывается или задерживается.

Ограничение скорости может быть выполнено двумя способами:

  1. отбросить все пакеты, превышающие предел скорости — ограничение скорости (дроппер или формирователь) (100% -ный ограничитель скорости при размере очереди = 0)
  2. задерживать пакеты, которые превышают определенный предел скорости в очереди и передают его, когда это возможно — выравнивание скорости (планировщик) (100% выравнивание скорости, когда размер очереди = неограниченный )

Следующий рисунок объясняет разницу между ограничение скорости и выравнивание скорости :

Как вы можете видеть, в первом случае весь трафик превышает определенную скорость и отбрасывается.В другом случае трафик превышает определенную скорость и задерживается в очереди и передается позже, когда это возможно, но обратите внимание, что пакет может быть задержан только до тех пор, пока очередь не будет заполнена. Если в буфере очереди больше нет места, пакеты отбрасываются.

Для каждой очереди мы можем определить два ограничения скорости:

  • CIR (подтвержденная скорость передачи информации) — (лимит в RouterOS) в наихудшем сценарии поток получит этот объем трафика независимо от других транспортные потоки.В любой момент времени пропускная способность не должна опускаться ниже установленной скорости.
  • MIR (Максимальная скорость передачи данных) — ( max-limit в RouterOS) в лучшем случае, максимальная доступная скорость передачи данных для потока, если есть свободная часть полосы пропускания.

Простая очередь — простой способ ограничить трафик для конкретной цели. Кроме того, вы можете использовать простые очереди для создания расширенных приложений QoS. У них есть полезные интегрированные функции:

  • организация очереди однорангового трафика;
  • применение правил очереди в выбранные интервалы времени;
  • приоритезация;
  • с использованием нескольких меток пакетов из / ip firewall mangle
  • формирование трафика (планирование) двунаправленного трафика (один лимит на общую загрузку + загрузка)

Простые очереди имеют строгий порядок — каждый пакет должен пройти через каждую очередь, пока не достигнет одной очереди, которая соответствует параметрам пакета, или пока не будет достигнут конец списка очередей.Например, в случае 1000 очередей пакет для последней очереди должен будет пройти через 999 очередей, прежде чем он достигнет места назначения.

Пример конфигурации

В следующем примере у нас есть одно устройство SOHO с двумя подключенными ПК и сервером.

В этом случае у нас есть соединение со скоростью 15 Мбит / с от интернет-провайдера. Мы хотим быть уверены, что сервер получает достаточно трафика, поэтому настроим простую очередь с параметром limit-at , чтобы гарантировать, что сервер будет получать 5 Мбит / с:

 / очередь простая
добавить limit-at = 5M / 5M max-limit = 15M / 15M name = queue1 target = 192.168.88.251 / 32 

Вот и все. Сервер получит скорость трафика 5 Мбит / с независимо от других потоков трафика. Если вы используете конфигурацию по умолчанию, убедитесь, что правило FastTrack отключено для этого конкретного трафика, в противном случае оно будет обходить простые очереди, и они не будут работать.

Дерево очередей создает только однонаправленную очередь в одном из HTB. Это также единственный способ добавить очередь в отдельный интерфейс. Таким образом можно упростить конфигурирование — вам не нужны отдельные отметки для загрузки и выгрузки — только загрузка попадет в общедоступный интерфейс, и только загрузка попадет в частный интерфейс.Основное отличие от Simple Queues состоит в том, что Queue tree не упорядочен — весь трафик проходит его вместе.

Пример конфигурации

В следующем примере мы отметим все пакеты, приходящие из предварительно сконфигурированного in-interface-list = LAN , и ограничим трафик деревом очередей на основе этих меток пакетов.

Создадим список адресов межсетевого экрана:

 [admin @ MikroTik]> / ip список адресов брандмауэра
добавить адрес = www.youtube.com list = Youtube
[admin @ MikroTik]> печать списка адресов брандмауэра IP
Флаги: X - отключено, D - динамическое
 № СПИСОК АДРЕС СОЗДАНИЯ-ВРЕМЯ ТАЙМАУТА
 0 Youtube www.youtube.com 17 октября 2019 г. 14:47:11
 1 D ;;; www.youtube.com
     Youtube 216.58.211.14 17 окт.2019 14:47:11
 2 D ;;; www.youtube.com
     Youtube 216.58.207.238 17 окт.2019 14:47:11
 3 D ;;; www.youtube.com
     Ютуб 216.58.207.206 17 окт.2019 14:47:11
 4 D ;;; www.youtube.com
     Youtube 172.217.21.174 17 окт.2019 14:47:11
 5 D ;;; www.youtube.com
     Youtube 216.58.211.142 17 окт.2019 14:47:11
 6 D ;;; www.youtube.com
     Ютуб 172.217.22.174 17 окт.2019 14:47:21
 7 D ;;; www.youtube.com
     Youtube 172.217.21.142 17 окт.2019 14:52:21

 

Пометить пакеты с помощью средства блокировки межсетевого экрана:

 [admin @ MikroTik]> / ip firewall mangle
add action = mark-packet chain = forward dst-address-list = Youtube in-interface-list = LAN new-packet-mark = pmark-Youtube passthrough = да 

Настроить дерево очереди на основе ранее отмеченных пакетов:

 [admin @ MikroTik] / дерево очереди
добавить max-limit = 5M name = Limiting-Youtube packet-mark = pmark-Youtube parent = global 

Проверьте статистику дерева очередей, чтобы убедиться, что трафик соответствует:

 [admin @ MikroTik]> статистика печати дерева очереди
Флаги: X - отключено, I - недопустимо
 0 name = "Limiting-Youtube" parent = global packet-mark = pmark-Youtube rate = 0 packet-rate = 0 queued-bytes = 0 queued-packets = 0 байтов = 67887 пакетов = 355 отброшено = 0 

Этот список подменю по умолчанию создает типы очередей и позволяет добавлять новые пользовательские.

По умолчанию RouterOS создает следующие предопределенные типы очередей:

 [admin @ MikroTik]> / тип очереди печати
Флаги: * - по умолчанию
 0 * name = "default" kind = pfifo pfifo-limit = 50

 1 * name = "ethernet-default" kind = pfifo pfifo-limit = 50

 2 * name = "wireless-default" kind = sfq sfq-perturb = 5 sfq-allot = 1514

 3 * name = "синхронный-по умолчанию" kind = красный красный-предел = 60 красный-мин-порог = 10 красный-максимум-порог = 50 красный-всплеск = 20 красный-средний-пакет = 1000

 4 * name = "hotspot-default" kind = sfq sfq-perturb = 5 sfq-allot = 1514

 5 * name = "pcq-upload-default" kind = pcq pcq-rate = 0 pcq-limit = 50KiB pcq-classifier = src-address pcq-total-limit = 2000KiB pcq-burst-rate = 0 pcq-burst-threshold = 0 pcq-burst-time = 10 с pcq-src-address-mask = 32
     pcq-dst-адрес-маска = 32 pcq-src-address6-mask = 128 pcq-dst-address6-mask = 128

 6 * name = "pcq-download-default" kind = pcq pcq-rate = 0 pcq-limit = 50KiB pcq-classifier = dst-address pcq-total-limit = 2000KiB pcq-burst-rate = 0 pcq-burst-threshold = 0 pcq-burst-time = 10 с pcq-src-address-mask = 32
     pcq-dst-адрес-маска = 32 pcq-src-address6-mask = 128 pcq-dst-address6-mask = 128

 7 * name = "only-hardware-queue" kind = none

 8 * name = "multi-queue-ethernet-default" kind = mq-pfifo mq-pfifo-limit = 50

 9 * name = "default-small" kind = pfifo pfifo-limit = 10 

Все RouterBOARDS имеют тип очереди по умолчанию « only-hardware-queue» с «kind = none».«only-hardware-queue» оставляет интерфейс только с кольцевым буфером аппаратного дескриптора передачи, который сам по себе действует как очередь. Обычно в кольцевом буфере дескриптора передачи может быть поставлено в очередь для передачи не менее 100 пакетов. Размер кольцевого буфера дескриптора передачи и количество пакетов, которые могут быть поставлены в очередь, различаются для разных типов MAC-адресов Ethernet. Отсутствие программной очереди особенно выгодно в системах SMP, поскольку устраняет необходимость синхронизации доступа к ней с разных процессоров / ядер, что требует значительных ресурсов.Наличие возможности установить «only-hardware-queue» требует поддержки в драйвере Ethernet , поэтому он доступен только для некоторых интерфейсов Ethernet, которые в основном встречаются на RouterBOARD.

«multi-queue-ethernet-default» может быть полезен в системах SMP с интерфейсами Ethernet, которые поддерживают несколько очередей передачи и имеют поддержку драйвера Linux для нескольких очередей передачи. Наличие одной программной очереди для каждой аппаратной очереди может сократить время, затрачиваемое на синхронизацию доступа к ним.

Улучшение от only-hardware-queue и multi-queue-ethernet-default присутствует только тогда, когда нет записи «/ queue tree» с конкретным интерфейсом в качестве родительского.

Виды

Виды очередей — это алгоритмы обработки пакетов. Kind опишите, какой пакет будет передан следующим в строке. RouterOS поддерживает следующие типы очередей:

  • FIFO (BFIFO, PFIFO, MQ PFIFO)
  • RED
  • SFQ
  • PCQ

FIFO

Эти виды основаны на алгоритме FIFO (First-In-First-Out). ).Разница между PFIFO и BFIFO заключается в том, что один измеряется в пакетах, а другой — в байтах. Эти очереди используют параметры pfifo-limit и bfifo-limit .

Каждый пакет, который не может быть поставлен в очередь (если очередь заполнена), отбрасывается. Большие размеры очереди могут увеличить задержку, но лучше использовать канал.

MQ-PFIFO — это pfifo с поддержкой нескольких очередей передачи. Эта очередь полезна в системах SMP с интерфейсами Ethernet, которые поддерживают несколько очередей передачи и имеют поддержку драйвера Linux для нескольких очередей передачи.Этот вид использует параметр mq-pfifo-limit .

RED

Random Early Drop — это механизм организации очередей, который пытается избежать перегрузки сети, контролируя средний размер очереди . Средний размер очереди сравнивается с двумя пороговыми значениями: минимальным (мин. ) и максимальным (макс. ) порогом. Если средний размер очереди (avg q ) меньше минимального порога, пакеты не отбрасываются. Когда средний размер очереди превышает максимальный порог, все входящие пакеты отбрасываются.Но если средний размер очереди находится между минимальным и максимальным пороговыми значениями, пакеты случайно отбрасываются с вероятностью P d , где вероятность является точной функцией среднего размера очереди: P d = P max (среднее q — min th ) / (max th — min th ). Если средняя очередь растет, вероятность отбрасывания входящих пакетов также растет. P max — коэффициент, с помощью которого можно регулировать резкость вероятности отбрасывания пакета (в простейшем случае P max может быть равным единице.Диаграмма 8.2 показывает вероятность отбрасывания пакета в алгоритме RED.

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *