Что такое dhcp сервер маршрутизатора: Что такое DHCP в роутере: настройка, включение и выключение

Содержание

Что такое DHCP в роутере: настройка, включение и выключение

В локальной сети каждое устройство имеет свой уникальный IP-адрес — набор цифр, который идентифицирует его и позволяет другим устройствам обмениваться с ним данными. IP-адреса могут прописываться вручную для каждого устройства, однако это неудобно, так как требует отдельной настройки каждого компьютера для работы с сетью. Чтобы автоматизировать этот процесс, используется протокол динамического конфигурирования хостов – DHCP.

Что такое DHCP

В больших сложно структурированных сетях за раздачу IP-адресов отвечает специальный компьютер — сервер. Для домашней сети или сети небольшого офиса в этом нет необходимости, достаточно обычного роутера.

Все современные роутеры в своём функционале имеют встроенную службу DHCP. Если она настроена и включена, вам не потребуется отдельно настраивать сетевое подключение на компьютере, ноутбуке, планшете или смартфоне. Для беспроводных устройств просто нужно включить Wi-Fi, найти в списке беспроводных сетей свою и ввести пароль для подключения к ней. Если же соединение с сетью осуществляется через кабель, достаточно чтобы он был подключён к сетевой карте вашего компьютера.

Когда в сети появляется новое устройство, служба DHCP проверяет список свободных IP-адресов и присваивает ему один из них. При этом дублирование адресов исключено.

Как настроить DHCP

По умолчанию служба DHCP на роутерах уже настроена. Достаточно подключить клиентское устройство через Wi-Fi или кабель и ему будет автоматически присвоен IP-адрес. Однако может возникнуть потребность изменить настройки DHCP, отключить или включить его. Рассмотрим настройку DHCP на примере роутера TP-link. Для других маршрутизаторов алгоритм будет точно такой же.

Заходим в веб-интерфейс роутера и в меню справа видим пункт «DHCP» и подпункт «Настройка DHCP». На открывшейся вкладке можно изменить параметры, прописанные по умолчанию. Также здесь можно включить или выключить службу DHCP.

Для службы DHCP должен быть задан диапазон используемых IP-адресов, которые вписываются в соответствующие поля. Начальный IP-адрес это соответственно первый адрес диапазона, а конечный IP-адрес — последний. По умолчанию диапазон IP указан с 192.168.0.100 по 192.168.0.199. Но можно прописать, например, с 10.1.1.1 по 10.1.1.99. Можно вообще указать диапазон в пределах двух-трёх адресов, например, по количеству клиентских устройств.

Следующий обязательный пункт — срок действия адреса в минутах. Это время, на которое конкретный IP может присваиваться конкретному устройству. По его истечении IP может быть изменён или присвоен другому устройству.

Остальные пункты заполнять необязательно, DHCP сам укажет нужные параметры для клиентских устройств. Однако эти параметры при желании можно прописать вручную.

Основной шлюз это IP-адрес маршрутизатора — канал, по которому происходит обмен трафиком с интернетом. Обычно он указывается, если доступ в интернет осуществляется через точку доступа с другим адресом. Но если в вашей сети только один роутер и он подключён к интернету напрямую, прописывать здесь ничего не нужно.

Домен по умолчанию — это доменное имя вашей сети. В небольших сетях, где используется небольшое количество клиентских устройств, настраивать его не имеет смысла.

Предпочитаемый и альтернативный DNS-сервер обычно указываются провайдером. Но можно вписать сюда публичные DNS-сервера Google – 8.8.8.8 и 8.8.4.4. Это, например, помогает устранить неполадки с доступом к интернету — бывает, что DNS провайдера глючат, подключение есть, но страницы не открываются. Также это часто позволяет обойти блокировки доступа к определённым ресурсам, например, торрентам.

После внесения изменений нажмите кнопку «Сохранить», чтобы применить новые настройки.

Для того, чтобы ваша сеть начала работать с новыми параметрами, роутер необходимо перезагрузить.

Чтобы клиентские устройства могли подключиться к службе DHCP, в настройках сетевого подключения у них должен быть установлен параметр «Получить IP-адрес автоматически».

Как включить DHCP

Если служба DHCP на вашем роутере отключена, включить её можно здесь же, в меню DHCP — настройки DHCP. Для этого нужно поставить галочку в пункте «Включить» и нажать кнопку «Сохранить» внизу страницы. Служба будет запущена. Если этого не произошло, перезагрузите роутер.

Как выключить DHCP

Если служба DHCP вам не нужна, когда, например, вы решили вручную прописать IP для всех своих устройств, отключить её можно точно так же. Переходим на вкладку «Настройка DHCP» и ставим галочку в пункте «Отключить». Сохраняем настройки. Теперь клиентские устройства при подключении к вашей сети не смогут получать IP-адреса автоматически.

Список клиентов

Для того, чтобы посмотреть какие именно устройства в данный момент подключены к вашей службе DHCP, в пункте меню «DHCP» веб-интерфейса вашего роутера перейдите в подпункт «Список клиентов DHCP». Здесь вы увидите таблицу с информацией о текущих подключениях.

ID — означает порядковый номер.

Имя клиента — это имя устройства, если оно ему присвоено.

МАС-адрес — соответственно МАС-адрес данного устройства.

Назначенный IP — адрес, который был присвоен устройству сервером DHCP.

Срок действия — соответственно, оставшееся время, в течение которого данный адрес будет действителен.

Если у вас возникли опасения, что к вашей сети подключился кто-то посторонний, вы можете в любой момент проверить информацию о подключенных устройствах на этой вкладке. Для того чтобы обновить текущую информацию, нажмите кнопку «Обновить». Список подключённых устройств будет обновлён.

Резервирование адресов

Служба DHCP предоставляет IP-адреса клиентским устройствам на определённый промежуток времени. После этого адрес может быть изменён. Также, подключаясь к сети, каждый компьютер или смартфон каждый раз будет получать новый адрес. А тот адрес, который использовался им ранее, может быть предоставлен другому устройству. Обычно смена адресов происходит незаметно для пользователя и не влияет на работу сети. Однако может возникнуть необходимость сделать так, чтобы у конкретного компьютера IP-адрес не менялся. Это может быть актуально, если вы играете по локальной сети в игры или же данному компьютеру присвоены какие-то специфические функции, которые будут работать только при статичном IP.

Есть простой способ решить эту задачу с помощью DHCP — зарезервировать IP-адрес за конкретным компьютером.

Для этого переходим в подпункт «Резервирование адресов» пункта меню «DHCP». Если ранее вы уже резервировали адреса, здесь будет доступен список устройств, который можно редактировать по мере необходимости. Если же нет, жмём кнопку «Добавить».

В открывшемся окне нужно ввести МАС-адрес устройства и IP, который будет за ним зарезервирован.

Здесь же можно включить или выключить резервирование адреса для этого устройства, изменив соответствующий параметр в пункте «Состояние».

После ввода параметров нажмите кнопку «Сохранить». Теперь это устройство всегда будет получать при подключении к сети только этот IP-адрес.

После сохранения параметров вы вернётесь в предыдущее окно. В списке устройств теперь будет видно то, которое вы только что добавили. Нажав «Изменить», вы можете отредактировать параметры резервирования адреса. А с помощью пункта «Удалить» удалить устройство из списка и отменить резервирование.

С помощью кнопок «Включить всё», «Отключить всё» и «Удалить всё» вы можете управлять резервированием адресов для всех устройств из списка.

Для применения сделанных изменений вам понадобится перезагрузить роутер. Напоминание об этом появится в нижней части окна.

DHCP-сервер на роутере: что это, как настроить

Как и в глобальной сети, в локальной для корректной работы, каждому устройству необходимо присвоить свой IP адрес. При малом количестве устройств, этот процесс возможно выполнить вручную.

Содержание статьи

Что представляет собой dhcp-сервер на роутере

Когда устройств становится слишком много или вы не можете предугадать MAC адреса каждого из них, например, в кафе или на большом предприятии, необходимо как-то автоматизировать данный процесс. Выполняет эту задачу DHCP-сервер (англ. Dynamic Host Configuration Protocol — протокол динамической настройки узла).

Основной алгоритм, подразумевает всего четыре главных шага:

  1. Телефон отправляет запрос по широковещательному адресу.
  2. DHTP отвечает на запрос и отправляет сообщение с IP адресом.
  3. Телефон подтверждает предложенный IP.
  4. Для предотвращения неполадок из-за помех, сервер вновь посылает IP. Чтобы телефон сверил его с уже полученным. И при несовпадении адресов, процедура повторяется с 1 шага.

В локальных сетях, которыми являются не только проводные, но и wi-fi сети, также необходимо присваивать уникальные IP адреса, для каждого аппарата. И в роутере, для решения этой задачи встроен свой DHCP-сервер.

Как правильно настроить dhcp-сервер на роутере

Большинство современных роутеров, имеют заранее включённый DHCP. Но бывают случаи, когда необходимо изменить настройки или полностью отключить автоматическую раздачу адресов.

ВАЖНО. Не изменяйте настройки, если вы не знаете за что они отвечают. Некорректные данные могут привести к полной неработоспособности роутера. И для восстановления доступа в интернет, придётся вызывать специалиста.

Первым делом зайдите в графический интерфейс управления роутера. Ищем вкладку настройки, затем подпункт настройки DHCP.

Для корректной работы необходимо задать диапазон доступных IP адресов. Этот пункт является обязательным. Диапазон рассчитывается исходя из первого и последнего значения. Обычно задают значения – от 192.168.0.100, до 192.168.0.199. Но самостоятельно можно задать любой желаемый диапазон.

Другим обязательным пунктом будет время использования. Обычно сервер выдаёт IP как бы в аренду, и время этой аренды и задаётся в данном пункте. Но возможно и бессрочно резервировать IP за определённым устройством. Для этого в данном пункте прописывают значение «0» или «00».

СПРАВКА. Возможны и другие значения, они будет зависеть от модели роутера. И чтобы их узнать, необходимо ознакомиться со спецификацией устройства.

Последующие пункты настроек необязательные. Сервер самостоятельно задаёт корректные значения. Но при необходимости их также возможно задать вручную.

Способы включения и выключения dhcp-сервера

Если по каким-то причинам DHCP был отключён и его необходимо включить. Сделать это возможно в уже знакомой вкладке настройки. Обычно данный пункт обозначен либо двумя кнопками окошками, где нужно отметить желаемый вариант, либо кнопкой рычагом, которая меняет своё значение от нажатия.

Выключается DHCP в том же меню? где и включается. И действия отличаются только выбором необходимого значения. После выбора настроек необходимо нажать на кнопку «сохранить», если настройки не вступят в силу, то перезагрузите роутер.

Подпишитесь на наши Социальные сети

Что Такое DHCP Сервер и Как Включить и Настроить На Роутере За 5 Минут?

Что такое DHCP сервер и для чего он нужен? Этим вопросом задается каждый новичок при подключении роутера к интернету или настройке WiFi сети на компьютере с Windows 7, 8 или 10. По умолчанию DHCP активен на любом роутере, будь то TP-Link, Asus, Zyxel, Keenetic, D-Link, Tenda, Mercusys, Upvel, Netis, Huawei, и в большинстве случаев не требует дополнительной настройки. Также DHCP является одним из самых популярных типов подключения к интернету провайдера. Однако, в его использовании есть нюансы, которые влияют на появление ошибок в работе. В этой статье опробую объяснить простыми словами «для чайников» о назначении DHCP сервера на маршрутизаторе, как его включить и настроить.

Что такое DHCP сервер — простыми словами для чайников

Если говорить простыми словами, то DHCP сервер — это специальная функция на роутере, которая в автоматическом режиме назначает IP адреса для каждого подключающегося к сети устройства.

Он работает как для клиентов, которые соединяются по кабелю, например, стационарных компьютеров. Так и для мобильных девайсов — ноутбуков, смартфонов, Смарт ТВ, IP камер и т.д., которые подключаются к интернету по wifi.

О том, что такое я IP адрес, я подробно рассказывал в другой статье. Если коротко, то это уникальный идентификатор любого устройства внутри локальной сети. Соединились вы со своим wifi — тут же роутер назначил по DHCP для него отдельный IP адрес.

Что такое «DHCP» или «Динамический IP» в настройках подключения к интернету?

То же самое касается и выхода в интернет. DHCP, или «Динамический IP», — это один из типов соединения, при котором оборудование провайдера вашему роутеру или компьютеру (если он напрямую подключен к интернету кабелем) выдает IP адрес в автоматическом режиме в соответствии с заранее выставленными настройками.

Наверняка при подключении своего роутера к интернету вы видели такой тип соединения с провайдером, как «DHCP». Он подразумевает, что никаких настроек для работы с интернетом вам вводить не требуется. А все конфигурации производятся на стороне провайдера. Узнать, как именно тип требуется указывать в вашем случае, необходимо у службы технической поддержки вашего поставщика услуг.

Для чего нужен DHCP сервер на роутере?

Вернемся к локальной сети, так как настраивать DHCP сервер на собственном роутере придется именно вам. Мы выяснили, что у каждого компьютера, ноутбука, телефона, ТВ, приставки, камеры или любого другого девайса, подключенного к маршрутизатору по кабелю или беспроводному сигналу, имеется свой IP адрес для обмена информацией между собой. Зная IP, можно, например, с компьютера-клиента с Windows подключиться к ТВ приставке на Android и транслировать на нее видео, которое находится в папке на жестком диске ПК.

Также на использовании IP адресов построена простейшая система видеонаблюдения и много других более сложных конструкций. Наличие работающего DHCP сервера на роутере избавляет от необходимости вручную прописывать эти адреса для каждого устройства.

Представьте, что его бы не было — тогда каждый раз, когда бы мы подключались к wifi с ноутбука или любого другого гаджета, нужно было бы вручную задавать его в настройках. А если таких компьютеров десятки, сотни..? Плюс еще держать где-то всю информацию, какому компьютеру какой адрес назначен. Про гостевой доступ, когда к сети подключаются не зарегистрированные ранее девайсы, вообще можно было бы забыть. Не будут же ваши гости, ничего не понимающие в сетевых параметрах, сами настраивать свои ноутбуки и смартфоны на работу в вашей сети.

Если же на роутере включен DHCP сервер, то мы имеем то, к чему привыкли. Просто подключаемся к wifi, вводим пароль и пользуемся. А вся эта непонятная «кухня» с IP адресами и портами остается за кадром.

Иногда случается, что на Windows вылезает ошибка о том, что DHCP не работает. О том, как ее исправить, у нас есть отдельная инструкция.

Но бывают и такие ситуации, когда DHCP сервер нужно отключать или же даже при активной функции назначать адреса вручную. Сделать это можно не только на профессиональном дорогом оборудовании Cisco, но и на самом обычном домашнем роутере. Так что давайте разберемся вместе, что к чему.

Настройка DHCP сервера на маршрутизаторе

По умолчанию на всех роутерах настройкой DHCP сервера заниматься не нужно. Он всегда включен и оптимизирован для работы. Но кое-что изменить все же можно.

DHCP сервер на роутере TP-Link

На роутерах TP-Link настройка DHCP сервера находится в одноименном разделе меню в старой версии панели администратора или в рубрике «Дополнительные настройки — Сеть — DHCP-сервер» в новой

Разберем каждый из параметров, доступных для настройки:

  • Начальный и Конечный IP адрес, или Пул адресов — те значения, которые будут выдаваться вновь подключаемым устройствам. С помощью этого параметра можно ограничить количество одновременно подключаемых гаджетов, с которыми будет работать DHCP сервер.

    Не хотим, чтобы к нашему wifi коннектилось более 5 клиентов, ставим от 100 до 104. Своим же собственным компьютерам и смартфонам можем задать IP вручную вне этого диапазона.

  • Срок действия адреса — время в минутах, в течение которого выданный айпишник будет работать. Время истекло — выдается новый.
  • Основной шлюз — это адрес маршрутизатора, то есть «шлюза», за которым заканчивается локальная сеть и начинается глобальная — интернет.
  • Предпочитаемый и Альтернативный DNS сервер — здесь можно оставлять поля пустыми, либо опять же прописать ай-пи роутера, либо указать адреса от Google или Яндекс.

Asus

Сервер DHCP на маршрутизаторе ASUS

У роутеров ASUS параметры настройки DHCP находятся в разделе «Локальная сеть — DHCP»

Zyxel, Keenetic

Включаем DHCP в роутере Zyxel Keenetic

На маршрутизаторах Zyxel Keenetic DHCP сервер включается в разделе «Домашняя сеть», вкладка «Сегменты». Логика работы здесь основана на том, что можно его включить или отключить отдельно для каждого из типов сетей — основной или гостевой.

Изначально он так же включен, а для тонкой настройки DHCP на Zyxel Keenetic кликаем по строчке с нужной сетью. Здесь все то же самое, что и на других, только время аренды указывается не в минутах, а в секундах.

Если вы купили себе новый маршрутизатор Keenetic, то управление настройками DHCP сервера происходит в разделе «Домашняя сеть». Здесь много всего, поэтому нам нужно найти блока «Параметры IP»

Тут задается IP роутера и маска, а также активируется DHCP сервер. Можно также его отключить совсем или использовать в качестве оного другой роутер (Relay).

Если нажать на «Показать настройки DHCP», то откроются дополнительные параметры, такие как пул адресов, стартовый IP, шлюз и DNS сервера

D-Link

Включить DHCP сервер на роутере D-Link

Для активации DHCP сервера на роутере D-Link необходимо открыть меню «Сеть — LAN». Здесь можно поменять IP адрес самого роутера, задать диапазон назначаемых адресов для других компьютеров, а также привязать статический IP различным устройствам.

Из режимов работы DHCP доступен также Relay на тот случай, если маршрутизатор D-Link подключен в качестве вспомогательной точки доступа к другому основному роутеру.

Mercusys

Настройка DHCP на Mercusys

На роутерах Mercusys настройка DHCP находится в разделе «Сеть». Для его включения ставим «тумблер» в положение «ON». И назначаем диапазон IP адресов для раздачи (начальный и конечный). Здесь же можно указать дополнительные DNS сервера для стабилизации подключения.

Upvel

Активация DHCP на wifi маршрутизаторе Upvel

DHCP сервер на маршрутизаторе Upvel настраивается в разделе «Интерфейс LAN». Тут все просто — ставим на «вкл» или «выкл» и устанавливаем начальный и конечный IP

Netis

Состояние DCHP на маршрутизаторе Netis

Точно также минимум настроек и на роутерах Нетис. Выбираем в меню «Сеть — LAN», активируем DHCP и выставляем данные

Huawei

Настройка DHCP на Huawei

Для активации сервера DHCP на роутерах Huawei надо открыть одноименный раздел в блоке «Wi-Fi»

Видео, как включить DHCP сервер роутера


Спасибо!Не помогло

Лучшие предложения

Александр

Специалист по беспроводным сетям, компьютерной технике и системам видеонаблюдения. Выпускник образовательного центра при МГТУ им. Баумана в Москве. Автор видеокурса «Все секреты Wi-Fi»

Задать вопрос

Как включить DHCP на роутере для автоматической раздачи IP-адресов

Многие из нас для подключения нескольких клиентов (компьютер, телевизор, планшет, смартфон…) к сети Интернет используют дома или в офисе сетевое устройство. Как правило, для выхода в глобальную сеть используют маршрутизатор, который присваивает каждому подключенному к нему устройству свой уникальный IP-адрес. Назначение уникального сетевого адреса устройству будет выполняться автоматически, если включить DHCP на роутере, а всем клиентам локальной сети в настройках созданного подключения активировать опцию «Получить IP-адрес автоматически».

После этого, все устройства, находящиеся в домашней или офисной сети, будут выходить в Интернет под одним IP-адресом, но в локальной сети они будут иметь разный IP. DHCP очень востребованная опция и если вы решите подключить компьютер к телевизору и воспроизводить мультимедийный контент на втором устройстве с помощью медиа-сервера или захотите передать видеопоток с PC на TV через Windows Media, то функцию DHCP на маршрутизаторе нужно активировать, иначе все придется настраивать вручную. Используя DHCP-сервер можно смотреть видео на Android планшете или смартфоне размещенное на компьютере.

Чтобы активировать DHCP, нужно зайти в настройки роутера. Для этого введите в адресную строку браузера адрес шлюза (обычно 192.168.1.1 или 192.168.0.1), введите в форму логин, пароль и нажмите кнопку «Вход». Кстати, если сетевое устройство раньше использовалось для подключения к сети у другого интерне-провайдера, то рекомендую сначала сделать сброс настроек до заводских и подключиться к текущему представителю услуг.

Активация протокола автоматической конфигурации на роутере.

Как правило, по умолчанию данная опция на сетевом устройстве включена, но в силу разных причин у некоторых пользователей она находится не в активном состоянии. Я покажу как включить DHCP на роутере ASUS и TP-Link, а вы по аналогии сможете включить протокол динамической настройки узла на любой другой модели от какого-то ни было производителя. Принцип на всех устройствах один и тот же, лишь оболочка интерфейса разная.

ASUS. После активации в интерфейсе, перейдите в раздел «Локальная сеть» на вкладку «DHCP-сервер» и в пункте «Включить DHCP-сервер» переведите переключатель в положение «Да». На этой же странице вы можете задать начальный и конечный пул IP-адресов. По сути, это диапазон уникальных сетевых адресов, один из которых маршрутизатор будет присваивать устройству при подключении к нему.

Чтобы каждый раз при подключении устройства (компьютер, телевизор, смартфон…) к локальной сети роутер присваивал ему один и тот же сетевой адрес, нужно привязать IP- к MAC-адресу клиента (описана процедура назначения статического IP детально). Таким образом у планшета, ноутбука и других устройств в домашней или офисной сети будет свой постоянный сетевой адрес, и вы гарантированно избежите любого рода конфликтов.

Например, чтобы дать постоянный IP-адрес ноутбуку, нужно сначала узнать MAC-адрес компьютера, а после в настройках активировать опцию «Включить назначения вручную» и выбрать из выпадающего списка это устройство. В соседнем поле прописать желаемый свободный IP из диапазона и нажать кнопку добавить. Изменения вступят в силу после нажатия кнопки «Применить» и перезагрузки. Как видите, у меня постоянный IP получает четыре клиента.

TP-LINK. После входа в интерфейс сетевого устройства перейдите на вкладку «DHCP» -> «Настройки DHCP» (Settings). На этой странице вы можете включить DHCP-сервер и задать начальный и конченый IP-адрес в одноименных полях для локальной сети. Обращаю ваше внимание, что на вкладке «Сеть» (Network) — «Локальная сеть» (LAN) указан текущий IP-адрес роутера, следовательно, назначить его какому-то другому устройству он не может.

Поэтому начальный IP- нужно задавать с учетом сетевого узла маршрутизатора и присваивать следующий за ним. Например, если стоит 192.168.1.1, то начальный IP-адрес может быть 192.168.1.2; 192.168.1.3 или как в моем случае 192.168.1.100. Все остальные настройки не являются обязательными, но если нужно, то можете уменьшить срок действия адреса.

По окончанию срока устройство которому был выдан IP попросит его продлить. Диалог происходит незаметно для вас и если в сети очень много клиентов, то в этом случае опция актуальна, поскольку не забивает таблицу. Срок действий адреса, имя, MAC- и IP-адрес вы можете посмотреть в списке подключенных к сети клиентов (DHCP Clients List). Если в локальной сети от 3 до 10 клиентов, то оставьте всё по умолчанию или задайте максимальное значение (2880 минут).

На роутере есть возможность прикрутить клиенту постоянный IP-адрес. Таким образом, при подключении к сети, сетевое устройство будет выдавать устройству один и тот же IP. Для этого нужно перейти на вкладку «Резервирование адресов» (Address Reservation) и нажмите кнопку «Добавить новую». Пропишите MAC-адрес устройства, задайте свободный IP-адрес из имеющегося диапазона. В выпадающем списке «Состояние» поставьте «Включить» и нажмите кнопку «Обновить». Все настройки вступят в силу после перезагрузки роутера.

После того как вы включите DHCP-сервер на роутере, убедитесь, что все клиенты (компьютер, телевизор, приставка…) в настройках имеют статус «Получить IP-адрес автоматически». Пока!

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

Читайте также

Поделитесь в соцсетях:

Что такое DHCP и как это работает?!

Привет, друзья! Сегодня я хочу рассказать что же такое DHCP, для чего это нужно и как всё работает. Почему я поднимаю эту тему? Да просто уже устал объяснять прописные истины. Ко мне постоянно поступает множество вопросов по настройкам модемов и роутеров и я понимаю, что большинство просто не в курсе даже самых-самых основополагающих принципов функционирования локальной сети. Смысл тогда лезть в настройку устройства, если не понимаешь даже что собираешься делать?! Именно для повышения уровня компьютерной грамотности я и написал эту статью.

Напомню сначала, что есть два основных типа вычислительных сетей — локальные (LAN) и глобальные (WAN).

Локальная сеть работает в пределах одной комнаты \ квартиры \ здания \ организации. То есть её размер ограничен одним или несколькими сегментами.

Глобальная сеть — это, конечно же, самая крупная глобальная сеть в мире — Интернет. К какой бы сети Вы не подцепились — Вы должны получить в ней адрес, помогающий идентифицировать любое подключенное устройство. Он будет присвоен на время (динамически) или навсегда (статически). Кроме этого вы получаете маску сети, адрес шлюза и DNS-серверов. Без этого работать ничего нормально не будет. Так вот контролировать этот процесс в автоматическом режиме и призван протокол DHCP. Без него в крупной сети будет полнейший бардак.

Есть такой протокол DHCP….

И вот мы плавно подошли к основной теме статьи. DHCPDynamic Host Configuration Protocol— это протокол динамической настройки узла. Он клиент-серверный и предназначен для настройки каждого подключенного хоста с помощью удаленного сервера. На сегодняшний день DCHP поддерживается «из коробки» практически каждого современной операционной системой. В крупных сетях это реально отличная альтернатива рутинной ручной настройке сетевых параметров для сервера и подключаемых устройств, позволяющая системному администратору упросить настройку и управление своим сегментом сети.

Протокол DHCP имеет свой собственный порядок обмена сообщениями между сервером и клиентами, в процессе которого они обмениваются сообщениями. Структура сообщений DHCP выглядит так:

Поле Длина (байты) Описание
op 1 Тип сообщения
htype 1 Тип адреса аппаратной части
hlen 1 Длина адреса аппаратной части
hops 1 Используемое количество агентов ретрансляции. Клиенты устанавливают значение на 0.
xid 4 ID  (уникальный идентификационный номер) транзакции используемой клиентом и серверов во время сессии
secs 2 Прошедшее время (в секундах) с момента запроса клиентом начала процесса
flags 2 Значение флагов
ciaddr 4 IP-адрес клиента (если имелся ранее).
yiaddr 4 IP-адрес, предложенный сервером клиенту
siaddr 4 IP-адрес сервера
giaddr 4 IP-адрес relay-агента (агента ретрансляции)
chaddr 16 Адрес аппаратной части клиента (в основном MAC).
sname 64 Имя сервера.
file 128 Название загрузочного файла.
options Переменная. Поле опций, где указываются различные дополнительные параметры конфигурации      Дополнительные опции

Как работает DHCP

При работе протокола динамической адресации используются четыре типа сообщений, которыми обмениваются клиент и сервер. Давайте рассмотрим их подробнее.

DHCPDISCOVER
С данного сообщение начинается процесс взаимодействия между клиентом и сервером посредством DHCP. Оно отправляется клиентом (компьютером, телефоном, планшетом, телевизором или устройством), которое подключилось к данной сети. Сообщение широковещательное, то есть в нём используется 255.255.255.255 как IP-адрес доставки, а исходным адресом является 0.0.0.0

DHCPOFFER
Это сообщение отправляется сервером хосту в ответ на полученный ранее DHCPDISCOVER. В нём содержатся все необходимые сетевые настройки, применив которые новое устройство сможет работать в этом сегменте.

DHCPREQUEST
Опять широковещательно сообщение, которое клиент отправляет серверу в ответ DHCPOFFER. Оно означает, что клиент выбрал отправленный ему вариант конфигурации сетевого подключения.

DHCPACK
Финальное сообщение от сервера DHCP клиенту в ответ на DHCPREQUEST. Оно обозначает конец процесса общения, начатого с сообщения DHCPDISCOVER. Получив его, клиент должен применить согласованные ранее настройки сетевого интерфейс, используя предоставленные опции.

Прочие сообщения протокола:

DHCPNAK
Полная противоположность сообщению DHCPACK. Оно означает прекращение общения между сервером, описанного выше. Необходимо начать процедуру заново!

DHCPRELEASE
Сообщение отправляется клиентом в тот момент, когда он завершает процесс использования занимаемого им IP-адреса.

DHCPDECLINE
Если предлагаемый сервером IP-адрес уже занят, то клиент  отправляет серверу данное сообщение и после этого процесс их общения перезапускается с самого начала.

DHCPINFORM
Этот вид сообщений отправляется клиентом серверу в тех случаях, когда клиенту присвоен статический IP-адрес, и выделение динамического не требуется. В ответ сразу прилетает DHCPACK.

Механизм общения клиента и сервера

Теперь, когда мы узнали все типы используемых в протоколе DHCP сообщений, давайте посмотрим как на практике происходит общение клиента и сервера.

Этап 1. Клиентское устройство — компьютер, телефон, принтер, телевизор и т.п.- подключается к сети. Он отправляет широковещательный запрос DHCPDISCOVER в поисках сервера. Для этого используется транспортный протокол UDP и порт 67. Начинается процесс авторизации.

Этап 2. Сервер получил запрос DHCPDISCOVER, то в ответ шлёт сообщение DHCPOFFER, где предлагает клиенту варианты настройки сетевого адаптера — IP-адрес, маску подсети, шлюз и DNS-серверы. и информация о шлюзе. Отправка идёт уже не в широковещательном формате а непосредственно хосту, отправившему запрос. Для этого в поле CHADDR прописывается его MAC-адрес. Теперь используется тот же протокол UDP, но порт уже 68.

Этап 3. Клиент просматривает выбранные конфигурации, выбирает приемлемую ему и формирует сообщение DHCPREQUEST, указав в нём какой вариант он выбрал. Если в сети несколько DHCP-серверов и прилетело несколько сообщений DHCPOFFER, то клиент указывает в ответе нужный ему сервер.

Этап 4. Сервер получает от клиента DHCPREQUEST и отправляет в ответ DHCPACK, говоря клиентскому устройству о том, что оно теперь в праве использовать назначенный ему IP-адрес. На этом процесс общения оканчивается и новый хост появляется в сети.

Аренда IP-адресов

Как я уже сказал ранее, IP-адреса выдаются DHCP-сервером на определённое заранее время — Lease Time. Это значение задаётся при настройке сервера обычно в минутах или часах, но в некоторых случаях может быть задано и в секундах. Время аренды периодически обновляется, говоря серверу о том, что данный узел «живой». Как только половина срока аренды пройдёт, DCHP-клиент будет пытаться автоматически продлить время аренды путем обмена сообщениями DHCPREQUEST и DHCPACK.

Когда срок аренды адреса истечёт, а подтверждение не прилетит, либо прилетит пакет DHCPRELEASE, сервер сможет присвоить данный IP-адрес другому компьютеру или устройству, подключающемуся в данный момент времени.

Настройка DHCP на роутере

Первым делом Вы должны попасть в настройки своего WiFi-роутера. Сделать это можно либо с компьютера, введя в браузере его локальный IP (обычно это 192.168.1.1 или 192.168.0.1). После авторизации необходимо в главном меню веб-интерфейса найти раздел, отвечающий за локальную сеть (LAN). В некоторых случаях, как в моём примере, настройка DCHP на роутере выведена в отдельный раздел:

Включение и выключение сервера обычно выполняется с помощью галочек «Включить»/»Отключить» или «Enable»/»Disable». На некоторых моделях это может быть выполнено в виде выпадающего списка.

Как правило, на любом WiFi-маршрутизаторе можно задать пул IP-адресов для клиентов, которые будут выдаваться сервером. При необходимости его можно увеличить, либо убавить, оставив адреса для статических подключений.

Ещё один важный параметр — это время аренды IP-адреса (тот самый Lease Time) о котором я рассказывал выше. По умолчанию на моём роутере он выставлен на 120 минут. Максимальное значение — 2000 минут. После того, как Вы внесёте какие-то изменения в настройки устройства — обязательно не забудьте сохранить настройки. В противном случае, после перезагрузки в силу вступят старые параметры.

 

DHCP сервер — определение протокола динамической конфигурации хоста

DHCP (протокол динамической конфигурации хоста) — это протокол, используемый для быстрого, автоматического и централизованного управления распределением IP-адресов в сети. DHCP также используется для настройки правильной маски подсети, шлюза по умолчанию и информации DNS-сервера на устройстве.

Сервер DHCP используется для выдачи уникальных IP-адресов и автоматической настройки другой сетевой информации. В большинстве домов и малых предприятий маршрутизатор выступает в роли DHCP — сервера. В больших сетях один компьютер может выступать в качестве сервера DHCP.

Короче говоря, процесс выглядит следующим образом: устройство (клиент) запрашивает IP-адрес у маршрутизатора (хоста), после чего хост назначает доступный IP-адрес, чтобы позволить клиенту обмениваться данными в сети.

Когда устройство включено и подключено к сети, в которой есть сервер DHCP, оно отправит на сервер запрос, который называется запросом DHCPDISCOVER. После того, как пакет DISCOVER достигает сервера DHCP, сервер пытается удержать IP-адрес, который может использовать устройство, а затем предлагает клиенту адрес с пакетом DHCPOFFER.

Как только предложение было сделано для выбранного IP-адреса, устройство отвечает на DHCP-сервер пакетом DHCPREQUEST, чтобы принять его, после чего сервер отправляет ACK, который используется для подтверждения того, что устройство имеет этот конкретный IP-адрес, и для определения количество времени, в течение которого устройство может использовать адрес до получения нового.

Если сервер решит, что устройство не может иметь IP-адрес, он отправит NACK. Все это, конечно, происходит очень быстро, и вам не нужно знать какие-либо технические подробности, которые вы только что прочитали, чтобы получить IP-адрес от сервера DHCP.

Плюсы и минусы использования DHCP

Компьютер или любое другое устройство, которое подключается к сети (локальной или интернет), должно быть правильно настроено для связи в этой сети. Поскольку DHCP позволяет выполнять такую ​​настройку автоматически, он используется практически на каждом устройстве, которое подключается к сети, включая компьютеры, смартфоны, игровые приставки и т. д.

Из-за этого динамического назначения IP-адресов меньше вероятность того, что два устройства будут иметь одинаковый IP-адрес с которым очень легко столкнуться при использовании назначенных вручную статических IP-адресов.

Использование DHCP также значительно упрощает управление сетью. С административной точки зрения каждое устройство в сети может получить IP-адрес только с настройками сети по умолчанию, которые настроены для автоматического получения адреса. Единственная альтернатива — вручную назначать адреса каждому устройству в сети.

Поскольку эти устройства могут получать IP-адрес автоматически, они могут свободно перемещаться из одной сети в другую (учитывая, что все они настроены с использованием DHCP) и автоматически получать IP-адрес, что очень полезно для мобильных устройств.

В большинстве случаев, когда устройству назначается IP-адрес DHCP-сервером, этот IP-адрес будет меняться при каждом подключении устройства к сети. Если IP-адреса назначаются вручную, это означает, что администрация должна не только выдавать конкретный адрес каждому новому клиенту, но уже назначенные адреса должны быть вручную назначены, чтобы любое другое устройство могло использовать этот же адрес. Это не только отнимает много времени, но и ручная настройка каждого устройства также увеличивает вероятность возникновения ошибок, созданных человеком.

Хотя использование DHCP имеет множество преимуществ, безусловно, есть и некоторые недостатки. Динамические, изменяющиеся IP-адреса не должны использоваться для устройств, которые являются стационарными и требуют постоянного доступа, таких как принтеры и файловые серверы.

Хотя подобные устройства существуют преимущественно в офисных средах, нецелесообразно назначать им постоянно меняющийся IP-адрес. Например, если сетевой принтер имеет IP-адрес, который изменится в какой-то момент в будущем, то каждый компьютер, подключенный к этому принтеру, должен будет регулярно обновлять свои настройки, чтобы их компьютеры понимали, как связаться с принтером.

Этот тип настройки крайне не нужен и его можно легко избежать, если неиспользовать DHCP для этих типов устройств, а вместо этого назначить им статический IP-адрес.

Та же идея вступает в игру, если вам нужен постоянный удаленный доступ к компьютеру в вашей домашней сети. Если DHCP включен, этот компьютер получит новый IP-адрес в какой-то момент, что означает, что тот, который вы записали в качестве этого компьютера, не будет точным в течение длительного времени. Если вы используете программное обеспечение для удаленного доступа , основанное на IP-адресе, вам необходимо использовать статический IP-адрес для этого устройства.

Сервер DHCP

Сервер DHCP определяет область или диапазон IP-адресов, которые он использует для обслуживания устройств с адресом. Этот пул адресов является единственным способом, которым устройство может получить действительное сетевое соединение.

Это еще одна причина, по которой DHCP так полезен — потому что он позволяет множеству устройств подключаться к сети в течение определенного периода времени, не нуждаясь в огромном пуле доступных адресов. Например, даже если DHCP-сервер определяет только 20 адресов, 30, 50 или даже 200 (или более) устройств могут подключаться к сети при условии, что не более 20 одновременно используют один из доступных IP-адресов.

Поскольку DHCP назначает IP-адреса на определенный период времени ( период аренды ), использование таких команд, как ipconfig, чтобы найти IP-адрес вашего компьютера, со временем даст разные результаты.

Хотя DHCP используется для доставки динамических IP-адресов своим клиентам, это не означает, что статические IP-адреса также нельзя использовать одновременно. Сочетание устройств, которые получают динамические адреса, и устройств, которым вручную назначены их IP-адреса, могут оба существовать в одной сети.

Даже интернет-провайдер использует DHCP для назначения IP-адресов. Это можно увидеть при идентификации вашего публичного IP-адреса. Вероятно, со временем он изменится, если в вашей домашней сети не будет статического IP-адреса, что обычно имеет место только в тех компаниях, которые имеют общедоступные веб-службы.

В Windows APIPA назначает специальный временный IP-адрес, когда DHCP-сервер не может доставить функциональный адрес устройству, и использует этот адрес до тех пор, пока не сможет получить работающий.

[Конспект админа] Как подружиться с DHCP и не бояться APIPA / Блог компании Сервер Молл / Хабр

Сервис, выдающий IP-адреса устройствам в локальной сети, кажется одним из самых простых и всем знакомых. Тем не менее у моих младших коллег до сих пор временами всплывают вопросы вроде «компьютер что-то получает какой-то странный адрес», а появление второго DHCP-сервера в одном сетевом сегменте вызывает некоторый трепет или проблемы в работе сети.

Чтобы у прочитавших этот материал такие вопросы не возникали, мне хотелось бы собрать в кучу основную информацию про работу механизмов выдачи адресов IP, особенности и примеры настройки отказоустойчивых и защищенных конфигураций. Да и возможно матерым специалистам будет интересно освежить нейронные связи.

Немного теории и решения интересных и не очень практических задач — под катом.

В современной локальной сети выдачей адресов обычно занимаются специализированные сервисы с поддержкой протоколов. Самым популярным из них является DHCP (Dynamic Host Configuration Protocol).


В принципе, специально для функционирования небольших сетей был создан стек технологий под названием Zeroconf. Он позволяет обойтись без каких-либо централизованных сервисов и серверов, включая, но не ограничиваясь выдачей IP-адресов. Им закрываются (ну, или почти закрываются) следующие вопросы:

Получение IP-адреса (Automatic Private IP Addressing или APIPA). Система сама назначает себе IP из сети 169.254.0.0/16 (кроме сеток /24 в начале и конце диапазона), основываясь на MAC-адресе и генераторе псевдослучайных чисел. Такая система позволяет избежать конфликтов, а адрес из этой сети называют link-local — в том числе и потому, что эти адреса не маршрутизируются.

Поиск по имени. Система анонсирует свое сетевое имя, и каждый компьютер работает с ним как с DNS, храня записи у себя в кэше. Apple использует технологию mDNS (Multicast DNS), а Microsoft — LLMNR (Link-local Multicast Name Resolution), упомянутую в статье «Домены, адреса и Windows: смешивать, но не взбалтывать».

Поиск сетевых сервисов. Например, принтеров. Пожалуй, самым известным протоколом является UPnP, который помимо прочего умеет сам открывать порты на роутерах. Протокол довольно сложен, в нем используется целый набор надстроек вроде использования http, в отличие от второго известного протокола — DNS-SD (DNS Service Discovery), который попросту использует SRV-записи, в том числе при работе mDNS.

При всех плюсах Zeroconf — без каких-либо сакральных знаний можно собрать рабочую сеть, просто соединив компьютеры на физическом уровне, — IT-специалистам он может даже мешать.

Немного раздражает, не так ли?

В системах Windows для отключения автонастройки на всех сетевых адаптерах необходимо создать параметр DWORD с именем IPAutoconfigurationEnabled в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters и поставить ему значение 0.

Разумеется, Zeroconf подходит разве что для небольших изолированных сетей (например, встретились с приятелем с ноутбуками, соединили их по Wi-Fi и давай играть Diablo II, не тратя время на какие-то сервера), да и выводить локальную сеть в интернет тоже хочется. Чтоб не мучаться со статическими настройками каждого компьютера, были созданы специальные протоколы, включая героя дня — DHCP.


Одна из первых реализаций протокола для выдачи IP-адресов появилась более 30 лет назад и называлась RARP (Reverse Address Resolution Protocol). Если немного упростить принцип его работы, то выглядело это так: клиент делал запрос на широковещательный адрес сети, сервер его принимал, находил в своей базе данных привязку MAC-адреса клиента и IP — и отправлял в ответ IP.

Схема работы RARP протокола.

И все вроде работало. Но у протокола были минусы: нужно было настраивать сервер в каждом сегменте локальной сети, регистрировать MAC-адреса на этом сервере, а передавать дополнительную информацию клиенту вообще не было возможности. Поэтому на смену ему был создан протокол BOOTP (Bootstrap Protocol).

Изначально он использовался для бездисковых рабочих станций, которым нужно было не только выдать IP-адрес, но и передать клиенту дополнительную информацию, такую, как адрес сервера TFTP и имя файла загрузки. В отличие от RARP, протокол уже поддерживал relay — небольшие сервисы, которые пересылали запросы «главному» серверу. Это сделало возможным использование одного сервера на несколько сетей одновременно. Вот только оставалась необходимость ручной настройки таблиц и ограничение по размеру для дополнительной информации. Как результат, на сцену вышел современный протокол DHCP, который является совместимым расширением BOOTP (DHCP-сервер поддерживает устаревших клиентов, но не наоборот).

Важным отличием от устаревших протоколов является возможность временной выдачи адреса (lease) и передачи большого количества разной информации клиенту. Достигается это за счет менее тривиальной процедуры получения адреса. Если в старых протоколах схема была простая, вида запрос-ответ, то теперь схема следующая:


  • Клиент ищет сервер широковещательным запросом, запрашивая в том числе и дополнительные настройки.
  • Сервер отвечает клиенту, предлагая ему IP-адрес и другие настройки.
  • Клиент подтверждает принятую информацию широковещательным запросом, указав в подтверждении IP-адрес выбранного сервера.
  • Сервер соглашается с клиентом, отправляя ему запрос, по получении которого клиент уже настраивает сетевой интерфейс или отвергает его.

Схема общения клиента с сервером пересылки и сервером.

Подробнее про схему взаимодействия сервера и клиента и про структуру запросов и ответов можно почитать, например, в материале «Структура, формат и назначение DHCP пакетов».


На нескольких собеседованиях меня спрашивали: «А какой транспорт и порт использует DHCP?» На всякий случай отвечаем: «Сервер UDP:67, клиент UDP:68».

С разными реализациями DHCP-сервера сталкивались многие, даже при настройке домашней сети. Действительно, сейчас сервер есть:


  • На практически любом маршрутизаторе, особенно SOHO.
  • На системах Windows Server. О сервере и его настройке можно почитать в официальной документации.
  • На системах *nix. Пожалуй, самое популярное ПО — ISC DHCP Server (dhcpd) и «комбайн» Dnsmasq.

Конкретных реализаций довольно много, но, например, на SOHO-маршрутизаторах настройки сервера ограничены. В первую очередь это касается дополнительных настроек, помимо классического «IP-адрес, маска, шлюз, сервер DNS». А как раз эти дополнительные опции и вызывают наибольший интерес в работе протокола. С полным списком можно ознакомиться в соответствующем RFC, я же разберу несколько интересных примеров.


В этом разделе я рассмотрю практическое применение опций DHCP на оборудовании MikroTik. Сразу обращу внимание на то, что не все опции задаются очевидно, формат параметров описан в wiki. Следует отметить также то, что опции клиент применяет, только когда сам их попросит. В некоторых серверах можно принудительно отправить настройки: например, в ISC DHCP Server за это отвечает директива dhcp-parameter-request-list, а в Dnsmasq —* *—dhcp-option-force. MikroTik и Windows такого не умеют.

Option 6 и Option 15. Начнем с простого. Настройка под номером 6 — это серверы DNS, назначаемые клиентам, 15 — суффикс DNS. Назначение суффикса DNS может быть полезным при работе с доменными ресурсами в недоменной сети, как я описывал в статье «Как мы сокращали персонал через Wi-Fi». Настройка MikroTik под спойлером.


Настройка MikroTik, option 15
#Добавляем опцию 15. содержимое — сконвертированный в HEX суффикс.

/ip dhcp-server option

add code=15 name=dns-suffix value=0x57687920616c6c207468697320736869743f

#создаем набор опций

/ip dhcp-server option sets

add name=dns option=dns-suffix

#Добавляем опцию к DHCP-серверу для клиентов.

/ip dhcp-server network

set [find comment="wi-fi client dhcp"] dhcp-option-set=dns

Знание, что сервер DNS — это тоже опция, недавно пригодилось мне, когда разным клиентам нужно было выдать разные серверы DNS. Решение вида «выдать один сервер и сделать разные правила dst-nat на 53 порт» не подходило по ряду причин. Часть конфигурации снова под спойлером.


Настройка MikroTik, option 6
#настройка опций, обратите внимание, что ip экранирован одинарными кавычками

/ip dhcp-server option

add code=6 name=google value="'8.8.8.8'"

add code=6 name=cloudflare value="'1.1.1.1'"

#настройка клиентов

/ip dhcp-server lease

add address=10.0.0.2 dhcp-option=google mac-address=11:11:11:11:11:11 server=dhcp

add address=10.0.0.3 dhcp-option=cloudflare mac-address=22:22:22:22:22:22 server=dhcp

Option 66 и Option 67. Эти настройки пришли еще с BOOTP и позволяют указать TFTP-сервер и образ для сетевой загрузки. Для небольшого филиала довольно удобно установить туда микротик и бездисковые рабочие станции и закинуть на маршрутизатор подготовленный образ какого-нибудь ThinStation. Пример настройки DHCP:

/ip dhcp-server option

add name="option66" code=66 value="s'192.168.88.1'"

add name="option67" code=67 value="'pxelinux.0'"

/ip dhcp-server option sets

add name="set-pxe" options=option66,option67

Option 121 и Option 249. Используются для передачи клиенту дополнительных маршрутов, что может быть в ряде случаев удобнее, чем прописывать маршруты на шлюзе по умолчанию. Настройки практически идентичные, разве что клиенты Windows предпочитают вторую. Для настройки параметра маршруты надо перевести в шестнадцатеричный вид, собрав в одну строку маску сети назначения, адрес сети и шлюз. Также, по RFC, необходимо добавить и маршрут по умолчанию. Вариант настройки — под спойлером.


Настройка маршрутов

Предположим, нам нужно добавить клиентам маршрут вида dst-address=10.0.0.0/24 gateway=192.168.88.2, а основным шлюзом будет 192.168.88.1. Приведем это все в HEX:


Соберем все это счастье в одну строку и получим настройку:

/ip dhcp-server option

add code=121 name=classless value=0x0A0000c0a8580200c0a85801

Подробнее можно прочитать в статье «Mikrotik, DHCP Classless Route».

Option 252. Автоматическая настройка прокси-сервера. Если по каким-то причинам в организации используется непрозрачный прокси, то удобно будет настроить его у клиентов через специальный файл wpad (pac). Пример настройки такого файла разобран в материале «Proxy Auto Configuration (PAC)». К сожалению, в MiroTik нет встроенного веб-сервера для размещения этого файла. Можно использовать для этого пакет hotspot или возможности metarouter, но лучше разместить файл где-либо еще.

Option 82. Одна из полезнейших опций — только не для клиента, а для DHCP-релея. Позволяет передать серверу информацию о порте коммутатора, к которому подключен клиент, и id самого коммутатора. Сервер на основе этой информации в свою очередь может выдать уже клиенту какой-то определенный набор настроек или просто занести в лог — чтобы в случае необходимости найти порт подключения клиента, не приходилось заходить на все свитчи подряд (особенно, если они не в стеке).

После настройки DHCP-Relay на маршрутизаторе в информации о клиентах появятся поля Agent Circuit ID и Agent Remote ID, где первое — идентификатор порта коммутатора, а второе — идентификатор самого коммутатора.

Выдача адресов с option 82.

Информация выдается в шестнадцатиричном формате. Для удобства восприятия при анализе журнала DHCP можно использовать скрипты. Например, решение для решения от Microsoft опубликовано в галерее скриптов Technet под названием «Декорирование DHCP опции 82».

Также опция Option 82 активно используется в системе биллинга провайдеров и при защите сети от посторонних вмешательств. Об этом чуть подробнее.


Ввиду простоты протокола и присутствия широковещательных запросов есть эффективные атаки на инфраструктуру — в основном типа MITM («человек посередине»). Атаки производятся посредством поднятия своего DHCP-сервера или релея: ведь если контролировать выдачу сетевых настроек, можно запросто перенаправить трафик на скомпрометированный шлюз. Для облегчения атаки используется DHCP starvation (представляясь клиентом или релеем, злоумышленник заставляет «родной» DHCP-сервер исчерпать свои IP-адреса). Подробнее про реализацию атаки можно почитать в статье «Атакуем DHCP», методом же защиты является DHCP Snooping.

Это функция коммутатора, которая позволяет «привязать» DHCP-сервер к определенному порту. Ответы DHCP на других портах будут заблокированы. В некоторых коммутаторах можно настроить и работу с Option 82 при ее обнаружении в пакете (что говорит о присутствии релея): отбросить, заменить, оставить без изменения.

В коммутаторах MikroTik включение DHCP Snooping производится в настройках бриджа:

#Включаем dhcp-snooping и option 82

/interface bridge

add name=bridge

set [find where name="bridge"] dhcp-snooping=yes add-dhcp-option82=yes

#ставим настраиваем доверенный порт

/interface bridge port

add bridge=bridge interface=ether1

add bridge=bridge interface=ether2 trusted=yes

Настройка в других коммутаторах происходит аналогичным образом.


Стоит отметить, что не все модели MikroTik имеют полную аппаратную поддержку DHCP Snooping — она есть только у CRS3xx.

Помимо защиты от злых хакеров эта функция избавит от головной боли, когда в сети появляется другой DHCP-сервер — например, когда SOHO-роутер, используемый как свич с точкой доступа, сбрасывает свои настройки. К сожалению, в сетях, где встречается SOHO-оборудование, не всегда бывает грамотная структура кабельной сети с управляемыми маршрутизаторами. Но это уже другой вопрос.

Красивая коммутационная — залог здоровья.

К другим методам защиты можно отнести Port Security («привязка» определенного MAC-адреса к порту маршрутизатора, при обнаружении трафика с других адресов порт будет блокироваться), Анализ трафика на количество DHCP-запросов и ответов или ограничение их количества, ну и, конечно, различные системы IPS\IDS.

Если говорить не только о защите сети, но и о надежности, то не лишним будет упомянуть и про возможности отказоустойчивого DHCP. Действительно, при своей простоте DHCP часто бывает одним из ключевых сервисов, и при выходе его из строя работа организации может быть парализована. Но если просто установить два сервера с идентичными настройками, то ни к чему, кроме конфликта IP-адресов, это не приведет.

Казалось бы, можно поделить область выдачи между двумя серверами, и пусть один выдает одну половину адресов, а второй — другую. Вот только парализованная половина инфраструктуры немногим лучше, чем целая.

Разберем более практичные варианты.

В системах Windows Server начиная с 2012 система резервирования DHCP работает «из коробки», в режиме балансировки нагрузки (active-active) или в режиме отказоустойчивости (active-passive). С подробным описанием технологии и настройками можно ознакомиться в официальной документации. Отмечу, что отказоустойчивость настраивается на уровне зоны, поэтому разные зоны могут работать в разном режиме.

Настройка отказоустойчивости DHCP-сервера в Windows.

В ISC DHCP Server для настройки отказоустойчивости используется директива failover peer, синхронизацию данных предлагается делать самостоятельно — например, при помощи rsync. Подробнее можно почитать в материале «Два DHCP сервера на Centos7…»

Если же делать отказоустойчивое решение на базе MikroTik, то без хитростей не обойтись. Один из вариантов решения задачи был озвучен на MUM RU 18, а затем и опубликован в блоге автора. Если вкратце: настраиваются два сервера, но с разным параметром Delay Threshold (задержка ответа). Тогда выдавать адрес будет сервер с меньшей задержкой, а с большей задержкой — только при выходе из строя первого. Синхронизацию информации опять же приходится делать скриптами.

Лично я в свое время изрядно потрепал себе нервов, когда в сети «случайно» появился роутер, подключенный в локальную сеть и WAN, и LAN интерфейсами.

Расскажите, а вам приходилось сталкиваться с проказами DHCP?

2 Конфигурация DHCP для маршрутизатора Packet Tracer

В этом примере маршрутизатора DHCP Cisco Packet Tracer мы сосредоточимся на конфигурации DHCP в Cisco Packet Tracer . Другими словами, мы увидим, как настроить DHCP-сервер с помощью Packet Tracer Router . Перед запуском я хочу дать некоторую основную информацию о DHCP .

Как вы знаете, DHCP использует порты UDP 67 и UDP 68 . Он имеет систему обмена сообщениями для связи между DHCP-сервером и DHCP-клиентом .Эти сообщения системы обмена сообщениями и их типы описаны ниже:

  • DHCP Discover (широковещательный)
  • DHCP Offer (широковещательный)
  • DHCP Request (широковещательный)
  • DHCP Ack (широковещательный)
  • DHCP Nak (одноадресный)
  • Выпуск DHCP (одноадресный)
  • Отклонение DHCP (одноадресный)
  • DHCP Inform (одноадресный)

Сообщения DHCP

Вы может достичь Все лаборатории Cisco Packet Tracer Labs и СКАЧАТЬ Примеры Packet Tracer с .формат pkt .


Вы можете СКАЧАТЬ эти уроки Packet Tracer Example с .pkt форматом ЗДЕСЬ.


  1. Во-первых, клиент отправляет широковещательное сообщение «DHCP Discovery» , в котором упоминается, что ему нужен IP-адрес.
  2. Затем DHCP-серверы отвечают с предложениями конфигурации клиенту посредством «DHCP Offer» одноадресного сообщения
  3. После этого DHCP-клиент отправляет широковещательное «DHCP Request» сообщение в сеть с « Идентификатор транзакции » первого DHCP-сервера , отправляющего Offer .Остальные серверы понимают, что клиент хочет использовать сервер , который имеет связанный «идентификатор транзакции» .
  4. Наконец, сервер отправляет одноадресное сообщение «Подтверждение» клиенту , в котором упоминается, что назначение IP-адреса успешно выполнено, или он отправляет сообщение об отказе с именем « DHCP-NACK ».

Для настройки DHCP маршрутизатора Packet Tracer Router необходимо выполнить несколько основных шагов.Для этой конфигурации важным моментом являются широковещательные домены. Если у нас есть только один широковещательный домен в нашей топологии, наша работа проще, иначе мы должны получить помощь от команды «ip-helper address» .

Что такое команда ip helper address ? Команда IP-адреса помощника — это команда, которая помогает нам убедить маршрутизатор и заставить его передавать широковещательные пакеты.

Теперь давайте перейдем к двум различным топологиям конфигурации и посмотрим, как настроить сервер в трассировщике пакетов для DHCP, как настроить сервер DHCP в трассировщике пакетов .


Конфигурация DHCP Packet Tracer для одного широковещательного домена

Наша топология одного широковещательного домена показана ниже. Существует маршрутизатор, который помимо функций маршрутизации будет выполнять роль нашего DHCP-сервера . И есть переключатель для ПК.

Пример топологии DHCP (один широковещательный домен)

Во-первых, давайте посмотрим Как настроить DHCP-сервер на маршрутизаторе Packet Tracer для Один широковещательный домен .Для этого первого случая нашего примера трассировщика пакетов DHCP Cisco, топология One Broadcast Domain , которую мы будем использовать, выглядит так, как показано ниже. Существует маршрутизатор, который будет выполнять роль Server помимо функций маршрутизации. И есть переключатель для ПК.


На routerA сначала мы дадим IP-адрес интерфейсу маршрутизатора, который подключен к коммутатору. Во-вторых, мы создадим DHCP-пул с именем IPD.В этом пуле мы будем упоминать IP-адреса, которые будут предоставлены DHCP-клиентам . После этого мы назначим адрес интерфейса маршрутизатора в качестве адреса маршрутизатора по умолчанию для клиентов. И в последней части мы исключим некоторые адреса с помощью команды « ip dhcp excluded address », которые мы не хотим использовать во время этого динамического назначения IP. С помощью команды « ip dhcp excluded address » указанные адреса не будут использоваться в пуле.

RouterA #  конфигурационный терминал 
RouterA (config) #  интерфейс fastEthernet 1/0 
RouterA (config-if) #  IP-адрес 192.168.10.1 255.255.255.0 
RouterA (config-if) #  без выключения 

% LINK-5-CHANGED: интерфейс FastEthernet1 / 0, состояние изменено на "вверх"
% LINEPROTO-5-UPDOWN: Линейный протокол на интерфейсе FastEthernet1 / 0, состояние изменено на up <
 

RouterA (config-if) #  выход 
RouterA (config) #  ip dhcp pool IPD 
RouterA (dhcp-config) #  сеть 192.168.10.0 255.255.255.0 
RouterA (dhcp-config) #  маршрутизатор по умолчанию 192.168.10.1 
RouterA (dhcp-config) #  выход 
RouterA (config) #  ip dhcp excluded-address 192.168.10.1 192.168.10.10 
RouterA (config) #  ip dhcp excluded-address 192.168.10.12 192.168.10.14 
 

После этой настройки, когда мы проверим IP-адрес PC0, мы увидим IP-адрес 192.168.10.11 . Потому что это первый доступный адрес в пуле DHCP .

Мы также можем проверить информацию о пуле с помощью команды Cisco « show ip dhcp pool ».


Конфигурация DHCP Tracer для нескольких широковещательных доменов

Наш второй случай - , как включить DHCP на маршрутизаторе для нескольких широковещательных доменов .Во втором примере отслеживания пакетов Cisco мы будем использовать ip helper, команду cisco « ip helper-address ». Итак, что такое вспомогательный IP-адрес ?

Многие CCNA узнают, что маршрутизаторы не передают широковещательные рассылки. Но прогресс в CCIE , сетевые инженеры узнают, что это не так. Потому что вы можете передавать широковещательный трафик для многих протоколов как DHCP с помощью команды « ip-helper address ». Здесь мы будем ссылаться только на широковещательную передачу DHCP-запросов .Мы снова можем использовать маршрутизатор в качестве DHCP-сервера , но в этой топологии я использую отдельный DHCP-сервер вместо маршрутизатора.

Пример топологии DHCP (несколько широковещательных доменов)

В первую очередь мы настроим DHCP-сервер для его пулов DHCP и его IP-конфигурации. IP-адрес - 192.168.1.10, а шлюзом по умолчанию будет IP-адрес интерфейса маршрутизатора, обращенного к DHCP-серверу.

Для подсетей 192.168.1.0 и 10.10.0.0 должно быть два DHCP-пула . На снимке экрана ниже показано, как эти назначения будут выполняться на DHCP-сервере .


В маршрутизаторе Packet Tracer будет выполнена следующая конфигурация для двух разных подсетей DHCP :

RouterC #  конфиг терминал 
RouterC (config) #  интерфейс fa0 / 0 
RouterC (config-if) #  IP-адрес 10.10.0.1 255.255.255.255,0 
RouterC (config-if) #  IP-адрес-помощника 192.168.1.10 
RouterC (config-if) #  без выключения 
RouterC (config-if) #  выход 
RouterC (config) #  интерфейс fa1 / 0 
RouterC (config-if) #  IP-адрес 192.168.1.1 255.255.255.0 
RouterC (config-if) #  IP-адрес-помощника 192.168.1.10 
RouterC (config-if) #  без выключения 
RouterC (config-if) #  конец 
RouterC #  запуск копирования 
 

После этой конфигурации мы можем попробовать динамическое назначение IP-адреса на ПК, выбрав динамическую опцию на экране настройки IP, как показано ниже.

Как видите, наши ПК получают свою IP-конфигурацию от DHCP-сервера . Назначение IP выполняется автоматически.


Сообщения DHCP

Основы конфигурации маршрутизатора Packet Tracer

Здесь я хотел бы дать вам некоторую информацию о , как в основном настроить маршрутизатор Cisco на Packet Tracer . Это не часть DHCP Configuration , но они необходимы для настройки маршрутизатора.Итак, здесь мы узнаем, как настроить наш ноутбук для подключения к маршрутизатору, как изменить имя маршрутизатора, как установить пароли на маршрутизаторах Cisco, как шаг за шагом настроить консольный доступ и базовую конфигурацию статической маршрутизации.


Конфигурация ноутбука для подключения маршрутизатора

В Cisco Packet Tracer вы можете напрямую щелкнуть маршрутизаторы и подключить их. Но если вы хотите сделать это через консольное соединение с ноутбуком с помощью консольного кабеля, как в реальном мире, вы можете сделать это с помощью ноутбука и маршрутизатора.Для этого вам нужно настроить программное обеспечение терминала ноутбука, а затем консольный кабель для подключения ноутбука и маршрутизатора.

Когда вы щелкнете по портативному компьютеру на cisco Packet Tracer, вы увидите несколько вкладок. Во вкладке рабочего стола есть конфигурация терминала. Когда вы нажмете на нее, вы увидите настройки терминала. Если вы хотите подключиться к маршрутизатору, вы должны установить следующие настройки:

бит в секунду: 9600

бит данных: 8

четность: нет

стоповые биты: 1

Управление потоком: Нет

После настройки этих конфигураций вы будете готовы подключить свой маршрутизатор к трассировщику пакетов.


Как начать настройку на маршрутизаторе Cisco?

Во всех маршрутизаторах есть специальные команды настройки для запуска настройки маршрутизатора. В маршрутизаторах Cisco это тоже стандарт. Чтобы начать настройку маршрутизатора на трассировщике пакетов, мы должны сначала использовать команду « enable ». Это даст нам права администратора, а затем мы будем использовать « configure terminal », чтобы начать настройку маршрутизатора с трассировщиком пакетов. Вы можете использовать эту длинную версию или даже « conf t » для этого.

Маршрутизатор>  включить 

Маршрутизатор #  настроить терминал 
Введите команды конфигурации, по одной в каждой строке. Закончите CNTL / Z.

Маршрутизатор (конфигурация) #
 

Как настроить имя маршрутизатора?

Все маршрутизаторы имеют имя по умолчанию. Но обычно это имя меняется, чтобы иметь более значимые имена маршрутизаторов. Эти имена маршрутизаторов могут показывать местоположение маршрутизатора, его уровень, важность и т. Д. С помощью одного или нескольких слов мы можем дать специальное имя маршрутизаторам на трассировщике пакетов.

Чтобы дать имя маршрутизатора маршрутизатору Cisco на трассировщике пакетов, мы используем команды « hostname ». Мы можем использовать эту команду в режиме настройки маршрутизаторов Cisco. Здесь мы можем установить имя нашего маршрутизатора как XYZ

Маршрутизатор (конфигурация) #  имя хоста XYZ 
 

Как настроить Включить секретный пароль?

Чтобы обезопасить наш маршрутизатор, сначала мы должны дать ему пароль. В маршрутизаторах Cisco используются разные пароли.Один из основных паролей, используемых в маршрутизаторах, - « enable password ». Это пароль, который сохраняет пароль в виде открытого текста. Но есть также еще один пароль, который называется « включить секретный пароль ». Этот пароль хранит пароли с MD5, и он более безопасен. Вы можете четко увидеть значение параметра enable password в конфигурации, но вы не можете увидеть значение enable secret password в конфигурации.

Здесь давайте настроим наш секретный пароль включения как abc123.

XYZ (config) #  включить секретный пароль abc123 

 

Кстати, команда для шифрования паролей - « служба шифрования паролей ». Мы будем использовать эту команду для шифрования наших паролей.

XYZ (config) #  сервисный пароль-шифрование 
 

Как настроить консольный доступ на маршрутизаторах Cisco?

Перед подключением необходимо выполнить подключение консоли. Это базовая конфигурация маршрутизатора, необходимая для подключения к маршрутизатору с ноутбуком.

Мы используем команду « line console 0 » для доступа к конфигурации консоли. Мы определим пароль, давайте это abcdef . После этого мы будем использовать ключевое слово « логин ».

XYZ (config) #  строка консоли 0 

XYZ (строка конфигурации) #  пароль   abcdef 

XYZ (config-line) #  логин 
 

Помимо этой базовой конфигурации консоли, есть также некоторые другие шаги настройки в рамках этого доступа к консоли, которые очень помогут вам во время конфигурации нашего маршрутизатора с трассировщиком пакетов.Вот эти команды:

  • синхронное ведение журнала
  • время ожидания exec
  • размер истории

При синхронном ведении журнала мы можем установить синхронизацию консоли, чтобы избежать повреждения команд. Если мы не используем эту команду, маршрутизатор может распечатать некоторые выходные данные во время ввода команд, и через некоторое время это может раздражать.

XYZ (config-line) #  синхронная запись 
 

Exec timeout - это команда, которая используется для настройки тайм-аута маршрутизатора.Это может быть установлено в минутах и ​​секундах. Если вам не нужен тайм-аут, вы можете использовать с этой командой 0. Здесь мы будем использовать 3 минуты 30 секунд. По истечении этого периода, если не будет никаких действий, маршрутизатор перейдет в режим ожидания. Кстати, таймаут по умолчанию - 10 минут для маршрутизаторов Cisco.

XYZ (строка конфигурации) #  время ожидания выполнения 3 30 
 

Последняя команда связана с историей команд . Мы можем установить последние запомненные команды с помощью команды history .Здесь мы установим это как 20 команд.

XYZ (строка конфигурации) #  история 20 
 

Как установить IP-адреса интерфейса на маршрутизаторах Cisco?

Одна из наиболее важных и часто выполняемых конфигураций - это конфигурация интерфейсов на маршрутизаторах. Итак, как дать IP-адрес и активировать интерфейс маршрутизатора Cisco? Мы будем использовать команду « ip address » с именем интерфейса на маршрутизаторах.Здесь давайте настроим GigabitEthernet 0/0 маршрутизатора с IP-адресом 192.168.0.5/24 .

XYZ (config) #  интерфейс GigabitEthernet 0/0 
XYZ (config-if) #  IP-адрес 192.168.0.5 255.255.255.0 
XYZ (config-if) #  без выключения 
 

По умолчанию все интерфейсы маршрутизаторов отключены. Итак, чтобы открыть эти порты, мы должны использовать команду « no shutdown ».

После этой конфигурации наш порт может быть вверх или вниз в зависимости от другого конца.Если на другом конце нет проблем и есть конфигурация, то наш порт будет работать.


Как настроить статическую маршрутизацию на маршрутизаторах Cisco?

Статическая маршрутизация - это самый простой и наиболее часто используемый тип маршрутизации на маршрутизаторах. Иногда нам необходимо использовать статическую маршрутизацию в конфигурациях маршрутизатора с трассировщиком пакетов. Итак, здесь мы увидим, как в основном настроить статическую маршрутизацию.

Для статической маршрутизации мы будем использовать команду « ip route » с сетью назначения, маской подсети и шлюзом, который мы будем использовать в первую очередь для доступа к этой сети.Подумайте об этом, мы должны получить доступ к сети 10.0.0.0/24 , и наш шлюз для доступа к этой сети - 172.16.0.1 . Итак, наша статическая конфигурация маршрутизации будет выглядеть, как показано ниже:

XYZ (configf) #  IP-маршрут 10.0.0.0 255.255.255.0 172.16.0.1 
 

Базовые команды проверки маршрутизатора Packet Tracer

После базовой конфигурации вы можете проверить свои конфигурации с помощью основных команд проверки маршрутизатора .Некоторые из этих команд приведены ниже:

  • show startup-config
  • show running-config
  • show interfaces
  • show ip route

show startup-config показывает начальная конфигурация, которая хранится в NVRAM .

show running-config показывает текущую конфигурацию. Он хранится в RAM .

С помощью команды show interfaces вы можете проверить состояние и конфигурацию интерфейсов.

С помощью команды show ip route вы можете увидеть информацию о маршрутизации как статической, так и динамической маршрутизации.

В маршрутизаторах используется множество других команд show. Вы познакомитесь со всем этим, попрактиковавшись в Cisco Packet Tracer. В следующих уроках мы увидим все эти команды одну за другой.

.

Как настроить DHCP-сервер в Packet Tracer. - Основные сведения о компьютерных сетях

Здравствуйте и добро пожаловать! Это руководство поможет вам настроить DHCP-сервер как на маршрутизаторе, так и на обычном сервере в Cisco Packet Tracer. В обоих случаях настройка проста, если у вас есть базовые знания об IP-адресации. Тогда к делу!

Настройка DHCP-сервера на маршрутизаторе.

  1. Построить топологию сети:

2.На маршрутизаторе настройте интерфейс fa0 / 0 , чтобы он работал как шлюз по умолчанию для нашей локальной сети.

Маршрутизатор
> включить
Маршрутизатор # конфигурационный терминал
Маршрутизатор (конфигурация) #int fa0 / 0
Маршрутизатор (config-if) #ip add 192.168.1.1 255.255.255.0
Маршрутизатор (config-if) # без выключения
Маршрутизатор (config-if) #exit 

3. Настройте DHCP-сервер на маршрутизаторе. На сервере мы определим пул DHCP , IP-адресов, которые будут назначены хостам, шлюз по умолчанию для локальной сети и DNS-сервер .

Маршрутизатор
 (конфигурация) #
Маршрутизатор (конфигурация) #ip dhcp pool MY_LAN
Маршрутизатор (dhcp-config) # сеть 192.168.1.0 255.255.255.0
Маршрутизатор (dhcp-config) # default-router 192.168.1.1
Маршрутизатор (dhcp-config) # dns-server 192.168.1.10

 

Мы можем добавить команду ip dhcp excluded-address в нашу конфигурацию, чтобы настроить маршрутизатор на исключение адресов с 192.168.1.1 по 192.168.1.10 при назначении адресов клиентам. Команда ip dhcp excluded-address может использоваться для резервирования адресов, которые статически назначаются ключевым узлам.

Итак, добавьте указанную выше команду в режим глобальной конфигурации .

Маршрутизатор
 (конфигурация) #ip dhcp excluded-address 192.168.1.1 192.168.1.10 

4. Теперь перейдите на каждый компьютер и на вкладках конфигурации IP включите DHCP . Каждый компьютер должен иметь возможность получить IP-адрес, шлюз по умолчанию и DNS-сервер, как определено в шаге 2.

Например, чтобы включить DHCP на ПК1:

Щелкните PC1-> Desktop-> IP configuration. Затем включите DHCP:

Сделайте то же самое для других ПК.

Вы можете проверить конфигурацию, отправив эхо-запрос на ПК2 с ПК1. Пинг должен пройти успешно.

Это так просто!

Теперь сделаем то же самое, используя общий сервер вместо маршрутизатора:

Настройка службы DHCP на универсальном сервере в Packet Tracer.

1. Постройте топологию сети в пакетном трассировщике

2. Настройте статический IP-адрес на сервере (192.168.1.2/24).

3. Теперь настройте службу DHCP на общем сервере.

Для этого щелкните сервер, затем щелкните вкладку Services . Вы выберете DHCP в меню. Затем перейдите к определению параметров сети DHCP следующим образом:

Имя пула : MY_LAN

Шлюз по умолчанию: 192.168.1.1

DNS-сервер: 192.168.1.2

Начальный IP-адрес: 192.168.1.0

Маска подсети: 255.255.255.0

Максимальное количество пользователей: 256

Щелкните , добавьте , затем Сохранить. Запись DHCP включена в список.

Вот конфигурации на сервере:

После того, как вы все настроили, включите службы DHCP.

4. Наконец, включите настройку DHCP на каждом ПК. Все три компьютера должны быть настроены автоматически.

В качестве примера приведем конфигурацию DHCP на ПК1:

Приложение: Вы можете определить DHCP-сервер в одном широковещательном домене для обслуживания хостов в разных широковещательных доменах .Если вы хотите это сделать, вам следует рассмотреть возможность использования команды ip helper-address . Чтобы узнать больше об этом, вы можете прочитать мою статью о конфигурации вспомогательного IP-адреса .

Успех! Успех!

Надеюсь, вы нашли этот пост полезным. Прокомментируйте, чтобы помочь улучшить его.

Вы также можете прочитать:

Нравится:

Нравится Загрузка ...

Связанные

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Theme: Overlay by Kaira Extra Text
Cape Town, South Africa