Разное

Mikrotik backup config: backup — Download exported Mikrotik config

Содержание

сброс настроек, бекапы и DualBoot — asp24.ru

Разбор множества мелких, относительно связанных между собой, тем: программный и аппаратный сброс настроек, функция Protected RouterBoot, бекапы и экспорт конфигурации, разбивка flash памяти на разделы.

 

Программный сброс настроек

Если есть доступ к роутеру от пользователя с full правами, то можно сбросить все настройки через [System] → [Reset Configuration]

Что тут есть:

  • Keep user setting — не удалять учетные записи пользователей.
  • CAPS mode — после сброса искать контроллер CAPsMAN.
  • No Default Configuration — не создавать дефолтную конфигурацию после сброса.
  • Do Not backup — не создавать бекап перед сбросом. Если не отметить, то созданный бекап не будет запаролен.
  • Run After Reset — скрипт, который будет выполнен после сброса и перезагрузки роутера.
  • Во время сброса содержимое flash памяти не затирается.

Консольный вариант:

/system reset-configuration no-defaults=yes skip-backup=yes

 

Аппаратный сброс настроек

Все зависит от модели роутера, возможно три варианта:

Присутствует кнопка reset

Для начала отключаем питание, зажимаем reset и включаем питание. Отпускаем через:

  • 3 секунды(до мигания ACT) — загрузка с запасного бутлоадера. Помогает если произошел сбой при обновлении системы либо firmware.
  • 5 секунд(ACT мигает) — сброс настроек.
  • 10 секунд(ACT перестает мигать) — поиск контроллера CAPsMAN.
  • 15 секунд(ACT не горит) — поиск сервера netinstall.

Контактная площадка

На wiki утверждают, что все девайсы оснащены подобной площадкой. Ради интереса вскрыл RB491-2nD и не обнаружил таковой.

Технология сброса: отключаем питание, замыкаем площадку(бипер издает хрипящий писк) и не отпускаем до полной загрузки.

Перемычка

Присутствует на старых моделях.

Технология сброса: отключаем питание, замыкаем перемычку, ждем полной загрузки, убираем перемычку.

Protected RouterBoot

Может случится ситуация, когда после сброса чужого(иначе вы бы знали) роутера он не будет загружаться дальше «первого пика» — это новая фитча от Mikrotik затирающая всю флеш память( включая RouterOS), для восстановления потребуется netinstall.

Про RouterBoot

RouterBoot — начальный загрузчик на девайсах Mikrotik, с ним можно взаимодействовать через Serial интерфейс и одно из предназначений Protected RouterBoot не давать вмешиваться в процесс загрузки.

Загрузчик разделен на две части:

  • Recovery — поставляется вместе с девайсом и совпадает с Factory Firmware.
  • Current — поставляется с пакетом system, но обновляется отдельно.

Посмотреть текущие версии можно в [System] → [RouterBoard]. Кнопкой [Upgrade] производится обновление Current загрузчика. Если система работает плохо и загружается только с резервного(как написано разделом выше), то в [Settings] можно явно указать recovery загрузчик в качестве постоянного, опция Auto Upgrade для обновления current загрузчика вместе с RouterOS. И раз мы тут — опция Silent Boot отключает звуки во время загрузки.

Консольный вариант


/system routerboard print
/system routerboard setting print

/system routerboard upgrade

/system routerboard setting set force-backup-booter=yes

/system routerboard setting set silent-boot=yes

 

Даунгрейд до Bugfix и спец. версия загрузчика

На форуме и wiki предупреждают, что все эксперементально и делается на ваш страх и риск. Читайте тему, там есть список моделей и файлов обновлений, я напишу на примере RB951G.
Ошибка выглядит так:

 Загружаем отсюда, пакет *.dpk для своей архитектуры.

Копируйте на устройство, если у вас bugfix ветка то достаточно перезагрузиться, если нет читаем дальше.

Откат прошивки. Вариант 1:

[System] → [Packages] → [Check for updates]
Channel: Bugfix Only
нажимаем [Download and Install]
Консольный вариант:

/system package update set channel=bugfix
/system package update check-for-updates
/system package update install

 Откат прошивки. Вариант 2:

Загружаем необходимую версию(6.40.8 на данный момент) RouterOS из архива, распаковываем и копируем на MikroTik необходимые пакеты.

Далее: [System] → [Packages] → [Downgrade]

 Консольный вариант:

/system package downgrade

Результат:

 [System] → [RouterBoard] → [Settings]

Включаем Protected RouterBoot=yes, что теперь.

  • Взаимодействие с RouterBoot на этапе загрузки будет невозможно.
  • Кнопка Reset будет работать в единственном режиме — затирать flash память. Опции reformat-hold-button и reformat-hold-button-max определяют минимальное и максимальное значение время удержания кнопки Reset. Необходимо попасть в установленный промежуток. Форматирование памяти может занимать до 5 минут.
  • Etherboot не будет работать.
  • Сброс через замыкания контактов на плате не будет работать.

Я не призываю вас включать эту опцию в обязательном порядке, думайте сами когда оно вам надо, а когда можно обойтись без подобных мер.

Восстановление прошивки средствами netinstall

Netinstall — универсальный инструмент для прошивки и предварительной настройки роутеров MikroTik. При использовании происходит ворматирование внутренней памяти и конфигурации, без изменения останутся только настройки в [System] → [RouterBOARD]

Доступен только для ОС Windows по ссылке. Конфликтует с некоторыми фаерволами и антивирусами(добавлять в исключения), могут быть проблемы при запуске от пользователей с ограниченными правами — запускаем «От администратора».

Порядок действий

  • Потребуются файлы прошивки отсюда. можете брать целиковый main, либо распаковать необходимые пакеты из extra, обязателен только пакет system.
  • Проводное соединение с роутером. Причем ПК и роутер должны находиться в пределах одного сегмента сети, лучше соединять кабелем напрямую.
  • Рекомендуют отключить на ПК все лишние сетевые интерфейсы. На практике — проблем с этим обычно не возникает.
  • Установить на проводном интерфейсе к которому подключен роутер статический ip, например: 192.168.100.1/24.
  • Если на Mikrotik присутствует порт с надписью Boot, то подключаетесь к нему, если нет — к первому порту.
  • Запускаем Netinstall, в [Net Booting] необходимо включить Boot Server Enabled и указать ip из выбранной ранее подсети, например: 192.168.100.10.

  • Отключаем питание MikroTik, зажимаем Reset и ждем 15 секунд(пока роутер не появится в Netinstall). Если кнопка Reset отсутствует, то замыкаем контактную площадку либо перемычку.
  • В [Browse] выбираем каталог с необходимыми файлами RouterOS, отмечаем необходимые.
  • Нажимаем [install].

На что еще способен netinstall

  • Key — можно обновить лицензию. SoftID необходим для заказа ключа.
  • Keep old configuration — сохранить конфигурацию и восстановить ее после прошивки.
  • IP address/Netmask & gateway — настроить ip.
  • Baud rate — установть скорость Serial интерфейса.
  • Configure script — скрипт, который будет запущен после пошивки.
  • Apply default config — загрузить конфигурацию по умолчанию. Работает если предыдущие три пункта не установлены.
  • Flashfig — утилита для массовой настройки новых девайсов, подробнее тут.

 

Бекап и экспорт конфигурации в Mikrotik

Бинарный бекап

  • Включает в себя практически полную(не переносятся файлы, сертификаты и ключи ipsec) копию настроек RouterOS.
  • Шифрованию в бекапах подвергаются только системные учетные записи.
  • Не редактируется.
  • Восстановление затирает текущую конфигурацию.
  • Желательно восстанавливать на аналогичную модель Mikrotik.
  • Возможно восстановить на отличных от оригинального моделях. Но в бинарном бекапе настройки интерфейсов привязываются к внутреннему id и при восстановлении реальные и системные номера портов ethernet будут перепутаны. Если на новом девайсе не хватает физических интерфейсов — настройки восстановятся, но будут ссылаться на unknown.

Создания бекапа:

[Files] → [Backup]

Name — имя файла. по умолчанию будет —
Password — пароль. По умолчанию используется пароль текущего пользователя.
Don’t encrypt — не шифровать бекап.

Консольный вариант:

/system backup save
# Все ключи опциональны
# name=<string> - имя
# password=<string> - пароль
# dont-encrypt=<yes|no> - не шифровать

Восстановление:

[Files] → [Подсветить необходимый файл] → [Restore]

 онсольный вариант:

/system backup load name=<имя> password=<пароль>

Дополнительно:

Экспорт и импорт конфигурации

  • Не включает настройки системных пользователей.  Клик.
  • Можно сохранить(export) и загружать(import) только из консоли.
  • Возможно скопировать как целиковый конфиг, так и часть.
  • Не шифруется.
  • Можно редактировать.
  • Во время загрузки(import) конфигурации текущая затерта не будет.
  • Можно восстанавливать на любую модель, путаницы в интерфейсах не будет, но если интерфейсов не будет хватать соответствующие настройки не восстановятся.
  • В последних обновлениях RouterOS починили восстановление Scripts и Schedulers. Теперь они восстанавливаются без ошибок с указанными пользователями, сами пользователи созданы не будут.

Варианты export:

  • compact — только отличия от дефолтной конфигурации. По умолчанию в RouterOS 6. Конфликтут с verbose.
  • verbose — наиболее полная конфигурация. По умолчанию в RouterOS 5. Конфликтует с compact.
  • hide-sensitive — не экспортировать пароли, ключи и пр.
  • terse — не разрывать строки.

export не сохраняет конфигурацию в файл, если явно не задать ключ file=<имя файла> расширение rsc будет добавлено автоматически.

# Показать текущую конфигурацию
/export
# Сохранить полную конфигурацию в файл
/export verbose file=config
# Сохранить конфигурацию ip address в файл
/ip address export file=config-ip-add
# Загрузить конфигурацию из файла
/import file=config.rsc

 

DualBoot в Mikrotik(Partition)

Flash накопитель можно разбить на несколько разделов и установить несколько копий RouterOS(в том числе различных). В случае неудачной загрузки с основного раздела будет загружаться следующий указанный. Функция доступна на девайсах с MIPS, PowerPC и CCR серии.

Разбивка на разделы:

[Partition] → [Repartition]

 

partitions repartition partitions=2

Необходимо указать итоговое число разделов. Есть два ограничения: максимальное число разделов — 8 и минимальный размер раздела: 32MB on MIPS; 40MB on PowerPC; 48MB on CCR.

Новый раздел будет пустым, необходимо скопировать на него текущую прошивку через [Copy to].

 

partitions copy-to part1

В консоли лучше видны свойства разделов: Активный(A) — с которого будет произведена следующая загрузка и раздел с которого была загружена система®.

Смена активного раздела происходит в его свойствах кнопкой [Activate]. Опция Fallback to отвечает за выбор раздела, если загрузка не удалась.


partitions activate part1

partitions set part1 fallback-to=part0

partitions set part1 fallback-to=etherboot

[Save Config To] — Сохранить конфигурацию с текущего® раздела на выбранный.
[Restore Config From] — Сохранить конфигурацию с выбранного раздела на текущий®.

partitions save-config-to part1
partitions restore-config-from part1

Функционал интересный, но имеет два недостатка: Не все роутеры комплектуются достаточным количеством flash памяти. Сбои в RouterOS, даже при обновлении, не такое частое явление.

 

 

Источник публикации

 

 

 

 

 

 

 

Резервное копирование Mikrotik через Oxidized

Прочитано:
4 381

Итак сегодня речь пойдет об инструменте в задачу которого входит выполнение централизованного резервного копирования конфигурационных файлов (те которые выполняются с расширением rsc) оборудования Mikrotik. Плюс инструмент умеет отображать разницу в изменениях, а делает он это через складирование изменений посредством системы контроля версий GIT. Я если честно давно искал такой инструмент и вот я воплотил свою задумку разобрав от и до все шаги по разворачиванию сервиса oxidized в систему Ubuntu 18.04 Server amd64. Узнал я о нем это просматривая опубликованные презентации посвященные Mikrotik, к примеру если через поисковую систему Google ввести «Автоматизируем бэкап — MUM — MikroTik»

Предварительные действия: На всех Mikrotik(ах) для которых Вы хотите осуществлять резервное копирование нужно сделать учетную записи с минимальными правами, к примеру только на чтение:

[email protected]:~$ ssh -l admin 172. 33.33.22

[[email protected]] > user add name=test password=Aa1234567 group=read

[[email protected]] > quit



[email protected]:~$ ssh -l admin 172.33.33.22

 

[[email protected]] > user add name=test password=Aa1234567 group=read

 

[[email protected]] > quit

Connection to 172.33.33.22 closed.

[email protected]:~$

Шаг №1: Настраиваю систему

[email protected]:~$ hg clone —insecure https://[email protected]/hg/dproject

[email protected]:~$ sudo ./dproject/default



[email protected]:~$ hg clone —insecure https://[email protected]/hg/dproject

 

[email protected]:~$ sudo ./dproject/default

Полученная текущая система с учетом моего скрипта настройки который я применяю в своей локальной сети:

[email protected]:~$ uname -a && lsb_release -a

Linux srv-bionic 4. 15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 18.04.2 LTS

Release: 18.04

Codename: bionic

[email protected]:~

Шаг №2: Устанавливаю пакет Oxidized в систему Ubuntu 18.04 Server amd64:

[email protected]:~$ sudo apt-get install ruby ruby-dev libsqlite3-dev libssl-dev pkg-config cmake libssh3-1-dev libicu-dev -y

[email protected]:~$ gem install oxidized oxidized-script oxidized-web



[email protected]:~$ sudo apt-get install ruby ruby-dev libsqlite3-dev libssl-dev pkg-config cmake libssh3-1-dev libicu-dev -y

 

[email protected]:~$ gem install oxidized oxidized-script oxidized-web

Fetching: asetus-0. 3.0.gem (100%)

ERROR: While executing gem ... (Gem::FilePermissionError)

You don't have write permissions for the /var/lib/gems/2.5.0 directory.

[email protected]:~$ sudo gem install oxidized oxidized-script oxidized-web

Done installing documentation for charlock_holmes, rack, tilt, rack-protection, sinatra, emk-sinatra-url-for, temple, haml, htmlentities, puma, rb-fsevent, ffi, rb-inotify, sass-listen, sass, backports, rack-test, multi_json, sinatra-contrib, oxidized-web after 675 seconds

22 gems installed

[email protected]:~$

Шаг №3: Cоздаю пользователя oxidized, с правами которого будет запускаться система бэкапа:

[email protected]:~$ sudo useradd -m -p [email protected] -s /bin/bash oxidized

На время даю права повышения привилегий, в конце заметки заберу.

[email protected]:~$ sudo usermod -aG sudo oxidized

Шаг №4: Создаю структуру запуска приложения oxidized

[email protected]:~$ sudo su - oxidized

[email protected]:~$ oxidized -v

0.26.1

[email protected]:~$

[email protected]:~$ whereis oxidized

oxidized: /usr/local/bin/oxidized

[email protected]:~$ oxidized

edit ~/.config/oxidized/config

[email protected]:~$ mkdir ~/.config/oxidized/crashes

[email protected]:~$ mkdir ~/.config/oxidized/mikrotik/

[email protected]:~$ sudo find / -name oxidized

/home/oxidized

/home/oxidized/. config/oxidized

/run/sudo/ts/oxidized

/usr/local/bin/oxidized

/var/lib/gems/2.5.0/gems/oxidized-web-0.13.1/lib/oxidized

/var/lib/gems/2.5.0/gems/oxidized-0.26.1/lib/oxidized

/var/lib/gems/2.5.0/gems/oxidized-0.26.1/bin/oxidized

/var/lib/gems/2.5.0/gems/oxidized-script-0.6.0/lib/oxidized

/var/lib/gems/2.5.0/doc/oxidized-web-0.13.1/ri/lib/oxidized

[email protected]:~$

Шаг №5: Преднастраиваем GIT для устройств Mikrotik бекапы которых будут хранится в репозитарии:

[email protected]:~$ sudo apt-get install git -y

[email protected]:~$ git config --global user.email "[email protected]"

[email protected]:~$ git config --global user.name "oxidized"

[email protected]:~/. ([\[email protected]]+[#>]\s?)$/

rest: 0.0.0.0:8888

next_adds_job: false

vars: {}

groups: {}

models: {}

pid: "/home/oxidized/.config/oxidized/pid"

log: "/home/oxidized/.config/oxidized/log"

crash:

directory: "/home/oxidized/.config/oxidized/crashes"

hostnames: false

stats:

history_size: 10

input:

#Тип подключения к устройству

default: ssh

#Расширенное логирование отключено

debug: false

ssh:

secure: false

map:

verify_host_key: never

utf8_encoded: true

#где хранится конфигурации GIT

output:

default: git

git:

user: oxidized

email: [email protected]

repo: "/home/oxidized/.config/oxidized/oxidized.git"

git:

user: oxidized

email: [email protected]

repo: "/home/oxidized/. config/oxidized/devices/devices.git"

#Откуда берется информация об устройства которые бекапятся

source:

default: csv

csv:

file: "/home/oxidized/.config/oxidized/mikrotik/router.db"

delimiter: !ruby/regexp /:/

#Структура строки в router.db: name:model:ip:port:username:password

map:

name: 0

model: 1

ip: 2

port: 3

username: 4

password: 5

model_map:

cisco: ios

juniper: junos

mikrotik: routeros


1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

71

72

73

74

75

76

77

78

79

80

81

82

83

84

85

86

87

88

89

90

91

92

93

94

95

96

97

98

99

100

101

102

103

104

105

106

107

108

109

110

111

112

113

114

115

116

117

118

119

120

121

122

123

---

 

model: routeros

 

resolve_dns: true

 

#Как часто делать бекапы

 

interval: 3600

 

use_syslog: false

 

debug: false

 

threads: 30

 

timeout: 20

 

retries: 3

 

prompt: !ruby/regexp /^([\w. @-]+[#>]\s?)$/

 

rest: 0.0.0.0:8888

 

next_adds_job: false

 

vars: {}

 

groups: {}

 

models: {}

 

pid: "/home/oxidized/.config/oxidized/pid"

 

log: "/home/oxidized/.config/oxidized/log"

 

crash:

 

directory: "/home/oxidized/.config/oxidized/crashes"

 

hostnames: false

 

stats:

 

history_size: 10

 

input:

 

#Тип подключения к устройству

 

default: ssh

 

#Расширенное логирование отключено

 

debug: false

 

ssh:

 

secure: false

 

map:

 

verify_host_key: never

 

utf8_encoded: true

 

#где хранится конфигурации GIT

 

output:

 

default: git

 

git:

 

user: oxidized

 

email: [email protected]

 

repo: "/home/oxidized/.config/oxidized/oxidized.git"

 

git:

 

user: oxidized

 

email: [email protected] ru

 

repo: "/home/oxidized/.config/oxidized/devices/devices.git"

 

#Откуда берется информация об устройства которые бекапятся

 

source:

 

default: csv

 

csv:

 

file: "/home/oxidized/.config/oxidized/mikrotik/router.db"

 

delimiter: !ruby/regexp /:/

 

#Структура строки в router.db: name:model:ip:port:username:password

 

map:

 

name: 0

 

model: 1

 

ip: 2

 

port: 3

 

username: 4

 

password: 5

 

model_map:

 

cisco: ios

 

juniper: junos

 

mikrotik: routeros

На заметку: Если не настроена авторизация на Mikrotik через публичный ключ, т. е. Вход на Mikrotik с одним лишь указанием логина, то в конфигурационный файл oxidized следует добавить параметр: verify_host_key: never

Шаг №7: Копируем публичный ssh—ключ на Mikrotik:

[email protected]:~$ ssh-keygen



[email protected]:~$ ssh-keygen

Your identification has been saved in /home/oxidized/. ssh/id_rsa.

Your public key has been saved in /home/oxidized/.ssh/id_rsa.pub.

[email protected]:~$ cp ~/.ssh/id_rsa.pub idrsa

[email protected]:~$ ftp 172.33.33.22



[email protected]:~$ cp ~/.ssh/id_rsa.pub idrsa

 

[email protected]:~$ ftp 172.33.33.22

Connected to 172.33.33.22.

220 MikroTik FTP server (MikroTik 6.42.5) ready

Name (172.33.33.22:ekzorchik): admin

ftp> put idrsa

ftp> quit

[email protected]:~$

[email protected]:~$ ssh [email protected]

[[email protected]] > user ssh-keys import public-key-file=idrsa user=test

[[email protected]] > quit



[email protected]:~$

 

[email protected]:~$ ssh [email protected] 33.33.22

 

[[email protected]] > user ssh-keys import public-key-file=idrsa user=test

 

[[email protected]] > quit

Connection to 172.33.33.22 closed.

[email protected]:~$

[email protected]:~$ ssh [email protected] — подключение проходит без каких либо запросов на ввод пароля.

Шаг №8: Теперь создаю файл подключения к оборудованию Mikrotik:

[email protected]:~$ nano ~/.config/oxidized/mikrotik/router.db

mikrotik:routeros:172.33.33.22:22:test:Aa1234567



[email protected]:~$ nano ~/.config/oxidized/mikrotik/router.db

 

mikrotik:routeros:172.33.33.22:22:test:Aa1234567

Шаг №9: Проверяю запуск и соответственно на предмет каких-либо ошибок препятствующих запуску:

[email protected]:~$ oxidized ~/. config/oxidized/config

Puma starting in single mode...

* Version 3.11.4 (ruby 2.5.1-p57), codename: Love Song

* Min threads: 0, max threads: 16

* Environment: development

* Listening on tcp://0.0.0.0:8888

Use Ctrl-C to stop

У каждой строчке есть колонка «Actions»

  • Первая иконка: Посмотреть текущий конфигурационный файл
  • Вторая иконка: Посмотреть историю изменений конфигурационного файла
  • Третья иконка: Это запуск процедуры снятия изменения в репозитарий

Шаг №10: См.логи если что-то пошло не так

[email protected]:~$ tail -f /home/oxidized/.config/oxidized/log

W, [2019-03-04T11:34:49.491810 #28328] WARN -- : /mikrotik status no_connection, retries exhausted, giving up

I, [2019-03-04T11:36:11.666786 #28380] INFO -- : Oxidized starting, running as pid 28380

I, [2019-03-04T11:36:11. 669229 #28380] INFO -- : lib/oxidized/nodes.rb: Loading nodes

I, [2019-03-04T11:36:11.812262 #28380] INFO -- : lib/oxidized/nodes.rb: Loaded 1 nodes

I, [2019-03-04T11:36:14.351899 #28380] INFO -- : Configuration updated for /mikrotik

Шаг №11: Для того, чтобы oxidized стартовал как служба, сделайте следующее:

[email protected]:~$ sudo find / -name oxidized.service

/var/lib/gems/2.5.0/gems/oxidized-0.26.1/extra/oxidized.service

[email protected]:~$ sudo cp /var/lib/gems/2.5.0/gems/oxidized-0.26.1/extra/oxidized.service /lib/systemd/system/

[email protected]:~$ sudo nano /lib/systemd/system/oxidized.service

[Unit]

Description=Oxidized - Network Device Configuration Backup Tool

After=network-online.target multi-user.target

Wants=network-online. target

[Service]

ExecStart=/usr/local/bin/oxidized

User=oxidized

KillSignal=SIGKILL

Environment="OXIDIZED_HOME=/home/oxidized/.config/oxidized/"

[Install]

WantedBy=multi-user.target


1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

[Unit]

 

Description=Oxidized - Network Device Configuration Backup Tool

 

After=network-online.target multi-user.target

 

Wants=network-online.target

 

[Service]

 

ExecStart=/usr/local/bin/oxidized

 

User=oxidized

 

KillSignal=SIGKILL

 

Environment="OXIDIZED_HOME=/home/oxidized/.config/oxidized/"

 

[Install]

 

WantedBy=multi-user.target

[email protected]:~$ sudo systemctl enable oxidized. service

Created symlink /etc/systemd/system/multi-user.target.wants/oxidized.service → /lib/systemd/system/oxidized.service.

[email protected]:~$ sudo systemctl start oxidized

[email protected]:~$ sudo systemctl status oxidized | head -n5

● oxidized.service - Oxidized - Network Device Configuration Backup Tool

Loaded: loaded (/lib/systemd/system/oxidized.service; enabled; vendor preset: enabled)

Active: active (running) since Mon 2019-03-04 12:16:53 MSK; 9s ago

Main PID: 29039 (oxidized)

Tasks: 7 (limit: 2322)

Проверяю, что ожидаются соединения на порт 8888

[email protected]:~$ sudo netstat -tulpn | grep :8888

tcp 0 0 127.0.0.1:8888 0.0.0.0:* LISTEN 29039/puma 3.11.4 (



tcp 0 0 127. 0.0.1:8888 0.0.0.0:* LISTEN 29039/puma 3.11.4 (

[email protected]:~$

Шаг №12: По умолчанию у сервиса нет возможности указать авторизацию, а потому в конфиге config изменяю доступ на 172.0.0.1

[email protected]:~$ nano ~/.config/oxidized/config

#rest: 0.0.0.0:8888

rest: 127.0.0.1:8888



#rest: 0.0.0.0:8888

 

rest: 127.0.0.1:8888

[email protected]:~$ sudo apt-get install nginx -y

[email protected]:~$ sudo rm /var/www/html/index.nginx-debian.html

[email protected]:~$ sudo unlink /etc/nginx/sites-available/default

[email protected]:~$ sudo unlink /etc/nginx/sites-enabled/default

Создаю файл связки логина и пароля для аутентификации через Web—интерфейс:

[email protected]:~$ sudo sh -c "echo -n 'ekzorchik:' >> /var/www/html/. htpasswd"

[email protected]:~$ openssl passwd -apr1

Password: [email protected]

Verifying - Password: [email protected]

$apr1$rwseclUD$ANBsXcpdvR.07mthC2PLO.

[email protected]:~$ sudo sh -c "openssl passwd -apr1 >> /var/www/html/.htpasswd"

Password: [email protected]

Verifying - Password: [email protected]

[email protected]:~$ cat /var/www/html/.htpasswd

ekzorchik:$apr1$V6ZTHWcF$bdDbxqPJAQAzfdXw7Z9n/0



ekzorchik:$apr1$V6ZTHWcF$bdDbxqPJAQAzfdXw7Z9n/0

[email protected]:~$ sudo chown -R www-data:www-data /var/www/html/.htpasswd

[email protected]:~$ sudo nano /etc/nginx/sites-available/oxidized

server {

listen 172. 33.33.4:80;

server_name _;

root /usr/share/nginx/html;

include /etc/nginx/default.d/*.conf;

location / {

auth_basic "UserName and Password Please";

auth_basic_user_file /var/www/html/.htpasswd;

proxy_pass http://127.0.0.1:8888/;

}

}


1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

server {

 

listen 172.33.33.4:80;

 

server_name _;

 

root /usr/share/nginx/html;

 

include /etc/nginx/default.d/*.conf;

 

location / {

 

auth_basic "UserName and Password Please";

 

auth_basic_user_file /var/www/html/.htpasswd;

 

proxy_pass http://127.0.0.1:8888/;

 

}

 

}

[email protected]:~$ sudo ln -s /etc/nginx/sites-available/oxidized /etc/nginx/sites-enabled/oxidized

[email protected]:~$ sudo nginx -t

nginx: the configuration file /etc/nginx/nginx. conf syntax is ok

nginx: configuration file /etc/nginx/nginx.conf test is successful

[email protected]:~$ sudo systemctl restart nginx && sudo systemctl status nginx | head -n5

● nginx.service - A high performance web server and a reverse proxy server

Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)

Active: active (running) since Mon 2019-03-04 12:19:27 MSK; 34ms ago

Docs: man:nginx(8)

Process: 29084 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)

[email protected]:~$

 

Работает! Итого я для себя разобрал, как использовать инструмент oxidized на Ubuntu 18.04 Server amd64 для создания резервных копий с оборудования Mikrotik и просмотра внесенных изменений через Web-интерфейс с применением системы контроля версий на базе GIT. Жалко что нельзя использовать Mercurial — мне данная система контроля версий ближе, у меня все на ней построено: скрипты, конфигурационные файлы и т. д. А пока на этом у меня всё, с уважением автор блога Олло Александр aka ekzorchik.

Автоматический BackUP конфигов Mikrotik по SSH+FTP

Итак, у вас в компании есть много филиалов, где в качестве роутера используется Mikrotik. И вот нежданно-негаданно происходит казус — с роутером чтото случилось (пожар, потоп, скачек напруги, молния, админ идиот и тп), и просят подготовить новый. Бывало такое? И что мы делаем в таком случае? …. судорожно пытаемся вспомнить «А че ж там было настроено, а какой там провайдер … а как же узнать настройки» ну и еще много вопросов 🙂
Немного ознакомившись с админкой Mikrotik (с той его частью что доступна по ssh), я понял, что очень многое, если не все!, можно настраивать через ssh, не применяя web интерфейс либо winbox. А раз так, то это дает нам возможность автоматизировать действия по настройке и бекапу Mikrotik роутеров.
Вот роясь в своих древних скриптах, нашел «заготовку» для автоматизации бекапов большого количества однотипных устройств доступных по ssh.
Немного подправил, потестил и предлагаю Вам вот такой скриптик на perl для автоматического полного бекапа настроек Mikrotik.

#!/usr/bin/perl -w

#use strict;
use warnings;
use Net::Ping;
use Net::SSH::Expect;

my @routers = qw(10.100.100.1 10.100.150.1 10.100.200.1);

my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);
$year += 1900;
my @abbr = qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec);
my $now_date = "$mday-$abbr[$mon]-$year";

foreach my $router (@routers)
{
 my $p = Net::Ping->new("tcp", 2);
  $p->port_number(scalar(getservbyname("ssh", "tcp")));
        if ( $p->ping( "$router" ) )
           {
            print "Router $router is UP!\n";
#            print " - SSH OK! Trying to connect ...\n";
               my $ssh = Net::SSH::Expect->new (
                   host => "$router",
                   password => 'Mikrotik_Passwkrd',
                   user => 'Mikrotik_Admin',
                   raw_pty => 1,
                   no_terminal => 1,
                   debug => 1,
                   );
                    my $login_output = $ssh->login();
                    my $name = $ssh->exec("system identity print");
                    $name =~ s%\s*$%%g;
                    $name =~ s%\s*name:\ %%g;
                    my $backup_name = "$name\_$now_date";
                        print "Backing UP . ...\n";
                        $ssh->exec("system backup save name=$backup_name");
                        print "Upload backupfile over FTP\n";
                        $ssh->exec("tool fetch address=10.250.100.200 src-path=$backup_name\.backup user=for_backup mode=ftp password=FTP_Password dst-path=/for_backup/mikrotiks/$backup_name upload=yes");
                        print "Deleting backup ....\n";
                        $ssh->exec("file print ; file remove $backup_name\.backup ;");
                 $ssh->close();
           }
        else
           {
            print "Router $router is Down!\n";
           }
}

Извините за мой «французский», но perl я сколько не пытаюсь изучить, все времени нехватает … такчто уж простите корявость написания. Исправления и замечания приветствуются!
Итак, что делает данный скрипт:
В цикле проверяет «живость» конкретного роутера из списка роутеров
если жив

  • пробуем соединиться по ssh
  • получаем имя устройства
  • делаем бекап
  • сливаем бекап по FTP
  • удаляем бекап
  • выходим
  • Опробовано, работает!
    Итак, случись что с неким микротиком, конфиг которого сбекапился, нам достаточно подлить готовый бекап на новый девайс и отдать на отправку 🙂
    Enjoy

    Mikrotik auto before reset backup

    Разбор множества мелких, относительно связанных между собой, тем: программный и аппаратный сброс настроек, функция Protected RouterBoot, бекапы и экспорт конфигурации, разбивка flash памяти на разделы.

    Программный сброс настроек

    Если есть доступ к роутеру от пользователя с full правами, то можно сбросить все настройки через [System] → [Reset Configuration]

    • Keep user setting — не удалять учетные записи пользователей.
    • CAPS mode — после сброса искать контроллер CAPsMAN.
    • No Default Configuration — не создавать дефолтную конфигурацию после сброса.
    • Do Not backup — не создавать бекап перед сбросом. Если не отметить, то созданный бекап не будет запаролен.
    • Run After Reset — скрипт, который будет выполнен после сброса и перезагрузки роутера.
    • Во время сброса содержимое flash памяти не затирается.

    Аппаратный сброс настроек

    Все зависит от модели роутера, возможно три варианта:

    Присутствует кнопка reset

    Для начала отключаем питание, зажимаем reset и включаем питание. Отпускаем через:

    • 3 секунды(до мигания ACT) — загрузка с запасного бутлоадера. Помогает если произошел сбой при обновлении системы либо firmware.
    • 5 секунд(ACT мигает) — сброс настроек.
    • 10 секунд(ACT перестает мигать) — поиск контроллера CAPsMAN.
    • 15 секунд(ACT не горит) — поиск сервера netinstall.

    Контактная площадка

    На wiki утверждают, что все девайсы оснащены подобной площадкой. Ради интереса вскрыл RB491-2nD и не обнаружил таковой.

    Технология сброса: отключаем питание, замыкаем площадку(бипер издает хрипящий писк) и не отпускаем до полной загрузки.

    Перемычка

    Присутствует на старых моделях.

    Технология сброса: отключаем питание, замыкаем перемычку, ждем полной загрузки, убираем перемычку.

    Protected RouterBoot

    Может случится ситуация, когда после сброса чужого(иначе вы бы знали) роутера он не будет загружаться дальше «первого пика» — это новая фитча от Mikrotik затирающая всю флеш память( включая RouterOS), для восстановления потребуется netinstall.

    Про RouterBoot

    RouterBoot — начальный загрузчик на девайсах Mikrotik, с ним можно взаимодействовать через Serial интерфейс и одно из предназначений Protected RouterBoot не давать вмешиваться в процесс загрузки.

    Загрузчик разделен на две части:

    • Recovery — поставляется вместе с девайсом и совпадает с Factory Firmware.
    • Current — поставляется с пакетом system, но обновляется отдельно.

    Посмотреть текущие версии можно в [System] → [RouterBoard]. Кнопкой [Upgrade] производится обновление Current загрузчика. Если система работает плохо и загружается только с резервного(как написано разделом выше), то в [Settings] можно явно указать recovery загрузчик в качестве постоянного, опция Auto Upgrade для обновления current загрузчика вместе с RouterOS. И раз мы тут — опция Silent Boot отключает звуки во время загрузки.

    Даунгрейд до Bugfix и спец. версия загрузчика

    На форуме и wiki предупреждают, что все эксперементально и делается на ваш страх и риск. Читайте тему , там есть список моделей и файлов обновлений, я напишу на примере RB951G.
    Ошибка выглядит так:

    Загружаем отсюда , пакет *.dpk для своей архитектуры.

    Копируйте на устройство, если у вас bugfix ветка то достаточно перезагрузиться, если нет читаем дальше.

    Откат прошивки. Вариант 1:

    [System] → [Packages] → [Check for updates]
    Channel: Bugfix Only
    нажимаем [Download and Install]
    Консольный вариант:

    Откат прошивки. Вариант 2:

    Загружаем необходимую версию(6.40.8 на данный момент) RouterOS из архива , распаковываем и копируем на MikroTik необходимые пакеты.

    Далее: [System] → [Packages] → [Downgrade]

    [System] → [RouterBoard] → [Settings]

    Включаем Protected RouterBoot=yes, что теперь.

    • Взаимодействие с RouterBoot на этапе загрузки будет невозможно.
    • Кнопка Reset будет работать в единственном режиме — затирать flash память. Опции reformat-hold-button и reformat-hold-button-max определяют минимальное и максимальное значение время удержания кнопки Reset. Необходимо попасть в установленный промежуток. Форматирование памяти может занимать до 5 минут.
    • Etherboot не будет работать.
    • Сброс через замыкания контактов на плате не будет работать.

    Я не призываю вас включать эту опцию в обязательном порядке, думайте сами когда оно вам надо, а когда можно обойтись без подобных мер.

    Восстановление прошивки средствами netinstall

    Netinstall — универсальный инструмент для прошивки и предварительной настройки роутеров MikroTik. При использовании происходит ворматирование внутренней памяти и конфигурации, без изменения останутся только настройки в [System] → [RouterBOARD]

    Доступен только для ОС Windows по ссылке . Конфликтует с некоторыми фаерволами и антивирусами(добавлять в исключения), могут быть проблемы при запуске от пользователей с ограниченными правами — запускаем «От администратора».

    Порядок действий

    • Потребуются файлы прошивки отсюда. можете брать целиковый main, либо распаковать необходимые пакеты из extra, обязателен только пакет system.
    • Проводное соединение с роутером. Причем ПК и роутер должны находиться в пределах одного сегмента сети, лучше соединять кабелем напрямую.
    • Рекомендуют отключить на ПК все лишние сетевые интерфейсы. На практике — проблем с этим обычно не возникает.
    • Установить на проводном интерфейсе к которому подключен роутер статический ip, например: 192.168.100.1/24.
    • Если на Mikrotik присутствует порт с надписью Boot, то подключаетесь к нему, если нет — к первому порту.
    • Запускаем Netinstall, в [Net Booting] необходимо включить Boot Server Enabled и указать ip из выбранной ранее подсети, например: 192.168.100.10.
    • Отключаем питание MikroTik, зажимаем Reset и ждем 15 секунд(пока роутер не появится в Netinstall). Если кнопка Reset отсутствует, то замыкаем контактную площадку либо перемычку.
    • В [Browse] выбираем каталог с необходимыми файлами RouterOS, отмечаем необходимые.
    • Нажимаем [install].

    На что еще способен netinstall

    • Key — можно обновить лицензию. SoftID необходим для заказа ключа.
    • Keep old configuration — сохранить конфигурацию и восстановить ее после прошивки.
    • IP address/Netmask & gateway — настроить ip.
    • Baud rate — установть скорость Serial интерфейса.
    • Configure script — скрипт, который будет запущен после пошивки.
    • Apply default config — загрузить конфигурацию по умолчанию. Работает если предыдущие три пункта не установлены.
    • Flashfig — утилита для массовой настройки новых девайсов, подробнее тут.

    Бекап и экспорт конфигурации в Mikrotik

    Бинарный бекап

    • Включает в себя практически полную(не переносятся файлы, сертификаты и ключи ipsec) копию настроек RouterOS.
    • Шифрованию в бекапах подвергаются только системные учетные записи.
    • Не редактируется.
    • Восстановление затирает текущую конфигурацию.
    • Желательно восстанавливать на аналогичную модель Mikrotik.
    • Возможно восстановить на отличных от оригинального моделях. Но в бинарном бекапе настройки интерфейсов привязываются к внутреннему id и при восстановлении реальные и системные номера портов ethernet будут перепутаны. Если на новом девайсе не хватает физических интерфейсов — настройки восстановятся, но будут ссылаться на unknown.

    Name — имя файла. по умолчанию будет —
    Password — пароль. По умолчанию используется пароль текущего пользователя.
    Don’t encrypt — не шифровать бекап.

    [Files] → [Подсветить необходимый файл] → [Restore]

    • www.mikrotikpasswordrecovery.net — сервис извлечения системных учетных записей из не шифрованных backup.
    • github.com/BigNerd95/RouterOS-Backup-Tools — неофициальный скрипт для частичной распаковки backup.

    Экспорт и импорт конфигурации

    • Не включает настройки системных пользователей. Клик.
    • Можно сохранить(export) и загружать(import) только из консоли.
    • Возможно скопировать как целиковый конфиг, так и часть.
    • Не шифруется.
    • Можно редактировать.
    • Во время загрузки(import) конфигурации текущая затерта не будет.
    • Можно восстанавливать на любую модель, путаницы в интерфейсах не будет, но если интерфейсов не будет хватать соответствующие настройки не восстановятся.
    • В последних обновлениях RouterOS починили восстановление Scripts и Schedulers. Теперь они восстанавливаются без ошибок с указанными пользователями, сами пользователи созданы не будут.
    • compact — только отличия от дефолтной конфигурации. По умолчанию в RouterOS 6. Конфликтут с verbose.
    • verbose — наиболее полная конфигурация. По умолчанию в RouterOS 5. Конфликтует с compact.
    • hide-sensitive — не экспортировать пароли, ключи и пр.
    • terse — не разрывать строки.

    export не сохраняет конфигурацию в файл, если явно не задать ключ file= расширение rsc будет добавлено автоматически.

    DualBoot в Mikrotik(Partition)

    Flash накопитель можно разбить на несколько разделов и установить несколько копий RouterOS(в том числе различных). В случае неудачной загрузки с основного раздела будет загружаться следующий указанный. Функция доступна на девайсах с MIPS, PowerPC и CCR серии.

    Разбивка на разделы:

    Необходимо указать итоговое число разделов. Есть два ограничения: максимальное число разделов — 8 и минимальный размер раздела: 32MB on MIPS; 40MB on PowerPC; 48MB on CCR.

    Новый раздел будет пустым, необходимо скопировать на него текущую прошивку через [Copy to].

    В консоли лучше видны свойства разделов: Активный(A) — с которого будет произведена следующая загрузка и раздел с которого была загружена система®.

    Смена активного раздела происходит в его свойствах кнопкой [Activate]. Опция Fallback to отвечает за выбор раздела, если загрузка не удалась.

    [Save Config To] — Сохранить конфигурацию с текущего® раздела на выбранный.
    [Restore Config From] — Сохранить конфигурацию с выбранного раздела на текущий®.

    Функционал интересный, но имеет два недостатка: Не все роутеры комплектуются достаточным количеством flash памяти. Сбои в RouterOS, даже при обновлении, не такое частое явление.

    Что бы сохранить конфигурацию MikroTik существует несколько способов и сейчас мы их рассмотрим:

    1. Самый простой способ, это воспользоваться утилитой WinBox.

    Для этого откроем меню Files и нажмем Backup.

    В поле Name пишем название нашей резервной копии, при желании можем зашифровать введя пароль в поле Password, если пароль не требуется, ставим галочку Don’t Encrypt и нажимаем на кнопку Backup. После этого в списке файлов появится наша резервная копия. Что бы сохранить резервную копию к себе на компьютер, перетащите файл мышкой к себе на локальный диск.

    Что бы восстановить резервную копию, выбираем файл и нажимаем Restore.

    Перед восстановлением сбросьте все настройки через меню System -> Reset Configuration.

    2. Сохранение резервной копии через терминал.

    Зайдите в терминал через меню New Terminal и введите команду:

    system backup save name=Backup_term (имя можно придумать любое)

    После чего появится надпись:

    Saving system configuration
    Configuration backup saved

    и в списке файлов будет наша резервная копия

    Что бы восстановить резервную копию, введите команду:

    system backup load name=Backup_term

    Настройки будут восстановлены из файла Backup_term

    3. Сохранение настроек в текстовом формате.

    Настройки вашего устройства можно сохранить так же и в текстовом формате. Это удобно если требуется сравнить 2 конфигурации или изменить какие то настройки.

    Что бы сохранить настройки в текстовом формате зайдите в New Terminal и введите команду:

    После выполнения команды появится в файлах сохраненная наша конфигурация

    Что бы восстановить конфигурацию, введите команду:

    Иногда встречаются ситуации, когда требуется сохранить только часть настроек, например настройки dhcp сервера, правила и тд, для этого существуют следующие команды:

    Операционная система RouterOS позволяет сохранить настройки MikroTik, и быстро восстановить резервную копию, чтобы возобновить работу устройства. Это очень удобно, если вы напортачили с настройками, или вам нужно выполнить одинаковую настройку нескольких устройств MikroTik. В этой статье мы расскажем, как создать резервную копию настроек MikroTik, восстановить ее или перенести на другое устройство.

    Сохранение и восстановление настроек MikroTik

    Чтобы сохранить настройки MikroTik, выполните следующее:

    1. Откройте в программе Winbox меню Files.
    2. Нажмите кнопку Backup.
    3. Во всплывающем окне нажмите кнопку Backup.
      При желании можете указать в поле Name имя файла и пароль в поле Password.
      По умолчанию файлы бэкапов шифруются, чтобы злоумышленники не смогли извлечь из них пароли, например, к Wi-Fi. Галочка Don’t encrypt позволяет отключить шифрование файла с резервными настройками.

    После этого в списке появится файл с именем MikroTik-xxxxxxxx-xxxx.backup , где ххххххxx-хххх – это дата и время создания файла.

    Далее резервную копию конфигурации MikroTik можно сохранить на компьютер, перетащив файл на рабочий стол или в проводник Windows.

    Перед восстановлением настроек, нужно сбросить все настройки устройства, чтобы в нем не остались какие-то настройки из текущей конфигурации.

    1. Откройте меню System – Reset Configuration.
    2. Поставьте галочку No Default Configuration.
    3. Нажмите кнопку Reset Configuration.
    4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

    После перезагрузки подключайтесь к устройству по MAC адресу, поскольку IP адрес будет отсутствовать. В программе Winbox нужно нажать мышкой на MAC-адрес устройства и нажать кнопку Connect.

    Чтобы восстановить конфигурацию MikroTik, выполните следующее:

    1. Откройте меню Files.
    2. Выберите файл с резервной копией.
    3. Нажмите кнопку Restore.
    4. В появившемся окне нажмите кнопку Restore.
      Если вы делали бэкап с паролем, то введите пароль в поле Password.
    5. В всплывающем окне нажмите Yes для восстановления конфигурации и перезагрузки устройства.

    Перенос настроек MikroTik на другое устройство

    Для переноса настроек на другое устройство MikroTik, нужно сохранить настройки в файл в текстовом виде. Этот файл можно будет редактировать, если возникнут проблемы при переносе настроек.

    Переносить настройки можно только на устройства MikroTik со схожей аппаратной конфигурацией. Вы не сможете перенести настройки с роутера на 10 LAN портов, на роутер с 5-ю LAN портами. При этом будут выдаваться ошибки. Можно конечно вручную отредактировать файл с настройками, но это довольно сложный и долгий процесс.

    Чтобы сохранить настройки MikroTik в текстовом формате, откройте меню New Terminal и выполните следующую команду:

    Название файла может быть любым. В названии файла желательно указывать дату, чтобы потом не запутаться. В данном случае в названии файла указана дата 20170403 – 3 апреля 2017 года. Файлы с датой, указанной таким образом, будет очень удобно сортировать по имени в проводнике или в файловом менеджере Total Commander, FAR Manager или MC (Linux).

    Далее нужно скопировать созданный файл в другое устройство. Для этого сначала перетащите файл на рабочий стол Windows. После этого перетащите его в новое устройство в меню Files.

    Перед импортированием настроек, нужно сбросить конфигурацию устройства, иначе будет конфликт с текущими настройками и при импорте будут выдаваться ошибки.

    1. Откройте меню System – Reset Configuration.
    2. Поставьте галочку No Default Configuration.
    3. Нажмите кнопку Reset Configuration.
    4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

    Чтобы импортировать настройки MikroTik, откройте меню New Terminal и выполните следующую команду:

    При переносе настроек между похожими роутерами MikroTik с одинаковым количеством портов, но с разными процессорами или памятью, во время импорта могут возникать ошибки. Я как-то пытался перенести настройки между двумя очень схожими роутерами. При этом выдавало ошибку, что указанная частота памяти не поддерживается устройством. В этом случае откройте файл с настройками на компьютере, отредактируйте необходимую настройку или удалите ее.

    Частичный перенос настроек

    Бывают ситуации, когда нужно сохранить часть настроек, например, правила фаервола, скрипты, NAT, правила маркировки пакетов и т.п. Для этого помогут следующие команды:

    Автоматическое создание резервных настроек MikroTik и отправка на email

    Чтобы не забывать делать резервные копии конфигурации MikroTik, вы можете автоматизировать этот процесс и отправлять бэкапы себе на email.

    Создание скрипта

    Откройте меню System – Scripts и нажмите "красный плюсик", чтобы добавить новый скрипт. В поле Name укажите название скрипта, в поле Source вставьте скрипт и нажмите кнопку OK.

    Чтобы протестировать работу скрипта, нажмите кнопку Run Script, и на ваш почтовый ящик будут высланы резервные копии. Процесс выполнения скрипта можно отслеживать в меню Log.

    Скрипт для отправки резервной копии настроек MikroTik на email:

    Для RouterOS v6.x

    В примере указан скрипт для сервиса Gmail. При отправке через Gmail нужно предварительно разрешить ненадежным приложениям доступ к аккаунту. Для этого залогиньтесь, на странице "Мой аккаунт" перейдите в раздел "Ненадежные приложения" и выберите "Включить". Подробнее читайте Как разрешить ненадежным приложениям доступ к аккаунту.

    Чтобы использовать сервис Рамблер Почта, замените в скрипте smtp.gmail.com на mail.rambler.ru. Чтобы использовать сервис Яндекс Почта, замените в скрипте smtp.gmail.com на smtp.yandex.ru. Также не забудьте изменить значения [email protected] и your_gmail_password на свои.

    Настройка планировщика

    Теперь нужно настроить с какой периодичностью будут создаваться резервные копии, и отправляться на email. Для этого настроим планировщик (Sheduler).

    Откройте меню SystemSheduler и нажмите кнопку "плюсик", чтобы добавить новую задачу.

    В открывшемся окне настраиваем параметры задачи:

    • в поле Name указываем имя задачи, например send_backup_to_email;
    • в поле Interval указываем с какой периодичностью будет выполняться скрипт. Мы указали интервал 24 часа. Для отладки работы планировщика укажите интервал 5 минут и текущее время Start Time. И не забудьте настроить время на MikroTik в меню System – Clock;
    • в поле On Event указываем, какую команду необходимо выполнить при запуске задачи. Мы указали команду /system script run backup_to_email, которая запускает скрипт backup_to_email;
    • нажимаем кнопку OK для сохранения задачи.

    Теперь каждый день в 00:00:00 будет создаваться резервная конфигурация MikroTik и отправляться вам на email.

    Полезные скрипты для mikrotik RouterOS

    16.09.2014 - 22:43

    Делаем бекап конфигов микрота и отправляем на удаленный FTP сервер:

    {
    local username "никнейм"
    #ftp account
    local ftphost "имя сервера"
    local ftpuser "логин"
    local ftppassword "пароль"
    local ftppath "/pub/mikrotik"

    #create full system backup files
    /system backup save name="$username.backup"
    :delay 30s;

    #create config export files
    /export compact file="$username.rsc"
    :delay 30s;

    # upload the system backup
    :log info message="Uploading system backup"
    /tool fetch address="$ftphost" src-path="$username.backup" user="$ftpuser" mode=ftp password="$ftppassword" dst-path="$ftppath/$username.backup" upload=yes
    :delay 30s;

    # upload the config export
    :log info message="Uploading config export"
    /tool fetch address="$ftphost" src-path="$username.rsc" user="$ftpuser" mode=ftp password="$ftppassword" dst-path="$ftppath/$username. rsc" upload=yes
    :delay 30s;

    # find file name $username- then remove
    :foreach i in=[/file find] do={ :if ([:typeof [:find [/file get $i name] "$username"]]!="nil") do={/file remove $i}; }
    :log info message="Configuration backup finished.";
    }

    Бекап по частям
    Микротик1 (экспорт):

    ip firewall  export file=ip-firewall.rsc
    ip pool export file=ip-pool.rsc
    ip route export file=ip-route.rsc

    Микротик2 (импорт):

    import file=ip-firewall.rsc
    import file=ip-pool.rsc
    import file=ip-route.rsc

    Добавляем автоматически 254 маршрута:

    for x from=1 to=254 do={ /ip route add dst-address="192.168.$x.0/24" gateway=192.168.201.10 }

    Указываем мост одной командой для всех интерфейсов:

    >interface bridge port add interface=ether1 bridge=bridge-local; ip address set 0 interface=bridge-local; ip dhcp-server set 0 interface=bridge-local

    Меняем MAC на интерфейсе на свой:

    /interface ethernet set ether1 mac-address=00:01:00:00:00:00

    Проверяем шлюз провайдера, если он отличается от статического - синхронизируем:

    :global ispgw [ip dhcp-client get [/ip dhcp-client find interface=ether1-gateway] gateway ];
    :global ispgwstat [ip route get  [/ip route find comment="ISP1" ] gateway  ];

    #:log info ("$ispgw" )
    #:log info ("$ispgwstat" )

    :if ($ispgw = $ispgwstat ) do={ :log info ("ISP GW OK" ) } else={ ip route set [/ip route find comment="ISP1"] gateway=$ispgw;  :log info ("ISP GW COMPLETE" )}

    Если через PPPOE соединение некоторые сайты не открываются.
    Необходимо сделать изменения в Firewall > Mangle.
    Удалить динамические правила change MSS all ppp.
    Добавить правило:

    /ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

    Изменить профиль, что бы динамические правила больше не создавались:

    PPP > Prifiles > Default > General > Change TCP MSS “no”

    Локальное перенаправление портов:

    /ip firewall nat
    add action=dst-nat chain=dstnat dst-address=192.168.224.1 dst-port=8181 \
        in-interface=bridge-local protocol=tcp src-address=192.168.224.0/24 \
        to-addresses=192.168.224.20 to-ports=8080
    add action=dst-nat chain=dstnat dst-address=192.168.224.1 dst-port=8182 \
        in-interface=bridge-local protocol=tcp src-address=192.168.224.0/24 \
        to-addresses=192.168.224.20 to-ports=555
    add action=src-nat chain=srcnat dst-address=192.168.224.20 dst-port=8080 \
        out-interface=bridge-local protocol=tcp src-address=192. 168.224.0/24 \
        to-addresses=192.168.224.1 to-ports=8181
    add action=src-nat chain=srcnat dst-address=192.168.224.20 dst-port=555 \
        out-interface=bridge-local protocol=tcp src-address=192.168.224.0/24 \
        to-addresses=192.168.224.1 to-ports=8182

    Прикручиваем клиент DDNS сервиса no-ip.org #2

    ##############Script Settings##################

    :local NOIPUser "логин_ноип"
    :local NOIPPass "пароль_ноип"
    :local WANInter "интерфейс_в_инет"

    ###############################################

    :local NOIPDomain "домен_ноип"
    :local IpCurrent [/ip address get [find interface=$WANInter] address];
    :for i from=( [:len $IpCurrent] - 1) to=0 do={
      :if ( [:pick $IpCurrent $i] = "/") do={
        :local NewIP [:pick $IpCurrent 0 $i];
        :if ([:resolve $NOIPDomain] != $NewIP) do={
          /tool fetch mode=http user=$NOIPUser password=$NOIPPass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$NOIPDomain&myip=$NewIP" keep-result=no
          :log info "NO-IP Update: $NOIPDomain - $NewIP"
         }
       }
    }

    Дописать текст в файл:

    :local ts [/system clock get time]
    :set ts ([:pick $ts 0 2]. [:pick $ts 3 5].[:pick $ts 6 8])

    :local ds [/system clock get date]
    :set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])

    :local ContentsFile [/file get isp-stat.txt contents];
    /file set isp-stat.txt contents="$ContentsFile\nISP DOWN-$ds-$ts"

    Проверка средней скорости интернет и запись в log файл:

    :local txAvg 0
    :local rxAvg 0

    :local ts [/system clock get time]
    :set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8])

    :local ds [/system clock get date]
    :set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])

    tool bandwidth-test protocol=tcp direction=transmit address=ip_bandsw_test_server duration=5s do={
    :set txAvg ($"tx-total-average" / 1048576 );
    }

    tool bandwidth-test protocol=tcp direction=receive address=ip_bandsw_test_server duration=5s do={
    :set rxAvg ($"rx-total-average" / 1048576 );
    }

    :local ContentsFile [/file get isp-quality.txt contents];
    /file set isp-quality. txt contents="$ContentsFile\n$ds-$ts tx: $txAvg Mbps - rx: $rxAvg Mbps"

    Цвет лога:

    log info "blah blah this log is in black"
    log warning "blah blah this log is in blue"
    log error "blah blah this log is in red"

    Проверка баланса, оператор Life (автор AHouse):

    /tool sms set receive-enabled=yes
    /tool sms inbox remove [/tool sms inbox find phone="5433"]
    /log info "Get current ballance"
    /tool sms send usb5 phone-number=5016 message="CHECKBALANCE"
    #ждем смску сбаллансом
    /log info "Delay 60s..."
    :delay 60s
    /log info "Searching Ballance message..."
    :local SMSGateBallance [ :pick [/tool sms inbox get value-name=message number=[/tool sms inbox find phone="5433"]] 0 15 ]
    #/log info $SMSGateBallance
    :if ([:len $SMSGateBallance] >1) do={ /log info $SMSGateBallance } else={ /log info "Ballance SMS not found !!!" }

    Скрипт проверяет смену IP домена DDNS и меняет IP в поле "Host:" NetWatch

    :global dnshostname "alik. no-ip.org"

    :global currentip [:resolve $dnshostname]
    :log info "Current loopback ip alik: ($currentip)"

    :global oldip [/tool netwatch get [/tool netwatch find comment="alik"] host]
    :log info "Old loopback ip alik: ($oldip)"

    :if ($currentip = $oldip ) do={ :log info ("Alik NW OK" ) } else={ /tool netwatch set [/tool netwatch find comment="alik"] host=$currentip; :log info ("Alik NW COMPLETE" )}

    Сброс повисших сессий на порту 5060:

    :foreach i in=[/ip firewall connection find dst-address~":5060" protocol~"udp"] do={ /ip firewall connection remove $i }

    или

    :local pingcount 5;
    :local hostping 8.8.8.8;
    :local pingresultA [/ping $hostping count=$pingcount];
    :if ($pingresultA > 0) do={:put "connect"} else= { :foreach i in=[/ip firewall connection find dst-address~":5060" protocol~"udp"] do={ /ip firewall connection remove $i } }

    Как перенести настройки MikroTik | Копирование настроек

    Часто можно встретить задачу, когда:

    • конфигурацию с маршрутизатора(роутера) MikroTik нужно перенести на другое устройство в связи с заменой;
    • происходит настройка нескольких аналогичных устройств MikroTik.

    И во всех этих задачах было бы рациональным использовать метод переноса конфигурации. Он будет состоять из двух этапов:

    1. Выгрузка конфигурации с устройства источника MikroTik-1;
    2. Загрузка конфигурации в устройство назначение MikroTik-2.

    Методы переноса настроек между устройствами MikroTik

    Действия со стороны устройства источника(MikroTik-1)

    Для переноса конфигурации между маршрутизаторами(роутерами), коммутаторами(свитчами) или точками доступа WiFi MikroTik можно воспользоваться двумя распространенными методами:

    С иcпользованием файла BACKUP

    /system backup save name=Backup-File

    С использование скрипт файла

    /export file=Backup-Script.rsc

    Оба файла будут созданы во внутренней памяти устройства. Но какая разница между этими методами? При создании скриптового файла, его можно изменить перед применением. Это позволит:

    • Установить другой IP адрес на интерфейс;
    • Изменить MAC адрес;
    • Параметры DHCP сервера;
    • другие настройки.

    Действие со стороны устройства приемника(MikroTik-2)

    Метод переноса настроек посредством Backup подходит только для оборудования одной модели.

    Импорт файла типа Backup

    Данный файл необходимо перенести во внутреннюю память устройства, а затем нажать кнопку “Restore” и указать backup файл.

    Устройство будет перезагружено, а перенесенная конфигурация применена.

    Применение скрипт файла

    Полученный файл читается через любой текстовый редактор. Конечную версию конфигурации нужно скопировать в буфер обмена(выделить текст и Ctrl+C) и вставить(Ctrl+V) в терминальное окно со стороны конечного устройства MikroTik.

    Пример копирования настроек MikroTik

    В качестве примера будут выступать два  маршрутизатора(роутера) MikroTik RB2011UiAS-2HnD-IN, которые после обновления сетевой инфраструктуры будут выполнять роль обычных коммутаторов(с точкой доступа). В качестве метода по переносу настроек между устройствами MikroTik будет выбран метод скрипта, который позволит предварительно подготовить конфигурацию в текстовом файле, для исключения дальнейшей донастройки коммутатора.

    Поддержи автора статьи, сделай клик по рекламе ↓↓↓

    Со стороны коммутатора MikroTik-1

    Будет выгружена конфигурация

    /export file=Backup-Script.rsc

    и скопирована на ПК для редактирования. Будут изменены такие настройки:

    • MAC адрес локального Bridge. Новый MAC адрес будет отличаться на +1 в адресе;
    • IP адрес Bridge.

    По разделам это такие блоки:

    /interface bridge
    add admin-mac=B2:F6:3B:C5:33:36 auto-mac=no name=Bridge-LAN
    /ip address
    add address=10. 224.1.9/24 interface=Bridge-LAN network=10.224.1.0

    Со стороны коммутатора MikroTik-2

    Подготовленный скрипт необходимо скопировать во внутреннюю память устройства. А следующий шаг произведет одновременно два действия:

    • Процедуру “Reset“;
    • Выполнение скрипта после сброса.

    Настройка находится System→Reset Configuration

    И после перезагрузки останется только установить пароль для администратора устройства, который в таком виде(не зашифрованном) не переносится.

    ЕСЛИ конфигурация в виде скрипта не загрузилась после перезагрузки нужно:

    1. Открыть файл Backup-Script.rsc в любом текстовом редакторе и скопировать весь текст;
    2. Открыть окно терминала Winbox-а(Terminal), вставить и выполнить скопированные команды.

    Перенос настроек в MikroTik с ошибкой

    Очень часто процедура копирования настроек между двумя роутерами MikroTik закачивается без успеха. Выводится ошибка или после перезагрузки роутер MikroTik попросту не работает.

    Для того, чтобы выяснить какая именно ошибка, подойдёт только метод с использованием файла типа RSC. На моменте, где будет возникать ошибка будет происходить остановка выполнения срипта.

    Частые ошибки при копировании настроек в MikroTik

    1. Разные прошивки;
    2. У MikroTik-1 есть модуль WiFi на 5ГГц, а у MikroTik-2 он отсутствует;
    3. У MikroTik-1 есть порт SFP, а у MikroTik-2 он отсутствует;
    4. Разное количество портов.

    Есть вопросы или предложения по копированию настроек в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий

    MikroTik Backup and Restore Configuration с использованием Winbox

    Функция

    Backup and Restore в MikroTik Router помогает восстановить конфигурацию маршрутизатора, когда работающий маршрутизатор не работает из-за сбоя оборудования. Если у вас есть резервная копия неисправного маршрутизатора и вы покупаете новый маршрутизатор MikroTik, а затем загружаете и восстанавливаете этот файл резервной копии, вы получите работающую сеть без каких-либо проблем. Файл резервной копии MikroTik также полезен, если вы, к сожалению, забыли пароль администратора с правами администратора.Вы можете легко восстановить забытый пароль с помощью файла резервной копии, используя инструменты восстановления пароля MikroTik. Таким образом, регулярное резервное копирование запущенной конфигурации MikroTik очень полезно для сетевого администратора. Как сделать резервную копию файла конфигурации MikroTik автоматически по электронной почте, обсуждалось в моей предыдущей статье, и в этой статье я покажу, как сделать резервную копию и восстановить файл конфигурации MikroTik вручную с помощью Winbox.

    Как сделать резервную копию файла конфигурации MikroTik

    Создать резервную копию конфигурации MikroTik с помощью графического интерфейса Winbox легко, но вы можете использовать веб-интерфейс WebFig, который следует той же процедуре, что и Winbox. Следующие шаги покажут, как сделать резервную копию файла конфигурации MikroTik с помощью графического интерфейса Winbox.

    • Войдите в свой маршрутизатор MikroTik, используя Winbox с правами администратора.
    • Щелкните пункт меню «Файлы». Появится окно со списком файлов.
    • Нажмите кнопку «Резервное копирование». Появится окно резервного копирования.
    • Введите имя файла резервной копии (MikorTikBackup) в поле ввода Имя.
    • Вы можете дополнительно ввести пароль, если хотите, чтобы ваш файл конфигурации был защищен паролем с помощью шифрования в поле ввода пароля.
    • Установите флажок Не шифровать. Вы можете не устанавливать этот флажок, если хотите сохранить файл конфигурации в зашифрованном виде, но если вы хотите использовать этот файл резервной копии для восстановления пароля, вы должны установить этот флажок, иначе инструмент восстановления пароля не сможет восстановить пароль пользователя из зашифрованного файла резервной копии.
    • Нажмите кнопку «Резервное копирование».
    • Теперь вы найдете файл резервной копии (MikorTikBackup.backup) в окне списка файлов.
    • Перетащите этот файл резервной копии на свой компьютер.Ваш файл резервной копии будет загружен в желаемое место. Вы также можете использовать любой FTP-клиент (FileZilla), чтобы загрузить этот файл резервной копии на свой компьютер.

    Файл конфигурации резервного копирования MikroTik

    В качестве альтернативы вы можете запустить следующую команду из командной строки MikroTik для резервного копирования файла конфигурации MikroTik с помощью команды.

    [admin @ MikroTik]> имя сохранения резервной копии системы = MikroTikBackup dont-encrypt = yes Сохранение конфигурации системы

    Резервная копия конфигурации сохранена

    [admin @ MikroTik]>

    Как восстановить файл конфигурации MikroTik

    Вы можете легко восстановить MikroTik файл резервной копии с помощью графического интерфейса Winbox или веб-интерфейса WebFig.Следующие шаги покажут, как восстановить конфигурацию MikroTik из файла резервной копии с помощью графического интерфейса Winbox.

    • Войдите в свой маршрутизатор MikroTik, используя Winbox с правами администратора.
    • Щелкните пункт меню «Файлы». Появится окно со списком файлов.
    • Перетащите файл резервной копии с компьютера в окно со списком файлов. Вы также можете использовать любой FTP-клиент (FileZilla) для загрузки файла резервной копии в окно списка файлов MikroTik.
    • Нажмите кнопку «Восстановить». Появится окно восстановления.
    • Выберите загруженный файл резервной копии из раскрывающегося меню «Файл резервной копии».
    • Введите пароль к файлу, если вы указали его во время резервного копирования в поле ввода пароля.
    • Нажмите кнопку «Восстановить». Вы увидите окно подтверждения для восстановления и перезагрузки маршрутизатора. Нажмите кнопку Да.
    • Теперь ваша резервная конфигурация будет успешно восстановлена, и ваш маршрутизатор будет перезагружен.

    В качестве альтернативы вы можете запустить следующую команду, чтобы восстановить загруженный файл конфигурации.

    admin @ MikroTik]> имя загрузки резервной копии системы = MikroTikBackuppassword:

    Восстановить и перезагрузить? [y / N]: y

    Восстановление конфигурации системы

    Конфигурация системы восстановлена, выполняется перезагрузка

    [admin @ MikroTik]>

    Если у вас возникли какие-либо затруднения относительно правильного выполнения вышеуказанных шагов, посмотрите мое видео о конфигурации резервного копирования и восстановления MikroTik используя Winbox. Я надеюсь, что это уменьшит ваше замешательство.

    Как сделать резервную копию и восстановить конфигурацию MikroTik с помощью Winbox обсуждалось в этой статье.Я надеюсь, что теперь вы сможете успешно выполнить резервное копирование и восстановление конфигурации MikroTik Router. Однако, если вы столкнетесь с какими-либо затруднениями при резервном копировании и восстановлении конфигурации маршрутизатора MikroTik, не стесняйтесь обсуждать в комментариях или свяжитесь со мной со страницы контактов. Я сделаю все возможное, чтобы остаться с тобой.

    розбак · PyPI

    Описание проекта

    Установка

     pip3 установить rosbak
     

    Что такое росбак

    rosbak - это инструмент командной строки Python, который позволяет создавать резервные копии Mikrotik RouterOS.
    маршрутизаторы и коммутаторы.

    Хранение файлов резервных копий внутри RouterOS обычно небезопасно, так как оборудование
    не получится, у вас нет к ним доступа.

    rosbak выполняет резервное копирование RouterOS и копирует файлы в указанное место.

    • RouterOS> = 6.45, поскольку rosbak использует scp
    • RouterOS ssh сервис должен быть включен
    • У вас должен быть доступ к хосту RouterOS

    Использование

     rosbak [параметры] <хост>
     

    e.грамм.

      rosbak -d / резервное копирование router1
      

    Конфигурация

    Вы можете поместить конфигурацию в /usr/local/etc/rosbak. yml

    Конфигурация содержит глобальную переменную dir , которая указывает на резервную копию по умолчанию
    местоположение (вы можете использовать параметр {host}, например, / backups / {host}, в этом случае резервные копии
    хранятся, например, к / резервные копии / router1 )

    Разделы хоста в файле конфигурации могут содержать IP-адрес маршрутизатора ( адрес ), порт,
    резервный задержка и т. д.

    Файл конфигурации не является обязательным.

    Почему задержка резервного копирования

    RouterOS выполняет резервное копирование в фоновом режиме. Параметр задержки резервного копирования требуется спросить
    rosbak ждать указанное количество секунд перед копированием резервной копии.

    Экспорт

    Параметр командной строки -x или экспорт: true в конфигурации хоста сообщает
    rosbak для выполнения экспорта конфигурации ( / файл экспорта = . .. )

    Экспорт конфигурации полезен, когда вам нужно частично восстановить резервную копию,
    копирование настроек вручную по одному (например,грамм. при восстановлении на другом
    модель).

    Авторские права и гарантия

    rosbak предоставляется "как есть" по лицензии MIT. rosbak - сторонний инструмент
    и не является аффилированным лицом SIA Mikrotīkls.

    Скачать файлы

    Загрузите файл для своей платформы. Если вы не уверены, что выбрать, узнайте больше об установке пакетов.

    Файлы для росбака, версия 0.0,1
    Имя файла, размер Тип файла Версия Python Дата загрузки Хеши
    Имя файла, размер

    rosbak-0. 0.1.tar.gz

    (3,4 кБ)

    Тип файла
    Источник
    Версия Python

    Никто

    Дата загрузки
    Хеши

    Вид

    ansible-mikrotik / mikrotik-backup-config.yml at master · wynandbooysen / ansible-mikrotik · GitHub

    ansible-mikrotik / mikrotik-backup-config.yml at master · wynandbooysen / ansible-mikrotik · GitHub

    Постоянная ссылка

    30 строк (26 слотов)

    1018 байт

    ---
    # Ansible Playbook для резервного копирования конфигурации устройства Mikrotik как в сценарий, так и в файл резервной копии
    # Версия 1 - 01. 07.2017
    #
    # ansible.cfg
    # [paramiko_connection]
    # pty = False
    #
    - имя: Mikrotik Backup Device Configuration
    хосты: mikrotik
    вар:
    ftpserver_var: speedtest.tele2.net
    ftpuser_var: аноним
    ftppass_var:
    соединение: paramiko
    пользователь: admin
    gather_facts: no
    задач:
    - имя: Выполнение резервного копирования Mikrotik в локальное хранилище
    raw: / system backup save name {{inventory_hostname}}
    - имя: Экспорт текущей конфигурации в текст
    необработанный: / export file = {{inventory_hostname}}
    - имя: FTP резервный файл
    raw: / tool fetch address = {{ftpserver_var}} src-path = {{inventory_hostname}}. backup user = {{ftpuser_var}} mode = ftp dst-path = / upload / {{inventory_hostname}}. backup upload = yes
    - имя: Конфигурация экспорта FTP
    raw: / tool fetch address = {{ftpserver_var}} src-path = {{inventory_hostname}}. Rsc user = {{ftpuser_var}} mode = ftp dst-path = / upload / {{inventory_hostname}}. Rsc upload = да

    Вы не можете выполнить это действие в настоящее время.Вы вошли в систему с другой вкладкой или окном. Перезагрузите, чтобы обновить сеанс.
    Вы вышли из системы на другой вкладке или в другом окне. Перезагрузите, чтобы обновить сеанс.

    Backup-cronjob для конфигурации Mikrotik RouterOS

    Для периодического резервного копирования конфигурации наших новых маршрутизаторов с Mikrotik RouterOS я хотел иметь задание cron: получить экспорт активной конфигурации, возможно даже резервную копию системы, хранить в резервной папке и хранить их в течение определенного периода хранения.

    В итоге я написал задание cron самостоятельно, в результате чего получился небольшой сценарий bash.

    Backup_RouterOS использует и требует доступа SSH к целевому маршрутизатору, а также SFTP. На самом устройстве нет никакого дополнительного расписания или сценариев, cronjob полностью работает удаленно. Чтобы улучшить ситуацию, сценарий bash может обрабатывать более одного маршрутизатора, сохраняя резервные копии в папках для каждого маршрутизатора и каждый день.

    Чтобы настроить сценарий резервного копирования, не стесняйтесь его скопировать:

    • создайте ключ SSH-DSS (без SSH-RSA!) В качестве пользователя, выполняющего резервное копирование:

      Указав нестандартное расположение, задание cron будет сложнее использовать, поэтому по возможности не меняйте.

    • скопируйте файл открытого ключа (id_dsa.pub) на маршрутизатор (ы), используя SFTP, FTP или даже перетащив его в Winbox. После этого импортируйте открытый ключ SSH пользователю RouterOS. Здесь это не рассматривается, потому что в вики MikroTik уже есть прекрасная статья:
      http://wiki.mikrotik.com/wiki/Use_SSH_to_execute_commands_%28DSA_key_login%29
    • Создайте собственно cronjob:
        #! / bin / bash
      СЕГОДНЯ = $ (/ bin / date +% Y-% m-% d)
      ЧАС = $ (/ bin / date +% H-00)
      КОМПАКТНЫЙ = $ (/ bin / date +% Y% m% d_% H% M)
      BASEDIR = "/ резервное копирование / микротик"
      ВРАЩАЕТСЯ = 7
      МАРШРУТИЗАТОРЫ = "1.2.3.4
      1.2.3.5 "
      ПОЛЬЗОВАТЕЛЬ = "админ"
      если ["$ 1" == "отладка"]; тогда
            установить -x
      фи
      для МАРШРУТИЗАТОРА в $ ROUTERS; делать
          mkdir -p $ BASEDIR / $ TODAY / $ ROUTER 2> / dev / null
          / bin / chmod 0750 $ BASEDIR;
        
          / usr / bin / ssh $ USER @ $ ROUTER "/ export file = export _ $ {COMPACT}" && \
              / usr / bin / scp -q $ USER @ $ ROUTER: / export _ $ {COMPACT} .rsc $ BASEDIR / $ TODAY / $ ROUTER / && \
              / usr / bin / ssh $ USER @ $ ROUTER "/ file remove export _ $ {COMPACT} .rsc"
        
          / usr / bin / ssh $ USER @ $ ROUTER "/ system backup save name = backup _ $ {COMPACT}" &> / dev / null && \
              спать 1 && \
              / usr / bin / scp -q $ USER @ $ ROUTER: / backup _ $ {COMPACT}. резервное копирование $ BASEDIR / $ TODAY / $ ROUTER / && \
              / usr / bin / ssh $ USER @ $ ROUTER "/ file удалить резервную копию _ $ {COMPACT} .backup"
        
          / usr / bin / find $ BASEDIR -mindepth 1 -maxdepth 1 -type d -mtime + $ ROTATES -exec rm -rf "{}" \;
      сделано
        

      Измените переменные для BASEDIR , ROTATES и USER . Параметр «МАРШРУТИЗАТОРЫ» представляет собой список целевых маршрутизаторов, разделенных пробелами (IP-адреса и имена хостов работают одновременно).

    • В настоящее время каждый маршрутизатор должен быть настроен для приема одного и того же имени входа с одним и тем же ключом SSH.
    • Как настроить сам cronjob также считается базовым знанием. Если вам неизвестна конфигурация, обратитесь к wikipedia 🙂

    . Как всегда, эта cronjob поставляется без каких-либо гарантий. Пожалуйста, протестируйте и не используйте в производстве до этого!

    Решено: NCM вводит мусор в конфигурацию резервного копирования MikroTik .

    ..

    Резервное копирование конфигураций - самая важная функция NCM, и ее преимущество - простота. Однако после настройки электронных писем различий я замечаю мусор

    В частности, '[m' и '[33m' и некоторые другие, похоже, вводятся в случайные области конфигурации, но затем исправляются.Генерация постоянных различий, когда на самом деле ничего не изменилось

    , т.е.

    добавить мост = "Клиентский мост PPPoE" горизонт = 10 интерфейс = sfp1

    add bridge = "Client PPPoE Bridge" горизонт = 10 interface = \

    add bridge = "Client PPPoE Bridge" горизонт = 10 [minterface = \

    «ether2.10 - клиент PPPoE»

    «ether2.10 - клиент PPPoE»

    добавить мост = «клиентский мост PPPoE» горизонт = 10 интерфейс = sfp1

    ....

    ....

    добавить адрес = 172. 17.6.60 идентификатор клиента = 1: 24: 18: 1d: 54: 6b: b9 mac-адрес = \

    добавить адрес = 172.17.6.60 client-id = 1: 24: 18: 1d: 54: 6b: b9 mac-address = \

    24: 18: 1D: 54: 6B: B9 server = [mXanDHCP

    24: 18: 1D: 54: 6B: B9 server = XanDHCP

    добавить адрес = 172.17.6.26 client-id = 1: 0: 4: 56: ea: 73: 7f mac-address = \

    добавить адрес = 172.17.6.26 client-id = 1: 0: 4: 56: ea: 73: 7f mac-address = \

    ....

    ....

    добавить сеть- type = broadcast passive = yes

    add network-type = broadcast passive = yes

    add dead-interval = 4s hello-interval = 1s interface [m = ether1 network-type = \

    добавить dead-interval = 4s hello-interval = 1s interface = ether1 network-type = [34; 1m \

    point-to-point retransmit-interval = 2s

    point-to -point retransmit-interval = 2s

    Это немедленно убивает NCM как продукт для нас, если нет простого решения, вся идея заключается в том, чтобы избавиться от этих маленьких головных болей, чтобы нам не нужно было создавать свои собственные платформы. Я ожидал, что резервное копирование mikrotik будет «просто работать», поскольку оно указано как официально поддерживаемое

    Кто-нибудь сталкивался с этим, и у кого-нибудь есть решение?

    Это происходит для множества наших маршрутизаторов, а не только для одного или двух, в частности.

    Кроме того, нам нужно, чтобы NCM игнорировал строки, начинающиеся с #, опять же, я решил, что это должно быть частью профиля «официально поддерживаемого» устройства. В верхней части экспорта конфигурации всегда указываются время и дата, они меняются каждый раз, когда выполняется резервное копирование, и, таким образом, генерируются различия, которые мне не нужны.Как указать символы, которые следует игнорировать?

    Как сделать резервную копию и восстановить настройки конфигурации Mikrotik

    by admin

    Как сделать резервную копию и восстановить настройки конфигурации Mikrotik

    Это движение Ops, когда вы настроили любую конфигурацию маршрутизатора и забыли пароль для входа, а также сделали не бэкап настроек. Когда вы выполняете сброс настроек маршрутизатора, вам нужна резервная копия настроек конфигурации, но сейчас вы ничего не можете сделать.Резервное копирование конфигурации является важной функцией в каждом маршрутизаторе или устройстве, чтобы сэкономить ваше время для следующей настройки. Если вы являетесь поставщиком интернет-услуг, вам может потребоваться настраивать маршрутизатор Mikrotik каждый раз, но если вы используете резервное копирование настроек, вы можете сэкономить 80% времени, используемого при ручной настройке. Всегда делайте резервную копию конфигурации для любого маршрутизатора или устройства, требующего настройки. В этом посте вы получите простое руководство по резервному копированию и восстановлению настроек MikroTik Router из Winbox.

    Резервное копирование конфигурации поможет вам сократить время простоя сети в случае отказа любого оборудования, на котором вам поможет резервное копирование конфигурации. Просто восстановите настройки резервного копирования и управляйте сетью без простоев и снова и снова борйтесь за настройку, меняя оборудование.

    Еще одним преимуществом резервного копирования конфигурации Mikrotik является то, что если, к сожалению, вы забыли настройки входа в систему на маршрутизаторе, вы можете быстро сбросить настройки Mikrotik до заводских настроек и восстановить его.Чтобы вернуть настройки ОС Mikrotik Router из Winbox, необходимо войти в устройство Mikrotik из утилиты конфигурации Winbox.

    Шаги резервного копирования конфигурации Mikrotik

    Откройте утилиту Winbox и войдите в маршрутизатор MikroTik. Настройте маршрутизатор все параметры и IP-адрес, которые вы хотите, в соответствии с конфигурацией вашей сети.

    Перейти к опции «Файл» в левом вертикальном меню.

    Нажмите кнопку Backup, чтобы сохранить файлы конфигурации во флэш-памяти маршрутизатора.

    Дайте имя файлу резервной копии конфигурации. Вы можете использовать данные с именем маршрутизатора, чтобы идентифицировать резервную копию при необходимости ее восстановления.

    Если вы хотите защитить файл резервной копии паролем, чтобы только вы могли восстановить файл, введите пароль и нажмите кнопку резервного копирования для процесса резервного копирования настроек.

    Файл конфигурации будет создан внутри папки Flash File, как показано на рисунке ниже.

    Выберите файл и нажмите кнопку «Копировать» или щелкните файл правой кнопкой мыши и нажмите кнопку загрузки, чтобы экспортировать файл резервной копии конфигурации Mikrotik на ПК.

    Сохраните резервную копию настроек маршрутизатора на безопасном диске, чтобы вы могли использовать ее для восстановления при необходимости.

    После загрузки файла резервной копии вы можете восстановить настройки в любое время, если вы сделали сброс настроек маршрутизатора до заводских или приобрели новый маршрутизатор MikroTik.

    Шаги восстановления конфигурации MikroTik

    После резервного копирования теперь шаги восстановления немного проще для маршрутизатора MikroTik. Использование процесса резервного копирования и восстановления конфигурации позволяет сэкономить 80% времени по сравнению с ручной настройкой маршрутизатора MikroTik.

    Подключите новый маршрутизатор или, если вы выполнили сброс настроек, выполните шаги для восстановления из резервной копии.

    Теперь перейдите к файлу для восстановления настроек.

    Нажмите кнопку загрузки, чтобы загрузить файл резервной копии с диска ПК во флэш-память MicroTik.

    Просмотрите папку на жестком диске, где вы сохранили файл конфигурации, и нажмите «Открыть» для загрузки.

    Файл резервной копии настроек Mikrotik загрузится и отобразится в списке файлов, как показано на рисунке ниже.

    Выберите файл и нажмите кнопку восстановления, чтобы применить настройки.

    «Вы хотите восстановить конфигурацию и перезагрузить»

    Нажмите кнопку «Да».

    Маршрутизатор восстановит конфигурацию и перезагрузится.

    Winbox отключится после восстановления настроек и перезагрузки маршрутизатора.

    Маршрутизатор доступа с данными восстановленных настроек, которые вы настроили перед резервным копированием файлов.

    Это простой и разумный способ сократить время простоя сети в случае сбоя любого маршрутизатора Mikrotik или установки нового маршрутизатора MikroTik в той же сети.

    Методы резервного копирования и восстановления настроек Mikrotik одинаковы для всех моделей маршрутизаторов Mikrotik. Вы можете использовать это руководство для резервной конфигурации на Mikrotik RB2011, RB750, Basebox, Omnitik и любом маршрутизаторе MikroTik, который поставляется с прошивкой маршрутизатора.

    Другой метод - это резервное копирование и восстановление настроек Mikrotik с помощью команд.

    Связанное сообщение

    Скрипт резервного копирования MIkrotik

    Команда сценария резервного копирования Mikrotik

    MikroTik Backup and Restore Procedure, и перетащите в папку на ПК, чтобы скопировать.Функция резервного копирования системы позволяет без труда сохранять и загружать конфигурацию устройства. Подробнее о функции резервного копирования читайте в разделе «Система / Резервное копирование». Экспорт конфигурации. Имя команды: / export. Команда экспорта выводит сценарий, который можно использовать для восстановления конфигурации. Команду можно вызвать на любом уровне меню, и она действует для

    Manual: Configuration Management, Привет всем, пару недель назад я узнал, что годы резервного копирования RouterOS все красиво и аккуратно организованы на одном из наших серверов резервного копирования. Восстановление файлов конфигурации на роутерах MikroTik всегда было проблемой.Я задумал сделать идеальный сценарий восстановления конфигурации для роутеров MikroTik. Вы пытались вставить команды конфигурации в роутер MikroTik? Ага, не работает. Как только сценарий добавляет интерфейс к мосту или изменяет IP… Подробнее

    Резервный сценарий - MikroTik, Вот объяснение синтаксиса сценария шаблона FTP: выполнила команду, обратите внимание, что папка резервной копии Как писать просто скрипт для автоматического резервного копирования конфигурации MikroTik и загрузки на FTP-сервер. Подобно тому, как я писал о резервном копировании конфигурации Cisco в посте автоматического резервного копирования конфигурации CISCO, здесь я покажу вам, как я делаю резервное копирование сетевых устройств MikroTik.

    Mikrotik сценарий резервного копирования FTP

    SCRIPT - Резервное копирование на FTP - MikroTik - MikroTik, Вот сценарий, который я только что написал для резервного копирования файлов .rsc и .backup на FTP. В настоящее время тестируется только на ROS 6.6. Код: Выбрать все. # Установить локальные переменные. Создание шаблона сценария FTP. Эта процедура очень проста и проста в использовании.Откройте блокнот («Пуск»> «Программы»> «Стандартные»> «Блокнот») и введите следующее: o 192.168.0.1 21 ПОЛЬЗОВАТЕЛЬ ftp mypass binary $ 192.168.0.1 - Завершение резервного копирования маршрутизатора, завершение работы Вот объяснение синтаксиса сценария шаблона FTP:

    Резервное копирование на внешнее FTP Полезный скрипт - MikroTik - MikroTik, Кроме того, мы также будем использовать Script & Scheduler для его автоматизации. Учебное пособие Как выполнить автоматическое резервное копирование Mikrotik: отправить резервную копию файла на автоматический FTP Резервную копию конфигурации можно использовать для резервного копирования конфигурации MikroTik RouterOS в двоичный файл, который можно сохранить на маршрутизаторе или загрузить с него с помощью FTP для будущего использования.Восстановление конфигурации можно использовать для восстановления конфигурации маршрутизатора точно так же, как это было в момент создания резервной копии, из файла резервной копии.

    Mikrotik AutoBackup: отправка файлов резервных копий на FTP-сервер, Сценарий автоматического резервного копирования FTP для Mikrotik RouterOS. GitHub Gist: мгновенно обменивайтесь кодом, заметками и фрагментами. Резервную копию конфигурации можно использовать для резервного копирования конфигурации MikroTik RouterOS в двоичный файл, который можно сохранить на маршрутизаторе или загрузить с него с помощью FTP для будущего использования.Восстановление конфигурации можно использовать для восстановления конфигурации маршрутизатора точно так же, как это было в момент создания резервной копии, из файла резервной копии.

    Сценарий конфигурации MikroTik

    Руководство: Управление конфигурацией, сценарий RouterOS разделен на несколько командных строк. используется для импорта конфигурации из файлов, созданных командой экспорта или написанных вручную вручную. Динамический DNS на частном DNS-сервере (ОС маршрутизатора, Bind, Apache и сценарий оболочки) Сценарий обновления динамического DNS для ChangeIP.com Сценарий обновления динамического DNS для ChangeIP за NAT

    Сценарии, Время - деньги: мне нравится знать, сколько времени требуется для выполнения сценариев, поэтому я всегда включаю это как первую часть тела сценария, I Восстановление файлов конфигурации на роутерах MikroTik всегда было проблемой. Я задумал сделать идеальный сценарий восстановления конфигурации для роутеров MikroTik. Вы пытались вставить команды конфигурации в роутер MikroTik? Ага, не работает. Как только сценарий добавляет интерфейс к мосту или изменяет IP… Подробнее

    Manual: Scripting, Как создать сценарий конфигурации Mikrotik. 4950 просмотров4,9 тысяч просмотров. • 6 февраля 2018 г. 16 12. Продолжительность публикации: 4:27
    Размещено: 6 февраля 2018 г. [admin @ MikroTik]> / ip address print Флаги: X - отключено, I - недопустимо, D - динамическое # ADDRESS NETWORK BROADCAST INTERFACE 0 10.1.0.172/24 10.1.0.0 10.1.0.255 bridge1 1 10.5. 1.1 / 24 10.5.1.0 10.5.1.255 ether1 [admin @ MikroTik]> / ip address export file = address [admin @ MikroTik]> / file print # ИМЯ ТИП РАЗМЕР СОЗДАНИЕ-ВРЕМЯ 0 address.rsc script 315

    Mikrotik auto backup скрипт

    Автоматическое резервное копирование, Я хочу добавить текущую дату в имя файла резервной копии.Вот моя версия сценария автоматического резервного копирования, у него много функций, таких как резервное копирование в автоматическое централизованное резервное копирование. Введение. Хотя создание резервных копий электронной почты несложно, в конечном итоге они становятся проблемой из-за конфликта со спам-фильтрами и довольно быстрого заполнения почтового ящика получателя (особенно если несколько маршрутизаторов отправляют по электронной почте свои обычные резервные копии через короткие промежутки времени) таким образом, вся процедура резервного копирования кажется неорганизованной, медленной и неуклюжей.

    Автоматическое резервное копирование - MikroTik - MikroTik, Этот сценарий предоставляет возможность создавать ежедневные резервные копии Mikrotik по электронной почте.Вы также можете включить автоматическое обновление RouterOS или оставить только Как написать простой скрипт для автоматического резервного копирования конфигурации MikroTik и загрузки на FTP-сервер. Подобно тому, как я писал о резервном копировании конфигурации Cisco в посте автоматического резервного копирования конфигурации CISCO, здесь я покажу вам, как я делаю резервное копирование сетевых устройств MikroTik. Существует 2 типа резервного копирования MikroTik: резервное копирование конфигурации и

    Mikrotik RouterOS автоматическое резервное копирование и сценарий обновления, Кроме того, мы также будем использовать Script & Scheduler для его автоматизации.Учебное пособие Как AutoBackup Mikrotik: Отправить резервную копию файла на автоматический FTP Шаг 2: Скрипт для хранения файла резервной копии и отправки по электронной почте. После завершения настройки электронной почты мы не будем писать скрипт, который будет хранить файл резервной копии и затем отправлять файл резервной копии на желаемый почтовый адрес. Выполните следующие шаги, чтобы написать скрипт на вашем роутере MikroTik. Перейдите в System> Scripts и нажмите PLUS SIGN (+), чтобы добавить новый скрипт. Новая команда резервного копирования

    MikroTik

    Процедура резервного копирования и восстановления MikroTik, Перетащите файл из Winbox в папку на ПК, чтобы скопировать его.Простое, доступное, безопасное и непрерывное резервное копирование для всех ваших компьютеров и серверов. Попробовать бесплатно. Более 12 000 клиентов восстановили данные после атаки программ-вымогателей. Защитите свои данные прямо сейчас.

    Руководство: Управление конфигурацией, Ура! P.S .: Всем могучим фанатам командной строки. Не все люди хорошо разбираются в синтаксисе. Не все люди чувствуют себя спасенными в среде командной строки. Если у вас есть резервная копия неисправного маршрутизатора и вы покупаете новый маршрутизатор MikroTik, а затем загружаете и восстанавливаете этот файл резервной копии, вы получите работающую сеть без каких-либо проблем. Файл резервной копии MikroTik также полезен, если вы, к сожалению, забыли пароль администратора с правами администратора.

    Руководство: Система / Резервное копирование, Текстовая конфигурация Резервный текстовый файл .rsc. Подключитесь к роутеру с Winbox; Нажмите «Новый терминал»; Выполните команду export file = myconfig.cfg. 4. Важно: при восстановлении двоичного файла резервной копии на новый маршрутизатор Mikrotik резервная копия изменит MAC-адреса всех интерфейсов, чтобы они соответствовали предыдущему маршрутизатору. Обычно это не проблема, если вы не используете резервную копию для настройки второго маршрутизатора.

    Mikrotik восстанавливает резервную копию на другое устройство

    Клонирование устройства с помощью резервного копирования и восстановления - MikroTik, Привет, я пытаюсь скопировать текущую рабочую конфигурацию wAP ac и применить ее к другому wAP ac. (да, после восстановления мне нужно сбросить Mac и Важно: при восстановлении двоичного файла резервной копии на новый маршрутизатор Mikrotik резервная копия изменит MAC-адреса всех интерфейсов в соответствии с предыдущим маршрутизатором. Обычно это не проблема, если вы не используете резервная копия для настройки второго маршрутизатора.

    резервное копирование и восстановление на другое устройство - MikroTik, Возможно ли, если я хочу настроить устройства в прозрачном мосту Привет, о, хорошо, поэтому я не должен использовать резервное копирование и восстановление, но должен использовать функцию экспорта и резервного копирования и восстановления в MikroTik Router помогает восстановить конфигурацию маршрутизатора, когда работающий маршрутизатор не работает из-за сбоя оборудования. Если у вас есть резервная копия неисправного маршрутизатора и вы покупаете новый маршрутизатор MikroTik, а затем загружаете и восстанавливаете этот файл резервной копии, вы получите работающую сеть без каких-либо проблем.

    Восстановить резервную копию на другое устройство? - MikroTik - MikroTik, Backup предназначен только для того же устройства, на котором установлена ​​та же версия ROS. Более новые версии одних и тех же устройств могут немного отличаться. Если вы восстанавливаете резервную копию MikroTik на другое устройство, у вас, скорее всего, будут дублирующиеся MAC-адреса в вашей сети, потому что конфигурация MikroTik имеет тенденцию восстанавливаться вместе с информацией о MAC-адресах. Если вы хотите восстановить MAC-адрес интерфейса по умолчанию, откройте новый терминал и выполните следующую команду:

    Облако резервного копирования системы MikroTik

    Резервное копирование.Начиная с RouterOS v6.44, можно хранить резервную копию вашего устройства на облачном сервере MikroTik. Служба резервного копирования позволяет загружать зашифрованный файл резервной копии, загружать его и применять файл резервной копии к вашему устройству до тех пор, пока ваше устройство может подключиться к облачному серверу MikroTik.

    Резервную копию конфигурации можно использовать для резервного копирования конфигурации MikroTik RouterOS в двоичный файл, который можно сохранить на маршрутизаторе или загрузить с него с помощью FTP для будущего использования. Восстановление конфигурации можно использовать для восстановления конфигурации маршрутизатора точно так же, как это было в момент создания резервной копии, из файла резервной копии.

    Автоматическое централизованное резервное копирование Введение. Хотя создание резервных копий электронной почты несложно, в конечном итоге они становятся проблемой из-за конфликта со спам-фильтрами и довольно быстрого заполнения почтового ящика получателя (особенно если несколько маршрутизаторов отправляют по электронной почте свои обычные резервные копии через короткие промежутки времени) таким образом, вся процедура резервного копирования кажется неорганизованной, медленной и неуклюжей.

    Скрипт резервного копирования электронной почты Mikrotik gmail

    Отправить резервную копию электронной почты, сценарий похож на что-то вроде (вы можете добавить к нему любую информацию, которая вам нужна: дата, идентификатор / инструмент, электронная почта, отправка на = yourmail @ gmail.com subject = "bla-bla-bla" Чтобы отправить электронное письмо с регулярным резервным копированием всех системных настроек, необходимо выполнить три шага. Во-первых, вы должны убедиться, что вы установили настройки SMTP-сервера исходящей электронной почты в "tool email", а затем создайте сценарий который генерирует сам файл резервной копии, наконец, необходимо создать расписание для регулярного запуска этого сценария резервного копирования

    Как автоматически перенести резервную копию моего микротика в мой gmail, _by_e-mail ". У меня есть адрес Gmail, и вы можете увидеть мою пересылку и дату] в $ [/ system clock get time] Script ": log info" Сценарий ежедневного резервного копирования В этом примере показано, как отправлять электронную почту с экспортом конфигурации каждые 24 часа.1. Настройте SMTP-сервер [admin @ MikroTik] / электронная почта инструмента> set server = 10.1.1.1 port = 25 from = "[email protected]" 2. Добавьте новый скрипт с именем "export-send"

    Создать резервную копию и отправить его по электронной почте - MikroTik, Чтобы отправить электронное письмо с регулярным резервным копированием всех настроек системы, необходимо создать расписание для регулярного запуска этого сценария резервного копирования.

    Добавить комментарий

    Ваш адрес email не будет опубликован. Обязательные поля помечены *

    2021 © Все права защищены. Карта сайта