Настройка igmp mikrotik: Настройка IPTV на Mikrotik

Содержание

Настройка IPTV на Mikrotik

Для примера настройки IPTV мы взяли Mikrotik RB2011UiAS-2HnD. Не совсем домашний роутер, конечно, но настройка на других устройствах принципиально ничем отличаться не будет.

Содержание:

  1. Reset Configuration роутера.
  2. Обновляем ПО роутера (добавляем пакет для IPTV).
  3. Настройка IGMP Proxy.
  4. Добавляем исключения Firewall.
  5. Настройка Wi-Fi.

Сброс настроек точки доступа

Этот пункт необязателен. Если вы настраиваете IPTV на роутере с рабочими настройками, которые вы делали ранее, то выполнять нижеописанные действия не нужно. Не помешает также сделать бекап конфигурации.

Однако иногда, если во время настройки IPTV на МикроТик что-то пошло не так, лучший выход — это «обнулить» конфигурацию и сделать все заново.

Сбросить настройки к заводским можно тремя способами:

Программно — заходим в WinBox, открываем меню System и делаем Reset Configuration.

 Механически: зажимаем кнопку Reset на вашем Mikrotik и ждем, пока роутер не перезагрузится.  (На большинстве Mikrotik советуем зажимать кнопку ДО включения оборудования, и, не отпуская держать около 10-ти секунд после включения)

 Reset Configuration в меню самого роутера (на экране настройки). Актуально только при наличии сенсорного экрана на роутере.

Обновление RouterOS (добавление пакета для IPTV)

Обновление необходимо для того, чтобы установить дополнительный пакет для IPTV.

Заходим на сайт Mikrotik, ищем в списках линейку вашей модели и скачиваем последнюю версию прошивки для нее. Обратите внимание, выбираем не прошивку с основными пакетами (main), а с дополнительными (extra):

 

Открываем WinBox, заходим на роутер (советуем заходить изначально по мак-адресу, это облегчит дальнейший процесс настройки). Чтобы обновить ПО роутера, идем в меню Files.

Открываем его и перетаскиваем в окно Files наш скачанный файл из распакованного архива под названием multicast-x.xx-mipsbe.npk

.

 

Пакет добавлен и после этого мы перезагружаем оборудование в меню SystemReboot.

Роутер перезагрузится и обновит прошивку. Процесс может занять до 5-ти минут. Питание в это время отключать не следует!

После перезагрузки открываем System — Packages и смотрим, появился ли модуль multicast.


Если таковой имеется, значит, вы все сделали правильно.

Настройка IGMP Proxy

Открываем в меню MikroTik Routing — IGMP Proxy. Нам нужно добавить новый интерфейс, для этого кликаем на плюс (как указано на скрине).

В новом интерфейсе, в поле Interface выбираем порт, по которому у нас поступает интернет, в нашем случае это ether2-master и устанавливаем галочку галочку 

Upstream, как на скриншоте:

Чуть ниже в поле Alternative Subnets следует указать альтернативные подсети. В том случае, если вы не знаете, что туда вписывать, попробуйте самые распространенные варианты: 10.0.0.0/8; 172.16.0.0/12; 192.168.0.0/16.


В крайнем случае можно оставить и нули, но лучше все же найти нужную подсеть, чтобы роутер не обращался ко всему интернету.

Подтверждаем изменения, нажимаем OK.

Создаем еще один интерфейс, кликая по синему плюсу, но теперь мы не ставим галочку напротив Upstream и при этом выбираем порт тот, на который мы будем перебрасывать IPTV — то есть тот, к которому подключено устройство, на котором мы будем смотреть IPTV. 

В нашем случае это bridge, потому что к нему подключен стационарный ПК.

То есть в первом случае мы указывали порт, куда входят данные, а теперь – откуда выходят.

После мы нажимаем кнопку Settings и ставим галочку напротив Quick Leave. Делаем мы это для того, чтобы иметь возможность быстро переключаться между каналами.

 

Настройка Firewall

Настраиваем  наш Firewall, который не пропускает IPTV на данный момент, для этого мы создаем новый терминал, нажимаем New Terminal и открывается вот такое окно:

 

Теперь мы должны выполнить в этой консоли несколько команд:

/ip firewall filter add action=accept chain=input comment=»Allow IGMP» disabled=no in-interface=ether2-master protocol=igmp

/ip firewall filter add action=accept chain=input comment=»IPTV UDP incoming» disabled=no dst-port=1234 in-interface=ether2-master protocol=udp

/ip firewall filter add action=accept chain=forward comment=»IPTV UDP forwarding» disabled=no dst-port=1234 protocol=udp

1234 – порт неофициально зарегистрированный для передачи потокового видео и IPTV

ether2-master — это интерфейс, на который приходит IPTV от провайдера.

Далее нужно в меню IP выбрать пункт  Firewall и перейти на вкладку Filter Rules. Мы создали исключающие правила, и чтобы они работали, они должны быть выше запрещающих. Перетягиваем их вверх с помощью мыши.

Настройка Wi-Fi

В случае, если вы раздаете или собираетесь раздавать IPTV посредством Wi-Fi нужно добавить дополнительные настройки. Для этого открываем по порядку:

После нажатия кнопки Advanced Mode появляются дополнительные параметры:

  • В поле WMM Support ставим enabled — включаем поддержку передачи multimedia по Wi-Fi. 
  • В поле Multicast Helper ставим full. Этот параметр включает отправку мультикаст клиентам, сидящим на Wi-Fi.

Все, подтверждаем кнопкой OK и наслаждаемся просмотром программ.

Осталось только проверить работоспособность нашей конфигурации.  Мы использовали для этого IPTV плеер, предварительно загрузив лист каналов для нашего провайдера (Велтон Телеком) в настройках плеера. 


Мы можем видеть, что наша настройка полностью работоспособна. Приятного просмотра!

Mikrotik RouterOS и IPTV — настройка IGMP протокола

Большое количество современных технологий, ежедневно входит в нашу повседневную жизнь. И некоторые из них, становятся неотъемлемой частью нашего быта. Одной из таких технологий, стало интернет телевидение или IPTV. Еще пару лет назад, эта технология казалась нам чем-то невероятным и несбыточным, а сегодня уже многие из нас имеют широкополосное соединение с сетью и используют эту технологию в замен обычного эфирного телевидения или как альтернативу другим, например спутниковым источникам телевизионного вещания. Сегодня мы рассмотрим вариант настройки маршрутизатора под управлением сетевой операционной системы Mikrotik RouterOS для работы с наиболее часто используемым в технологии IPTV протоколом — IGMP.

Коротко, IGMP (Internet Group Management Protocol) — это протокол применяемый в сетях использующих IP протокол для управления групповой передачей данных (Multicast).

Большинство современных бытовых и SOHO маршрутизаторов, работа которых построена на собственном программном обеспечении и управляемых через WEB-интерфейс, имеют уже встроенную возможность включения этого протокола. Однако, в операционной системе Mikrotik RouterOS, которая установлена практически на всех маршрутизаторах компании Mikrotik, работа с этим протоколом — опциональна. И изначально не предусмотрена. Однако, это легко решаемо при помощи пакетов, которые можно скачать на сайте производителя.

И так, для начала работы с протоколом IGMP, нам необходимо посетить страницу загрузок компании Mikrotik — http://www.mikrotik.com/download. Там выбрать ваше оборудование и версию вашего программного обеспечения, после чего скачать файл с дополнительными пакетами — All packages.

После чего, необходимо разархивировать полученный файл, и найти там пакет multicast-x.xx-***.npk. Теперь запускаем фирменную утилиту Winbox и подключаемся к нашему маршрутизатору.

Переходим в раздел Files и обычным перетаскиванием, копируем туда наш пакет.

Внимание! Версия устанавливаемого пакета, должна совпадать с версией вашего ПО!

Для завершения его установки, все что нам осталось, это перегрузить наш маршрутизатор в меню System -> Reboot

После перезагрузки, нам надо убедиться, что пакет multicast установлен. Для этого, опять подключаемся к нашему маршрутизатору при помощи утилиты Winbox, переходим в раздел System -> Packages, где он должен появиться в списке установленных пакетов.

Если все так, и установка прошла успешно, то в разделе Routing у вас должен появиться пункт IGMP Proxy. В который нам и надо перейти. Здесь нам надо создать два новых правила на вкладке Interface.

Кнопкой “+”, добавляем первое правило. Где в качестве Interface, выбираем тот интерфейс, к которому у нас подключен кабель провайдера предоставляющего услугу IPTV, например ether1. Если соединение с провайдером осуществляется посредством одного из туннельных протоколов, например PPPoE, то в качестве Inteface, необходимо выбрать название этого соединения.

Вписываем значение 0.0.0.0/0 в поле Alternative Subnets и ставим галочку возле Upstream.

Сохраняем правило кнопкой OK. И создаем еще одно. Только на этот раз, нам нужно в качестве Interface, выбрать интерфейс, к которому у нас подключена IPTV приставка. Например ether3. Больше никаких изменений в этом правиле производить не надо.

В результате, у нас должно получиться два правила.

Алексей С., специально для LanMarket

Как настроить IPTV на MikroTik — asp24.

ru

Установка пакета multicast

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast. Для этого выполните следующее:

  • Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download;
  • Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии.
  • Нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;
     
  • Распакуйте скаченный архив с дополнительными пакетами;
  • Откройте в Winbox меню Files;
     
  • Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npk в Winbox окно File List

     

  • Перезагрузите роутер через меню System — Reboot или через терминал командой system reboot.

После перезагрузки в меню System — Packages должен появиться модуль multicast.

 

Настройка

IGMP Proxy

Выполним настройку IGMP Proxy на MikroTik.

Откройте меню Routing — IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV.

 

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16.

Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0. Но так лучше не делать. Используйте 0.0.0.0/0 только если не смогли найти необходимую подсеть.

После ввода параметров нажмите кнопку OK.

 

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV.

 

В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK.  В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

 

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

 

Настройка Firewall

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте меню New Terminal.

 

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment=»Allow IGMP» disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=input comment=»IPTV UDP incoming» disabled=no dst-port=1234 in-interface=ether1 protocol=udp

/ip firewall filter add action=accept chain=forward comment=»IPTV UDP forwarding» disabled=no dst-port=1234 protocol=udp

ether1 — это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

 

После этого откройте меню IP — Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

 

Настройка Wi-Fi

Если вы транслируете IPTV по Wi-Fi, то необходимо выполнить следующие настройки.

  1. Откройте меню Wireless.
  2. Перейдите на вкладку Interfaces.
  3. Откройте двойным щелчком беспроводной интерфейс wlan1.
  4. Перейдите на вкладку Wireless.
  5. Нажмите кнопку Advanced Mode.

 

Найдите параметр WMM Support и выберите enabled. Он включит поддержку Wi-Fi multimedia. Если у вас много клиентов, то его лучше не включать, поскольку один клиент может мультикастом съесть весь канал.

В параметре Multicast Helper выберите full. Это позволит отправлять мультикаст пакеты по MAC адресам клиентам, подключенным к Wi-Fi.

После этого нажмите кнопку OK.

 

На этом настройка IPTV на MikroTik окончена.

©http://www.technotrade.com.ua/Articles/iptv_config_mikrotik.php

Mikrotik для работы с IPTV

 

Внимание, услуга IPTV предоставляется в тестовом режиме.

  1. Проверка и добавление необходимых пакетов
    Все манипуляции будем проводить через утилиту WinBox (загрузить можно здесь
    http://www.mikrotik.com/download/winbox.exe). Для начала проверим наличие пакета
    Multicast, он необходим для работы с таким типом трафика. Запускаем WinBox и
    подключаемся по IP или MAC – адресу:

После загрузки всех данных идем в главное меню:
System – Packadges, появится новое окно в котором отобразится список установленных
пакетов.
Важно! Перед тем как начать все операции крайне желательно обновить пакеты
установленные в маршрутизаторе. Для этого в окне Packadge List нажать кнопку Check For
Updates и далее нажать Download & Install, после чего маршрутизатор самостоятельно
скачает, установит новые версии пакетов и перезагрузится.

По умолчанию на маршрутизаторе данного пакета нет, его необходимо устанавливать
вручную. Для этого сначала смотрим на тип архитектуры процессора – он указан в заголовке
окна WinBox – и выглядит например так: mipsbe, arm, x86 и другие. После чего идем на сайт
https://mikrotik.com/ в раздел Download, и скачиваем набор Extra packages для своей
архитектуры ветви Current. После загрузки и распаковки архива перетаскиваем пакет для
работы с мультикастом прямо в окно WInBox. Проконтролировать загрузку можно нажав
пункт Files в меню. После загрузки перезагружаем наш маршрутизатор для чего нажимаем в
меню System – Reboot.

Ждем пока маршрутизатор загрузится и установит новый пакет в систему. После загрузки
опять запускаем WinBox и подключаемся для дополнительной настройки.

2. Настройка igmp-прокси
Переходим в меню: Routing – IGMP Proxy (он появляется после успешной установки пакета
для работы с multicast), и сначала включаем быстрое переключение каналов: кнопка Settings
– ставим галочку Quick Leave и сохраняем параметры нажатием OK. После чего начинаем
добавлять интерфейсы.
Важно! Описываемый ниже подход предполагает, что порт в сторону провайдера один -ether1, остальные порты объединены в мост – bridge1 вместе с беспроводным интерфейсом
wlan1.
Для начала создаем Upstream: нажимаем кнопку +, указываем интерфейс: ether1, Alternative
Subnets: 234.0.0.0/24, 178.163.126.249, и ставим галочку Upstream, сохраняем и закрываем
нажатием кнопки OK. Потом добавляем Downstream: нажимаем кнопку +, указываем
интерфейс: bridge, сохраняем и закрываем нажатием кнопки OK.

Можно проверять работу IPTV на проводных интерфейсах.

3. Приложение
Для устойчивой работы IPTV по Wi-Fi необходимо включить ряд параметров:
Wireless – wlan1 – кнопка Advanced Mode, установить галочку Multicast Buffering, и
выбрать для Multicast Helper вариант full.


MIkrotik RouterOS — ИнжиНэт+ — оператор связи — Интернет, Телефон в г.Ивантеевка М.О | ИнжиНэт+ — оператор связи

Изначально, в RouterOS не установлен пакет Multicast, который нам нужен. Поэтому, начать необходимо с того, что на сайте производителя, скачать файл с дополнительными пакетами для своего типа маршрутизатора и версии операционной системы. Найти данные фалы, можно по ссылке – http://www.mikrotik.com/download

Далее, распаковав архив, найти в нём файл multicast-xx-xxxx.npk и подключится к маршрутизатору. При помощи фирменной утилиты Winbox, нужно переместить его (Drag&Drop) в окно раздела меню Files, как показано на изображении ниже.  

Рис. 1. Winbox

 

Теперь надо перегрузить маршрутизатор, System – Reboot

После перезагрузки, мы опять подключаемся к маршрутизатору, где в разделе System – Packeges, мы должны увидеть установленный ранее пакет Multicast.

Рис. 2. System – Packeges с установленным пакетом Multicast

 

И если пакет установлен, то в разделе Routing появится дополнительное меню IGMP Proxy, которое нам и нужно.

Рис. 3. Раздел Routing. Меню IGMP Proxy

 

Здесь мы открываем Settings и ставим галочку Quick Leave, для более быстрого переключения каналов, после чего, сохраняем настройки.

Рис. 4. Settings. Quick Leave

 

Потом на вкладке Interface, нужно создать две новые записи.

Первая:

Interface – выбрать физический интерфейс к которому подключен кабель провайдера, например ether1.

Alternative Subnet – указать сеть вещания IPTV (если она вам известна), или указать 0. 0.0.0/0.

Upstream – поставить галочку.

Рис. 5. Новые записи во вкладке Interface

 

Вторая:

Interface – здесь нужно только указать интерфейс, к которому подключена IPTV приставка. Например – ether5, или же, если приставок несколько или они подключены по Wi-Fi, то можно выбрать мост (brige).

Рис. 6. Подключена IPTV приставка – ether5

 

И после создания этих записей, если у вас включен Firewall, то необходимо создать ряд правил, которые разрешат IGMP и некоторые UDP пакеты.

Для этого, в меню IP – Firewall, на вкладке Filter Rules, добавляем такую запись:

Chain – input;

Protocol — igmp;

Action – accept.

Рис. 7. На вкладке Filter Rules добавляем записи: Chain – input; Protocol – igmp

 

Рис. 8. На вкладке Filter Rules добавляем запись: Action – accept

 

И еще одну, следующего содержания:

Chain – input;

Protocol — udp;

Dst Port – здесь, указываем порт, на котором идет вещание от провайдера;

Action – accept.

Рис. 9. На вкладке Filter Rules добавляем запись: Chain – input; Protocol – udp; Dst Port

 

Рис. 10. На вкладке Filter Rules, добавляем запись: Action – accept

 

Не забываем поднять новые правила выше запрещающих. Это ВАЖНО!

И если всё сделано правильно, то в меню Routing – IGMP Proxy, на вкладке MFC, должны появиться динамические правила, а так же пакеты, идущие через них.

Рис. 11. Меню Routing – IGMP Proxy

 

Ну и конечно же, на экране должно появиться изображение.

 

Mikrotik igmp proxy настройка – Тарифы на сотовую связь