Запустить приложение 1с: Процедура ЗапуститьПриложение() в 1с 8 выполняет запуск внешнего приложения либо о

Содержание

Процедура ЗапуститьПриложение() в 1с 8 выполняет запуск внешнего приложения либо о

Выполняет запуск внешнего приложения либо открытие файла с помощью ассоциированного с ним приложения.

Синтаксис

Процедура ЗапуститьПриложение() имеет следующий синтаксис:

ЗапуститьПриложение(СтрокаКоманды, [ТекущийКаталог], [ДождатьсяЗавершения], [КодВозврата])

А также альтернативный англоязычный синтаксис:

RunApp(CommandLine, [CurrentFolder], [WaitForReturn], [ReturnCode])

Параметры

Описание параметров процедуры ЗапуститьПриложение():

Имя параметра Тип Описание
СтрокаКоманды Строка Командная строка для запуска приложения либо имя файла, ассоциированного с некоторым приложением
ТекущийКаталог Строка Задает текущий каталог для запускаемого приложения. В режиме веб-клиента игнорируется
ДождатьсяЗавершения Булево Указывает на необходимость дождаться завершения запущенного приложения перед продолжением работы.

Значение по умолчанию: Ложь

КодВозврата Число, Неопределено Выходной параметр процедуры, в который помещается код завершения работы выполняемой команды системы, передаваемый приложением операционной системе (если такой код поддерживается). Имеет смысл только если указан параметр ДождатьсяЗавершения, а запускаемое приложение существует в системе и завершило свою работу корректно. В противном случае возвращает Неопределено.
Жирным шрифтом выделены обязательные параметры

Описание

Процедура ЗапуститьПриложение() выполняет запуск внешнего приложения либо открытие файла с использованием ассоциированного с ним приложения.

Примечание: В отличие от функции КомандаСистемы() запуск приложения выполняется непосредственно, минуя командный интерпретатор. Поведение метода зависит от используемой операционной системы и режима запуска. Используемые в реализации метода механизмы операционной системы допускают различные варианты использования. Например, в некоторых режимах метод может открывать html ссылки с помощью браузера «по умолчанию». Такие возможности не являются штатными т.к. не гарантируется их наличие во всех ОС и режимах запуска.

Внимание! При запуске 1С:Предприятия в пакетном режиме, а также при вызове метода на сервере будет вызвано исключение

Внимание!! Для работы метода на веб-клиенте необходимо предварительно подключить расширение работы с файлами

Внимание!!! При использовании метода на мобильной платформе возможно только открытие файла по ассоциации. На мобильной платформе под управлением ОС Windows параметр ДождатьсяЗавершения игнорируется, а результат выполнения возвращается сразу после запуска приложения

Доступность

Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, мобильное приложение(клиент), мобильное приложение(сервер).

Пример использования

Пример кода с использованием процедуры ЗапуститьПриложение():

//открывает web-страницу с помощью браузера "по-умолчанию"
ЗапуститьПриложение("C:\temp\test.html");
//открывает pdf-файл на просмотр
ФайлPDF = Новый Файл("C:\test.pdf");
Если ФайлPDF.Существует() Тогда
	ЗапуститьПриложение(ФайлPDF.ПолноеИмя);
КонецЕсли;

Читайте также:

  1. Как распечатать pdf документ сразу на принтер?

Работа с операционной системой в языке 1С 8.3, 8.2 (в примерах)

/// Как запустить внешнюю программу и
/// дождаться окончания её выполнения из 1с 8.3, 8.2
 
&НаКлиенте
Процедура ЗапуститьКалькуляторСОжиданием(Команда)
 
    Перем КодВозврата;
 
    ОткрытьЗначение("Запускаем калькулятор.");
 
    ЗапуститьПриложение(
        "calc.exe",
        "", // текущий каталог для запускаемого приложения
        Истина, // дожидаться завершения работы запущенного приложения
        КодВозврата // сюда попадёт код, возвращаемый программой
    );
 
    // сюда мы попадём только после того,
    // как пользователь закроет окно калькулятора
 
    ОткрытьЗначение("Вы закрыли калькулятор.");
 
КонецПроцедуры
 
/// Как запустить внешнюю программу без ожидания
/// окончания её выполнения из 1с 8.3, 8.2
 
&НаКлиенте
Процедура ЗапуститьКалькуляторБезОжидания(Команда)
 
    Перем КодВозврата;
 
    ЗапуститьПриложение(
        "calc.exe",
        "", // текущий каталог для запускаемого приложения
        Ложь, // дожидаться завершения работы запущенного приложения
        КодВозврата // сюда попадёт код, возвращаемый программой
    );
 
    // сюда мы попадём сразу после запуска калькулятора
    // не дожидаясь его закрытия
 
КонецПроцедуры
 
/// Как открыть сайт в браузере по умолчанию
/// в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьСайтВБраузереПоУмолчанию(Команда)
 
    ЗапуститьПриложение("http://helpme1c.ru");
 
КонецПроцедуры
 
/// Как открыть сайт в Internet Explorer из 1с 8.3, 8.2
 
// вариант #1
 
&НаКлиенте
Процедура КакОткрытьСайтВInternetExplorer(Команда)
 
    Shell = Новый COMОбъект("WScript.Shell");
    ProgramFiles = Shell.ExpandEnvironmentStrings("%PROGRAMFILES%");    
 
    ЗапуститьПриложение(ProgramFiles + 
        "\Internet Explorer\iexplore.exe http://helpme1c.ru");
 
    // главный недостаток этого варианта запуска приложения
    // с параметрами - нужно указывать полный путь к программе
 
КонецПроцедуры
 
// вариант #2 (мелькает чёрное окно)
 
&НаКлиенте
Процедура КакОткрытьСайтВInternetExplorer_2(Команда)
 
    КомандаСистемы("start iexplore.exe http://helpme1c.ru");
 
    // при запуске приложения с параметрами через команду системы
    // полный путь указывать не нужно, но будет мелькать
    // чёрное окно
 
КонецПроцедуры
 
/// Как открыть файл word или excel из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьФайлWordИлиExcel(Команда)
 
    ЗапуститьПриложение("c:\test.xlsx");    
 
КонецПроцедуры
 
/// Как открыть конкретную папку в проводнике из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакОткрытьПапкуВПроводнике(Команда)
 
    Shell = Новый COMОбъект("WScript.Shell");
    WindowsDir = Shell.ExpandEnvironmentStrings("%WINDIR%");    
 
    ЗапуститьПриложение(WindowsDir +
        "\explorer.exe ""C:\Program files""");
 
КонецПроцедуры
 
/// Как выделить нужный файл в проводнике из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакВыделитьФайлВПроводнике(Команда)
 
    Shell = Новый COMОбъект("WScript.Shell");
    WindowsDir = Shell.ExpandEnvironmentStrings("%WINDIR%");    
 
    // откроем проводник с выделенным файлом notepad.exe
 
    ЗапуститьПриложение(WindowsDir +
        "\explorer.exe /select,""C:\Windows\notepad.exe""");    
 
КонецПроцедуры
 
/// Как запустить приложение с параметрами из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакЗапуститьПриложениеСПараметрами(Команда)
 
    // Из примеров выше (запуска internet explorer и проводника)
    // видно, что для запуска программы с параметрами
    // нужно указывать полный путь к программе
 
    // например:
 
    ЗапуститьПриложение("C:\Windows\explorer.exe ""C:\Program files""");
 
    // либо использовать командный интерпретатор Windows,
    // но в этом случае будет мелькать чёрное окно
 
    КомандаСистемы("start explorer.exe ""C:\Program files""");
 
 
КонецПроцедуры
 
/// Как выполнить команду операционной системы из
/// приложения в 1с 8
 
&НаКлиенте
Процедура КакВыполнитьКомандуОперационнойСистемы(Команда)
 
    КомандаСистемы(
        "winver", // выполняется через командный интерпретатор windows
        "" // текущий каталог
        );
 
КонецПроцедуры
 
/// Как получить имя компьютера в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьИмяКомпьютера(Команда)
 
    Сообщить(ИмяКомпьютера()); // например, VOLK
 
КонецПроцедуры
 
/// Как получить каталог исполняемых файлов из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьКаталогИсполняемыхФайлов1С(Команда)
 
    // выведет полный путь к папке bin
    // из которой запущена 1с
 
    Сообщить(КаталогПрограммы());
 
    // например: 
    // C:\Program Files (x86)\1cv8t\8.3.4.482\bin\
 
КонецПроцедуры
 
/// Как получить каталог для временных файлов из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьКаталогДляВременныхФайлов(Команда)
 
    // получим каталог временных файлов для пользователя,
    // от имени которого запущено приложение
 
    Сообщить(КаталогВременныхФайлов()); // например, c:\temp\
 
КонецПроцедуры
 
/// Как получить стандартный каталог документов из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьКаталогДокументов(Команда)
 
    Сообщить(КаталогДокументов());
 
    // например
    // C:\Users\Пользователь\Documents\
 
КонецПроцедуры
 
/// Как получить информацию об экранах (dpi, разрешение)
/// клиента из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьИнформациюОбЭкранах(Команда)
 
    Для Каждого Экран Из ПолучитьИнформациюЭкрановКлиента() Цикл
        Сообщить("DPI " + Строка(Экран.DPI) + " Высота: " +
            Строка(Экран.Высота) + " Ширина: " + Строка(Экран.Ширина));
    КонецЦикла;
 
    // например
    // DPI 96 Высота: 1 024 Ширина: 1 280
 
КонецПроцедуры
 
/// Как получить рабочий каталог данных пользователя
/// из 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьРабочийКаталогДанныхПользователя(Команда)
 
    Сообщить(РабочийКаталогДанныхПользователя());
 
    // например
    // C:\Users\Пользователь\AppData\Roaming\1C\1cv8t\..
    // ..01c02859-1a28-4514-b595-2abdc95ebb97\071523a4-5..
    // ..16f-4fce-ba4b-0d11ab7a1893\App\
 
КонецПроцедуры
 
/// Как узнать текущий язык, используемый в приложении
/// в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьТекущийЯзыкСистемы(Команда)
 
    Сообщить(ТекущийЯзыкСистемы()); // ru
 
КонецПроцедуры
 
/// Как получить список пользователей операционной системы
/// в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьСписокПользователейОперационнойСистемы(Команда)
 
    ОткрытьЗначение("Внимание, если у вас учебная версия платформы," +
        " то код ниже сработает с ошибкой.");
 
    Для Каждого Пользователь Из ПользователиОС() Цикл
        Сообщить(Пользователь.ИмяДомена + ": " + 
            Пользователь.ИмяСервера +" локальный (" + 
            Пользователь.Локальный + ")"
        );
 
        Для Каждого Имя Из Пользователь.Пользователи Цикл
            Сообщить("  " + Имя);
        КонецЦикла;		
    КонецЦикла;
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Клиент ЭДО 8. Руководство пользователя. Ред. 2.7

Глава 1. Установка и запуск программы :: 1С:Клиент ЭДО 8. Руководство пользователя. Ред. 2.7

1.1.

1: 8 1: 8 .

1: 8 : , . .

, .

, 1: 8, . , .

, . :

■ ;

■ ;

■ , , .

1.2.

: ( ) 1: 8 .

:

■ , , — .

■ , .

1.3.

: . «1:». .

1.4.

1: 8 :

■ . >.

■ , . >.

■ . . >. .

■ HASP Device Driver. 1: 8, 1: 8 ( HASP Device Driver). >.

■ .

1: 8. 1: 8, 1: 8 .

1.5.

. , .

. , >, .

.

1.6.

1: 8 (, 1: 1 8).

1: 8 , . .

. .

.

>.

. . : , .

, ( ) >.

, .

>.

. .

>.

.

, .

, .

1.7.

1: 8 .

( ) 1:. (, , , ) .

, ( ). OK.

Работа с приложением в языке 1С 8.3, 8.2 (в примерах)

/// Как узнать имя текущего пользователя в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьИмяТекущегоПользователя(Команда)
 
    Сообщить(ИмяПользователя()); // Администратор
 
КонецПроцедуры
 
/// Как получить или изменить заголовок окна приложения в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПолучитьИлиИзменитьЗаголовокОкна(Команда)
 
    // заголовок в 1с состоит из двух частей: префикс (короткая часть)
    // и сам заголовок (длинная часть)
 
    Сообщить(
        ПолучитьКраткийЗаголовокПриложения()
    ); // обычно пустой
 
    Сообщить(
        ПолучитьЗаголовокКлиентскогоПриложения()
    ); // название конфигурации, например Бухгалтерия предприятия
 
    // сделаем такой заголовок - Ромашка.Бухгалтерия
    УстановитьКраткийЗаголовокПриложения("Ромашка");
    УстановитьЗаголовокКлиентскогоПриложения("Бухгалтерия");
 
КонецПроцедуры
 
/// Как узнать текущий вариант интерфейса в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьТекущийВариантИнтерфейса(Команда)
 
    Сообщить(
        ТекущийВариантИнтерфейсаКлиентскогоПриложения()
    ); // например, Такси или Версия8_2
 
КонецПроцедуры
 
/// Как узнать текущий размер основного шрифта в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьТекущийРазмерШрифта(Команда)
 
    Сообщить(
        ТекущийВариантОсновногоШрифтаКлиентскогоПриложения()
    ); // Крупный или Обычный
 
КонецПроцедуры
 
/// Как подключить или отключить обработчик ожидания
/// для управляемой формы в 1с 8.3, 8.2
 
&НаКлиенте
Процедура РаботаСОбработчикамиОжиданияФормы(Команда)    
 
    // подключаем, чтобы процедура СкажиПривет
    // вызвалась через 3 секунды
    // процедура СкажиПривет определена чуть ниже
    ПодключитьОбработчикОжидания(
        "СкажиПривет", // имя процедуры
        3, // интервал в секундах
        Истина // однократный вызов
    );
 
    // тут же отключаем
    ОтключитьОбработчикОжидания("СкажиПривет");
 
КонецПроцедуры
 
&НаКлиенте
Процедура СкажиПривет()
 
    Сообщить("Привет!");
 
КонецПроцедуры
 
/// Как подключить или отключить глобальный обработчик
/// оповещения в 1с 8.3, 8.2
 
&НаКлиенте
Процедура РаботаСГлобальнымиОбработчикамиОповещения(Команда)
 
    // подключаем экспортируемую процедуру глОбработкаОповещение,
    // которая определена в модуле управляемого приложения
    // также можно располагать её в одном из общих модулей
    ПодключитьОбработчикОповещения("глОбработкаОповещения");
 
    // тут же проводим тест
    Оповестить("Кошмар", "Монстр", Объект);
 
    // и отключаем этот обработчик оповещения
    ОтключитьОбработчикОповещения("глОбработкаОповещения");
 
КонецПроцедуры
 
/// Как узнать скорость клиентского соединения в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьСкоростьСоединения(Команда)
 
    Сообщить(
        ПолучитьСкоростьКлиентскогоСоединения()
    ); // Низкая или Обычная
 
КонецПроцедуры
 
/// Как узнать текущий режим запуска в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьТекущийРежимЗапуска(Команда)
 
    Сообщить(
        ТекущийРежимЗапуска()
    ); // Авто, ОбычноеПриложение или УправляемоеПриложение
    // Неопределено, если внешнее соединение
 
КонецПроцедуры
 
/// Как узнать строку соединения инормационной базы в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакУзнатьСтрокуСоединенияСБазой(Команда)
 
    // часто из неё можно вытащить полезную информацию
    Сообщить(
        СтрокаСоединенияИнформационнойБазы()
    ); // Например, File="D:\Bases\Пустая";
 
КонецПроцедуры
 
/// Как заблокировать работу пользователя в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакЗаблокироватьРаботуПользователя(Команда)
 
    ЗаблокироватьРаботуПользователя();
 
КонецПроцедуры
 
/// Как завершить работу системы (вызывая обработчики
/// закрытия) в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакЗавершитьРаботуСистемы(Команда)
 
    ЗавершитьРаботуСистемы(
        Истина, // запрашивать возможность
        Ложь, // (необ.) перезапустить после завершения
        "" // (необ.) дополнительные параметры, если делается перезапуск
    );
 
КонецПроцедуры
 
/// Как прекратить работу системы (не вызывая обработчики
/// закрытия) в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакПрекратитьРаботуСистемы(Команда)
 
    ПрекратитьРаботуСистемы(
        Ложь, // (необ.) перезапустить после завершения
        "" // (необ.) дополнительные параметры, если делается перезапуск
    );
 
КонецПроцедуры
 
/// Как запустить ещё один экземпляр 1С Предприятия в 1с 8.3, 8.2
 
&НаКлиенте
Процедура КакЗапуститьЕщёОдинЭкземпляр1С(Команда)
 
    // выдаст ошибку в учебной версии, так как
    // в ней нельзя запускать больше одного сеанса
 
    ЗапуститьСистему(
        "", // дополнительные параметры
        Истина // дождаться завершения запущенной системы для продолжения
    );
 
КонецПроцедуры
 
&НаКлиенте
Процедура РаботаСДатой(Команда)
    РаботаСДатойНаСервере();
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура РаботаСДатойНаСервере()
 
    /// Как узнать часовой пояс сеанса в 1с 8.3, 8.2
 
    Сообщить(
        ЧасовойПоясСеанса()
    ); // например, Australia/Brisbane
 
    /// Как узнать текущую дату сеанса в 1с 8.3, 8.2
 
    Сообщить(
        ТекущаяДатаСеанса()
    ); // например, 16.02.2017 10:32:59
 
КонецПроцедуры
 
&НаКлиенте
Процедура РаботаСПравамиИРолями(Команда)
    РаботаСПравамиИРолямиНаСервере();
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура РаботаСПравамиИРолямиНаСервере()
 
    /// Как узнать есть ли право у текущего пользователя
    /// применительно к объекту метаданных в 1с 8.3, 8.2
 
    // Какие могут быть права: Чтение, Изменение , Добавление,
    // Удаление, Проведение и т.д. (см. справку к функции
    // ПравоДоступа в конфигураторе)
 
    Если ПравоДоступа(
            "Чтение", Метаданные.Справочники.Контрагенты
    ) Тогда
        Сообщить("Доступ на чтение к данному справочнику открыт!");
    КонецЕсли;
 
    /// Как узнать включает ли определенная роль в себя
    /// определенное право применительно к объекту
    /// метаданных в 1с 8.3, 8.2
 
    Если Не ПравоДоступа(
        "Изменение", Метаданные.Справочники.Контрагенты,
        Метаданные.Роли.Администратор
    ) Тогда
        Сообщить("У роли Администратор нет прав на изменения справочника!");
    КонецЕсли;
 
    /// Как использовать функцию проверки прав для других пользователей
    /// в 1с 8.3, 8.2
 
    Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
 
    Для Каждого Пользователь Из Пользователи Цикл
 
        Если ПравоДоступа(
                "Чтение", Метаданные.Справочники.Контрагенты,
                Пользователь
        ) Тогда
            Сообщить("Доступ для " + Пользователь.Имя + " на чтение открыт!");
        КонецЕсли;
 
    КонецЦикла; 
 
    /// Как узнать включена ли определенная роль для
    /// текущего пользователя в 1с 8.3, 8.2
 
    Если РольДоступна("Администратор") Тогда
        Сообщить("Приветствую тебя, Администратор!");
    КонецЕсли;    
 
    /// Как проверить право у пользователя и в случае
    /// его отсутствия вызвать исключение в 1с 8.3, 8.2
 
    ВыполнитьПроверкуПравДоступа(
        "Изменение",
        Метаданные.Справочники.Контрагенты
    ); // Вызовет исключение "Нарушение прав доступа!"
 
КонецПроцедуры
 
&НаКлиенте
Процедура КакУзнатьПолноеИмяПользователя(Команда)
    КакУзнатьПолноеИмяПользователяНаСервере();
КонецПроцедуры
 
/// Как узнать полное имя пользователя в 1с 8.3, 8.2
 
&НаСервереБезКонтекста
Процедура КакУзнатьПолноеИмяПользователяНаСервере()
 
    Сообщить(
        ПолноеИмяПользователя()
    );
 
КонецПроцедуры
 
&НаКлиенте
Процедура РаботаСНастройкамиПользователей(Команда)
    РаботаСНастройкамиПользователейНаСервере();
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура РаботаСНастройкамиПользователейНаСервере()
 
    /// Как сохранить произвольные настройки пользователя
    /// в 1с 8.3, 8.2
 
    // сохраним в настройках имя и фамилию    
    Настройки = Новый Структура;
    Настройки.Вставить("Имя", "Владимир");
    Настройки.Вставить("Фамилия", "Милькин");
    Настройки.Вставить("Возраст", 31);
 
    ХранилищеОбщихНастроек.Сохранить(
        "Обработка.ТестированиеКода", // ключ объекта
        "Автор", // ключ настроек
        Настройки,
        , // описание настроек
        ИмяПользователя() // владелец настроек,
        // если опустить, то настройки сохранятся
        // для текущего пользователя
    );
 
    /// Как сохранить произвольные настройки для всех пользователей
    /// в 1с 8.3, 8.2
 
    Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
 
    Для Каждого Пользователь Из Пользователи Цикл
 
        ХранилищеОбщихНастроек.Сохранить(
            "Обработка.ТестированиеКода", // ключ объекта
            "Автор", // ключ настроек
            Настройки,
            , // описание настроек
            Пользователь.Имя // владелец настроек
        );
 
    КонецЦикла;    
 
    /// Как прочитать сохраненные настройки пользователя
    /// в 1с 8.3, 8.2
 
    // восстанавливаем сохраненные настройки
 
    ВосстановленныеНастройки = Неопределено;
    Попытка
        ВосстановленныеНастройки = 
            ХранилищеОбщихНастроек.Загрузить(
                "Обработка.ТестированиеКода", // ключ объекта
                "Автор", // ключ настроек
                , // описание настроек
                ИмяПользователя() // владелец настроек, если
                // опустить, то настройки прочитаются
                // для текущего пользователя
            );
        // если настроек нет, то будет возвращено значение "Неопределено"
    Исключение
        Сообщить("Что-то пошло не так..., возможно не хватает прав.");
    КонецПопытки;
 
    Если ВосстановленныеНастройки = Неопределено Тогда
        Сообщить("Не получилось прочитать настройки.");
    Иначе
        Сообщить(ВосстановленныеНастройки.Имя);
        Сообщить(ВосстановленныеНастройки.Фамилия);
        Сообщить(ВосстановленныеНастройки.Возраст);
    КонецЕсли;
 
    /// Как удалить сохраненные настройки пользователя в 1с 8.3, 8.2
 
    ХранилищеОбщихНастроек.Удалить(
        "Обработка.ТестированиеКода", // ключ объекта
        "Автор", // ключ настроек
        ИмяПользователя() // владелец настроек, пропускать нельзя
        // если указать Неопределено, то настрйка
        // удалиться у всех пользователей
    );
 
    /// Как удалить сохраненные настройки у всех пользователей в 1с 8.3, 8.2
 
    ХранилищеОбщихНастроек.Удалить(
        "Обработка.ТестированиеКода", // ключ объекта
        "Автор", // ключ настроек
        Неопределено // владелец настроек, пропускать нельзя
    );
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Как запустить 1С в режиме «Толстый клиент

Инструкция по запуску конфигураций на управляемых формах в режиме «Толстый клиент — Обычное приложение»

ДЛЯ ЧЕГО ЭТО НУЖНО

Запуск конфигураций 1С Предприятия на управляемых формах в режиме «Обычное приложение» требуется, если есть необходимость открыть обработку с обычной формой.

КАКИЕ КОНФИГУРАЦИИ РАБОТАЮТ НА УПРАВЛЯЕМЫХ ФОРМАХ

Это конфигурации такие как:
  • 1С Управление торговлей 11
  • 1С Управление нашей фирмой
  • 1С Розница 2
  • 1С Бухгалтерия 3
  • 1С ERP
  • 1C Комплексная 2

и другие интерфейс которых схож с указанными

КАК ЗАПУСТИТЬ 1С В РЕЖИМЕ ОБЫЧНОЕ ПРИЛОЖЕНИЕ

Запускаем 1С (окно списка баз)

В списке баз ставим курсор на базу которую нужно запустить в обычном режиме и жмем кнопку ИЗМЕНИТЬ

ДАЛЕЕ

Устанавливаем в поле «Дополнительные параметры запуска» ключ «/RunModeOrdinaryApplication» и жмем ГОТОВО

Запускаем 1С

1С в режиме «Обычное приложение»

Теперь можно открывать обработки на обычных формах

После работы с обработкой необходимо вернуть запуск 1С в управляемом режиме.
Для этого нужно убрать ключ «/RunModeOrdinaryApplication» в поле «Дополнительные параметры запуска»

Работа с операционной системой в 1С 8.3, 8.2

Главная страница » Каталог » Программистам » 1С Предприятие 8 » Работа с операционной системой в 1С 8.3, 8.2

Как запустить программу (приложение) и дождаться окончания её выполнения в 1с 8.3, 8.2

&НаКлиенте

Процедура ЗапуститьПриложениеИПодождать()

Перем КодВозврата;

Сообщить(«Запуск приложения»);

ЗапуститьПриложение(

«file.exe»,

«», // Каталог приложения

Истина, // Дождаться завершения работы приложения, которое запустили

КодВозврата // Код, возвращаемый программой

);

// Код, находящийся здесь, будет выполнен, после того, как пользователь закроет запущенное приложение

Сообщить («Приложение закрыто.»);

КонецПроцедуры

Как запустить программу (приложение), без ожидания окончания её выполнения в 1с 8.3, 8.2

&НаКлиенте

Процедура ЗапуститьПриложениеИНеЖдать()

Перем КодВозврата;

ЗапуститьПриложение(

» file.exe»,

«», // Каталог приложения

Ложь, // Дождаться завершения работы приложения, которое запустили

КодВозврата // Код, возвращаемый программой

);

// Код, находящийся здесь, будет выполнен, сразу после запуска приложения

КонецПроцедуры

Как открыть сайт в браузере по умолчанию в 1с 8.3, 8.2

&НаКлиенте

Процедура ОткрываемСайтВБраузереПоУмолчанию()

ЗапуститьПриложение(«https://okolokompa.ru»);

КонецПроцедуры

Как открыть сайт в Internet Explorer из 1с 8.3, 8.2

&НаКлиенте

Процедура ОткрываемСайтВInternetExplorer()

Shell = Новый COMОбъект(«WScript.Shell»);

ProgramFiles = Shell.ExpandEnvironmentStrings(«%PROGRAMFILES%»);

ЗапуститьПриложение(ProgramFiles + «\Internet Explorer\iexplore.exe https://okolokompa.ru»);

КонецПроцедуры

 

// ЕЩЁ

 

&НаКлиенте

Процедура ОткрываемСайтВInternetExplorer ()

КомандаСистемы(«start iexplore.exe http:// okolokompa.ru»);

КонецПроцедуры

Как открыть файл Word или Excel в 1с 8.3, 8.2

&НаКлиенте

Процедура ОткрываемWordИлиExcel()

ЗапуститьПриложение(«c:\документ.xlsx»);

ЗапуститьПриложение(«c:\документ.docx»);

КонецПроцедуры

Как открыть папку в проводнике Windows в 1с 8.3, 8.2

&НаКлиенте

Процедура ОткрываемПапкуВПроводнике()

Shell = Новый COMОбъект(«WScript.Shell»);

WindowsDir = Shell.ExpandEnvironmentStrings(«%WINDIR%»);

ЗапуститьПриложение(WindowsDir + «\explorer.exe «»C:\Наша папка»»»);

КонецПроцедуры

Как выделить нужный файл в проводнике в 1с 8.3, 8.2

&НаКлиенте

Процедура ВыделяемФайлВПроводнике()

Shell = Новый COMОбъект(«WScript.Shell»);

WindowsDir = Shell.ExpandEnvironmentStrings(«%WINDIR%»);

// открываем проводник с выделенным файлом

ЗапуститьПриложение(WindowsDir + «\explorer.exe /select,»»C:\Наша папка\Наш файл.exe»»»);

КонецПроцедуры

Как запустить приложение с параметрами в 1с 8.3, 8.2

&НаКлиенте

Процедура ЗапускаемПриложениеСПараметрами()

ЗапуститьПриложение(«C:\Windows\explorer.exe «»Параметры запуска»»»);

 

// ЕЩЁ

 

КомандаСистемы(«start explorer.exe «»Параметры запуска «»»);

КонецПроцедуры

Как выполнить команду операционной системы из приложения в 1с 8.3, 8.2

&НаКлиенте

Процедура ВыполняемКомандуОперационнойСистемы()

КомандаСистемы(

«ping 8.8.8.8», // Команда

«» // Текущий каталог

);

КонецПроцедуры

Как получить имя компьютера в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемИмяКомпьютера()

Сообщить(ИмяКомпьютера());

КонецПроцедуры

Как получить путь к каталогу исполняемых файлов в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемПутьККаталогуИсполняемыхФайлов1С()

// Выведет полный путь к папке bin из которой запущена 1с

Сообщить(КаталогПрограммы());

КонецПроцедуры

Как получить путь к каталогу временных файлов в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемПутьККаталогуВременныхФайлов()

Сообщить(КаталогВременныхФайлов());

КонецПроцедуры

Как получить путь к каталогу документов пользователя в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемПутьККаталогуДокументов()

Сообщить(КаталогДокументов());

КонецПроцедуры

Как получить информацию о мониторах (dpi, разрешение) в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемИнформациюОМониторах()

Для Каждого Монитор Из ПолучитьИнформациюЭкрановКлиента() Цикл

Сообщить(«DPI » + Строка(Монитор.DPI) + » Высота: » +

Строка(Монитор.Высота) + » Ширина: » + Строка(Монитор.Ширина));

КонецЦикла;

КонецПроцедуры

Как получить путь к рабочему каталогу данных пользователя в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемПутьКРабочемуКаталогуДанныхПользователя()

Сообщить(РабочийКаталогДанныхПользователя());

// Пример вывода

// C:\Users\Пользователь\AppData\Roaming\1C\1cv8t\..

// ..01c02859-1a28-4514-b595-2abdc95ebb97\071523a4-5..

// ..16f-4fce-ba4b-0d11ab7a1893\App\

КонецПроцедуры

Как узнать текущий язык системы в 1с 8.3, 8.2

&НаКлиенте

Процедура УзнаёмТекущийЯзыкСистемы()

Сообщить(ТекущийЯзыкСистемы()); // ru

КонецПроцедуры

Как получить список пользователей операционной системы в 1с 8.3, 8.2

&НаКлиенте

Процедура ПолучаемСписокПользователейОперационнойСистемы()

Для Каждого Пользователь Из ПользователиОС() Цикл

Сообщить(Пользователь.ИмяДомена + «: » +

Пользователь.ИмяСервера +» локальный (» +

Пользователь.Локальный + «)»

);

Для Каждого Имя Из Пользователь.Пользователи Цикл

Сообщить(»  » + Имя);

КонецЦикла;

КонецЦикла;

КонецПроцедуры


Вконтакте

Facebook

Twitter

Google+

Одноклассники

Мой мир

E-mail

Публикации

Приложение сервиса 1cfresh.com можно запустить на выполнение с помощью веб-браузера и с помощью тонкого клиента «1С:Предприятия».

Содержание

1. Запуск приложения сервиса с помощью браузера

Запустить приложение сервиса 1cfresh.com с помощью браузера можно:

  • на сайте сервиса;
  • с помощью прямой ссылки.

1.1. Запуск приложения на сайте сервиса

Чтобы запустить приложение на сайте сервиса, можно:

  1. Перейти на сайт сервиса: ввести в адресную строку браузера адрес сайта сервиса 1cfresh.com и нажать клавишу Enter (Ввод):

  2. Если сведения о вашей аутентификации в сервисе были сохранены (см. статью по ссылке), то вы сразу же войдете в сервис и в окно браузера будет выведена ваша страница Мои приложения.

    Иначе нужно ввести на начальной странице сайта 1cfresh.com ваши логин и пароль и нажать кнопку ВОЙТИ.

  3. На странице Мои приложения сайта сервиса щелкнуть мышью значок нужного приложения:

  4. Выбранное приложение будет запущено и с ним можно начать работать.

1.2. Запуск приложения с помощью прямой ссылки

Для запуска приложения сервиса с помощью прямой ссылки можно:

  1. Ввести адрес приложения («прямую ссылку») в адресную строку браузера:

  2. Нажать клавишу Enter (или Ввод).
  3. Если будет выведено окно аутентификации пользователя, нужно ввести в него логин и пароль в сервисе и нажать кнопку OK.

  4. Приложение будет запущено и с ним можно начать работать.

Чтобы получить прямую ссылку для запуска приложения, можно подвести указатель мыши к пиктограмме приложения на странице Мои приложения сайта сервиса и щелкнуть мышью появившийся рядом значок :

2. Запуск приложения с помощью тонкого клиента

Если на вашем компьютере установлен тонкий клиент «1С:Предприятия», то для запуска приложения сервиса 1cfresh.com можно:

  1. Запустить тонкий клиент. Например, в Windows для этого рекомендуется щелкнуть двойным щелчком мыши ярлык тонкого клиента на рабочем столе Windows.
  2. В выведенном окне Запуск 1С:Предприятия следует открыть группу 1cfresh.com, выделить в ней нужное приложение и нажать кнопку 1С:Предприятие.

  3. Если будет выведено окно c предложением обновить программу доступа, нужно нажать в нем кнопку Обновить и запустить:

  4. Если будет выведено окно аутентификации пользователя, нужно ввести в него логин и пароль в сервисе и нажать кнопку OK:

  5. Выбранное приложение будет запущено и с ним можно начать работать.

Об установке тонкого клиента и запуске приложений с помощью тонкого клиента рассказано в статьях:


См. также:

.net — C # — Application.Run ()

Переполнение стека
  1. Около
  2. Продукты
  3. Для команд
  1. Переполнение стека Общественные вопросы и ответы
  2. Переполнение стека для команд Где разработчики и технологи делятся частными знаниями с коллегами
  3. Вакансии Программирование и связанные с ним технические возможности карьерного роста
  4. Талант Нанимайте технических специалистов и создавайте свой бренд работодателя
  5. Реклама Обратитесь к разработчикам и технологам со всего мира
  6. О компании

Загрузка…

  1. Авторизоваться зарегистрироваться
  2. текущее сообщество

    • Переполнение стека Помогите болтать
    • Переполнение мета-стека
.

C # запустить приложение — qaru.

Переполнение стека
  1. Около
  2. Продукты
  3. Для команд
  1. Переполнение стека Общественные вопросы и ответы
  2. Переполнение стека для команд Где разработчики и технологи делятся частными знаниями с коллегами
  3. Вакансии Программирование и связанные с ним технические возможности карьерного роста
  4. Талант Нанимайте технических специалистов и создавайте свой бренд работодателя
  5. Реклама Обратитесь к разработчикам и технологам со всего мира
  6. О компании

Загрузка…

.

Что такое 1С: Предприятие?

Скачать обучающий курс «1С: Предприятие»
Посмотрите небольшой видеоурок о том, как разработать бизнес-приложение на платформе 1С: Предприятие.
Начните с создания первого бизнес-приложения на платформе 1С: Предприятие.

1С: Предприятие — это универсальная облачная и локальная система программ для автоматизации финансовой и более широкой операционной деятельности компании. «1С: Предприятие» обладает широкими возможностями для решения разнообразных задач современного бизнеса.Это достигается за счет «конфигурируемости» — возможности настраивать систему в зависимости от конкретных потребностей компаний и их бизнес-процессов.

1С: Предприятие — это больше, чем просто решение, автоматизирующее фиксированные бизнес-правила. Скорее, это набор программных инструментов, используемых разработчиками и пользователями. Систему можно логически разделить на два основных компонента, которые тесно взаимосвязаны: приложение и платформа, на которой выполняется приложение.

Чтобы объяснить взаимосвязь между системными компонентами 1С: Предприятия, сравним его с плеером Blu-ray.Хорошо известно, что плеер необходим для просмотра видео, прослушивания музыки или воспроизведения другого медиаконтента. Blue-ray является стандартным, но он отвечает самым разнообразным потребностям клиентов благодаря широкому ассортименту дисков с видео или музыкой на любой вкус.

Чтобы посмотреть видео, вам нужно вставить диск Blu-ray в проигрыватель, и проигрыватель будет воспроизводить контент (видео), который на нем записан. Кроме того, проигрыватели Blu-ray позволяют записывать собственный контент, то есть создавать новый диск Blu-ray с домашним видео.

Сам по себе проигрыватель бесполезен без диска Blu-ray, и точно так же диск Blu-ray бесполезен без проигрывателя (за исключением, возможно, подставки для чашки с кофе). Возвращаясь к 1С: Предприятию, можно сказать, что платформа — это своего рода «плеер», а приложение — это «диск». Платформа позволяет запускать приложение, а также изменять его или создавать новое. Платформа единая (1С: Предприятие 8), но можно создавать неограниченное количество приложений.Для запуска приложения у вас всегда должны быть и платформа, и само приложение (см. Диаграмму выше). Платформа не выполняет никаких задач автоматизации самостоятельно, так как ее цель — предоставить среду для разработки и запуска приложений. То же самое и с приложением: для его работы требуется Платформа 1С: Предприятие.

Платформа 1С: Предприятие дает следующие преимущества:

  • Значительно снижает технологическую сложность, эргономику и производительность корпоративных программных систем.
  • Позволяет опытным пользователям внедрять определенные бизнес-процессы.
  • Ускоряет и стандартизирует разработку, настройку и поддержку бизнес-приложений.
  • Обеспечивает полную открытость пользовательского интерфейса и кода решения, что позволяет лучше понимать и изменять бизнес-процессы.
  • Готова к интеграции с существующими приложениями 1С и сторонними системами.
  • Поддерживает веб-сервисы, ODBC, COM и так далее.
  • Поддерживает предпочитаемую архитектуру: Windows / Linux, MS SQL, PostgreSQL, IBM DB2 и Oracle DB.
  • Включает локальный или управляемый хостинг через Интернет, а также через Интернет, планшет или клиент Windows.

Система программ «1С: Предприятие»

Прикладная система «1С: Предприятие» ежедневно используется несколькими миллионами пользователей в бизнесе и правительстве для автоматизации операций, бухгалтерского учета, финансов, управления персоналом и управления.Компания 1С предоставляет ряд вертикальных решений для производственного, сбытового и сервисного бизнеса. Благодаря своей инновационной технологической платформе и множеству прикладных решений компания «1С» добилась широкой популярности благодаря своей открытости, скорости модификации и обновления программного обеспечения. «1С: Предприятие» — очень гибкая и масштабируемая платформа, отвечающая потребностям компаний размером от одного пользователя до сотен пользователей.


1С: Предприятие — это система приложений, включающая Платформу и Прикладные решения (готовые приложения).

Отличие платформы от применяемых решений простое: платформа, как следует из названия, поддерживает все применяемые решения. Платформа по сути стоит особняком, а прикладных решений много. Компания 1С и ее партнеры постоянно внедряют новые прикладные решения.

Преимущество такой платформы — повышение абстрактности программной системы. Платформа решает все задачи, связанные с технологической сложностью, производительностью, эргономикой и так далее.

1С: Предприятие позволяет:

  • Адаптируйте систему программного обеспечения к конкретному языку пользователей и экспертов в соответствующей предметной области.
  • Ускорьте и стандартизируйте разработку прикладных решений, а также их внедрение, настройку и обслуживание.
  • Разрешить клиентам видеть все алгоритмы применяемого решения и при необходимости изменять их.

Платформа 1С: Предприятия состоит из следующих частей:

  • Уровень данных / процессов, который предоставляет системные функции, такие как поддержка различных баз данных, сервера приложений, компонентов веб-сервера и компонентов веб-служб.
  • Business Components — предопределенные визуально настраиваемые строительные блоки (шаблоны), которые широко используются в корпоративных приложениях — каталогах, документах, регистрах накопления, механизме бухгалтерского учета, механизме вычислений и механизме бизнес-процессов.

На приведенной выше диаграмме бизнес-приложения показаны примеры использования для:

  • Каталоги — хранение списков клиентов, товаров и так далее.
  • Документ — бизнес-события, такие как заказы на закупку, заказы на продажу или счета-фактуры.
  • Регистр накопления — накопление проводок документов, например, дебиторская задолженность или банковский регистр.
  • Механизм учета — проводка бухгалтерских документов — обычно используется для создания специализированных регистров, а также главной книги.
  • Calculation engine — расчет заработной платы.
  • Бизнес-процесс — используется во всей системе.
Использование бизнес-компонентов значительно снижает стоимость разработки корпоративных приложений, поскольку позволяет компании сосредоточиться только на реализации своих конкретных бизнес-процессов, а не создавать базовые бизнес-функции с нуля.
На схеме ниже представлена ​​общая архитектура решения 1С, состоящая из платформы и приложений.
  • Платформа — состоит из сервера приложений, бизнес-компонентов (визуально настраиваемые строительные блоки) и среды IDE.
  • Бизнес-приложения, работающие на платформе — Компания 1С предоставляет решения для малого и среднего бизнеса — 1С: Бухгалтерия; а для корпоративных клиентов — ERP / MRP, HR, логистика, финансовая консолидация и так далее.Компания 1С и ее партнерская сеть также предлагают вертикальные решения для многих отраслей.

В следующей таблице приведены технологии и инструменты, входящие в 1С: Предприятие.

Следующая страница: Начало работы

.

Как заставить приложение C # .net запускать только один экземпляр в Windows?

Переполнение стека
  1. Около
  2. Продукты
  3. Для команд
  1. Переполнение стека Общественные вопросы и ответы
  2. Переполнение стека для команд Где разработчики и технологи делятся частными знаниями с коллегами
  3. Вакансии Программирование и связанные с ним технические возможности карьерного роста
  4. Талант Нанимайте технических специалистов и создавайте свой бренд работодателя
  5. Реклама Обратитесь к разработчикам и технологам со всего мира
  6. О компании

Загрузка…

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *