Разное

Bgp настройка mikrotik: Настройка BGP на маршрутизаторах Микротик

Настройка BGP на маршрутизаторах Микротик

Настройка интерфейса BGP

Разберемся как настроить BGP на маршрутизаторах Микротик, допустим нам нужно анонсировать сеть 212.45.0.0/24, наша автономная система AS20111. Подключаемся к маршрутизатору через winbox.  Переходим на вкладку Routing-BGP. В открывшемся окне выбираем вкладку Interfaces.

Кликаем два раза по интерфейсу default, если этого интерфейса нет, то создаем его нажав кнопку «+»-добавить.

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Заполняем поля как показано на картинке.

Name – название интерфейса, по умолчанию default

AS – номер нашей автономной системы

Router ID – IP адрес маршрутизатора Mikrotik

Ставим галочки Redistribute Connected, Redistribute-static, client-to-client-reflection

Обозначение остальных полей

Redistribute Connected – при включении  через это  соединение  будет распространяться информацию о подключенных маршрутах, т. е. маршрутах к сетям, к которым наш маршрутизатор может обратиться напрямую..

Redistribute-static при включении через это соединение будет распространяться информацию о статических маршрутах, т. е. маршрутах прописанных на нашем роутере,  раздел  ip -> routes

Redistribute-RIP – при включении через  интерфейс  BGP будет анонсировать информацию о маршрутах полученных через RIP

Redistribute-OSPF — при включении  через  интерфейс  BGP будет анонсировать информацию о маршрутах полученных через  ospf

Redistribute-Other-BGP – при включении  через интерфейс  BGP будет анонсировать информацию о маршрутах полученных через другое BGP соединение.

Out Filter — Цепочка фильтра маршрутизации вывода, используемая всеми одноранговыми узлами BGP, принадлежащими этому экземпляру

Confederation – Если используется конфедерация  BGP здесь  указываем номер автономной системы, который идентифицирует [локальную] конфедерацию в целом.

confederation-peers — Если используется конфедерация  BGP здесь указываем  список номеров автономных систем, внутренних для локальной конфедерации. Также поддерживаются диапазоны чисел. Например, 10,20,30-50.

Cluster ID – Идентификатор кластера, используется если этот интерфейс BGP является рефлектором маршрута.

Routing Table – название таблицы маршрутизации, в которой работает этот интерфейс  BGP

Создание фильтров BGP

Следующим шагом создадим фильтры для нашего BGP соединения. Нам нужно создать два типа фильтра, входящий и исходящий, в первом мы запретим посылать в нашу автономную систему префиксы извне нашей собственной сети, а так же другие не нужные префиксы, в исходящем фильтре мы запретим отправлять наружу все префиксы кроме нашего.

Создаем фильтры на вход. Нам нужно запретить следующие префиксы.

Все частные сети 10.0.0.0/8, 192.168.0.0/16 и 172.16.0.0/12

Канальные сети 169.254.0.0/16

Сеть многоадресной рассылки 224.0.0.0/4

Резервную сеть 240.0.0.0/4

Внутрикоммуникационную подсеть  127.0.0.0/8

А так же, нашу собственную сеть 212.45.0.0/24

Переходим на вкладку Routes-Filter и  нажимаем кнопку добавить.

 

Chain – цепочка правил для автономной системы партнера, если номер автономной системы партнера 2222 то здесь пишем AS2222-bgp-in

Prefix – префикс подсети прием с которой нам необходимо запретить

Далее переходим на Вкладку Actions (действие) и выбираем discard (запретить)

После чего нажимаем «OK»

Таким же образом создаем правила для следующих префиксов

После создания запрещающих правил, создаем правило разрешающее обращение к нашей AS со всех других сетей. Для этого в chain выбираем AS2222-bgp-in

Action ставим accept

Следующим шагом создадим фильтры для цепочки OUT, В ней запретим анонсировать наружу все сети кроме нашей .   Для начала создаем разрешающее правило для префикса 212.45.0.0/24. Нажимаем кнопку добавить правило.

Chain – для автономной системы 2222 будет AS2222-bgp-out

Prefix – префикс нашей сети 212.45.0.0/24

На вкладке Actions выбираем accept

И последним создаем запрещающее правило на анонсирование всех префиксов.

В результате всех действий должен получится список фильтров как на рисунке.

 

Настройка провайдера  BGP

Снова открываем пункт Routing-BGP, открываем вкладку Peers,  нажимаем кнопку добавить.

Заполняем поля как показано на рисунке

Name – название провайдера

Instance – интерфейс  BGP созданный на первом шаге, если у нас подключение к нескольким провайдерам, то соответственно здесь выбираем нужный нам интерфейс.

Remote AS – Автономная система партнера.

In Filter, Out Filter — фильтры созданные на втором шаге соответственно

Жмем ОК. Если все сделано правильно то в колонке state должен появиться статус  established? Установлено.

Для подключения более одного провайдера, нужно проделать все три шага для каждого

  1. Создать интерфейс
  2. Создать фильтры
  3. Создать Peer.

Обучающий курс по настройке MikroTik

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

OSPF Mikrotik. Полная инструкция по настройки OSPF на Микротик

OSPF (англ. Open Shortest Path First) — протокол динамической маршрутизации, основанный на технологии отслеживания состояния канала (link-state technology) и использующий для нахождения кратчайшего пути алгоритм Дейкстры.  В статье подробно рассмотрены различные  настройки OSPF на маршрутизаторах Mikrotik. Вся конфигурация  будет производится через GUI Winbox.

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Настройка OSPF c одной областью

Рассмотрим,  как настроить сеть OSPF c одной областью. Предположим, у нас есть следующая схема.

В примере сеть  состоит из трех маршрутизаторов mikrotik, соединенных вместе одним адресным пространством  10.10.1.0/24, и каждый маршрутизатор имеет еще по одной подключенной сети.

В этом примере на маршрутизаторах настроены следующие IP-адреса:

R1

Ether1-10.10.1.1/30

Ether2-10.10.1.5/30

Ether3-210.13.1.0/28

R2

Ether1-10.10.1.6/30

Ether2-10.10.1.9/30

Ether3-172.16.1.0/16

R3

Ether1-10.10.1.2/30

Ether2-10.10.1.10/30

Ether3-192.168.1.0/24

Конфигурация  OSPF осуществляется следующими основными шагами

  1. Настроить router-id
  2. Конфигурация области
  3. Конфигурация сети

Настройка router-id

Настраиваем маршрутизатор Микротик  R1

Переходим в меню Routing – OSPF вкладка  Instances. Здесь должен быть уже созданный экземпляр default , если его нет, то создаем.

Аналогично создаем экземпляры на всех остальных маршрутизаторах.

В консоли эти команды такие

R1:
[[email protected]] /routing ospf instance> add name=default

R2:
[[email protected]] /routing ospf instance> add name=default

R3:
[[email protected]] /routing ospf instance> add name=default

Как видно, router-id равен 0.0.0.0, это означает, что маршрутизатор будет использовать один из IP-адресов роутера  в качестве идентификатора маршрутизатора. В большинстве случаев рекомендуется настроить loopback интерфейс как идентификатор маршрутизатора. IP-адрес Loopback интерфейса является виртуальным, программным адресом, который используется для идентификации маршрутизатора в сети. Преимущества в том, что loopback-адрес всегда активен  и не может быть недоступен как физический интерфейс. Протокол OSPF использует его для связи между маршрутизаторами, идентифицированными  router-id.

Настроим loopback, для этого заходим в меню interfaces т  добавляем новый интерфейс, выбираем bridge

Делаем настройки как показаны на рисунке.

Напишем только имя loopback после чего нажимаем OK.

Следующим шагом, настраиваем ip адрес на интерфейсе. Для роутера R1 настроим ip 10.255.255.1/32

Настраиваем router-id как loopback. Для этого идем в routing — ospf, вкладка instance/ Выбираем наш экземпляр default,  В поле router-id, вписываем ip адрес loopback интерфейса,  10.255.255.1

Аналогичные настройки делаем на остальных маршрутизаторах R2 и R3

Консоль

[[email protected]] /interface bridge> add name=loopbackip address add address=10.255.255.1/32 interface=loopback /routing ospf instance> set 0 router-id=10.255.255.1

Настройка области OSPF

Переходим к конфигурации  области. Область backbone уже создана и дополнительной настройки не требуется.

«Обратите внимание что область backbone area-id должна быть 0.0.0.0»

Настройка Сети

Открываем меню Routing-OSPF вкладка Network,  Нажимаем кнопку добавить

В поле Network, прописываем сеть, Area выбираем backbone. Для роутера R1 прописываем адресацию в соответствии со схемой 10.10.1.0/30, 210.13.1.0/28 и 10.10.1.4/30. В результате должна получиться следующая картина

Консоль

[[email protected]] /routing ospf network> add network=210.13.1.0/28 area=backbone
[[email protected]] /routing ospf network> add network=10.10.1.0/30 area=backbone
[[email protected]] /routing ospf network> add network=10.10.1.4/30 area=backbone

В принципе,  для префиксов 10.10.1.0/30 и 10.10.1.4.30 можно было прописать 10.10.1.0/24, тогда получилось бы так

Аналогично настраиваем R2

R3

 

Консоль

R2:
[[email protected]] /routing ospf network> add network=172. 16.1.0/16 area=backbone
[[email protected]] /routing ospf network> add network=10.10.1.0/24 area=backbone

R3:
[[email protected]] /routing ospf network> add network=192.168.1.0/24 area=backbone
[[email protected]] /routing ospf network> add network=10.10.1.0/24 area=backbone

На этом конфигурация  OSPF завершена. Если все сделано правильно, то на вкладке OSPF  Interfaces должны появиться интерфейсы, а на вкладке Routes маршруты.

многозонная конфигурация OSPF

Настроим OSPF c несколькими областями как показано на рисунке.

Главной считается корневая (backbone area), имеющая номер 0 именно с ней мы работаем, когда настраиваем OSPF для одной зоны. В случае использования нескольких зон, использование корневой зоны обязательно, остальные же зоны подключаются к ней и называются regular area. Это означает, что мы имеем двухуровневую иерархию: корневая зона и все остальные.

Настраиваем экземпляры и ip адреса как делали это выше. Дальше нам нужно создать области.

Для маршрутизатора R1. Заходим в Routing-OSPF вкладка Areas, нажимаем кнопку добавить и добавляем новую область area1 c Area ID 0.0.0.1

Настраиваем префиксы в соответствии с нашей схемой

Область backbone

Область Area1

Должно получиться следующее

Консоль

/routing ospf area> add name=area1 area-id=0.0.0.1
/routing ospf area> ..
/routing ospf> network
/routing ospf network> add network=10.0.1.0/24 area=backbone
/routing ospf network> add network=10.1.1.0/30 area=area1

Конфигурация маршрутизатора R2

 

По такой же схеме настраиваем R3,R4.

Консоль

R2:
/routing ospf area> add name=area2 area-id=0.0.0.2
/routing ospf area>..
/routing ospf> network
/routing ospf network> add network=10.0.1.0/24 area=backbone
/routing ospf network> add network=10. 1.2.0/30 area=area2

R3:
/routing ospf area> add name=area1 area-id=0.0.0.1
/routing ospf area> ..
/routing ospf> network
/routing ospf network> add network=10.1.1.0/30 area=area1

R4:
/routing ospf area> add name=area2 area-id=0.0.0.2
/routing ospf area> ..
/routing ospf> network
/routing ospf network> add network=10.1.2.0/30 area=area2

Настройка маршрутов

После настройки всех роутеров проверим таблицу маршрутизации. Подключимся к роутеру R3 и дадим команду в консоли

ip route print

Вывод будет

[[email protected]] > ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 1 ADo  10.0.1.0/24                        10.1.1.1           110
 2 ADC  10. 1.1.0/30         10.1.1.2       ether1             110    
 3 ADo  10.1.2.0/30                        10.1.1.1           110       
 4 ADC  192.168.1.0/24      192.168.1.1    ether2             0

Как видно, удаленные сети 172.16.0.0/16 и 192.168.2.0/24 не входят в таблицу маршрутизации, поскольку они не распространяются OSPF. Функция перераспределения позволяет различным протоколам маршрутизации обмениваться информацией о маршрутизации, что позволяет, например, перераспределять статические или связанные маршруты в OSPF. В нашей настройке нам необходимо перераспределить подключенную сеть. Нам нужно добавить следующую конфигурацию на маршрутизаторах R1, R2 и R3.

Заходим в меню Routing – OSPF, вкладка instance, кликаем 2 раза экземпляру default b меняем Redistribute Connected Routes на as type 1

Или даем команду в консоли

[[email protected]] /routing ospf instance> set 0 redistribute-connected=as-type-1

Теперь проверьте маршрутизатор R3, чтобы узнать, установлены ли в таблице маршрутизации маршруты 192. 168.2.0/24 и 172.16.0.0/16.

[[email protected]] > ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 1 ADo  10.0.1.0/24                        10.1.1.1           110
 2 ADC  10.1.1.0/30         10.1.1.2       ether1             110     
 3 ADo  10.1.2.0/30                        10.1.1.1           110
 4 ADo  172.16.0.0/16                      10.1.1.1           110       
 5 ADC  192.168.1.0/24      192.168.1.1    ether2             0 
 6 ADo  192.168.2.0/24                     10.1.1.1           110

Настройка OSPF в NBMA сетях

NBMA ( Non-Broadcast Multiple Access)  сеть с множеством (больше двух) устройств  без широковещания, в которой не работает протокол ARP, так как в ней отключена широковещательная передача данных. В таких сетях вместо протокола ARP используется протокол NARP. Примером таких сетей является NBMA — Frame Relay.

Бывают ситуации когда для настройки OSPF предпочтительными являются сети  NMBA  например

  • в беспроводных сетях доставка мультикастовых пакетов не всегда надежна и использование multicast здесь может создать проблемы стабильности OSPF;
  • использование мультикастовой передачи может быть неэффективным в сетях с мостовой или ячеистой топологии (т. е. широковещательных доменах с большим уровнем 2)

Приступим к настройки по данной схеме

R1. Создаем экземпляр

Настраиваем ip адрес на интерфейсе

По аналогии делаем настройки на R2,R3,R4. Только router-id и ip адрес у каждого будет свой.

На R2
router-id=0.0.0.2
ip=10.1.1.2/24

На R3
router-id=0.0.0.3
ip=10.1.1.3/24

 

На R4
router-id=0.0.0.4
ip=10.1.1.4/24

В консоли

На R1 
/routing ospf instance add name=ospf1 router-id=0. 0.0.1
/ip address add address=10.1.1.1/24 interface=ether1 network=10.1.1.0

На R2
/routing ospf instance add name=ospf1 router-id=0.0.0.2
/ip address add address=10.1.1.2/24 interface=ether1 network=10.1.1.0

На R3
/routing ospf instance add name=ospf1 router-id=0.0.0.3
/ip address add address=10.1.1.3/24 interface=ether1 network=10.1.1.0

На R4
/routing ospf instance add name=ospf1 router-id=0.0.0.4
/ip address add address=10.1.1.4/24 interface=ether1 network=10.1.1.0

В примере только маршрутизаторам C и D разрешено назначать маршруты.

Следующим шагом настраиваем префикс  10.1.1.0/24 в backbone. Заходим на вкладку Networks и нажимаем кнопку добавить, добавляем сеть.

Далее заходим на вкладку NBMA neighbor жмем добавить, и создаем четыре  правила

Делаем аналогично для адреса 10.1.1.1 и 10.1.1.2 priority=0, а для адресов 10.1.1.3 и 10.1.1.4 priority=1

В итоге должно получиться следующее

Обратите внимание, что у адресов 10. 1.1.3 и 10.1.1.4, т.е маршрутизаторов R3 и R4 Priority = 1.

То же самое через консоль

routing ospf network add network=10.1.1.0/24 area=backbone
routing ospf nbma-neighbor add address=10.1.1.1 priority=0
routing ospf nbma-neighbor add address=10.1.1.2 priority=0
routing ospf nbma-neighbor add address=10.1.1.3 priority=1
routing ospf nbma-neighbor add address=10.1.1.4 priority=1

Эти же настройки делаем на остальных трех роутерах.

Настраиваем приоритеты на роутерах A и B. Добавляем новый интерфейс

Interface – интерфейс для OSPF

Priority = 0

Network Type ставим nbma

Консоль

routing ospf interface add interface=ether1 network-type=nbma priority=0

На маршрутизаторах C, D (они могут стать назначенным маршрутизатором):

Консоль

routing ospf interface add interface=ether1 network-type=nbma priority=1

На этом настройка OSPF завершена.

Обучающий курс по настройке MikroTik

Нужно разобраться с MikroTik, но не определились с чего начать? В курсе «Настройка оборудования MikroTik» все по порядку. Подойдет и для начала работы с этим оборудованием, и для того, чтобы систематизировать знания. Это видеокурс из 162 уроков и 45 лабораторных работ, построен на официальной программе MTCNA. Проходить можно, когда удобно и пересматривать по необходимости – материалы курса выдаются бессрочно. Также есть 30 дней на личные консультации с автором. На пробу выдают 25 уроков бесплатно, заказать их можно на странице курса.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

MikroTik для Больших Дядей N5

MikroTik для Больших Дядей (Задание 5)

Пятая часть.

Освежим в памяти схему сети.

Подведём небольшой итог всего того, чего мы добились.

На данный момент у нас работает MPLS и прохождение пакета стало быстрее, из за того, что трафик не стал заходить в процесс обычной маршрутизации, а подвергается процессу маршрутизации с помощью протокола MPLS на основании меток.

Когда маршрутизатор добавляет метку к пакету, такая процедура называется push. Метка добавляется между заголовков IP и ethernet именно поэтому MPLS называют протоколов уровня L2.5 OSI.

Ниже анимация формирования пакета MPLS.

Нечего интересного в данном процессе нет, просто добавили к пакету метку, не более чем. А вот дальнейший процесс будет показывать нагляднее почему MPLS выигрывает у обычного процесса IP маршрутизации.

Взгляните на процес forward при работающим MPLS. Процесс IP маршрутизации не происходит как такового. Так как до него просто пакет не доходит. Из таблицы forward MPLS маршрутизатор сверил метку 5000, понял, что её надо поменять на 8888 сменил метку (SWAP) и отправил next-hop-у.

Снятие метку называется процедура POP, процесс сложнее о нём мы поговорим немного позже. Так как снятие происходит, не на последнем маршрутизаторе, а на предпоследним, и само сняти не всегда приводит конкретно к снятию метки, а к изменению метки на специальные номера, те самые которые зарезервированные от 0 до 15.

Скорее всего появился вопрос «что нам дал MPLS», ну в первую очередь конечно ускорение процесса маршрутизации и всё! Сам MPLS в чистом виде, не так очевиден и зачастую не используется в том виде как это сделано сейчас у нас. Но появляется возможность использовать такие технологии как PW он же VPLS, а также VPN4

VPLS — это туннель, которые позволяет, пропустить через себя ethernet трафик, т.е для того чтобы предоставить услугу L2 VPN, по сути аналогичную роль в RouterOS выполняет EoIP туннель.

VPN4 — это способ доставки IP пакета, через MPLS сеть, т.е предоставление клиенту услуги L3 VPN, но самое главное, что клиент может использовать любые сети, и они не как не будут влиять на ваши сети и сети других ваших клиентов.

Но мы же провайдер, поэтому ручной метод нам не подходит, мы бы хотели всё и вся оптимизировать.

BGP

Перед тем как начать, настраивать BGP нам надо осознать, что всё что мы до этого делали, необходимо было для работы в BGP между Loopback адресами.

Уточним задачу, у нас есть клиент под Котору необходимо предоставить услуги L2VPN, между двумя маршрутизаторами CE.

И так нам необходимо связать два маршрутизатора CE с помощь протокола BGP и указать чем будет заниматься BGP протокол. Напомню, что он может распространять не только маршрутную информацию но и распространять дополнительную информацию, именно эту дополнительную информацию мы будем распространять.

Точно также как и в OSPF у BGP маршрутизатора есть RouterID значение должно быть уникальным в пределах одной AS.

AS — автономная система, помимо того что это номер 16 бит, а сейчас и все 32 бита, это ещё и политическая сущность, которая определяет, маршрутизаторы которые находятся в одной AS подчиняются одним правилам.

Для наших задач мы будем использовать отдельный instance и номер автономной системы 65000. Необходимо напомнить что диапазон номеров AS разделён на две части приватный и публичный, примерно также как и BOGON адреса, только есть одно серьёзное отличие, эти диапазоны намертво вшиты в протокол и его реализацию в RouterOS, поэтому вы ОБЯЗАНЫ использовать именно из приватного диапазона номера AS от 64512 до 65535. Публичный диапазон только если у вас есть своя AS либо на стендах когда вы делаете «один к одному».

И так сначала нам необходимо на CE маршрутизаторах создать BGP instance

/routing bgp instance add router-id=172.31.253.2 as=65000 name=bgp65000

Следующим шагом, нам необходимо связать два маршрутизатора, с помощью настроенных пиров BGP с двух сторон.

Давайте посмотрим на команду и распишем, какие параметры bgp Peer и для чего они нужны, не все, а только те который нам необходимы.

/routing bgp peer add address-families=l2vpn,l2vpn-cisco,vpnv4 instance=bgp65000 name=CE-2 remote-address=172.31.253.2 remote-as=65000 update-source=172.31.253.1

remote-address=172.31.243.2 — Указываем адрес противоположенного пира.

update-source=172.31.253.1 — Указываем адрес с которого будет строиться соединение, тут надо уточнить. Вы можете указать не адрес, а интерфейс, но если на интерфейс будет несколько IP адресов может произойти факап.

remote-as=65000 — Удалённая AS, если её номер совпадает с instance указанным в instance=bgp65000 то такое соединение считается как iBGP internal т.е. Внутренним. Если значения AS разные то такое поведение называется eBGP т.е. Внешнее соединение.

address-families=l2vpn,l2vpn-cisco,vpnv4 — так называемые типы данных которые будут передаваться с помощью данного пира BGP.

После того вы сделаете на всех маршрутизаторах, проверить то, что мы идём по верной дороге и всё у нас получается. Узнать состояние Peer

[[email protected]] > /routing bgp peer print 
Flags: X - disabled, E - established 
 #   INS.. REMOTE-ADDRESS                               REMOTE-AS  
 0 E bgp.. 172.31.253.2                                 65000 

Состояние соединения должно быть Established, слево флаг E.

VLPS

Когда мы строим VPLS то у пакета появляется не одна метка, а две (стек меток), первая метка обеспечивает прохождение трафика по MPLS сети, вторая метка указывает непосредственно на PW туннель.

Для того, чтобы запустить нашу «Трубу» или PW нам необходимо подготовить инфраструктуру. Надеюсь вы помните, что CE маршрутизатор, это тот маршрутизатор к которому подключается непосредственно клиенты.

Нам необходимо подготовить Bridge в порты которого будут присоединено оборудование клиента, также можно сделать и с vlan. Мы не будем добавлять интерфейсы нам достаточно для понимания самого принципа построения таких сетей.

И так необходимо создать Bridge c отключенным rstp\stp, мы не будем мешать нашему клиенту делать петли, если ему надо будет делает петли, пусть делает это его желание )), наша задача предоставить ему L2 туннель между точками включения на маршрутизаторах CE.

/interface bridge add name=bridge-C1 protocol-mode=none

Название бриджа позаимствовано из вымышленного номера договора либо какого-то внутренного номера. Пусть будет клиент под номером 1.

Далее нам необходимо объявить через BGP на CE маршрутизаторах VPLS туннели.

/interface vpls bgp-vpls add bridge=bridge-C1 bridge-horizon=10 export-route-targets=65000:1 import-route-targets=65000:1 name=C0001 pw-type=raw-ethernet route-distinguisher=172.31.253.1:0 site-id=1001

route-distinguisher=172.31.253.1:0 — Уникальное значение для каждого маршрутизатора, и в некоторых случаях может быть для уникальное значение для разных ролей. С помощью данного значения создаётся уникальность информации которая передаётся средствами BGP. Лучше всего укажите адрес loopback и просто порядковый номер, пока это неважно.

bridge=bridge-C1 — Когда VPLS поднимется, то интерфейс добавится автоматически в Bridge нашего клиента.

bridge-horizon=10 — технология которая позволит нам поднять fullmesh связь между все маршрутизаторами и защититься от возможной петли, если не указать, то она будет 100% при подключении следующего маршрутизатора. Смысл технологии очень простой если фрейм придёт в интерфейс Bridge, и у интерфейса с которого пришло фрейм установлено значение horizon, такой фрейм не будет отправлен в интерфейсы у которых значение horizon аналогичное. Будте пределы аккуратны, если на Bridge будет отключен rstp/stp и вы не установите значение horizon у вас будет L2 Loop.

pw-type=raw-ethernet — указываем какого типа PW.

site-id=1001 — уникальное значение, для всей AS и для каждого маршрутизатора. Тут надо быть внимательным, необходимо найти такой способ, чтобы сделать это значение с двух стороны уникальным и это значение не должно больше использоваться. Лучше все использовать такой подход, берём номер маршрутизатора умножаем на 1000 и прибавляем номер клиента. Получается, что значение site-id на первом маршрутизаторе будет для первого клиента 1001, а для второго 1002, на маршрутизаторе CE-3 3001 и соответственно 3002. Уникальность значения требуется из за того, что значение site-id используется для расчёта номера метки MPLS, но просто давать порядковые номера не очень удобно, в виду того, что придёться вести где-то документацию. Я несколько не призываю отказываться от документации, но всегда можно упростить себе жизнь прибегая к определённым шаблонам.

А наверное самое главное.

export-route-targets=65000:1 — хорошим кейсом (Вообще так и задумывалось, но некоторые игнорируют даней аспект) считается указывать сначала номер AS, а далее через разделитель двоеточие, номер клиента. Чтобы понять для чего этот параметр необходим, это уникальный идентификатор данного туннеля. Ключевое слово export т.е. Данный маршрутизатор будет «вещать» раскатывать всем своим пирам, о том что у него есть такой туннель VPLS. На стороне клиента данное значение должно быть указанно в поле import-route-targets.

import-route-targets=65000:1 — тип записи который мы ожидаем для сопоставления с данным VPLS туннелем, часто мы должны указать значение которое указанно на противоположенной стороне в export-route-targets.

Задачи

  • Создать BGP instance на CE маршрутизаторах. AS 65000
  • Создать BGP Peer на двух CE маршрутизаторах. FullMesh
  • Создаёте Bridge для нашего клиента.
  • Опубликуйте через BGP VPLS туннели на CE маршрутизаторах.
  • Чтобы закрепить результат
    • Необходимо к маршрутизатору PE-1 подключить ещё один CE маршрутизатор CE-3.
    • К маршрутизатору CE-1 подключен только клиент C1
    • К маршрутизатору CE-2 подключены клиенты C2 и С3
    • К маршрутизатору CE-3 подключены клиенты C2 и С3

Итого у нас есть два клиента C1 и C2

Следующий пост с заданием MikroTik для Больших Дядей (Задание 6)

Рассказать друзьям

Чатик телеграм

Настройка динамической маршрутизации по протоколу BGP :: Настройка оборудования Mikrotik :: Настройка оборудования

BGP (Border Gateway Protocol), это протокол динамической маршрутизации, предназначенный, главным образом, для обмена информацией о маршрутах между автономными системами. Именно на этом протоколе и построены все основные связи между отдельными сегментами в глобальной сети Интернет.

Для лучшего понимания, давайте сперва разберемся с некоторой терминологией, которая, в дальнейшем, поможет нам более четко осознать, что и для чего мы будем делать.

PI IP (Provider Independent IP) – это провайдеро-независимые IP адреса. Которые выделяются для подключения к сети интернет и имеют свою собственную независимую маршрутную политику.

Автономная система (AS) – это одна или несколько сетей, имеющих одну политику маршрутизации. AS, как уже было сказано, это основной элемент BGP маршрутизации и всей глобальной сети.

Как зарегистрировать свою собственную AS, и получить диапазон PI IP, в этой статье мы, по понятным причинам, рассматривать не будем. Мы сразу предположим, что мы являемся администраторами сети определенного предприятия, и у нас есть своя подсеть белых IP адресов и своя автономная система, для регистрации которой необходимо предоставить данные, о как минимум двух партнёрах, с которыми будет производиться обмен информацией о маршрутах. Это, как правило, провайдеры, каналы которых, вы будите использовать для подключения к сети интернет. Поэтому и рассматривать настройку оборудования, мы будем исходя из двух смежных автономных систем.

Рис.1. Протокол BGP

Итак, предположим, что наша автономная система – AS12345

Наша сеть, которую мы должны анонсировать в Интернет – 59.134.40.0/21

IP адрес нашего роутера 192.168.13.25

Наш партнер №1 (ISP1) имеет AS21212

IP адрес ISP1 – 192.168.13.1

Партнер №2 (ISP2) имеет AS34345

IP адрес ISP2 – 192.168.200.100

Производить настройку будем через утилиту Winbox. А начнём настройку с глобального процесса протокола BGP.

Для этого переходим в раздел меню Routing -> BGP, где на вкладке Instances, заходим в свойства записи default. Если такой записи нет, то добавляем её.

Name – имя записи. По умолчанию – default.

AS — наша автономная система

Router ID – IP адрес нашего роутера.

Так же ставим галочки возле параметров Redistribute Connected и Redistribute Static.

Рис.2. Настройка глобального процесса BGP

Теперь мы должны сделать настройки, касающиеся нашего первого партнёра ISP1. Для этого переходим на вкладку Peers и добавляем новую запись.

Name – имя записи. Например ISP1

Instance – default

Remote Address – IP адрес роутера ISP1

Remote AS – AS ISP1

In Filter – AS21212-bgp-in (эти фильтры мы создадим позже)

Out Filter – AS21212-bgp-out (эти фильтры мы создадим позже)

Рис.3. Настройка Peer

Теперь мы создадим фильтры bgp-in и bgp-out для автономной системы AS21212, провайдера ISP1.

В первом фильтре bgp-in, мы запретим посылать в нашу AS извне префиксы нашей собственной сети и прочие не нужные сети, в том числе и используемые только для частных сетей. Делается это для того, что бы “не правильно” настроенные роутеры других автономных систем, не присылали нам не нужную информацию и не перегружали наш маршрутизатор.

А во втором фильтре bgp-out мы запретим посылать наружу какие либо другие сети, кроме нашей. Опять же, чтобы не отправлять на другие автономные системы, ничего лишнего.

Открываем раздел Routing -> Filters и добавляем ряд новых правил, в которых мы запретим приём следующих подсетей:

Все частные сети 10.0.0.0/8, 192.168.0.0/16 и 172.16.0.0/12

Канальные сети 169.254.0.0/16

Сеть многоадресной рассылки 224.0.0.0/4

Резервную сеть 240.0.0.0/4

Внутрикоммуникационную подсеть 127.0.0.0/8

А так же, нашу собственную сеть 59.134.40.0/21

Chain – наша цепочка правил AS21212-bgp-in

Prefix – префикс подсети, приём которой мы запрещаем, например 10.0.0.0/8

Рис.4. Создание фильтров BGP

Переходим на вкладку Actions и выбираем Action: discard

Рис.5. Создание фильтров BGP

После чего сохраняем правило.

Повторяем это действие для всех оставшихся префиксов 192.168.0.0/16, 172.16.0.0/12, 169.254.0.0/16, 224.0.0.0/4, 240.0.0.0/4, 127.0.0.0/8 и 59.134.40.0/21.

Теперь создаём разрешающие правило для всех остальных префиксов, не вошедших в созданные ранее правила.

Chain – наша цепочка правил AS21212-bgp-in

Рис.6. Создание фильтров BGP

Переходим на вкладку Actions и выбираем Action: accept

Рис.7. Создание фильтров BGP

Следующим шагом будет создание цепочки правил bgp-out для автономной системы AS21212 провайдера ISP1. В ней, как мы и говорили раньше, запретим посылать наружу какие либо другие сети, кроме нашей.

Создаём такое правило:

Chain – наша цепочка правил AS21212-bgp-out

Prefix – префикс нашей подсети 59.134.40.0/21, посылка которого разрешена.

Рис.8. Создание фильтров BGP

А на вкладке Actions, выбираем Action:acept

Рис.9. Создание фильтров BGP

А последнее правило запретит посылку других сетей. Создаём его.

Chain – наша цепочка правил AS21212-bgp-out.

Рис.10. Создание фильтров BGP

А на вкладке Actions выбираем Action: discard.

Рис.11. Создание фильтров BGP

В итоге, у нас должен получиться примерно следующий список из 11 фильтров.

Рис.12. Список фильтров BGP

Настройка протокола BGP для первого партнера ISP1, завершена. Далее мы настроим Peer и цепочки правил для нашего второго партнера ISP2.

Возвращаемся в раздел Routing -> BGP и открываем вкладку Peers.

Добавляем нового партнера ISP2.

Name – имя записи. Например ISP2.

Instance – default.

Remote Address – IP адрес роутера ISP2.

Remote AS – AS ISP2.

In Filter – AS34345-bgp-in (как и в первом случае, фильтры мы создадим позже).

Out Filter – AS34345-bgp-out (как и в первом случае, фильтры мы создадим позже).

Рис.13. Добавление нового Peer

После этого, всё что нам осталось, это создать ещё две цепочки правил AS34345-bgp-in и AS34345-bgp-out в разделе меню Routing -> Filters. которые ничем не отличаются от тех 11 правил, что мы создавали ранее, кроме того, что сами цепочки должны называться Chain: AS34345-bgp-in и Chain: AS34345-bgp-out соответственно.

В итоге, в разделе Filters, должно быть 22 правила.

Рис.14. Общий список фильтров BGP

Если же у вас больше двух внешних каналов, то настройка всех последующих аналогично.

Алексей специально для asp24

Если Вы нашли ошибку в тексте, то выделите ее мышкой и нажмите Ctrl + Enter или нажмите здесь.

ISP Servis: Статьи и инструкции

Настройка BGP на Mikrotik
Прежде всего хотелось бы сказать, что настройка MikroTik BGP может осуществляться как с помощью CLI так и с помощью WebAdmin. В данной статье будет описываться настройка с помощью CLI.

Допустим наш номер AS — AS12345, IP адрес — 192.168.255.25, в Интернет нами передается префикс в виде 109.205.240.0/21
AS нашего пира ISP1 — AS11111, IP — 192.168.255.29, в этом случае не используется пароль MD-5.
См.рисунок.

Настройка глобального процесса BGP
/routing bgp instance set default as=12345 redistribute-static=yes redistribute-connected=yes router-id=192.168.255.25
/routing bgp network add network=109.205.240.0/21 synchronize=no

Настройка BGP партнера ISP1
/routing bgp peer add remote-address=192.168.255.29 remote-as=11111 instance=default out-filter=AS11111-bgp-out in-filter=AS11111-bgp-in

Фильтры BGP-out — выход разрешен только для нашей сети, если Микротик попытается отправить другие сети, фильтр этого сделать не позволит
/routing filter add action=accept chain=AS11111-bgp-out comment=»» disabled=no invert-match=no prefix=109.205.240.0/21 set-bgp-prepend=3
/routing filter add action=discard chain=AS11111-bgp-out comment=»» disabled=no invert-match=no

Так как в нашем примере ISP1 является резервным, мы должны настроить специальное правило для фильтра BGP-out. — set-bgp-prepend=3 . Специальное правило мы настроили с целью искусственного продления пути к нашей AS в атрибуте AS-PATH, который передается между BGP роутерами. В итоге весь входящий трафик будет проходить через второго ISP(конечно если подключение к ISP2 будет работать).

Фильтры BGP-in — при входе запретим посылать нам в AS извне не нужные префиксы и нашу собственную сеть.
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=10.0.0.0/8
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=169.254.0.0/16
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=192.168.0.0/16
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=172.16.0.0/12
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=224.0.0.0/4
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=240.0.0.0/4
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=127.0.0.0/8
/routing filter add action=discard chain=AS11111-bgp-in comment=»» disabled=no invert-match=no prefix=109.205.240.0/21
/routing filter add action=accept chain=AS11111-bgp-in comment=»» disabled=no invert-match=no

У нас есть соединение с первым ISP, которое мы можем проверить через WinBox.

Настройка BGP партнера ISP2
/routing bgp peer add remote-address=10.10.10.101 remote-as=22222 instance=default out-filter=AS22222-bgp-out in-filter=AS22222-bgp-in

Фильтры BGP-out — выход, как и в случае с ISP1, разрешен только для нашей сети, если Mikrotik будет пытаться отправить другие сети, фильтр этого не допустит. Кроме того, обратите внимание на отсутствие параметра для AS-PARH prepending, это указывает на то, что именно через этого пира будем принимать входящий трафик.
/routing filter add action=accept chain=AS22222-bgp-out comment=»» disabled=no invert-match=no prefix=109.205.240.0/21
/routing filter add action=discard chain=AS22222-bgp-out comment=»» disabled=no invert-match=no

Фильтры BGP-in — при входе запретим посылать нам в AS извне не нужные префиксы(серые адреса, bogons) и нашу собственную сеть.
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=10.0.0.0/8
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=169.254.0.0/16
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=192.168.0.0/16
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=172.16.0.0/12
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=224.0.0.0/4
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=240.0.0.0/4
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=127.0.0.0/8
/routing filter add action=discard chain=AS22222-bgp-in comment=»» disabled=no invert-match=no prefix=109.205.240.0/21
/routing filter add action=accept chain=AS22222-bgp-in comment=»» disabled=no invert-match=no set-bgp-local-pref=200

Последняя строка BGP-in фильтра ISP2 отличается от фильтра для ISP1 в том, что мы настроили Local preference 200 (по-умолчанию 100) для всех входящих путей от ISP2. Этим мы добились того, что весь исходящий трафик с нашей AS будет посылаться через провайдера ISP2.

BGP Mikrotik. « Blog of Khlebalin Dmitriy

BGP Mikrotik.

Туннель SSTP Голова-Филиал у меня уже настроен. Далее нам необходимы маршруты с обеих сторон. Можно их прописать статически, но с ростом филиалов это превратится в хаос, поэтому используем  динамическую маршрутизацию OSPF или BGP. Сегодня о BGP.

Это мой первый опыт настройки BGP (ранее я читал про BGP на Cisco, но до настройки дело так и не дошло), а на Микроте я и вовсе увидел все это в первый раз.

Вернемся к нашей схеме: у нас есть Голова и пока два филиала, необходимо чтоб везде (на всех маршрутизаторах) были динамические маршруты.

Mikrotik HEAD (2 провайдера).

Настроим инстансы для основного и резервного каналов.

Name – название интерфейса, по умолчанию default

AS – номер нашей автономной системы

Router ID – IP адрес маршрутизатора Mikrotik

Ставим галочки Redistribute Connected, Redistribute-static, client-to-client-reflection

Обозначение остальных полей

Redistribute Connected – при включении  через это  соединение  будет распространяться информацию о подключенных маршрутах, т. е. маршрутах к сетям, к которым наш маршрутизатор может обратиться напрямую..

Redistribute-static – при включении через это соединение будет распространяться информацию о статических маршрутах, т. е. маршрутах прописанных на нашем роутере,  раздел  ip -> routes

Redistribute-RIP – при включении через  интерфейс  BGP будет анонсировать информацию о маршрутах полученных через RIP

Redistribute-OSPF — при включении  через  интерфейс  BGP будет анонсировать информацию о маршрутах полученных через  ospf

Redistribute-Other-BGP – при включении  через интерфейс  BGP будет анонсировать информацию о маршрутах полученных через другое BGP соединение.

Out Filter — Цепочка фильтра маршрутизации вывода, используемая всеми одноранговыми узлами BGP, принадлежащими этому экземпляру

Confederation – Если используется конфедерация  BGP здесь  указываем номер автономной системы, который идентифицирует [локальную] конфедерацию в целом.

confederation-peers — Если используется конфедерация  BGP здесь указываем  список номеров автономных систем, внутренних для локальной конфедерации. Также поддерживаются диапазоны чисел. Например, 10,20,30-50.

Cluster ID – Идентификатор кластера, используется если этот интерфейс BGP является рефлектором маршрута.

Routing Table – название таблицы маршрутизации, в которой работает этот интерфейс  BGP.

 

Настроим пиры:

Name – название провайдера

Instance – интерфейс  BGP созданный на первом шаге, если у нас подключение к нескольким провайдерам, то соответственно здесь выбираем нужный нам интерфейс.

Remote AS – Автономная система партнера.

In Filter, Out Filter — фильтры созданные на втором шаге соответственно

 

Не забываем в фаерволе разрешить:

Переходим к настройке Mikrotik BRANCh2 (2 провайдера).

MikroTik BGP с динамической маршрутизацией Полная таблица, три узла

Конфигурация

AS47453 — автономная система от RIPE NCC

 / экземпляр маршрутизации bgp
добавить as = 47453 client-to-client-reflection = no name = itservice router-id = 93.155.130.1 

/ routing bgp instance
добавить как = 47453 отражение клиента в клиент = нет имени = itservice идентификатор маршрутизатора = 93.155.130.1

Рекламные сети

 / маршрутизация сети bgp
добавить сеть = 93.155.169.0 / 24 синхронизировать = нет
добавить сеть = 93.155.130.0 / 24 синхронизировать = нет
добавить сеть = 93.155.162.0 / 24 синхронизировать = нет
добавить сеть = 93.155.131.0 / 24 синхронизировать = нет 

/ маршрутизация сети bgp
добавить сеть = 93.155.169.0 / 24 синхронизировать = нет
добавить сеть = 93.155.130.0 / 24 синхронизировать = нет
добавить сеть = 93.155.162.0 / 24 синхронизировать = нет
добавить сеть = 93.155.131.0 / 24 синхронизировать = нет

Создать узел BGP

 / маршрутизатор bgp peer
instance = itservice name = mtel-int add in-filter = mtel-int-in out-filter = mtel-int-out удаленный-адрес = 213.226.26.113 удаленный-as = 12716
instance = itservice name = mtel-bg add in-filter = mtel-bg-in out-filter = mtel-bg-out удаленный-адрес = 213.226.26.117 remote-as = 12716
instance = itservice name = gcn add in-filter = gcn-in out-filter = gcn-out удаленный-адрес = 212.70.158.89 удаленный-as = 12615
instance = itservice name = thezone add in-filter = thezone-in out-filter = thezone-out remote-address = 93.155.130.66 remote-as = 34368 

/ маршрутизатор bgp peer
instance = itservice name = mtel-int add in-filter = mtel-int-in out-filter = mtel-int-out удаленный-адрес = 213.226.26.113 удаленный-as = 12716
instance = itservice name = mtel-bg add in-filter = mtel-bg-in out-filter = mtel-bg-out удаленный-адрес = 213.226.26.117 remote-as = 12716
instance = itservice name = gcn add in-filter = gcn-in out-filter = gcn-out удаленный-адрес = 212.70.158.89 удаленный-as = 12615
instance = itservice name = thezone add in-filter = thezone-in out-filter = thezone-out remote-address = 93.155.130.66 remote-as = 34368

Расширенные фильтры маршрутизации для манипулирования трафиком

ISP1 MTEL BG PEERING
цепочка = mtel-bg-out без параметра = высокий приоритет
цепочка = mtel-bg-in set-distance = 10 = высокий приоритет

ISP1 MTEL INTERNATIONAL
цепочка = mtel-int-out без параметра = высокий приоритет
цепочка = mtel-int-in set-bgp-local-pref = 200 = высокий приоритет

ISP2 GCN
цепочка = gcn-out set-bgp-prepend = 5 = средний приоритет
цепочка = gcn-in без параметра = средний приоритет

ISP3 TheZone
цепочка = thezone-out set-bgp-prepend = 10 = низкий приоритет
chain = thezone-in set-bgp-local-pref = 80 = низкий приоритет

 / фильтр маршрутизации
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.130.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.131.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.162.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-bg-out
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 93.155.130.0 / 24
добавить действие = сбросить цепочку = префикс mtel-bg-in = 93.155.131.0 / 24
добавить действие = сбросить цепочку = префикс mtel-bg-in = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 93.155.169.0 / 24
добавить действие = сбросить цепочку = mtel-bg-in prefix = 192.168.0.0 / 16 длина префикса = 16-32
добавить действие = сбросить цепочку = mtel-bg-in prefix = 172.16.0.0 / 12 prefix-length = 12-32
добавить действие = отказаться от цепочки = mtel-bg-in prefix = 10.0.0.0 / 8 prefix-length = 8-32
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 0.0.0.0 / 0
добавить действие = принять цепочку = mtel-bg-in set-distance = 10

добавить действие = принять цепочку = префикс mtel-int-out = 93.155.130.0 / 24
добавить действие = принять цепочку = префикс mtel-int-out = 93.155.131.0 / 24
добавить действие = принять цепочку = префикс mtel-int-out = 93.155.162.0 / 24
добавить действие = принять цепочку = mtel-int-out prefix = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-int-out
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.130.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.131.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 192.168.0.0 / 16 prefix-length = 16-32
добавить действие = отказаться от цепочки = mtel-int-in prefix = 172.16.0.0 / 12 prefix-length = 12-32
добавить действие = сбросить цепочку = mtel-int-in prefix = 10.0.0.0 / 8 prefix-length = 8-32
добавить действие = отказаться от цепочки = mtel-int-in prefix = 0.0,0.0 / 0
добавить действие = принять цепочку = mtel-int-in set-bgp-local-pref = 200

добавить действие = принять цепочку = префикс gcn-out = 93.155.130.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.131.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.162.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.169.0 / 24 set-bgp-prepend = 5
добавить действие = отказаться от цепочки = gcn-out
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.130.0 / 24
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.131.0 / 24
добавить действие = сбросить цепочку = префикс gcn-in = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.169.0 / 24
добавить действие = сбросить цепочку = префикс gcn-in = 192.168.0.0 / 16 длина префикса = 16-32
добавить действие = сбросить цепочку = префикс gcn-in = 172.16.0.0 / длина префикса 12 = 12-32
добавить действие = сбросить цепочку = префикс gcn-in = 10.0.0.0 / длина префикса 8 = 8-32
добавить действие = отказаться от цепочки = префикс gcn-in = 0.0.0.0 / 0
добавить действие = принять цепочку = gcn-in

добавить действие = принять цепочку = префикс зоны выхода = 93.155.130.0 / 24 set-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.131.0 / 24 set-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.162.0 / 24 набор-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.169.0 / 24 set-bgp-prepend = 10
добавить действие = отказаться от цепочки = зона-вне
добавить действие = отказаться от цепочки = префикс зоны = 93.155.130.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.131.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.169.0 / 24
добавить действие = сбросить цепочку = префикс зоны = 192.168.0.0 / длина префикса 16 = 16-32
add action = discard chain = thezone-in prefix = 172.16.0.0 / 12 длина префикса = 12-32
добавить действие = сбросить цепочку = префикс зоны = 10.0.0.0 / длина префикса 8 = 8-32
добавить действие = отказаться от цепочки = префикс зоны = 0.0.0.0 / 0
добавить действие = принять цепочку = зона-в set-bgp-local-pref = 80 

/ фильтр маршрутизации
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.130.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.131.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.162.0 / 24
добавить действие = принять цепочку = префикс mtel-bg-out = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-bg-out
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 93.155.130.0 / 24
добавить действие = сбросить цепочку = префикс mtel-bg-in = 93.155.131.0 / 24
добавить действие = сбросить цепочку = префикс mtel-bg-in = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 93.155.169.0 / 24
добавить действие = сбросить цепочку = mtel-bg-in prefix = 192.168.0.0 / 16 prefix-length = 16-32
добавить действие = сбросить цепочку = mtel-bg-in prefix = 172.16.0.0 / 12 prefix-length = 12-32
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 10.0.0.0 / 8 длина префикса = 8-32
добавить действие = отказаться от цепочки = префикс mtel-bg-in = 0.0.0.0 / 0
добавить действие = принять цепочку = mtel-bg-in set-distance = 10

добавить действие = принять цепочку = префикс mtel-int-out = 93.155.130.0 / 24
добавить действие = принять цепочку = префикс mtel-int-out = 93.155.131.0 / 24
добавить действие = принять цепочку = префикс mtel-int-out = 93.155.162.0 / 24
добавить действие = принять цепочку = префикс mtel-int-out = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-int-out
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.130.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.131.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 93.155.169.0 / 24
добавить действие = отказаться от цепочки = mtel-int-in prefix = 192.168.0.0 / 16 prefix-length = 16-32
добавить действие = отказаться от цепочки = mtel-int-in prefix = 172.16.0.0 / 12 prefix-length = 12-32
добавить действие = сбросить цепочку = mtel-int-in prefix = 10.0.0.0 / 8 prefix-length = 8-32
добавить действие = отказаться от цепочки = mtel-int-in prefix = 0.0,0.0 / 0
добавить действие = принять цепочку = mtel-int-in set-bgp-local-pref = 200

добавить действие = принять цепочку = префикс gcn-out = 93.155.130.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.131.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.162.0 / 24 set-bgp-prepend = 5
добавить действие = принять цепочку = префикс gcn-out = 93.155.169.0 / 24 set-bgp-prepend = 5
добавить действие = отказаться от цепочки = gcn-out
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.130.0 / 24
добавить действие = сбросить цепочку = префикс gcn-in = 93.155.131.0 / 24
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс gcn-in = 93.155.169.0 / 24
добавить действие = сбросить цепочку = префикс gcn-in = 192.168.0.0 / 16 длина префикса = 16-32
добавить действие = сбросить цепочку = префикс gcn-in = 172.16.0.0 / длина префикса 12 = 12-32
добавить действие = сбросить цепочку = префикс gcn-in = 10.0.0.0 / длина префикса 8 = 8-32
добавить действие = отказаться от цепочки = префикс gcn-in = 0.0.0.0 / 0
добавить действие = принять цепочку = gcn-in

добавить действие = принять цепочку = префикс зоны выхода = 93.155.130.0 / 24 набор-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.131.0 / 24 set-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.162.0 / 24 set-bgp-prepend = 10
добавить действие = принять цепочку = префикс зоны выхода = 93.155.169.0 / 24 set-bgp-prepend = 10
добавить действие = отказаться от цепочки = зона-вне
добавить действие = отказаться от цепочки = префикс зоны = 93.155.130.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.131.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.162.0 / 24
добавить действие = отказаться от цепочки = префикс зоны = 93.155.169.0 / 24
добавить действие = сбросить цепочку = префикс зоны = 192.168.0.0 / длина префикса 16 = 16-32
добавить действие = сбросить цепочку = префикс зоны = 172.16.0.0 / длина префикса 12 = 12-32
добавить действие = сбросить цепочку = префикс зоны = 10.0.0.0 / длина префикса 8 = 8-32
добавить действие = отказаться от цепочки = префикс зоны = 0.0.0.0 / 0
добавить действие = принять цепочку = зона-в set-bgp-local-pref = 80

Мониторинг

 [admin @ R1]> маршрутизация bgp peer print
Флаги: X - отключено, E - установлено
 # INSTANCE REMOTE-ADDRESS REMOTE-AS
 0 Электронная почта 213.226.26.113 12716
 1 Электронный сервис 213.226.26.117 12716
 2 Электронная служба 212.70.158.89 12615
 3 E itservice 93.155.130.66 34368 

[admin @ R1]> маршрутизация bgp peer print
Флаги: X — отключено, E — установлено
# INSTANCE REMOTE-ADDRESS REMOTE-AS
0 Электронный сервис 213.226.26.113 12716
1 Электронная почта 213.226.26.117 12716
2 Электронная служба 212.70.158.89 12615
3 Электронная служба 93.155.130.66 34368

 [admin @ R1]> маршрутизация bgp peer print status
Флаги: X - отключено, E - установлено
 0 E name = "mtel-int" instance = itservice удаленный-адрес = 213.226.26.113
     remote-as = 12716 tcp-md5-key = "" nexthop-choice = force-self
     multihop = без отражения маршрута = без задержки = 3 м ttl = по умолчанию
     in-filter = mtel-int-in out-filter = mtel-int-out
     семейства адресов = IP-адрес по умолчанию = никогда
     remove-private-as = no as-override = no passive = no use-bfd = no
     удаленный-идентификатор = 213.226.7.253 локальный адрес = 213.226.26.114
     время работы = 1w1d22h6m52s количество префиксов = 610947 отправлено обновлений = 11
     получено обновлений = 3637678 отозвано-отправлено = 0
     извлечено-получено = 163485 время удаленного удержания = 3 мес. время удержания б / у = 3 м
     used-keepalive-time = 1 мин. возможность обновления = да
     as4-capacity = да состояние = установлено

 1 E name = "mtel-bg" instance = itservice remote-address = 213.226.26.117
     remote-as = 12716 tcp-md5-key = "" nexthop-choice = force-self
     multihop = no route-reflection = no hold-time = 3m ttl = d 

Cisco to MikroTik — перевод команд — BGP — StubArea51.net

В мире сетевой инженерии изучение нового синтаксиса может быть сложной задачей, особенно если вам нужно быстро получить много деталей. Структура команд для RouterOS иногда может быть немного сложной, если вы привыкли к командам Cisco CLI. Большинство из нас, которые какое-то время занимались сетями, начали с оборудования Cisco, поэтому полезно провести сравнения между командами, особенно если вы пытаетесь построить сеть с помощью маршрутизатора MikroTik и Cisco.

Это первая публикация из серии, которую я хотел сделать на некоторое время, которая создает «Розеттский камень», по сути, между IOS и RouterOS.Мы планируем заняться рядом других сравнений команд, таких как OSPF, MPLS и VLAN, чтобы облегчить сетевым инженерам, прошедшим обучение в Cisco IOS, успешную реализацию устройств MikroTik / RouterOS. Хотя многие команды имеют практически одинаковую информацию, другие максимально близки. Поскольку не всегда бывает точное совпадение, иногда вам, возможно, придется запустить две или три команды, чтобы получить необходимую информацию.

Мы планируем заняться рядом других сравнений команд, таких как OSPF, MPLS и VLAN, чтобы облегчить сетевым инженерам, прошедшим обучение в Cisco IOS, успешную реализацию устройств Mikrotik / RouterOS.

Использование GNS для тестирования

Мы использовали GNS3 для эмуляции как Cisco IOS, так и RouterOS, чтобы мы могли сравнить разные команды и убедиться, что перевод был как можно более точным.

Команды BGP

Cisco Command MikroTik Command
показать сводку ip bgp маршрутизация bgp peer print краткая
routing ip bgp peer print status
show ip bgp neighbour 1.1.1.1 Advertised-routes routing bgp реклама print peer = peer_name
show ip bgp neighbour 1.1.1.1 Received-routes ip route print where loaded-from = peer_name
show ip route bgp ip route print where bgp = yes
clear ip bgp 172.31.254.2 soft in routing bgp peer refresh peer1
clear ip bgp 172.31.254.2 soft out routing bgp peer Resend peer1
BGP-Cisco (config) #router bgp 1 / routing bgp instance
set default as = 2
BGP-Cisco (config -router) #neighbor 172.31.254.2 remote-as 2 / routing bgp peer
add name = peer1 remote-address = 172.31.254.1 remote-as = 1
BGP-Cisco (config-router) # сеть 100.99.98.0 маска 255.255.255.0
BGP-Cisco (config-router) # сеть 100.99.97.0 маска 255.255.255.0
BGP-Cisco (config-router) #network 100.99.96.0 mask 255.255.255.0
/ routing bgp network
add network = 100.89.88.0 / 24
add network = 100.89.87.0 / 24
add network = 100.89.86.0 / 24
BGP-Cisco (config) #router bgp 1
BGP-Cisco (config-router) #neighbor 172.31.254.2 default-originate
/ routing bgp peer
add default-originate = always name = peer1 remote-address = 172.31.254.1 remote-as = 1

Примеры команд MikroTik RouterOS из таблицы выше


[[электронная почта защищена] ]> Маршрутизация bgp peer print краткая

Это быстрый способ получить список одноранговых узлов / AS и их статус

[[email protected]]> routing bgp peer print status

Это команда это даст вам более подробную информацию об узле BGP, включая MD5 uth, таймеры, полученные префиксы и состояние пиринга, а также другая информация.

[[email protected]]> маршрутизация рекламы bgp print peer = peer_name

Это позволит вам увидеть, какие префиксы BGP фактически объявляются одноранговому узлу и следующему магазину, который будет объявлен

[[email protected]]> ip route print где получено-от = peer_name

Это позволит вам увидеть, какие префиксы BGP фактически получены от однорангового узла и следующего магазина, который будет объявлен

Пример конфигурации BGP с использованием Mikrotik Router

В этой статье представлена ​​базовая конфигурация BGP, включая ASN и E-BGP.
BGP используется в соединении TCP и порт 179, при подключении к Интернету предприятие может использовать статический маршрут или имя протокола маршрутизации в качестве протокола маршрутизации пограничного шлюза (BGP).
См. Видео о настройке BGP

Настроить базовый IP-адрес наш маршрутизатор mikrotik

[admin @ Laxmi] / IP-адрес>

добавить адрес = 10.0.0.2 / 30 сеть = 10.0.0.0 широковещательная передача = 10.0.0.3 интерфейс = WAN1

добавить адрес = 172.16.0.2 / 30 сеть = 172.16.0.0 широковещательная передача = 172.16.0.3 интерфейс = WAN2

Настроить наш номер AS
[admin @ Laxmi] / routing bgp instance>
set default as = 100

Configure BGP Neighbor

[admin @ Laxmi] / routing bgp peer> add name = ISP1 remote-address = 10.0.0.1 remote-as = 200
[admin @ Laxmi] / routing bgp peer> add name = ISP2 remote-address = 172.16.0.1 remote-as = 300

Проверка BGP peer

[admin @ Laxmi] / routing bgp peer> print
Флаги: X — отключено, E — установлено
# INSTANCE REMOTE-ADDRESS REMOTE-AS
0 E по умолчанию 10.0.0.1 200
1 E по умолчанию 172.16.0.1 300

Конфигурация объявления сети

[admin @ Laxmi]>
/ routing bgp network
add network = 192.168.10.0 / 24 synchronize = no

Исходящая и входящая цепочка фильтров для ISP 1

[admin @ Laxmi]>
/ фильтр маршрутизации
add chain = ISP_1-out prefix = 192.168.10.0 / 24 действие = принять
добавить цепочку = ISP_1-out действие = сбросить
[admin @ Laxmi]>
/ фильтр маршрутизации
добавить цепочку = ISP_1-в действии = сбросить

Настройка исходящей и входящей цепочки фильтров для ISP 2
[admin @ Laxmi]>
/ routing filter
add chain = ISP_2-out prefix = 192.168.10.0 / 24 action = accept set-bgp-prepend = 5
[admin @ Laxmi]>
/ фильтр маршрутизации
add chain = ISP_2-in action = discard

[admin @ Laxmi]>
/ ip route
add gateway = 10.0.0.1 check-gateway = ping
add gateway = 172.16.0.1 check-gateway = ping distance = 10

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *