Разное

Mikrotik cloud hosted router: Экономим на лицензиях Mikrotik CHR / Хабр

Содержание

Установка Mikrotik Cloud Hosted Router на VPS хостинг Digital Ocean / Хабр

… или другой Linux-хостинг.

Сразу оговорюсь, что поскольку мне в процессе всех экспериментов уже поднадоело сносить и заново настраивать дроплет в DO, пример я буду выполнять в VMware ESXi, но на конечный результат это влиять не будет, команды все будут те же самые, в принципе, это применимо к любому облачному VPS хостингу, где у нас есть доступ по SSH.

За основу взят доклад Дмитрия Пичулина deemru на прошедшем 30 сентября MUM в Москве. В отличии от доклада Дмитрия, в данной статье не будет рассматриваться вопросы выбора хостинга и цен на него (в стремлении намутить облачный роутер подешевле), настройки полученного устройства. Рассмотрена будет лишь техническая сторона вопроса и решены пара проблем.

Вернувшись с MUM, я был в предвкушении, руки чесались запилить Mikrotik на Digital Ocean (в тот момент, там была Ubuntu Server, которая выполняла функции VPN-сервера). Полез смотреть архив выступлений, но его ещё не было и я написал письмо Дмитрию с просьбой поделиться слайдами. Получив презентацию, с холодной головой ринулся в бой — ломать свой дроплет полностью. Сделал всё, как в презентации, всё завелось. Легче и придумать нельзя. Скачиваем на хостинг образ, распаковываем, переводим файловую систему в read-only, заливаем образ на диск через dd. Но тут то меня и подстерегала первая нестыковочка — у Дмитрия при первой загрузке CHR автоматически произошло расширение файловой системы и она заняла весь диск, у меня же этого не произошло и пришлось довольствоваться 128 МБ.

Кто-то скажет 128 МБ на роутере хватит всем. Но меня эта ситуация в корне не устраивала, поэтому я принялся её устранять. Всем известно, что RouterOS основана на Linux, но от Linux’а там мало что осталось, поэтому после установки системы, её штатными средствами переразметить диск уже нельзя. Нельзя и загрузиться с какого-нибудь LiveCD и переразметить в нём (ну по крайней мере у DO нельзя). Попытки тыкаться fdisk’ом и parted’ом после заливки образа на диск, но до перезагрузки так же не привели к какому-либо положительному результату (эффекта либо не было вообще, либо я получал не загружающуюся систему).

Нормальные герои всегда идут в обход.

Итак для того чтобы получить RouterOS, установленную на Digital Ocean, в которой доступно 20 ГБ дискового пространства (ну или сколько там у Вас по тарифу) нам потребуется:

  • Собственно, сам droplet с установленным Linux дистрибутивом (в данном случае дистрибутив будет Ubuntu Server 16.04 x64, а вместо droplet’а будет виртуальная машина в ESXi, но ещё раз повторюсь, что роли это не сыграет), к которому у нас есть доступ по SSH.
  • Установленный на компьютере или сервере гипервизор (изначально я делал в VirtualBox, сейчас буду делать опять же в ESXi, на конечный результат это не влияет).
  • LiveCD вашего любимого Linux-дистрибутива (желательно, чтобы там был GUI, так будет удобнее).

Как вы видете, список не очень большой, каких-то особых требований к его пунктам нет, решение я старался сделать максимально универсальным и простым, чтобы можно было всё соорудить буквально на коленке из того, что есть.

Начнём с дроплета.

Нам нужно выяснить, какого объёма нам нужен диск в виртуальной машине, поэтому:

fdisk -l /dev/sda
Диск /dev/sda: 16 GiB, 17179869184 байтов, 33554432 секторов
Единицы измерения: секторов из 1 * 512 = 512 байтов
Размер сектора (логический/физический): 512 байт / 512 байт
I/O size (minimum/optimal): 512 bytes / 512 bytes
Тип метки диска: dos
Идентификатор диска: 0x7b5dbf9c

Устр-во    Загрузочный    Start Конец Секторы  Size Id Тип
/dev/sda1  *               2048 31457279 31455232   15G 83 Linux
/dev/sda2              31459326 33552383  2093058 1022M  5 Расширенный
/dev/sda5              31459328 33552383  2093056 1022M 82 Linux своп / Solaris

Как мы видим, у нас диск 17179869184 байт, запомним это значение.

Подготовка промежуточной машины

В гипервизоре создаём новую виртуальную машину. Её параметры особого значения не имеют, но можно, к примеру сделать их близкими к характеристикам дроплета. Размер диска лучше сделать с небольшим запасом, на всякий случай (почему-то 20ГБ в DO оказались меньше 20ГБ в VirtualBox). Настраиваем загрузку виртуальной машины с LiveCD.

Включаем её и после загрузки скачиваем любым удобным способом последнюю версию CHR, которую можно найти по ссылке:

Нам нужен образ Raw disk image (к примеру chr-6.37.1.img.zip). Распаковываем архив:

unzip chr-6.37.1.img.zip
Archive:  chr-6.37.1.img.zip
  inflating: chr-6.37.1.img

И заливаем образ на жёсткий диск с помощью dd (Дмитрий тут использовал утилиту pv, но я, если честно не вижу в этом смысла, т.к. образ маленький и разворачивается довольно быстро):

dd if=chr-6.37.1.img.zip of=/dev/sda
262144+0 records in
262144+0 records out
134217728 bytes (134 MB, 128 MiB) copied, 5.64304 s, 23.8 MB/s

вместо sda нужно указать ваш диск, его имя может отличаться.

Расширяем файловую систему RouterOS

Любители всё делать в консоли могут делать там, мне показалось быстрее и проще сделать всё в GParted.

Запускаем GParted, выбираем диск, на который установили RouterOS и с помощью функции Resize/Move увеличиваем размер второго раздела. Обратите внимание, что размер раздела за вычетом размера первого раздела не должен превышать размер диска Вашего дроплета, который мы посмотрели в самом начале (т.е. первый раздел у нас 32 МиБ, значит второй должен быть не более 17179869184 байт / 1048576 = 16384 МиБ и — 32, т.е. 16352 МиБ)

Не забываем применить изменения разметки диска.

Создаём новый образ и жмём его с помощью gzip:

dd if=/dev/sda bs=8196 count 17000 | gzip -9cf > chr.img.gz
17000+0 records in
17000+0 records out
139332000 bytes (139 MB, 133 MiB) copied, 3.30824 s, 42.1 MB/s

Значение 17000 мы получаем путём приведения размера образа при его развёртывании на диск. Там было 128 МиБ, т.е. 128 * 1024 = 131072 КиБ разделим размер на размер блока и округлим 131072 / 8 = 16384 ≈ 17000 блоков.

Заливаем полученный образ на дроплет и устанавливаем его

scp chr.img.gz [email protected]:~/

Где user — имя пользователя на вашем дроплете, а host — его адрес. Копирование будет выполняться в домашний каталог пользователя.

Принимаем сертификат ssh сервера, и вводим пароль, когда нас об этом попросят. После окончания копирования, эта виртуальная машина нам больше не понадобится.

Переходим на наш дроплет. Можно подключиться к нему по ssh или зайти через консоль. Убедимся, что наш образ скопировался, желающие могут проверить контрольные суммы. Переведём файловую систему в режим read-only и развернём образ на диск через gzip и dd:

echo u > /proc/sysrq-trigger && gunzip -c chr.img.gz | dd of=/dev/vda

Всё! CHR установлен на наш дроплет. Перезагрузимся:

reboot

Вас приветствует Mikrotik Cloud Hosted Router

@gexogen — обманщик!!!

На самом деле, хоть я и обещал, что нет никакой разницы, в Digital Ocean мы это делаем или в ESXi, разница всё-таки есть. В DO всё работает, а вот ESXi после перезагрузки упал в Kernel Panic. Но, в ESXi файловая система растягивается и так при первой загрузке и данные манипуляции не потребуются.

После перезагрузки входим под пользователем admin без пароля, после чего задаём пароль, прописываем ip адрес и дефолтный маршрут:

/system user set admin password=YOURPASSWORD

/ip address add address=YOUR.IP.ADD.RESS/MASK

/ip route add gateway=YOUR.GATE.WAY.IP

После чего можно подключаться к нему и настраивать через Winbox.

Заключение

На доступном месте можно установить внутри RouterOS виртуальную машину с Linux или использовать его как-нибудь иначе — на Ваше усмотрение (поднять FTP сервер или ещё что-нибудь).

Ссылки:

Презентация Дмитрия в фомате PDF
Запись его выступления
На всякий случай, ссылка на готовый образ под файловую систему на 20 ГБ (т.е. минимальный тариф DO за 5$)

» Как установить Mikrotik Cloud Hosted Router на SSD VDS

Установка собственного маршрутизатора, VPN-сервера или файрвола в “облаке” имеет множество применений, а в качестве программного обеспечения можно использовать как обычный сервер или VDS с Linux/FreeBSD, так и специализированные решения. Одно из таких решений – популярный Cloud Hosted Router™, особая версия Mikrotik RouterOS. Давайте попробуем установить этот продукт на обычную SSD VDS.

Итак, приступим. Возьмем для наших тестов SSD VDS 1G, причем минимальной конфигурации будет достаточно для большинства обычных применений. В качестве операционной системы выберем, например, Centos 7.x.

Производим заказ и буквально через несколько минут электронной почтой поступит письмо с информацией об IP-адресе и параметрах доступа. Отлично, теперь воспользуемся любым ssh-клиентом и авторизуемся в операционной системе нашей SSD VDS:

~ agl$ ssh cloud.router -lroot
The authenticity of host 'cloud.router ()' can't be established.
ECDSA key fingerprint is SHA256:Ye1+i0hx/pDS5lph0zJDmxZ2FuluCC/OI2RTLt4g+c8.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'cloud.router,' (ECDSA) to the list of known hosts.

В примере выше cloud.router – это имя хоста или IP-адрес виртуальной машины. Ок, мы авторизовались, теперь выполним несколько команд.

# wget https://download2.mikrotik.com/routeros/6.39.2/chr-6.39.2.img.zip
# echo u > /proc/sysrq-trigger && gunzip -c chr-6.39.2.img.zip | dd of=/dev/vda
# reboot

Расскажем, что делают эти команды. В первой строке – мы загружаем инсталляционный пакет (образ в формате img) Cloud Hosted Router, во второй – записываем образ на диск нашей VDS. Обратите внимание – мы записываем поверх существующей операционной системы, поэтому не экспериментируйте на действующих серверах с необходимыми данными, только на “чистых”.

Перезагружаем VDS, открываем VNC-консоль (если не нашли самостоятельно – в системе самообслуживания, в “Виртуальных Серверах” находим нашу VDS, затем нажимаем кнопочку “Перейти” и попадаем в панель управления VDS-сервером, а там на самом видном месте есть вызов встроенного VNC-клиента). На консоли нас уже будет ждать наш Cloud Hosted Router, авторизуемся с логином admin, пароль по-умолчанию отсутствует.

Можно начинать настройку и использование этого продукта. Не забудьте установить IP-адрес и задать пароль для администратора:

/system user set admin password=SuP3rPazw0rD
/ip address add address=xxx.xxx.xxx.xxx/24
/ip route add gateway=xxx.xxx.xxx.yyy

Приятного изучения и использования этого замечательного решения от Mikrotik!

Настройка MikroTik Cloud Hosted Router

Описание

MikroTik Cloud Hosted Router (CHR) — это операционная система RouterOS, предназначенная для работы в качестве виртуальной машины. Она поддерживает 64-разрядную архитектуру x86 и используется на большинстве популярных гипервизоров: VMWare, VirtualBox, Hyper-V, KVM, Xen.

Лицензия Cloud Hosted Router бывает трех видов: P1P10 и P-Unlimited. Они отличаются друг от друга только ограничением скорости интерфейсов. Весь остальной функционал RouterOS полностью работает во всех лицензиях без ограничений.

Лицензия

Ограничение скорости

Free 1 Мбит/с
P1 1 Гбит/с
P10 10 Гбит/с
P-Unlimited Без ограничений

С официального сайта можно бесплатно скачать образ диска для гипервизора, установить и протестировать Cloud Hosted Router с лицензией Free. У нее будут ограничения скорости на интерфейсах 1 Мбит/с.

Также CHR позволяет запросить 60-дневную пробную лицензию P1, P10 или P-Unlimited для полноценного тестирования. Для установки и последующей покупки лицензии вам потребуется зарегистрировать аккаунт на сайте mikrotik.com, если у вас его нет. Покупку и активацию лицензии нужно выполнить до того, как истечет пробный период 60 дней.

Минимальные системные требования для установки MikroTik CHR:

  • RouterOS версии 6.34 или позднее.
  • 64-битный процессор с поддержкой виртуализации.
  • 128 МБ оперативной памяти или более для одного экземпляра CHR.
  • 128 МБ дискового пространства для виртуального жесткого диска CHR.
    Поддерживается максимальный размер образа системного диска 16 ГБ.

Лицензии MikroTik RouterOS CHR можно отвязывать от одной виртуальной машины и привязывать к другой. Например, у вас установлена лицензия P1, и вы хотите ее заменить на P-Unlimited. Для этого покупается лицензия P-Unlimited и привязывается к виртуальной машине. Лицензия P1 освобождается и ее можно использовать в другой виртуальной машине.

MikroTik — Базовая настройка Cloud Hosted Router

Manual:CHR [link]

  • x86 — отдельная версия с привязкой лицензии к железу (HDD). Соответственно умеет работать на голом железе (без всяких виртуальных машин) и не требует регулярной(раз в месяц) проверки лицензии на сайте микротика.
  • CHR — версия для виртуальных сред не привязанная к железу и проверяющая лицензию периодически на сайте микрота.
  • Родные (MIPSBE, ARM, MMIPS и тп.) версии для железок Микротика.

Нам понадобится:

  • Аккаунт на офф. сайте MikroTik [link];
  • Гипервизор Oracle VM VirtualBox [link];
  • Образ диска (.файл VDI) в разделе CHR [link];
  • Useful tools — Winbox.

На сайте представлена довольно хорошая Wiki. По мере настройки, она нам обязательно понадобится. Так-же настроим L1 модели OSI на VirtualBox, он будет представлен:

  • WAN-интерфейсом в режиме Bridge для физического интерфейса хоста;
  • LAN-интерфейсами в виде x2 Виртуальных интерфейсов хоста.

Подготовим гипервизор для запуска образа диска CHR. В процессе создания виртуальной машины нам понадобится указать образ диска .VDI.

Раздел настроек:
Отключим все что не понадобится для работы CHR и настроим сеть.

Система -> Материнская плата: Жесткий диск;
Система -> Процессор: x2;
Аудио: Выкл;
Сеть -> Адаптер 1 -> Тип подключения -> Сетевой мост -> Физический Ethernet интерфейс;
Сеть -> Адаптер 2 -> Виртуальный адаптер хоста -> VitualBox Host-OnlyEthernet Adapter;
Сеть -> Адаптер 2 -> Виртуальный адаптер хоста -> VitualBox Host-OnlyEthernet Adapter #3. 

Запускаем «Winbox» на вкладке «Neighbors» находим роутер и подключаемся. После чего переходим в раздел «System -> Reset Configuration«: ставим галочку «No Default Configuration«, это позволит вернуться к первоначальной конфигурации.

Показать изображение:

Подойдет для большинства конфигураций.

CHR будет работать со следующими настройками:

 - Configuration mode: Router
 - Internet: PPPoE
 - Local Network:
IP Adress: 192.168.10.1
Netmask: 255.255.255.0/24
[*] Bridge All LAN Ports
[*] DHCP Server
DHCP Server Range: 192.168.10.50-192.168.10.254
[*] NAT
 - System
Router identity: MikroTik
Password: ********
Confirm Password: ********

Показать изображение:

Все тоже самое, но только в ручном варианте с использованием терминала.

PPPoE Client:

ether2 — интерфейс в сторону провайдера;
pppoe-out1 — имя создаваемого интерфейса.

/interface pppoe-client add interface=ether2 name=pppoe-out1 disabled=no user=***** password=***** use-peer-dns=yes add-default-route=yes default-route-distance=1

Bridge:

/interface bridge add name=bridge1 fast-forward=yes
/interface bridge port add interface=ether1 bridge=bridge1

Adresses:

/ip address add address=192. 168.10.1/24 interface=bridge1

Pool:

/ip pool add name=dhcp_pool1 ranges=192.168.10.50-192.168.10.254

DHCP Server:

/ip dhcp-server add name=dhcp1 interface=bridge1 lease-time=1d address-pool=dhcp_pool1 disabled=no
 - Networks
/ip dhcp-server network add address=192.168.10.0/24 gateway=192.168.10.1 netmask=24 dns-server=192.168.10.1

NAT:

/ip firewall nat
/ip firewall nat> add action=masquerade chain=srcnat out-interface=pppoe-out1

Рекомендации по защите маршрутизатора. Все они подходят к вышеуказанной конфигурации.

Показать настройки:

# Access username
/user set 0 name=MTv
# Access password
/user set MTv password="**********"
# Access by IP address
/user set MTv address=192.168.10.0/24

# RouterOS services
/ip service disable api,api-ssl,ftp,ssh,telnet,www,www-ssl
/ip service set winbox address=192.168.10.0/24

# MAC-Telnet
/tool mac-server set allowed-interface-list=none
# MAC-Winbox
/tool mac-server mac-winbox set allowed-interface-list=none
# MAC-Ping
/tool mac-server ping set enabled=no

# Neighbor Discovery
/ip neighbor discovery-settings set discover-interface-list=none

# Bandwidth server
/tool bandwidth-server set enabled=no

# Other clients services
/ip proxy set enabled=no
/ip socks set enabled=no
/ip upnp set enabled=no
/ip cloud set ddns-enabled=no update-time=no

# More Secure SSH access
/ip ssh set strong-crypto=yes

# IPv4 firewall to a router
/ip firewall filter
add action=accept chain=input comment="default configuration" connection-state=established,related
add action=accept chain=input src-address-list=allowed_to_router
add action=accept chain=input protocol=icmp
add action=drop chain=input
/ip firewall address-list
add address=192. 168.10.2-192.168.10.254 list=allowed_to_router
# IPv4 firewall for clients
/ip firewall filter
add action=fasttrack-connection chain=forward comment=FastTrack connection-state=established,related
add action=accept chain=forward comment="Established, Related"  connection-state=established,related
add action=drop chain=forward comment="Drop invalid" connection-state=invalid log=yes log-prefix=invalid
add action=drop chain=forward comment="Drop tries to reach not public addresses from LAN" dst-address-list=not_in_internet in-interface=bridge1 log=yes log-prefix=!public_from_LAN out-interface=!bridge1
add action=drop chain=forward comment="Drop incoming packets that are not NATted" connection-nat-state=!dstnat connection-state=new in-interface=ether1 log=yes log-prefix=!NAT
add action=drop chain=forward comment="Drop incoming from internet which is not public IP" in-interface=ether1 log=yes log-prefix=!public src-address-list=not_in_internet
add action=drop chain=forward comment="Drop packets from LAN that do not have LAN IP" in-interface=bridge1 log=yes log-prefix=LAN_!LAN src-address=!192. 168.10.0/24

/ip firewall address-list
add address=0.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=172.16.0.0/12 comment=RFC6890 list=not_in_internet
add address=192.168.0.0/16 comment=RFC6890 list=not_in_internet
add address=10.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=169.254.0.0/16 comment=RFC6890 list=not_in_internet
add address=127.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=224.0.0.0/4 comment=Multicast list=not_in_internet
add address=198.18.0.0/15 comment=RFC6890 list=not_in_internet
add address=192.0.0.0/24 comment=RFC6890 list=not_in_internet
add address=192.0.2.0/24 comment=RFC6890 list=not_in_internet
add address=198.51.100.0/24 comment=RFC6890 list=not_in_internet
add address=203.0.113.0/24 comment=RFC6890 list=not_in_internet
add address=100.64.0.0/10 comment=RFC6890 list=not_in_internet
add address=240.0.0.0/4 comment=RFC6890 list=not_in_internet
add address=192.88.99.0/24 comment="6to4 relay Anycast [RFC 3068]" list=not_in_internet

| [habrahabr] | [serveradmin] |

Как активировать Cloud Hosted Router MikroTik – NTema

Как быстро и удобно для пользователя активировать Cloud Hosted Router MikroTik

MikroTik Cloud Hosted Router (CHR) представляет собой отдельную версию фирменной операционной системы RouterOS, которая предназначена специально для работы в виртуальной среде.  

Системные требования

Минимальные требования:

  • Версия пакета: RouterOS v6.34 или новее
  • Центральный процессор: 64-битный с поддержкой виртуализации
  • Оперативная память: 128 МB или более
  • Диск: 128 МB дискового пространства для виртуального жесткого диска CHR (макс. 16 GB)

Примечание. Минимально необходимый объем оперативной памяти зависит от количества интерфейсов и количества процессоров. Вы можете получить приблизительное число, используя следующую формулу: RAM = 128 + [ 8 × (CPU_COUNT) × (INTERFACE_COUNT — 1)] 

Существует 4 различных образа виртуальных дисков на выбор. Обратите внимание, что это только образы дисков, и вы не можете просто запустить их.

  • RAW образ диска (.img file)
  • VMWare образ диска (.vmdk file)
  • Hyper-V образ диска (.vhdx file)
  • VirtualBox образ диска (.vdi file)

Образ для установки можно скачать с сайта https://www. mikrotik.com/download#chr (Raw disk image — Current).

Пошаговая установка CHR

  1. Загрузите образ виртуального диска для вашего гипервизора
  2. Создайте гостевую виртуальную машину
  3. Используйте ранее загруженный файл образа в качестве виртуального диска
  4. Запустите гостевую виртуальную машину CHR
  5. Войдите в свой новый CHR. Пользователь по умолчанию — «admin», без пароля

Обратите внимание, что работающие системы CHR можно клонировать и копировать, но копия будет знать о предыдущем испытательном периоде, поэтому вы не можете продлить пробный период, сделав копию своего CHR. Однако вы можете лицензировать обе системы по отдельности. Чтобы создать новую пробную систему, вам необходимо выполнить новую установку и перенастроить RouterOS.

Установка CHR

  • VMWare Fusion / Workstation and ESXi 6.5
  • VirtualBox
  • Hyper-V
  • Amazon Web Services (AWS)
  • Hetzner Cloud
  • Linode
  • Google Compute Engine
  • ProxMox

Информация о лицензиях

Бесплатная лицензия доступна на 60 дней – для всех существующих типов лицензий. Чтобы получить бесплатную лицензию, либо любую другую лицензию, необходимо зарегистрироваться на сайте mikrotik.com

Купить лицензию можно на сайте https://ntema.com.ua в разделе Сетевое Wi-Fi Программное обеспечение.

Важно! Использование бесплатной лицензии дает ограничение скорости сети 1 Мбит/сек.

Типы лицензий:

Название (ограничение скорости):

  • Free (1 Mbit)
  • P1 perpetual-1 (1 Gbit)
  • P10 perpetual-10 (10 Gbit)
  • P-Unlimited perpetual-unlimited (без ограничений)

Вечная — это пожизненная лицензия (купи один раз, пользуйся вечно). Можно перенести бессрочную лицензию в другой экземпляр CHR. Работающий экземпляр CHR укажет время, когда он должен получить доступ к серверу учетных записей, чтобы продлить свою лицензию. Если экземпляр CHR не сможет продлить лицензию, он будет вести себя так, как если бы пробный период истек, и не позволит обновить RouterOS до более новой версии.

После лицензирования работающей пробной системы вы должны вручную запустить функцию /system license renew из CHR, чтобы сделать ее активной. В противном случае система не будет знать, что вы лицензировали ее в своей учетной записи. Если вы не сделаете этого до истечения срока, установленного для системы, пробная версия закончится, и вам придется выполнить полную свежую установку CHR, запросить новую пробную версию и затем лицензировать ее с полученной лицензией.

Если вы планируете приобрести выбранную лицензию, вы должны сделать это в течение 60 дней с даты окончания пробной версии. Если пробная версия заканчивается, и в течение 2 месяцев после ее окончания покупки не совершаются, устройство больше не отображается в вашей учетной записи MikroTik. Вам нужно будет сделать новую установку CHR, чтобы сделать покупку в течение требуемого периода времени.

Чтобы запросить пробную лицензию, необходимо запустить команду «/system license renew» из командной строки устройства CHR. Вам будет предложено ввести имя пользователя и пароль вашей учетной записи mikrotik.com.

Важно! Если вы планируете использовать несколько виртуальных систем одного и того же типа, возможно, что следующий компьютер имеет такой же systemID, что и исходный. Это может произойти на некоторых облачных провайдерах, таких как Linode. Чтобы избежать этого, после первой загрузки выполните команду «/ system license generate-new-id», прежде чем запрашивать пробную лицензию. Обратите внимание, что эту функцию следует использовать только в том случае, если CHR работает на бесплатной лицензии RouterOS. Если вы уже получили платную или пробную лицензию, не используйте функцию регенерации, поскольку вы больше не сможете обновлять свой текущий ключ.

Активацию лицензии можно выполнить в командной строке или в графическом интерфейсе.

Активация лицензии в графическом интерфейсе

Используем графический интерфейс

  1. В Mikrotik OS заходим: System → License menu → Renew Licence
  2. Вводим данные своего аккаунта mikrotik. com и вид лицензии, который был приобретен.
  3. Нажать Start, и в следующем окне ОК.

4. В аккаунте на сайте mikrotik.com в разделе CHR/all keys найти строку с Вашей лицензией и нажать кнопку Upgrade, выбрав предоплаченную лицензию (prepaid key)

Активация лицензии в командной строке

1. Проверить тип текущей лицензии можно с помощью команды: system license print
На данном этапе тип лицензии – free:

[[email protected]] > /system license print
system-id: 6lR1ZP/utuJ
level: free

2. С помощью команды system license renew обновляем текущую лицензию. Вводим данные своего аккаунта mikrotik.com:

[[email protected]] > /system license renew
account: mymikrotikcomaccount
password: *********************
level: p1
status: done

3. Чтобы убедиться в успешной активации, проверяем лицензию еще раз: system license print:

[[email protected]] > /system license print
system-id: 6lR1ZP/utuJ
level: p1
next-renewal-at: jan/10/2016 21:59:59
deadline-at: feb/09/2016 21:59:59

Чтобы получить пробную версию более высокого уровня, настройте новый экземпляр CHR, обновите лицензию и выберите нужный уровень.

Подробная информация о работе Cloud Hosted Router содержится в MikroTik Wiki:

https://wiki.mikrotik.com/wiki/Manual:CHR#Cloud_Hosted_Router

Пошаговое руководство по генерации ключа авторизации аккаунта MikroTik

 

Установка MikroTik RouterOS на VDS VPS Cloud Hosted Router — База знаний

RouterOS — операционная система маршрутизаторов (роутеров) MikroTik. Данную операционную систему можно установить на сервер либо виртуальный сервер ( VDS / VPS ) .

Установка RouterOS на VDS

Для установки нам потребуется любой VDS сервер, подойдет сервер с минимальными характеристиками. Устанавливаем на сервер любую linux систему. В данной инструкции, в качестве операционной системы сервера, будет использоваться Ubuntu Server 20.04

Подключаемся к серверу по SSH (видео инструкция по подключению к серверу)

Создаем временный раздел для хранения образа диска

mount -t tmpfs tmpfs /tmp/

Переходим на сайт MikroTik и переходим в раздел Software

Скачиваем RAW образ из раздела Cloud Hosted Router. Копируем ссылку на загрузку ( правой кнопкой мышки на дискету и выбираем копировать ссылку)

На сервере выполняем команду

wget https://download.mikrotik.com/routeros/7.1beta2/chr-7.1beta2.img.zip 
(параметр wget - скопированная ссылка)

Устанавливаем unzip для распаковки zip архива

sudo apt-get install unzip

Распаковываем архив

unzip chr-7.1beta2.img.zip

Определяем имя диск на вашем сервере

fdisk -l 

Disk /dev/sda: 53.7 GB, 53687091200 bytes, 104857600 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x000da8dc

В нашем случае — sda

Записываем распакованный образ на диск

dd if=chr-7.1beta2.img of=/dev/sda bs=4M oflag=sync

где chr-7.1beta2. img — файл образа из архива
/dev/sda — диск виртуального сервера

Производим перезагрузку сервера командами

echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

После загрузки сервера, вы не сможете подключиться к нему удаленно, так как на сервере не указан Ваш IP. Для дальнейшей настройке сервера используйте KVM/VNC подключение к серверу.

Стандартный логин admin без пароля.

Настройка RouterOS

Настраиваем IP сервера

ip address add address=xxx.xxx.xxx.xxx/24 interface=ether1

Настраиваем шлюз

ip route add gateway=xxx.xxx.xxx.xxx

После этого вы уже можете перейти к настройке в веб-интерфейсе, для этого в браузере введите IP который вы настраивали выше.

После первого подключения обязательно установите пароль для пользователя admin

 

 

Установка Mikrotik Cloud Hosted Router на VPS хостинг Digital Ocean — asp24. ru

За основу взят доклад Дмитрия Пичулина @deemru на прошедшем 30 сентября MUM в Москве. В отличии от доклада Дмитрия, в данной статье не будет рассматриваться вопросы выбора хостинга и цен на него (в стремлении намутить облачный роутер подешевле), настройки полученного устройства. Рассмотрена будет лишь техническая сторона вопроса и решены пара проблем.

Вернувшись с MUM, я был в предвкушении, руки чесались запилить Mikrotik на Digital Ocean (в тот момент, там была Ubuntu Server, которая выполняла функции VPN-сервера). Полез смотреть архив выступлений, но его ещё не было и я написал письмо Дмитрию с просьбой поделиться слайдами. Получив презентацию, с холодной головой ринулся в бой — ломать свой дроплет полностью. Сделал всё, как в презентации, всё завелось. Легче и придумать нельзя. Скачиваем на хостинг образ, распаковываем, переводим файловую систему в read-only, заливаем образ на диск через dd. Но тут то меня и подстерегала первая нестыковочка — у Дмитрия при первой загрузке CHR автоматически произошло расширение файловой системы и она заняла весь диск, у меня же этого не произошло и пришлось довольствоваться 128 МБ.

Кто-то скажет 128 МБ на роутере хватит всем. Но меня эта ситуация в корне не устраивала, поэтому я принялся её устранять. Всем известно, что RouterOS основана на Linux, но от Linux’а там мало что осталось, поэтому после установки системы, её штатными средствами переразметить диск уже нельзя. Нельзя и загрузиться с какого-нибудь LiveCD и переразметить в нём (ну по крайней мере у DO нельзя). Попытки тыкаться fdisk’ом и parted’ом после заливки образа на диск, но до перезагрузки так же не привели к какому-либо положительному результату (эффекта либо не было вообще, либо я получал не загружающуюся систему).

Нормальные герои всегда идут в обход.

Итак для того чтобы получить RouterOS, установленную на Digital Ocean, в которой доступно 20 ГБ дискового пространства (ну или сколько там у Вас по тарифу) нам потребуется:

  • Собственно, сам droplet с установленным Linux дистрибутивом (в данном случае дистрибутив будет Ubuntu Server 16.04 x64, а вместо droplet’а будет виртуальная машина в ESXi, но ещё раз повторюсь, что роли это не сыграет), к которому у нас есть доступ по SSH.
  • Установленный на компьютере или сервере гипервизор (изначально я делал в VirtualBox, сейчас буду делать опять же в ESXi, на конечный результат это не влияет).
  • LiveCD вашего любимого Linux-дистрибутива (желательно, чтобы там был GUI, так будет удобнее).

Как вы видете, список не очень большой, каких-то особых требований к его пунктам нет, решение я старался сделать максимально универсальным и простым, чтобы можно было всё соорудить буквально на коленке из того, что есть.

Начнём с дроплета.

Нам нужно выяснить, какого объёма нам нужен диск в виртуальной машине, поэтому:

fdisk -l /dev/sda
Диск /dev/sda: 16 GiB, 17179869184 байтов, 33554432 секторов
Единицы измерения: секторов из 1 * 512 = 512 байтов
Размер сектора (логический/физический): 512 байт / 512 байт
I/O size (minimum/optimal): 512 bytes / 512 bytes
Тип метки диска: dos
Идентификатор диска: 0x7b5dbf9c

Устр-во    Загрузочный    Start Конец Секторы  Size Id Тип
/dev/sda1  *               2048 31457279 31455232   15G 83 Linux
/dev/sda2              31459326 33552383  2093058 1022M  5 Расширенный
/dev/sda5              31459328 33552383  2093056 1022M 82 Linux своп / Solaris

Как мы видим, у нас диск 17179869184 байт, запомним это значение.

Подготовка промежуточной машины.

В гипервизоре создаём новую виртуальную машину. Её параметры особого значения не имеют, но можно, к примеру сделать их близкими к характеристикам дроплета. Размер диска лучше сделать с небольшим запасом, на всякий случай (почему-то 20ГБ в DO оказались меньше 20ГБ в VirtualBox). Настраиваем загрузку виртуальной машины с LiveCD.

Включаем её и после загрузки скачиваем любым удобным способом последнюю версию CHR:

unzip chr-6.37.1.img.zip
Archive:  chr-6.37.1.img.zip
  inflating: chr-6.37.1.img

И заливаем образ на жёсткий диск с помощью dd (Дмитрий тут использовал утилиту pv, но я, если честно не вижу в этом смысла, т.к. образ маленький и разворачивается довольно быстро):

dd if=chr-6.37.1.img.zip of=/dev/sda
262144+0 records in
262144+0 records out
134217728 bytes (134 MB, 128 MiB) copied, 5.64304 s, 23.8 MB/s

вместо sda нужно указать ваш диск, его имя может отличаться.

Расширяем файловую систему RouterOS.

Любители всё делать в консоли могут делать там, мне показалось быстрее и проще сделать всё в GParted.

Запускаем GParted, выбираем диск, на который установили RouterOS и с помощью функции Resize/Move увеличиваем размер второго раздела. Обратите внимание, что размер раздела за вычетом размера первого раздела не должен превышать размер диска Вашего дроплета, который мы посмотрели в самом начале (т.е. первый раздел у нас 32 МиБ, значит второй должен быть не более 17179869184 байт / 1048576 = 16384 МиБ и — 32, т.е. 16352 МиБ)

Не забываем применить изменения разметки диска.

Создаём новый образ и жмём его с помощью gzip:

dd if=/dev/sda bs=8196 count 17000 | gzip -9cf > chr.img.gz
17000+0 records in
17000+0 records out
139332000 bytes (139 MB, 133 MiB) copied, 3.30824 s, 42.1 MB/s

Значение 17000 мы получаем путём приведения размера образа при его развёртывании на диск. Там было 128 МиБ, т.е. 128 * 1024 = 131072 КиБ разделим размер на размер блока и округлим 131072 / 8 = 16384 ≈ 17000 блоков.

Заливаем полученный образ на дроплет и устанавливаем его:

scp chr.img.gz [email protected]:~/

Где user — имя пользователя на вашем дроплете, а host — его адрес. Копирование будет выполняться в домашний каталог пользователя.

Принимаем сертификат ssh сервера, и вводим пароль, когда нас об этом попросят. После окончания копирования, эта виртуальная машина нам больше не понадобится.

Переходим на наш дроплет. Можно подключиться к нему по ssh или зайти через консоль. Убедимся, что наш образ скопировался, желающие могут проверить контрольные суммы. Переведём файловую систему в режим read-only и развернём образ на диск через gzip и dd:

echo u > /proc/sysrq-trigger && gunzip -c chr.img.gz | dd of=/dev/vda

Всё! CHR установлен на наш дроплет. Перезагрузимся:

reboot

Заключение.

На доступном месте можно установить внутри RouterOS виртуальную машину с Linux или использовать его как-нибудь иначе — на Ваше усмотрение (поднять FTP сервер или ещё что-нибудь).

© https://habrahabr.ru/post/312292/

Торговая площадка AWS: 404

войти в систему

Ваш сохраненный список
Партнеры

Продавать в AWS Marketplace

Главная страница Amazon Web Services
Помогите

AWS Marketplace в Twitter

Блог AWS Marketplace

Новостная лента

Решения


Бизнес-приложенияДанные и аналитикаDevOpsИнфраструктурное ПОИнтернет вещейМашинное обучениеМиграцияБезопасностьЭнергияФинансовые услугиЗдравоохранение и науки о жизниМедиа и развлеченияГосударственный секторТелекоммуникации
Программное обеспечение для инфраструктурыРезервное копирование и восстановлениеАналитика данныхВысокопроизводительные вычисленияМиграцияСетевая инфраструктураОперационные системыБезопасностьХранилище
DevOpsAgile Lifecycle ManagementРазработка приложенийСерверы приложенийСтеки приложенийНепрерывная интеграция и непрерывная доставкаИнфраструктура как кодОтслеживание проблем и ошибокМониторингАнализ журналаУправление источникамиТестирование
Приложения для бизнеса
Машинное обучениеСлужбы Human Review Решения MLСлужбы маркировки данныхКомпьютерное зрениеОбработка естественного языка Распознавание речиТекстИзображениеВидеоАудиоСтруктурированныеИнтеллектуальная автоматизация
Данные ПродуктыДанные о финансовых услугахДанные о здравоохранении и биологических наукахДанные для СМИ и развлеченийТелекоммуникационные данныеИгровые данныеАвтомобильные данныеПроизводственные данныеДанные об источникахДанные о розничной торговле, местоположении и маркетингеДанные государственного сектора
Интернет-аналитикаПриложенияПодключение устройствУправление устройствамиБезопасность устройствПромышленный IoTSmart для дома и города
Профессиональные услугиОценкаВнедрениеУправляемые услугиПремиум-поддержкаОбучение
ОтраслиОбразование и исследованияФинансовые услугиЗдоровье и науки о жизниМедиа и развлеченияПромышленность
AWS IQ
Веб-сайты и мобильные приложенияБазы данных и аналитикаСеть и безопасностьМашинное обучениеПроизводительность и сотрудничествоОптимизация затратДругое
Ресурсы
ВебинарыОбработка документовРуководства по внедрениюВидеоОтчеты аналитиков
Продавайте на AWS MarketplaceПортал управленияЗарегистрируйтесь в качестве продавцаРуководство продавцаПриложение для партнеровИстории успеха партнеров
О AWS MarketplaceЧто такое AWS Marketplace? Истории успеха клиентовБлог AWSПресс-релизыСобытияПомощь и часто задаваемые вопросыКарьера
Избранные категорииПодписки SaaSWindows ServerМобильные решения
Управление учетной записью Консоль управленияУправление счетами и расходамиПодписка на обновленияЛичная информацияСпособ оплатыУправление идентификацией и доступом AWSУчетные данные безопасностиЗапрос об увеличении лимита обслуживанияСвяжитесь с нами

AWS Marketplace принимает на работу!
Amazon Web Services (AWS) — это динамично развивающееся бизнес-подразделение Amazon. com. В настоящее время мы нанимаем инженеров по разработке программного обеспечения, менеджеров по продуктам, менеджеров по работе с клиентами, архитекторов решений, инженеров службы поддержки, системных инженеров, дизайнеров и многих других. Посетите нашу страницу карьеры или страницу карьеры для разработчиков, чтобы узнать больше.
Amazon Web Services — работодатель с равными возможностями.


© 2012-
2021 г.
, Amazon Web Services, Inc. или ее аффилированных лиц.Все права защищены.

Mikrotik Cloud Hostet Router (CHR)

описание продукта

Общее уведомление:

Уважаемый клиент, Мы больше не можем заниматься доставкой и продажей этого программного обеспечения частным клиентам (клиентам без действующего номера плательщика НДС) из стран-членов ЕС (кроме Германии!).

Учтите это при покупке.

———————————————— ——————————

Примечание:

Чтобы иметь возможность перенести лицензию на свой Mikrotik.com, вы должны отправить нам свое имя учетной записи через поле комментария в процессе покупки.

———————————————— ——————————

Воспользуйтесь этим методом, чтобы получить лицензию для вашего CHR,
http://wiki.mikrotik.com/wiki/Manual:CHR#Getting_the_License 

Cloud Hosted Router (CHR):

Cloud Hosted Router (CHR) — это версия RouterOS, предназначенная для работы в качестве виртуальной машины. Он поддерживает 64-битную архитектуру x86 и может использоваться на большинстве популярных гипервизоров, таких как VMWare, Hyper-V, VirtualBox, KVM и других.В CHR по умолчанию включены все функции RouterOS, но модель лицензирования отличается от других версий RouterOS.

CHR Licensing (всего 4 уровня лицензий):

  • бесплатно
  • p1 бессрочный-1 (45 долларов США)
  • p10 бессрочный-10 (95 долларов США)
  • p-безлимит бессрочный-безлимит (250 долларов США)

60-дневная бесплатная пробная лицензия доступна для всех уровней платных лицензий.Чтобы получить бесплатную пробную лицензию, у вас должна быть учетная запись на mikrotik.com, так как все управление лицензиями будет происходить там.

Perpetual — это пожизненная лицензия (купите один раз, используйте навсегда). Возможен перенос бессрочной лицензии на другой экземпляр CHR.

Работающий экземпляр CHR будет указывать время, когда ему необходимо получить доступ к серверу учетной записи для продления лицензии. Если экземпляр CHR не сможет продлить лицензию, он будет вести себя так, как будто пробный период истек, и не позволит обновить RouterOS до более новой версии.

Пожалуйста, позаботьтесь о том, чтобы CHR всегда был подключен к Интернету посредством лицензирования, устройство должно синхронизироваться с сервером лицензирования Mikrotik каждые 4 недели. Если вы пройдете эту процедуру, у вас будет еще 4 дополнительных недели.

Обратите внимание на официальный Mikrotik-Wiki: http://wiki.mikrotik.com/wiki/Manual:CHR — Вы также можете найти это в формате PDF в качестве приложения к этой статье

Установка виртуального маршрутизатора Mikrotik CHR | Яндекс.Облако

В Яндекс.Облаке можно развернуть виртуальный маршрутизатор Mikrotik Cloud Hosted Router из образа ВМ.Для установки Mikrotik Cloud Hosted Router и проверки его работоспособности:

  1. Перед тем, как начать.
  2. Создайте виртуальную машину с облачным маршрутизатором Mikrotik.
  3. Войдите в свою виртуальную машину и измените пароль.
  4. Создайте тестовую ВМ.
  5. Проверьте соединение между роутером и тестовой ВМ.

Если вам больше не нужны созданные ресурсы, удалите их.

Перед тем, как начать

  1. Заходим в консоль управления. Затем авторизуйтесь в Яндекс.Облако или зарегистрируйтесь, если у вас еще нет учетной записи.
  2. Убедитесь, что на странице выставления счетов вы связали платежный аккаунт, и он имеет статус ACTIVE или TRIAL_ACTIVE . Если у вас нет учетной записи для выставления счетов, создайте ее.

Если у вас есть активная биллинговая учетная запись, вы можете создать или выбрать папку для запуска ВМ на странице Яндекс.Облака.

Подробнее об облаках и папках.

Требуемые платные ресурсы

Оповещение

При использовании образа маршрутизатора Mikrotik Cloud Hosted Router без лицензии пропускная способность маршрутизатора ограничивается 1 Мбит / с.Чтобы снять это ограничение, установите лицензию.

В стоимость использования виртуального роутера и тестовой ВМ входит:

Создание виртуальной машины с помощью облачного маршрутизатора Mikrotik

  1. Откройте папку и щелкните Создать ресурс . Выберите Виртуальная машина .
  2. Введите имя виртуальной машины, например mikrotik-router .
  3. Выберите зону доступности с подсетью. Если вы не знаете, какая зона доступности вам нужна, оставьте значение по умолчанию.
  4. В разделе Изображения из Cloud Marketplace щелкните Выберите и выберите изображение Cloud Hosted Router .
  5. Менее Вычислительные ресурсы :
    • Выберите платформу для ВМ.
    • Укажите количество виртуальных ЦП и объем оперативной памяти:
      • Платформа : Intel Cascade Lake.
      • Гарантированная доля виртуальных ЦП : 100%.
      • виртуальных ЦП : 2.
      • Оперативная память : 2 ГБ.
  6. В разделе Network settings выберите требуемую сеть и подсеть и назначьте публичный IP-адрес виртуальной машине, выбрав его из списка или автоматически. Если у вас нет сети или подсети, создайте их на экране создания виртуальной машины.
  7. В поле Access введите логин и ключ SSH для доступа к виртуальной машине. Обратите внимание, что эти данные нужны только для создания виртуальной машины. Вы не можете использовать данные для доступа к маршрутизатору.
  8. Щелкните Create VM .

Создание виртуальной машины может занять несколько минут. Когда статус виртуальной машины изменится на RUNNING , вы можете войти в систему.

Оповещение

Установите сложный пароль администратора сразу после создания ВМ.

Смена пароля администратора на роутере

Маршрутизатор создан с общедоступным IP-адресом, поэтому вам необходимо изменить пароль администратора по умолчанию из соображений безопасности.

  1. Откройте страницу mikrotik-router VM в консоли управления.
  2. Скопируйте публичный адрес виртуальной машины и откройте его в браузере. Откроется экран первоначальной настройки маршрутизатора.
  3. Введите внутренний IP-адрес виртуальной машины в поле IP-адрес .
  4. На открывшейся странице введите новый пароль администратора, подтвердите его и нажмите Применить конфигурацию .Вы можете сделать другие настройки позже.

Создать тестовую ВМ

Создайте тестовую виртуальную машину в подсети, в которой размещается маршрутизатор, для проверки возможности подключения между маршрутизатором и виртуальной машиной.

  1. На странице папки в консоли управления щелкните Создать ресурс и выберите Виртуальная машина .

  2. В поле Name введите имя виртуальной машины: test-vm .

  3. Выберите ту же зону доступности, в которой находится mikrotik-router VM.

  4. В разделе Образы из Cloud Marketplace выберите образ Ubuntu .

  5. Менее Вычислительные ресурсы :

    • Выберите платформу для ВМ.
    • Укажите необходимое количество виртуальных ЦП и объем оперативной памяти.
    • Платформа : Intel Cascade Lake.
    • Гарантированная доля виртуальных ЦП : 5%.
    • виртуальных ЦП : 2.
    • RAM : 0.5 ГБ.
  6. В разделе Сетевые настройки выберите сеть и подсеть, в которых размещается виртуальная машина mikrotik-router .

  7. В поле Общий адрес выберите Без адреса .

  8. В поле Access введите логин и ключ SSH для доступа к виртуальной машине.

  9. Щелкните Create VM .

Проверьте соединение между роутером и тестовой ВМ

Оповещение

Если вы используете WinBox для доступа к маршрутизатору, подключитесь к маршрутизатору, используя IP-адрес виртуальной машины. Доступ по MAC не поддерживается в Яндекс.Облаке.

Убедитесь, что между маршрутизатором и тестовой ВМ установлено сетевое соединение:

  1. Откройте административный интерфейс маршрутизатора в браузере.
  2. Щелкните Терминал .
  3. В открывшемся терминале запустите ping <внутренний IP-адрес тестовой ВМ> .

Если пакеты доходят до тестовой виртуальной машины, можно приступать к настройке маршрутизатора. О роутере читайте в документации Mikrotik.

Удалить созданные ресурсы

Чтобы перестать платить за развернутые ресурсы, удалите виртуальные машины mikrotik-router и test-vm .

Если вы зарезервировали общедоступный статический IP-адрес, удалите его.

Лицензия MikroTik на облачный маршрутизатор P1 | Discomp

Описание продукта

Лицензия Cloud Hosted Router (CHR) предназначена для установки в виртуальной среде (VMWare, Hyper-V, VirtualBox, KVM и другие). Лицензия P1 имеет ограничение скорости в 1 Гбит для загрузки на интерфейс, а параметры с потерями основаны на лицензии L4.

Минимальное требование
  • Хост-процессор: 64-разрядный с поддержкой виртуализации
  • RAM: 128 МБ или больше
  • Диск: 128 МБ дискового пространства для виртуального жесткого диска CHR (макс .: 16 ГБ)
  • Версия пакета: RouterOS v6.34 или новее
CHR протестирован на следующих платформах
  • VirtualBox 5 в Linux и OS X
  • VMWare Fusion 7 и 8 в OS X
  • VMWare ESXi 6.5
  • Qemu 2.4.0.1 в OS X
  • Hyper-V в Windows Server 2008r2, 2012 и Windows 10 (на данный момент поддерживается только виртуальная машина Hyper-V поколения 1)
  • Xen Project 4.6.5
  • Сервер Xen 7.1
Доступно для установки

Последнюю версию загружаемого файла можно найти на сайте mikrotik.com.

  • Образ диска в формате RAW (файл . img)
  • Образ диска VMWare (файл .vmdk)
  • образ диска Hyper-V (.vhdx файл)
  • Образ диска VirtualBox (файл .vdi)
Как установить CHR
  1. Загрузите образ виртуального диска для вашего гипервизора
  2. Создать гостевую виртуальную машину
  3. Использовать ранее загруженный файл образа в качестве виртуального диска
  4. Запустить гостевую виртуальную машину CHR
  5. Войдите в свой новый CHR. Пользователь по умолчанию — admin, без пароля
  6. .

Порядок оформления заказа
  1. Для активации лицензии необходимо иметь учетную запись в MikroTik.Вы можете создать его бесплатно на сайте www.mikrotik.com
  2. После покупки лицензии на нашем веб-сайте вам необходимо отправить логин вашей регистрации MikroTik и номер счета на [email protected]
  3. Перенесем лицензию на ваш аккаунт MikroTik
  4. Активация осуществляется путем входа на MikroTik в свою учетную запись (Система -> Меню лицензии)

Подробные инструкции можно найти на официальном сайте http: //wiki. mikrotik.com / wiki / Руководство: CHR.

Важная информация и предостережения

В комплект не входит. Доставка купленного товара заключается в переводе соответствующей лицензии на указанный покупателем аккаунт MikroTik. Программное обеспечение и его последующая установка осуществляется покупателем путем загрузки с сайта MikroTik. Лицензии передаются только после оплаты.

Если лицензия системного идентификатора создана в искаженном / несовпадающем формате, ни изменение формы, ни лицензия не могут быть отозваны.Аналогично, в случае посредничества неверного имени учетной записи клиента MikroTik — уже осуществленная передача лицензии необратима! Вам необходимо купить новую лицензию!

Срок активации по договору

Активация обычно производится в течение 24 часов в рабочие дни, максимальная продолжительность активации установлена ​​в 72 рабочих часа. Право на активацию должно быть осуществлено в течение 12 месяцев с даты покупки.

Установите MikroTik CHR на облачный сервер Vultr

MikroTik Cloud Hosted Router (CHR) — это версия RouterOS для облачных серверов. Он обладает следующими характеристиками:

  • Межсетевой экран.
  • Сервер и клиент виртуальной частной сети (VPN).
  • Формирование полосы пропускания.
  • Качество обслуживания (QoS).
  • Возможность работать как точка беспроводного доступа.
  • Мостовое соединение.
  • Точка доступа на основе портала.

Лицензирование

MikroTik CHR имеет бесплатную и платную лицензии. Бесплатная лицензия имеет ограничение скорости 1Мбит.

1. Загрузите SystemRescueCD ISO

  1. Перейдите на страницу развертывания облачного сервера Vultr.
  2. Выберите ISO Library в разделе Server Type.
  3. Выберите SystemRescueCD .
  4. Выберите план сервера и разверните облачный сервер.

2. Загрузите и установите необработанный образ диска MikroTik RouterOS

.

  1. Перейдите на страницу загрузки MikroTik RouterOS.
  2. Прокрутите вниз до раздела « Cloud Hosted Router ».
  3. Щелкните правой кнопкой мыши образ гибкого диска в строке « Raw disk image » и « x.xx.x (Текущий) «столбец.
  4. Выберите в меню «Копировать ссылку». URL необработанного образа диска будет сохранен в буфере обмена вашей операционной системы.
  5. Откройте текстовый редактор и вставьте URL-адрес для безопасного хранения.
  6. На странице экземпляра сервера Vultr щелкните View Console для вашего запущенного экземпляра SystemRescueCD.
  7. Используйте команду wget , чтобы получить URL-ссылку, которую вы вставили в текстовый редактор, набрав ее в окне «Консоль просмотра».

      wget https://download2.mikrotik.com/routeros/x.xx.x/chr-x.xx.x.img.zip
      
  8. Используйте команду unzip для извлечения необработанного образа диска.

      распаковать chr-x. xx.x.img.zip
      
  9. Используйте команду dd для записи необработанного образа диска на виртуальный диск Vultr.

      дд, если = chr-x.xx.x.img.img из = / dev / vda
      
  10. В разделе Settings , Custom ISO вашего экземпляра сервера выберите опцию Remove ISO .Ваш сервер будет перезагружен.

  11. Обновите окно консоли просмотра и введите admin при новом входе в MikroTik. Пароль пуст. Просто нажмите клавишу «возврат».

MikroTik RouterOS теперь установлен на ваш экземпляр Vultr. Следуйте приведенному здесь руководству, чтобы обезопасить свой маршрутизатор и получить к нему удаленный доступ. Спасибо за прочтение.

Хотите внести свой вклад?

Вы можете заработать до $ 300 , добавляя новые статьи

MikroTik Cloud Hosted Router Лицензия P1

Облако
Лицензия Hosted Router (CHR) предназначена для установки в виртуальном
среда (VMWare, Hyper-V, VirtualBox, KVM и другие). Лицензия P1 имеет
ограничение скорости 1 Гбит для загрузки в интерфейс, и с потерями
параметры основаны на лицензии L4.

Минимальное требование

  • Хост-процессор: 64-разрядный с поддержкой виртуализации
  • ОЗУ: 128 МБ или более
  • Диск: 128 МБ дискового пространства для виртуального жесткого диска CHR
    диск (макс .: 16 ГБ)
  • Версия пакета: RouterOS v6.34 или новее

CHR протестирован на следующих платформах

  • VirtualBox 5 в Linux и OS X
  • VMWare Fusion 7 и 8 в OS X
  • VMWare ESXi 6.5
  • Qemu 2.4.0.1 в OS X
  • Hyper-V в Windows Server 2008r2, 2012 и Windows
    10 (На данный момент поддерживается только виртуальная машина Hyper-V поколения 1)
  • Xen Project 4.6.5
  • Xen Server 7.1

Доступно для установки

Последнюю версию загружаемого файла можно найти на сайте mikrotik.com.

  • Образ диска RAW (файл .img)
  • Образ диска VMWare (файл . vmdk)
  • Образ диска Hyper-V (.vhdx)
  • Образ диска VirtualBox (файл .vdi)

Как установить CHR

  1. Скачать виртуальный диск
    изображение для вашего
    гипервизор
  2. Создать гостевую виртуальную машину
  3. Использовать ранее загруженный файл образа как
    виртуальный диск.
  4. Запустить гостевую виртуальную машину CHR.
  5. Войдите в свой новый CHR. Пользователь по умолчанию — admin,
    без пароля

Порядок заказа

  1. Необходимо иметь аккаунт в MikroTik, чтобы
    активировать лицензию.Вы можете создать его бесплатно на сайте www.mikrotik.com.
  2. Приобретя лицензию на нашем сайте, вы
    необходимо отправить логин вашей регистрации MikroTik и счет-фактуру
    номер на [email protected]
  3. Передадим лицензию на ваш MikroTik
    учетная запись.
  4. Активация осуществляется путем входа в MikroTik в
    аккаунт (Система -> Меню лицензии)

Инструкции можно найти на официальном сайте http://wiki. mikrotik.com/wiki/Manual:CHR.

Важная информация и предостережения

В комплект не входит. Доставка купленного
продукт заключается в переносе соответствующей лицензии на аккаунт MikroTik
уточняется покупателем. Покупатель осуществляет программное обеспечение и его последующее
установка путем скачивания с сайта MikroTik. Лицензии переданы
только после оплаты.

Если лицензия System ID генерируется в
искаженный / несоответствующий формат, ни изменение формы, ни лицензия не могут быть
отозван.Аналогично, в случае посредничества клиента MikroTik
неверное имя аккаунта, уже осуществленная передача лицензии
необратимо! Вам необходимо купить новую лицензию!

Срок активации по договору

Активация обычно производится в течение 24 часов на рабочем месте.
дни; максимальная продолжительность активации 72 рабочих часа. Право на
активацию необходимо произвести в течение 12 месяцев с даты покупки.

MikroTik Cloud Hosted Router P-Unlimited Perpetual-Unlimited License, без ограничений

Кто такие MikroTik и для чего используются их продукты?

Начиная с нелицензионного 2. Частоты 4GHz и 5GHz, MikroTik разработали портфель продуктов фиксированной беспроводной широкополосной связи, который обслуживает множество приложений WISP, начиная от решений с высокой пропускной способностью для малых расстояний для городских развертываний и заканчивая надежными решениями беспроводной связи на сверхдальних расстояниях для развертывания в сельской местности. . Их ассортимент также включает в себя другие сетевые аспекты, такие как Wi-Fi внутри и снаружи помещений, красивые и мощные домашние маршрутизаторы 3G и LTE, а также продукты для коммутации и маршрутизации медных и оптоволоконных кабелей с пропускной способностью портов более 10 Гбит / с.В своем стремлении предоставить мощную маршрутизацию как можно большему количеству людей их последние продукты включают в себя ряд маршрутизаторов Core, которые обеспечивают высокую производительность сети по лучшей цене на рынке, а недавно они выпустили линейку CAT5 / 6 медные продукты для имитации подключения «оптоволокно к дому» и «пожар — к бизнесу» по сниженной цене — они называют эту технологию GPEN — Gigabit Passive Ethernet Network.

История MikroTik

MikroTik — латвийская компания, основанная в 1996 году для разработки маршрутизаторов и беспроводных интернет-провайдеров.MikroTik развивалась на протяжении многих лет и предлагает гибкие, многофункциональные и экономичные аппаратные и программные решения для интернет-провайдеров и предприятий по всему миру. Их опыт использования стандартного оборудования для ПК и полных систем маршрутизации позволил им в 1997 году создать собственную операционную систему под названием RouterOS. RouterOS обеспечивает высокую стабильность, контроль и гибкость для всех видов интерфейсов данных и решений маршрутизации. В 2002 году MikroTik решила производить собственное оборудование, и так родился бренд RouterBOARD.У них есть реселлеры по всему миру, включая Южную Африку. Последние продукты MikroTik специально разработаны, чтобы сделать существующие Интернет-технологии более быстрыми, мощными и доступными для более широкого круга пользователей. Вы можете купить эти лучшие в своем классе продукты MikroTik прямо на сайте www. miro.co.za.

Преимущества использования MikroTik в Южной Африке

Многие из лояльных клиентов MikroTik из Южной Африки не только любят продукты, но и выбирают MikroTik специально для программного обеспечения RouterOS.MikroTik RouterOS — это операционная система и программное обеспечение маршрутизатора, которые превращают обычный ПК или оборудование MikroTik RouterBOARD в выделенный маршрутизатор. Некоторые из основных функций RouterOS MikroTik включают поддержку 802.11a / b / g / n / ac, настраиваемый протокол Nv2 TDMA, улучшенное качество обслуживания (QoS), межсетевой экран с отслеживанием состояния, туннели (VPN), мост STP с фильтрацией, WDS и виртуальный AP, точки доступа для доступа Plug-and-Play, RIP, OSPF, BGP, маршрутизация MPLS, удаленный графический интерфейс WinBox и веб-администрирование, высокая доступность с помощью VRRP, связывание интерфейсов, Telnet / mac-telnet / ssh / console admin, в реальном времени настройка и мониторинг, поддержка 3G / LTE, поддержка OpenFlow.

MikroTik предлагает широкий спектр продуктов, включая внутреннее и внешнее оборудование для помещений заказчика (CPE) и решения для точек беспроводного доступа (AP), маршрутизаторы операторского класса с новейшими многоядерными процессорами и их серию Smart Switch, а также небольшие интегрированные медные и оптоволоконные маршрутизаторы под управлением RouterOS для сборки ваших собственных систем. MikroTik предлагает более 160 различных продуктов.

MikroTik известен не только своим широким спектром различных продуктов и технологий, но и своей простой в использовании операционной системой.Опыт и знания MikroTik позволили им стать глобальным брендом, обслуживающим практически любой бизнес, от крупнейших корпоративных гигантов до домашних пользователей — у MikroTik есть решение для каждой потребности!

Партнерство MiRO с MikroTik

MiRO Южная Африка поставляет продукцию MikroTik более 16 лет и с тех пор играет ключевую роль в расширении MikroTik в Южной Африке. MiRO стремится управлять надежной и стабильной цепочкой поставок продуктов MikroTik в южной части Африки и имеет все необходимое для поддержки бренда на местном рынке.Вы можете не только приобретать устройства MikroTik в MiRO, но также MiRO может помочь вам с предпродажной поддержкой, обучением на международном уровне и послепродажной поддержкой.

MiRO предлагает новейшую и лучшую линейку MikroTik, чтобы вы тоже могли сделать правильный выбор при выборе лучшего решения, которое подойдет вам.

Их полный ассортимент включает:

· Решения CPE и AP для установки внутри и вне помещений 2,4 ГГц, 5 ГГц и 60 ГГц на любой бюджет.

· Маршрутизаторы операторского класса с новейшими многоядерными процессорами и серией интеллектуальных коммутаторов MikroTik.

· Небольшие интегрированные маршрутизаторы под управлением RouterOS для сборки ваших собственных систем.

· Аксессуары, такие как корпуса RouterBoard, блоки питания и RouterBoard.

· Оптоволоконные решения, такие как серия CWDM

· Модельный ряд продуктов GPEN.

Добавить комментарий

Ваш адрес email не будет опубликован.

2022 © Все права защищены. Карта сайта