Разное

Mikrotik export настроек: Как сохранить конфигурацию MikroTik

Содержание

Как сохранить конфигурацию MikroTik

Что бы сохранить конфигурацию MikroTik существует несколько способов и сейчас мы их рассмотрим:

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

1. Самый простой способ, это воспользоваться утилитой WinBox. 

Для этого откроем меню Files и нажмем Backup.

В поле Name пишем название нашей резервной копии, при желании можем зашифровать введя пароль в поле Password, если пароль не требуется, ставим галочку Don’t Encrypt и нажимаем на кнопку Backup. После этого в списке файлов появится наша резервная копия. Что бы сохранить резервную копию к себе на компьютер, перетащите файл мышкой к себе на локальный диск.

Что бы восстановить резервную копию, выбираем файл и нажимаем Restore

Перед восстановлением сбросьте все настройки через меню System -> Reset Configuration.

2. Сохранение резервной копии через терминал.

Зайдите в терминал через меню New Terminal и введите команду:

system backup save name=Backup_term (имя можно придумать любое)

После чего появится надпись:

Saving system configuration
Configuration backup saved

и в списке файлов будет наша резервная копия

Что бы восстановить резервную копию, введите команду:

system backup load name=Backup_term

Настройки будут восстановлены из файла Backup_term

3. Сохранение настроек в текстовом формате.

Настройки вашего устройства можно сохранить так же и в текстовом формате. Это удобно если требуется сравнить 2 конфигурации или изменить какие то настройки.

Что бы сохранить настройки в текстовом формате зайдите в New Terminal и введите команду:

export file=config_backup.rsc

После выполнения команды появится в файлах сохраненная наша конфигурация

Что бы восстановить конфигурацию, введите команду:

import file=config_backup.rsc 

Иногда встречаются ситуации, когда требуется сохранить только часть настроек, например настройки dhcp сервера, правила и тд, для этого существуют следующие команды:

ip address export file=ip.rsc
ip firewall mangle export file=mangle.rsc
ip firewall nat export file=nat.rsc
ip firewall filter export file=filter.rsc
queue simple export file=simple.rsc
ip dns export file=dns.rsc
files backup export file=backup.rsc
system script export file=script.rsc
system scheduler export file=scheduler.rsc
tool e-mail export file=email.rsc
ip firewall address-list export file=address-list.rsc
ip route export file=route.rsc
ip dhcp-server network export file=network.rsc
queue type export file=type.rsc
queue tree export file=tree.rsc
queue simple export file=simple.rsc
interface ethernet export file=ethernet.rsc
ip pool export file=pool.rsc
ppp profile export file=profile.rsc
log export file=log.rsc

 

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

Как сохранить, восстановить, перенести конфигурацию


Автор Админ На чтение 6 мин. Просмотров 1.4k. Опубликовано
Обновлено

На роутерах Mikrotik есть функция создания резервной копии конфигурации системы. Для чего это нужно? Регулярный бэкап настроек поможет избежать ряда проблем. Например:

  • Маршрутизатор полностью вышел из строя. Вы оперативно сможете его восстановить, вернув прежние установки;
  • Обновление прошивки MikroTik прошло неудачно;
  • Если во время внесения изменений в работу логики оборудования что-то пойдет не так, то всегда будет возможность вернуть роутер к прежним параметрам;

Рекомендуем создавать бэкап настроек перед каждым внесением изменений в конфигурацию.

Как сохранить конфигурацию MikroTik

На устройствах Mikrotik backup конфигурации можно сделать несколькими способами: бинарный файл (backup) и экспорт (export).

Давайте сравним эти способы. Разберемся, чем они отличаются, какие особенности имеют:

Бинарный файл (backup) Экспорт (export)
Делает только полную копию системы, сохраняя сертификаты, пароли учетных записей. Можно выполнить бэкап нужного раздела или всей конфигурации. Не сохраняет сертификаты, учетные данные.
Используется ТОЛЬКО на том оборудовании, на котором создавался. Можно восстанавливать конфигурацию RouterOS на любом другом маршрутизаторе данной марки.
Перед восстановлением стирает старые настройки, заменяя их новыми. При восстановлении старые и новые настройки объединяются.
Работает из графического интерфейса и консоли. Доступен только из консоли.
Надо знать пароль администратора, при котором создавалась резервная копия. Пароль не нужен. Есть режим отладки. Можно определить, из-за чего импорт не происходит.
Нет возможности посмотреть содержимое файла и внести изменения. Можно открыть текстовым редактором. Есть возможность редактировать конфигурацию с последующим импортом.

Бинарный файл (backup)

Напомним, что этот способ создает только полную копию настроек RouterOS, сохраняя данные учетных записей и сертификаты.

Важно! Используется ТОЛЬКО на том же оборудовании, на котором создавался.

Создание полной резервной копии системы

Через графический интерфейс Winbox

Порядок действий:

  • Заходим на MikroTik через Winbox;
  • Files => Backup.

Откроется окно со следующим содержанием:

  • Name — задать имя резервной копии;
  • Password — задать пароль шифрования;
  • Encryption — задать тип шифрования.

Если самостоятельно не указать имя для сохраняемой конфигурации, то оно генерируется автоматически и будет иметь вид:

[идентификатор-устройства][дата]-[время].backup

Мы создали резервную копию системы. Проверяем:

Важно! Если есть папка flash, то бэкап должен находиться в ней. Иначе после перезагрузки Mikrotik он удалится.

Консоль

Консоль открывается через Winbox (вкладка New Terminal) или подключением по ssh (например с помощью программы Putty). После соединения с маршрутизатором достаточно ввести команду:

> /system backup save name=[имя-файла]

где [имя-файла] — это имя создаваемого файла (можно задать любое, на свое усмотрение).

Восстановление настроек конфигурации из бинарного файла

Для того чтобы восстановить настройки Mikrotik из резервной копии (*.backup), нужно:

  • зайти в меню Files;
  • выбрать необходимый бэкап;
  • нажать Restore.

в появившемся окне ввести пароль, подтвердить действие.

Далее появится сообщение: Do you want to restore configuration and reboot?

Подтверждаем. После этого маршрутизатор уйдет на перезагрузку, восстановив настройки.

Из консоли:

> system backup load name=flash/MikroTik-20200518-2154.backup

Экспорт конфигурации (export)

Данный метод создает бэкап нужного раздела или всей конфигурации RouterOS, сохраняя ее в формате *.rsc, при этом информация о паролях и сертификатах пользователя не сохраниться. Особенность создания резервной копии настроек способом export — файл конфигурации можно открыть текстовым редактором и внести изменения. А также возможен импорт настроек на любом оборудовании компании Mikrotik.

Экспорт полной конфигурации

Запустим Winbox и откроем New Terminal:

Чтобы выполнить экспорт полной конфигурации с детальным описанием настроек, нужно использовать команду:

> export file=full-backup verbose

  • full-backup — имя создаваемого файла, задается произвольно.
  • verbose — параметр, означающий экспорт с полным описанием переменных.

По умолчанию export конфигурации делается с кратким описанием параметров:

> export file=full-backup

Частичный перенос настроек Mikrotik

Способ export позволяет сохранять настройки конфигурации блоками с их последующим переносом на любой маршрутизатор Mikrotik. Рассмотрим пример, когда нам нужно выполнить частичный бэкап конфигурации. Для этого сохраним раздел NAT:

> ip firewall nat export file=nat-export

Восстановление настроек Mikrotik

Чтобы восстановить конфигурацию из бэкап, нужно находясь в корневом каталоге выполнить команду import. Приведем в пример восстановление полной конфигурации:

> import full-backup.rsc

Где: Full-backup — имя файла сохраненной конфигурации.

Также можно выполнить импорт в режиме отладки, где этот процесс будет проходить пошагово. Если конфигурация будет с ошибкой или несовместимыми параметрами, то мы поймем, на каком этапе возникает проблема. Для этого запустим import с ключом verbose:

> import file-name=nat-export.rsc verbose=yes

Как сохранить бэкап на ПК

Mikrotik поддерживает технологию Drag&Drop, поэтому, чтобы сохранить файл резервной копии у себя на ПК, достаточно кликнуть по нему мышкой и, удерживая, перенести в любое место рабочего стола или папки.

Сохранить настройки Mikrotik с помощью скрипта

Процесс сохранения настроек системы RouterOS можно упростить. Давайте напишем скрипт, который будет делать полный бэкап системы двумя способами (бинарный файл и *.rsc):

  • для начала скачаем script:
  • перейдем: System => Script => +.
  • придумаем название скрипту: backup;
  • откроем скачанный скрипт любым текстовым редактором, скопируем его содержимое и вставим в поле: Source;
  • OK.

Проверим:

  • Run Script;
  • Откроем меню Files.

Автоматическое создание и отправка Mikrotik backup на e-mail

Создание скрипта

Создадим скрипт, который будет выполнять бэкап полной конфигурации системы двумя способами (backup, export). Отправлять его на электронную почту и удалять с маршрутизатора.

Скачиваем готовый скрипт. В этом примере отправка будет осуществляться на почту yandex:

Откроем его и внесем изменения в следующие строки:

  • Укажем smtp-сервер от e-mail;
  • Почту получателя;
  • Пароль.

Создадим скрипт:

  • меню System => Scripts => +.
  • назначим произвольное имя;
  • скопируем содержимое файла, затем вставим его в поле Source;
  • OK.

Для проверки запустим Script:

Проверим почту:

Как мы видим, бэкапы системы пришли и удалились с устройства Mikrotik. Скрипт работает.

Настройка планировщика

Последним шагом настройки будет автоматическая отправка резервных копий по расписанию. Для этого откроем планировщик:

  • System => Scheduler => +.
  • придумаем имя задания;
  • зададим интервал;
  • On Event, впишем точное имя (учитывая регистр букв) нашего скрипта;
  • OK.

Если вы все сделали правильно, то раз в семь дней вам на почту будут приходить полные резервные копии системы.

Mikrotik сохранить конфигурацию

На всех роутерах в mikrotik сохранить конфигурацию очень просто, если у вас установлена утилита winbox для конфигурирования RouterOS то лучше всего воспользоваться ей. Открываем ее идем в раздел Files – Backup, далее задаем имя и нажимаем на кнопку «backup».

Если хотите чтоб кроме вас этот бэкап не кто не смог восстановить и прочитать задаем пароль. После у вас создастся файл с именем которое вы задали.

Если вы хотите углубить свои знания по работе с роутерами MikroTik, то наша команда рекомендует пройти курсы которые сделаны на основе MikroTik Certified Network Associate и расширены автором на основе опыта . Подробно читайте ниже.

Сохранить настройки mikrotik в файл

Было глупо хранить backup только на самом миrротике, поэтому лучше его сохранить в файл на компьютер. Для этого созданный бэкап нужно просто скачать на компьютер, нажимаем правой кнопкой мыши на имя файла и выбираем download. Но есть одно, но, если вы хотите просмотреть конфигурацию при открытии этого файла текстовым редактором увидите абрукадабру. Для этого случая есть команда «export compact file=config» где «config» это имя фала которое задаётся произвольно.

После ее выполнения в терминале, у вас в разделе file появится файл с именем «config» и расширением script. Его также можно скачать на компьютер и открыть блокнотом для редактирования, в нем будет все в читабельном виде.

Как восстановить микротик из бэкапа

Восстановить микротик из бэкапа так же просто, как и создать его. Если файл backup находится у вас на ПК, загрузите его в роутер после выберете его и нажмите на кнопку «Restore».

После восстановления перезагрузите устройство и настройки вступят в силу. Если вы хотите восстановить старый бэкап на новый роутер убедитесь, что вы знаете от него логин и пароль, так как после применения учетные данные на роутере поменяются на те которые были в файле восстановления. Для тренировки или для того, чтобы посмотреть настройки в бэкапе можете его восстановить на виртуальном роутере, да и вообще все тесты проводить лучше сначала в виртуальной среде. Как это сделать и на чем описано в статье про эмулятор eve-ng.

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

Для начинающих:Резервное копирование — MikroTik WiKi rus

Есть старая шутка: «системные администраторы делятся на тех, кто еще не делает резервное копирование и на тех, кто уже делает резервное копирование». Иногда к этой шутке добавляют третью часть: «и на тех, кто уже делает резервное копирование и проверяет резервные копии».

Введение

В RouterOS существует 2 типа резервных копий: .backup (бинарный файл с конфигурацией) и .rsc (файл в котором вся конфигурация представлена в текстовом виде команд консоли). Тип .rsc нельзя экспортировать или импортировать в графическом режиме, а импортировать можно только через диалог сброса конфигурации.

Научиться работать с MikroTik можно с помощью видеокурса "Настройка оборудования MikroTik". Помимо всех тем из официальной программы MikroTik MTCNA курс содержит много дополнительного материала. Курс сочетает теоретическую часть и практику – настройку маршрутизатора по техническому заданию. Поддержку по курсу оказывает его автор Дмитрий Скоромнов, который является официальным тренером MikroTik (TR0680) и по совместительству автором этой Wiki.
Полезные материалы по теме MikroTik:
* Чек-лист по настройке MikroTik * Матрица продуктов MikroTik: модель, артикул, информация по процессору (архитектура, частота, количество ядер), уровень лицензии, объем ОЗУ и ПЗУ, наличие модулей Wi-Fi на разных частотах и коэффициенты усиления встроенных антенн и многое другое. Всего более 30-ти параметров для каждого из 151-го устройства в списке.

Через графический интерфейс

Формат .backup

Экспорт

Резервное копирование (экспорт) через графический интерфейс MikroTik

  1. В раделе Files нажать кнопку Backup
  2. Ввести желаемое имя
  3. Задать пароль и шифрование при необходимости
  4. Нажать кнопку Backup
  5. В списке файлов должен появится файл с названием которое вы ввели и расширением .backup
Импорт

Восстановление (импорт) через графический интерфейс MikroTik

  1. В раделе Files выбрать нужный файл бэкапа и нажать кнопку Retore
  2. Ввести пароль, если он был задан
  3. Нажать кнопку Restore
  4. Нажать Yes — после этого последует перезагрузка и восстановление конфигурации

Формат .rsc

Экспорт

Экспорт через графический интерфейс не возможен.

Импорт

Резервное копирование (экспорт) настроек в формате *.rsc через графический интерфейс MikroTik

  1. Выбрать раздел System
  2. Выбрать раздел Restore
  3. Свериться со списком файлов раздела Files и выбрать глазами нужный
  4. Выбрать этот файл в выпадающем списке Run After Reset
  5. Выбрать Reset Configuration, затем Yes — после этого роутер будет перезагружен и применен выбранный конфигурационный файл

Через консоль

Формат .rsc

Экспорт

При экспорте файл с именем которое вы задали в команде и расширением .rsc появляется в корне раздела Files.

Экспорт всей конфигурации:

export file=test.rsc

Экспорт отдельного раздела (на примере раздела ip adress):

/ip address export file=address.rsc
Импорт
import file=test.rsc
Исправление проблем при импорте или экспорте
  • Попробуйте полностью сбросить устройство и применить конфигурацию
  • Попробуйте использовать ключ
verbose=yes

Он покажет в каком месте файла остановился импорт, этим же ключем можно пользоваться и при проблемах с экспортом (принцип тот же, покажет место на котором экспорт остановился)

При импорте:

import file=test.rsc verbose=yes

При экспорте:

export file=test.rsc verbose=yes

Формат .backup

Экспорт
system backup save name=test
Импорт
system backup load name=test

У вас может быть запрошен пароль, если вы не устанавливали пароль, то он пуcт и вам просто нужно нажать клавишу enter.

После диалога запроса пароля, будет диалог о перезагрузке, в котором нужно ввести y, после чего будет перезагрузка и восстановление конфигурации из выбранного файла.

Научиться работать с MikroTik можно с помощью видеокурса "Настройка оборудования MikroTik". Помимо всех тем из официальной программы MikroTik MTCNA курс содержит много дополнительного материала. Курс сочетает теоретическую часть и практику – настройку маршрутизатора по техническому заданию. Поддержку по курсу оказывает его автор Дмитрий Скоромнов, который является официальным тренером MikroTik (TR0680) и по совместительству автором этой Wiki.
Полезные материалы по теме MikroTik:
* Чек-лист по настройке MikroTik * Матрица продуктов MikroTik: модель, артикул, информация по процессору (архитектура, частота, количество ядер), уровень лицензии, объем ОЗУ и ПЗУ, наличие модулей Wi-Fi на разных частотах и коэффициенты усиления встроенных антенн и многое другое. Всего более 30-ти параметров для каждого из 151-го устройства в списке.

Использование возможностей резервного копирования и восстановления устройств MikroTik.

10.06.2020

Описание

Функция резервного копирования конфигурации (backup) может быть использована для сохранения конфигурации настроек MikroTik RouterOS в двоичный файл, который может быть сохранен на маршрутизаторе или выгружен с него по протоколу FTP для дальнейшего использования. Восстановление из файла конфигурации можно использовать для возврата конфигурации, которая была в момент создания резервной копии. В процедуре восстановления предполагается, что конфигурация восстанавливается на том же маршрутизаторе, где изначально был создан файл резервной копии (или на другом маршрутизаторе той же модели и с той же версией RouterOS), поэтому при смене оборудования на другое, конфигурация может загрузиться в частично поврежденном виде.

Экспорт конфигурации можно использовать для выгрузки полной или частичной конфигурации MikroTik RouterOS на экран консоли или в текстовый файл (скрипт), который можно загрузить с маршрутизатора по протоколу FTP. Дамп конфигурации — это набор команд, которые добавляют (без удаления существующей конфигурации) выбранную к текущей конфигурации маршрутизатора. Средство импорта конфигурации выполняет пакет консольных команд из файла-скрипта.

Команда сброса системы используется для удаления всей конфигурации на маршрутизаторе. Перед этим может быть полезно сделать резервную копию конфигурации маршрутизатора.

Резервное копирование системы

Функция резервного копирования системы позволяет вам легко сохранять и загружать конфигурацию устройства. Узнать больше о функции резервного копирования можно в соответствующем разделе официального руководства: https://wiki.mikrotik.com/wiki/Manual:System/Backup.

Экспорт конфигурации

Название команды: /export

Команда export выводит скрипт, который может быть использован для восстановления конфигурации. Команду можно вызывать на любом уровне меню, и она действует для данного уровня меню и всех подуровней меню. Вывод может быть сохранен в файл, доступный для загрузки через FTP.

Описание команды
file=[filename] – сохраняет вывод команды export в файл
Пример
[[email protected]] > ip address print
Flags: X — disabled, I — invalid, D — dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 10.1.0.172/24 10.1.0.0 10.1.0.255 bridge1
1 10.5.1.1/24 10.5.1.0 10.5.1.255 ether1
[[email protected]] >

Чтобы сделать файл экспорта:
[[email protected]] ip address> export file=address
[[email protected]] ip address>

Чтобы увидеть файлы экспорта, хранящиеся на маршрутизаторе:
[[email protected]] > file print
# NAME TYPE SIZE CREATION-TIME
0 address.rsc script 315 dec/23/2003 13:21:48
[[email protected]] >

Компактный экспорт

Начиная с версии RouterOS 5.12 был добавлен «export compact». Это позволяет экспортировать только ту часть конфигурации, которая не является конфигурацией RouterOS по умолчанию.
Примечание: Начиная с версии v6rc1 «export compact» является поведением по умолчанию. Для экспорта в старом стиле используйте подробный экспорт.
Например, компактный экспорт OSPF:
[[email protected]] /routing ospf> export compact
# jan/02/1970 20:16:32 by RouterOS 5.12
# software id = JRB7-9UGC
#
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1
/routing ospf interface
add disabled=yes interface=wlan1 network-type=point-to-point
/routing ospf network
add area=backbone network=10.255.255.36/32
add area=backbone disabled=yes network=10.5.101.0/24
add area=backbone network=10.10.10.0/24
[[email protected]] /routing ospf>

Компактный экспорт представляет еще одну функцию, которая указывает, какая часть конфигурации является конфигурацией по умолчанию в RouterOS и не может быть удалена. Как в примере ниже, «*» указывает, что данная часть OSPF является частью конфигурации по умолчанию.

[[email protected]] /routing ospf instance> print
Flags: X — disabled, * — default
0 * name=»default» router-id=0.0.0.0 distribute-default=never
redistribute-connected=as-type-1 redistribute-static=no
redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no
metric-default=1 metric-connected=20 metric-static=20 metric-rip=20
metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in
out-filter=ospf-out

Импорт конфигурации

Название команды: /import

Команда корневого уровня /import [имя_файла] выполняет сценарий, сохраненный в файле с указанным именем. Выполнение этой команды добавит конфигурацию из указанного файла в текущую конфигурацию. Этот файл может содержать любые консольные команды, включая скрипты. Может использоваться для восстановления конфигурации или ее частей после потери конфигурации.

Описание команды
file=[filename] — загружает экспортированную конфигурацию из файла в маршрутизатор
Автоматический импорт

В RouterOS можно автоматически выполнять файлы-сценарии. Файл сценария должен называться any.auto.rsc — как только этот файл будет загружен по FTP на маршрутизатор, он будет автоматически выполнен, как и команда ‘/import’. Этот метод работает только с FTP.

Как только файл загружен, он автоматически выполняется. Информация о выполнении команд записывается в any.auto.log


Пример
Чтобы загрузить сохраненный файл экспорта, используйте следующую команду:

[[email protected]] > import address.rsc
Opening script file address.rsc

Script file loaded and executed successfully
[[email protected]] >

Сброс конфигурации

Название команды: / system reset-configuration

Данная команда очищает всю пользовательскую конфигурацию на маршрутизаторе и устанавливает конфигурацию по-умолчанию, включая имя пользователя и пароль («admin» и без пароля), IP-адреса и другие настройки стираются, а интерфейсы отключаются. После команды сброса маршрутизатор перезагрузится. По-умолчанию — это либо заводская конфигурация по-умолчанию, которую можно увидеть в статье «Конфигурации по умолчанию»( https://wiki.mikrotik.com/wiki/Manual:Default_Configurations), либо это может быть пользовательская конфигурация по-умолчанию, которая может быть установлена интеграцией файла RSC при использовании Netinstall.


Описание команды:
keep-users: хранит пользователей маршрутизатора, пароли и ключи хоста ssh (начиная с v6.45.1)
no-defaults: не загружает никаких настроек по умолчанию, просто очищает все
skip-backup: автоматическое резервное копирование не создается перед сбросом, если указано yes
run-after-reset: укажите имя файла экспорта для запуска после сброса

Примечание: Если задан параметр run-after-reset, параметр no-defaults будет игнорироваться и будет загружен только указанный сценарий!
Предупреждение: Если на устройстве имеется папка с названием «flash», то файл confscript.rsc должен храниться в этой папке чтобы команда «run-after-reset» работала. Все, что находится вне этой папки хранится на диске RAM, содержимое которого удаляется при перезагрузке или выключении питания.
Предупреждение: Если RouterOS был установлен с помощью netinstall и в качестве начальной конфигурации был указан сценарий, то команда сброса выполнит этот сценарий после очистки конфигурации. Для того чтобы остановить этот процесс, вам придется выполнить переустановку RouterOS.

Пример:
[[email protected]] > system reset-configuration
Dangerous! Reset anyway? [y/N]: n
action cancelled
[[email protected]] >

Устранение неполадок при импорте


Части конфигурации, на которые нужно обратить внимание в экспортированных файлах .rsc.

Что следует удалить из файлов экспорта, созданных с помощью: «/export», перед попыткой импорта на новом устройстве.

Переименование интерфейса, которое противоречит схеме именования Ethernet по-умолчанию на новом устройстве.


/interface ethernet
set [ find default-name=ether5 ] auto-negotiation=no name=ether1-gateway
set [ find default-name=ether6 ] name=ether2
set [ find default-name=ether7 ] name=ether3
set [ find default-name=ether8 ] name=ether4
set [ find default-name=ether1 ] name=ether5
set [ find default-name=ether2 ] name=ether6
set [ find default-name=ether3 ] name=ether7
set [ find default-name=ether4 ] name=ether8

В более ранней версии экспорта записи по умолчанию могут отображаться с командой «add» вместо «set». Это следует отредактировать перед импортом, чтобы избежать ошибок.

Проверьте, совпадают ли значения интерфейса/модуля: ether/wlan/modem/com/etc на новом и старом устройствах. Если какие-то из них из них будут отсутствовать, то это приведет к ошибке при импорте .rsc.

В случае проблемного импорта попробуйте выполнить сброс конфигурации на данном устройстве и запустить команду импорта с аргументом verbose=yes. Этот аргумент позволит продолжить процесс выполнения импорта даже в случае наличия ошибки импорта, но отобразит то место, где импорт не удался. Таким образом, указывая, где необходимо отредактировать файл импорта .rsc.

Задержка запуска

Если ваша конфигурация опирается на интерфейсы, которые могли еще не запуститься после выполнения команды, предлагается ввести задержки или контролировать, пока все необходимые интерфейсы не станут доступны. Этот пример сценария позволяет вам установить, сколько интерфейсов вы ожидаете, и как долго ждать, пока они станут доступными:


{
:local i 0
#Number of interfaces. It is necessary to reconfigure this number for each device (/interface print count-only)
:local x 10
#Max time to wait
:local t 30
while ($i
:put $i
:set $i ($i + 1)
:delay 1
}
if ($i = $t) do={
:log warning message=»Could not load all physical interfaces»
} else={
#Rest of your script
}
}

Приведенный выше сценарий будет ожидать, пока не появится 10 видимых интерфейсов или 30 секунд. Если в это время нет 10 интерфейсов, он поместит сообщение в журнал. Измените переменные в соответствии с вашими потребностями.

Ознакомиться с оригиналом руководства можно по ссылке: https://wiki.mikrotik.com/wiki/Manual:Configuration_Management.

Как сохранить конфигурацию MikroTik: настройка PARTITIONS в RouterOS

Настройка и особенности использования функции дополнительной защиты в RouterOS — PARTITIONS.

Просмотров: 6153

Что такое Partitions в Mikrotik

Маршрутизаторы производства MikroTik — это достаточно надежные устройства, которые могут работать годами без перезагрузок и зависаний. Тем не менее существуют ситуации, при которых есть риск потери конфигурации маршрутизатора или неисправности его операционной системы.

Такие ситуации могут возникнуть в случаях:

  • Обновления RouterOS. Если в процессе обновления происходит аварийное завершение работы, например, при потере питания, RouterOS может быть поврежден;
  • Нестабильности новых версий RouterOS. После обновления наблюдается неправильная работа, связанная с «глюками», «багами» новой версии. Причем откат к предыдущей версии не меняет ситуацию. Помогает только перестановка стабильной версии средствами NetInstall;
  • Повреждения флеш-памяти, связанное с конечным циклом записи/перезаписи, образования bad block и других причин, которые повреждают критические данные RouterOS.

Производителем реализован функционал защиты от таких проблем в виде возможности резервирования операционной системы и конфигурации на отдельном разделе загрузочного диска. Этот функционал называется PARTITIONs в RouterOS.

В данной статье подробно рассмотрим эту функциональность и особенности ее использования.

Для чего нужен Partitions

Функция Partitions позволяет разбить NAND flash-память устройства на несколько разделов, которые можно использовать независимо друг от друга. Это дает возможность хранить резервный «слепок» системы, с которого мы можем загрузиться в случае выхода из строя основной копии ОС по каким-либо причинам, а также установить свою собственную операционную систему, например, OpenWRT.

Partitioning поддерживается следующими типами процессоров:

Также есть ограничение на минимальный размер partition:

  • 32МБ для MIPS;
  • 40МБ для PPC;
  • 40МБ для ARM;
  • 48МБ для CCR.

 Максимальное число допустимых partition — до 8.

Практика применения Partitions

Рассмотрим практические аспекты применения Partitions в RouterOS.

Для того чтобы начать пользоваться функцией Partition на вашем устройстве, необходимо переразметить flash на требуемое количество разделов. Для этого необходимо выбрать меню Partition(1)→Repartition(2)→ввести необходимое количество разделов→выполнить Repartition(3)

Внимание! Рекомендуется перед выполнением Repartition сделать резервную копию системы и сохранить ее локально. При штатном выполнении основная система не повреждается.

После успешного выполнения «разбивки» вы увидите новые разделы после перезагрузки устройства. Для создания резервной копии RouterOS выберете основную партицию(1)→Copy To(2)→выберете раздел назначения(3)→Start(2)

Таким образом мы получили резервную копию системы на второй части диска.

Также доступны дополнительные действия и настройки:

  1. Save Config To(1) — сохранение только конфигурации на указанный раздел;
  2. Restore Config From(2) — восстановление конфигурации с указанного раздела на активный раздел. Внимание, после восстановления конфигурации маршрутизатор будет перезагружен;
  3. Activate(3) — меняет основной раздел для загрузки на указанный;
  4. Fallback To(4) — действие при неуспешной загрузке RouterOS:
    • next — загрузиться со следующего раздела;
    • part2 — загрузиться с указанного раздела;
    • etherboot — загрузиться по сети.

Заключение

Функционал Partitions достаточно прост и не требует много времени на настройку, зато позволяет повысить отказоустойчивость ваших устройств на порядок. Наиболее интересна эта функция будет при работе с удаленными маршрутизаторами. Потратив немного времени на изучение и внедрение этой функции сейчас, вы сэкономите ресурсы и затраты в будущем.

Вам помогла эта статья?

поделиться материалом:

Сохранение настроек через терминал – MikroTik Routers and Wireless

Чтобы сохранить резервную копию настроек MikroTik через терминал, выполните следующую команду.

system backup save name=backup_20170421

После этого будет создан файл backup_20170421. Название файла может быть любым. В названии файла желательно указывать дату, чтобы потом не запутаться.  В данном случае в названии файла указана дата 20121030 – 30 октября 2012 года. Файлы с датой, указанной таким образом, будет очень удобно сортировать по имени в проводнике или файловом менеджере Total Commander, FAR Manager или MC (Linux).
Чтобы восстановить резервную копию настроек MikroTik через терминал, выполните следующую команду.

system backup load name=backup_20170421

Настройки будут восстановлены из файла backup_20170421
Резервные копии MikroTik сохраняются в специальном формате и имеют не читабельный вид. Если вы захотите проанализировать две конфигурации, вам нужно сохранить настройки так, чтобы их можно было открыть в текстовом редакторе. Такие настройки можно будет самостоятельно редактировать, и загружать в MikroTik.

Чтобы сохранить настройки MikroTik в текстовом формате, выполните в терминале следующую команду:

export file=config_backup_20170421.rsc

Название файла может быть любым. В названии файла желательно указывать дату, чтобы потом не запутаться. В данном случае в названии файла указана дата 20170421 . Файлы с датой, указанной таким образом, будет очень удобно сортировать по имени в проводнике или файловом менеджере Total Commander, FAR Manager или MC (Linux).

Чтобы восстановить настройки MikroTik, выполните в терминале следующую команду:

import file=config_backup_20170421.rsc

Бывают ситуации, когда нужно сохранить часть настроек, например, правила фаервола, NAT и т.п. Для этого помогут следующие команды:

ip address export file=ip.rsc

ip firewall mangle export file=mangle.rsc

ip firewall nat export file=nat.rsc

ip firewall filter export file=filter.rsc

queue simple export file=simple.rsc

ip dns export file=dns.rsc

files backup export file=backup.rsc

system script export file=script.rsc

system scheduler export file=scheduler.rsc

tool e-mail export file=email.rsc

ip firewall address-list export file=address-list.rsc

ip route export file=route.rsc

ip dhcp-server network export file=network.rsc

queue type export file=type.rsc queue tree export file=tree.rsc

queue simple export file=simple.rsc

interface ethernet export file=ethernet.rsc

ip pool export file=pool.rsc

ppp profile export file=profile.rsc

Как сохранить, восстановить, перенести конфигурацию

Автор Админ На чтение 6 мин. Просмотров 1,4 тыс. Опубликовано
Обновлено

На роутерах Mikrotik есть функция создания резервной копии конфигурации системы. Для чего это нужно? Регулярный бэкап настроек поможет избежать ряда проблем. Например:

  • Маршрутизатор полностью вышел из строя.Вы оперативно восстановить его, вернув прежние установки;
  • Обновление прошивки MikroTik прошло неудачно;
  • Если во время внесения изменений в работу логики оборудования что-то пойдет не так, то всегда будет возможность вернуть роутер к прежним параметрам;

Рекомендуем создать бэкап настроек перед внесением изменений в конфигурацию.

Как сохранить конфигурацию MikroTik

На устройстве Mikrotik резервное копирование конфигураций, доступных для использования: бинарный файл (резервное копирование) и экспорт (экспорт).

Давайте сравним эти способы. Разберемся, чем они отличаются, какие особенности имеют:

Бинарный файл (резервная копия) Экспорт (экспорт)
Делает только полную копию системы, сохраняя сертификаты, пароли учетных записей. Можно выполнить бэкап нужного раздела или всей конфигурации. Не сохраняет сертификаты, учетные данные.
Используется ТОЛЬКО на том оборудовании, на котором создавался. Можно восстанавливать конфигурацию RouterOS на любом другом маршрутизаторе данной марки.
Перед восстановлением стирает старые настройки, заменяя их новыми. При восстановлении старых и новые настройки объединяются.
Работает из графического интерфейса и консоли. Доступен только из консоли.
Надо знать пароль администратора, при котором создавалась резервная копия. Пароль не нужен.Есть режим отладки. Можно определить, из-за чего импорт не происходит.
Нет возможности посмотреть содержимое файла и внести изменения. Можно открыть текстовым редактором. Есть возможность редактировать конфигурацию с последующим импортом.

Бинарный файл (резервный)

Напомним, что этот способ создает только полную копию настроек RouterOS, сохраняя данные учетных записей и сертификатов.

Важно! Используется ТОЛЬКО на том же оборудовании, на котором создавался.

Создание полной резервной копии системы

Через графический интерфейс Winbox

Порядок действий:

  • Заходим на MikroTik через Winbox;
  • Файлы => Резервное копирование.

Откроется окно со следующим содержанием:

  • Имя — указать имя резервной копии;
  • Пароль — задать пароль шифрования;
  • Encryption — установить тип шифрования.

Если самостоятельно не указать имя для сохраняемой конфигурации, то оно создается автоматически и будет иметь вид:

[идентификатор-устройство] [дата] — [время] .резервный

Мы создаем копию системы. Проверяем:

Важно! Если есть папка flash, то бэкап должен находиться в ней. Иначе после перезагрузки Mikrotik он удалится.

Консоль

Консоль открывается через Winbox (вкладка New Terminal) или подключением по ssh (например, с помощью программы Putty). После соединения с маршрутизатором достаточно команду:

> / system backup save name = [имя-файла]

где [имя-файла] — это имя создаваемого файла (можно задать любое, на свое усмотрение).

Восстановление настроек конфигурации из бинарного файла

Для того, чтобы восстановить настройки Mikrotik из резервной копии (* .backup), нужно:

  • зайти в меню Файлы;
  • выбрать необходимую бэкап;
  • нажать Restore.

в появившемся достижиме пароль, подтвердим действие.

Далее появится сообщение: Хотите восстановить конфигурацию и перезагрузиться?

Подтверждаем. После этого маршрутизатор уйдет на перезагрузку, восстановив настройки.

Из консоли:

> имя загрузки резервной копии системы = flash / MikroTik-20200518-2154.backup

Экспорт конфигурации (экспорт)

создает этот метод бэкап нужного раздела или всей конфигурации RouterOS, сохраняет ее в формате * .rsc, при этом пароли и сертификаты пользователя не сохраняются. Особенность создания резервной копии настроек способом экспорта — файл конфигурации можно открыть текстовым редактором и внести изменения.А также возможен импорт настроек на любом оборудовании компании Mikrotik.

Экспорт полной конфигурации

Запустим Winbox и откроем Новый Терминал:

выполнить экспорт полной конфигурации с детальным описанием настроек, нужно использовать команду:

> файл экспорта = подробное полное резервное копирование

  • full-backup — имя создаваемого файла, задается произвольно.
  • verbose — параметр, означающий экспорт с полным описанием числа.

По умолчанию экспорт конфигурации делается с кратким описанием параметров:

> файл экспорта = полная резервная копия

Частичный перенос настроек Mikrotik

Способ экспорта настройки конфигурации блоками с последующим переносом на любой маршрутизатор Mikrotik. Рассмотрим пример, когда нам нужно выполнить частичный бэкап конфигурации. Для этого сохраним раздел NAT:

> ip firewall nat export file = nat-export

Восстановление настроек Mikrotik

Чтобы восстановить восстановление из бэкап, нужно найти в корневом каталоге выполнить команду import.Приведем в пример восстановление полной конфигурации:

> импортировать полную резервную копию.rsc

Где: Полная резервная копия — имя файла сохраненной конфигурации.

Также можно выполнить импорт в режиме отладки, где этот процесс будет проходить пошагово. Если конфигурация будет с ошибкой или несовместимыми, то мы поймем, на каком этапе возникает проблема. Для этого запустим import с ключом verbose:

> импортировать имя-файла = нат-экспорт.rsc verbose = да

Как сохранить бэкап на ПК

Mikrotik поддерживает технологию Drag & Drop, чтобы сохранить резервную копию себя на ПК, достаточно кликнуть по нему мышкой и удерживать, перенести в любое место рабочего стола или папки.

Сохранить настройки Mikrotik с помощью скрипта

Процесс сохранения настроек системы RouterOS можно упростить. Давайте напишем скрипт, который будет делать полный бэкап двумя системами способами (бинарный файл и *.rsc):

  • для начала скачаем скрипт:
  • перейдем: Система => Скрипт => +.
  • придумаем название скрипту: backup;
  • откроем скачанный скрипт любым текстовым редактором, скопируем его содержимое и вставим в поле: Source;
  • ОК.

Проверим:

  • Выполнить скрипт;
  • Откроем меню Files.

Автоматическое создание и отправка Mikrotik backup на e-mail

Создание скрипта

скрипт, который будет выполнять бэкап полную конфигурацию системы двумя способами (резервное копирование, экспорт).Отправлять его на электронную почту и удалять с маршрутизатора.

Скачиваем готовый скрипт. В этом примере отправка будет осуществляться на почту яндекс:

Откроем его и внесем изменения в следующие строки:

  • Укажем smtp-сервер от электронной почты;
  • Почту получателя;
  • Пароль.

Создадим скрипт:

  • меню Система => Скрипты => +.
  • назначим произвольное имя;
  • скопируем содержимое файла, затем вставим его в поле Source;
  • ОК.

Для проверки запустим Скрипт:

Проверим почту:

Как мы видим, бэкапы системы пришли и удалились с устройства Mikrotik. Скрипт работает.

Настройка планировщика

Последним шагом будет автоматическая отправка резервных копий по расписанию. Для этого откроем планировщик:

  • Система => Планировщик => +.
  • придумаем имя задания;
  • зададим интервал;
  • По событию, впишем точное имя (данный регистр букв) нашего скрипта;
  • ОК.

Если вы все сделали правильно, то раз в семь дней вам на почту будут приходить полные резервные копии системы.

.

Mikrotik сохранить конфигурацию

На всех роутерах в микротиак сохранить конфигурацию очень просто, если у вас установлена ​​утилита winbox для конфигурирования RouterOS, то лучше всего использовать ей. Открываем ее идем в раздел Files — Backup, далее задаем имя и нажимаем на кнопку «backup».

Если хотите чтоб кроме вас этот бэкап не кто не смог восстановить и прочитать задаем пароль. После у вас создастся файл с именем которое вы задали.

Если вы хотите углубить свои знания по работе с роутерами MikroTik, то мы рекомендуем пройти курсы, которые сделаны на основе сертифицированного специалиста MikroTik по сети и расширены автором на основе опыта. Подробно читайте ниже.

Сохранить настройки mikrotik в файле

Было глупо хранить резервную копию только на самом мирротике, поэтому лучше его сохранить в файл на компьютер. Для этого созданного бэкап нужно просто скачать на компьютер, нажимаем правой кнопкой мыши на имя файла и выбираем загрузку.Но есть одно, но, если вы хотите просмотреть конфигурацию при открытии этого файла текстовым редактором дисплея абрукадабру. Для этого случая есть команда «export compact file = config» где «config» это имя фала которое задаётся произвольно.

После ее выполнения в терминале, у вас в разделе появится файл с именем «config» и расширением скрипта. Его также можно скачать на компьютер и открыть блокнот для редактирования, в нем будет все в читабельном виде.

Как восстановить микротик из бэкапа

Восстановить микротик из бэкапа так же просто, как и создать его.Если файл резервной копии находится у вас на ПК, загрузите его в роутер после выберете его и нажмите кнопку «Восстановить».

После восстановления перезагрузите устройство и настройки вступят в силу. Если вы хотите восстановить старые бэкап на новом роутер, убедитесь, что вы знаете, как после применения учетных данных на роутере поменять те, которые были в файле восстановления. Для тренировки или для того, чтобы посмотреть настройки в бэкапе, можно его восстановить на виртуальном роутере, да и вообще все тесты проводят лучше в среде.Как это сделать и на чем описать статью про эмулятор eve-ng.

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

.

Для начинающих: Резервное копирование — MikroTik WiKi rus

Есть старая шутка: «системные администраторы делятся на тех, кто еще не делает резервное копирование и на тех, кто уже делает резервное копирование». Иногда к этой шутке добавить третью часть: «и на тех, кто уже делает резервное копирование и проверяет резервные копии».

Введение

В RouterOS существует 2 типа резервных копий: .backup (бинарный файл с конфигурацией) и.rsc (файл в котором представлена ​​в текстовом виде командной консоли). Тип .rsc нельзя экспортировать или импортировать в графическом режиме, а импортировать можно только через диалог сброса конфигурации.

  Научиться работать с MikroTik  можно с помощью видеокурса «Настройка оборудования MikroTik». Помимо всех тем из официальных программ MikroTik MTCNA курс содержит много дополнительного материала. Курс сочетает теоретическую часть и практику - настройку маршрутизатора по техническому заданию.Поддержку по курсу оказывает его автор Дмитрий Скоромнов, который является официальным тренером MikroTik (TR0680) и по совместительству автором этой Wiki. 
 Полезные материалы по теме MikroTik: 
* Чек-лист по настройке MikroTik * Матрица продуктов MikroTik: модель, артикул, информация по процессору (архитектура, частота, количество ядер), уровень лицензии, объем ОЗУ и ПЗУ, наличие модулей Wi-Fi на разных частотах и ​​коэффициенты усиления встроенных антенн и многое другое. Всего более 30-ти параметров для каждого из 151-го устройства в списке.

Через графический интерфейс

Формат .backup

Экспорт

Резервное копирование (экспорт) через графический интерфейс MikroTik

  1. В раделе Файлы нажмите кнопку Backup
  2. Ввести желаемое имя
  3. Задать пароль и шифрование при необходимости
  4. Нажать кнопку Backup
  5. В списке файлов должен появиться файл с расширением.бэкап
Импорт

Восстановление (импорт) через графический интерфейс MikroTik

  1. В раделе файлы выбрать нужный файл бэкапа и нажать кнопку Retore
  2. Ввести пароль, если он был задан
  3. Нажать кнопку Восстановить
  4. Нажать Да — после этого последует перезагрузка и восстановление конфигурации

Формат .rsc

Экспорт

Экспорт через графический интерфейс не возможен.

Импорт

Резервное копирование (экспорт) настроек в формате * .rsc через графический интерфейс MikroTik

  1. Выбрать раздел Система
  2. Выбрать раздел Восстановить
  3. Свериться со списком файлов раздела Files и выбрать глазами нужный
  4. Выбрать этот файл в выпадающем списке «Запустить после сброса»
  5. Выбрать Reset Configuration, Да — после этого роутер будет перезагружен и применен выбранный конфигурационный файл

Через консоль

Формат.rsc

Экспорт

При экспорте файла с именем задается команда и расширяется .rsc появляется в корне раздела Files.

Экспорт всей конфигурации:

 файл экспорта = test.rsc
 

Экспорт отдельного раздела (на примере раздела ip-адрес):

 / файл экспорта IP-адреса = address.rsc
 
Импорт
 файл импорта = test.rsc
 
Исправление проблем при импорте или экспорте
  • Попробуйте полностью сбросить устройство и применить конфигурацию
  • Попробуйте использовать ключ
 verbose = yes
 

Он покажет в каком месте файла остановился импорт, этим же ключем можно пользоваться и при проблемах с экспортом (принцип тот же, покажет место на котором экспорт остановился)

При импорте:

 файл импорта = test.rsc verbose = да
 

При экспорте:

 файл экспорта = test.rsc подробный = да
 

Формат .backup

Экспорт
 имя сохранения резервной копии системы = test
 
Импорт
 имя нагрузки резервного копирования системы = тест
 

У вас может быть запрошен пароль, если вы не установите его, то он пуcт и вам просто нужно нажать на вход.

После запроса пароля будет диалог о перезагрузке, в котором нужно выполнить г. , после чего будет перезагрузка и восстановление конфигурации из выбранного файла.

  Научиться работать с MikroTik  можно с помощью видеокурса «Настройка оборудования MikroTik». Помимо всех тем из официальных программ MikroTik MTCNA курс содержит много дополнительного материала. Курс сочетает теоретическую часть и практику - настройку маршрутизатора по техническому заданию. Поддержку по курсу оказывает его автор Дмитрий Скоромнов, который является официальным тренером MikroTik (TR0680) и по совместительству автором этой Wiki. 
 Полезные материалы по теме MikroTik: 
* Чек-лист по настройке MikroTik * Матрица продуктов MikroTik: модель, артикул, информация по процессору (архитектура, частота, количество ядер), уровень лицензии, объем ОЗУ и ПЗУ, наличие модулей Wi-Fi на разных частотах и ​​коэффициенты усиления встроенных антенн и многое другое.Всего более 30-ти параметров для каждого из 151-го устройства в списке.

.

Mikrotik: сброс настроек, бекапы и DualBoot

Разбор множества мелких, относительно связанных между собой, тем: программный и аппаратный сброс настроек, функция Защищенный RouterBoot, бекапы и экспорт конфигурации, разбивка flash памяти на разделы.

Программный сброс настроек

Если есть доступ к роутеру от пользователя с полными правами, то можно сбросить все настройки через [Система] → [Сбросить конфигурацию]

Что тут есть:

  • Сохранить настройки пользователя — не удалять учетные записи пользователей.
  • CAPS mode — после сброса искать контроллер CAPsMAN.
  • Без конфигурации по умолчанию — не создать дефолтную конфигурацию после сброса.
  • Не создавать бекап — не создавать бекап перед сбросом. Если не отметить, то созданный бекап не будет запаролен.
  • Run After Reset — скрипт, который будет выполнен после сброса и перезагрузки роутера.
  • Во время сброса содержимого флэш-память не затирается.

Консольный вариант:

 / конфигурация сброса системы no-defaults = да skip-backup = да 

Аппаратный сброс настроек

Все зависит от модели роутера, возможно три варианта:

Присутствует кнопка сброса

Для начала отключаем питание, зажимаем сброс и включаем питание.Отпускаем через:

  • 3 секунды (до мигания ACT) — загрузка с запасного бутлоадера. Помогает если произошел сбой при обновлении системы либо прошивки.
  • 5 секунд (ACT мигает) — сброс настроек.
  • 10 секунд (ACT перестает мигать) — поиск контроллера CAPsMAN.
  • 15 секунд (ACT не горит) — поиск сервера netinstall.

Контактная площадка

На wiki утверждают, что все девайсы оснащены подобной площадкой. Ради интереса вскрыл RB491-2nD и не обнаружил таковой.

Технология сброса: отключаем питание, замыкаем площадку (бипер издает хрипящий писк) и не отпускаем до полной загрузки.

Перемычка

Присутствует на старых моделях.

Технология сброса: отключаем питание, замыкаем перемычку, ждем полной, убираем перемычку.

Защищенный RouterBoot

Может случится ситуация, когда после сброса чужого (иначе вы бы знали) роутера он не будет загружаться дальше «первого пика» — это новая фитча от Mikrotik затирающая всю флеш память (включая RouterOS), для восстановления потребуется netinstall.

Про RouterBoot

RouterBoot — начальный загрузчик на девайсах Mikrotik, с ним можно взаимодействовать через последовательный интерфейс и одно из предназначений Защищенный RouterBoot не давать вмешиваться в процесс загрузки.

Загрузчик раздел на две части:

  • Recovery — поставляется вместе с девайсом и совпадает с заводской прошивкой.
  • Current — поставляется с пакетом system, но обновляется отдельно.

Посмотреть текущую версию можно в [Система] → [RouterBoard].Кнопкой [Upgrade] производит обновление текущего загрузчика. Если работает плохо и загружается только с резервным (как написано разделом выше), то в [Settings] можно явно указать загрузчик в качестве постоянного, опция Auto Upgrade для обновления текущего загрузчика вместе с RouterOS. И раз мы тут — опция Silent Boot отключает звуки во время загрузки.

Консольный вариант

На каких версиях Прошивка работает Защищенный RouterBoot

Гарантированную работу обещают для девайсов с заводской прошивкой 3.24 и выше, если ваш девайс более старый, эта функция возможно активировать установив специальный пакет, но только на Bugfix версии RouterOS.

Даунгрейд до Bugfix и спец. версия загрузчика

[Система] → [RouterBoard] → [Настройки]

Включаем Защищенный RouterBoot = yes, что теперь.

  • Взаимодействие с RouterBoot на этапе будет невозможен.
  • Кнопка Reset будет работать в единственном режиме — затирать флэш-память. Параметры кнопка-переформатировать-удерживать и переформатировать-удерживать-кнопку-max определить минимальное и максимальное время удержания кнопки Сброс.Необходимо попасть в установленный промежуток. Форматирование памяти может занимать до 5 минут.
  • Etherboot не будет работать.
  • Сброс через замыкание контактов на плате не будет работать.

Я не предлагю вас ввести эту опцию в обязательном порядке, думайте когда оно вам надо, когда можно обойтись без подобных мер.

Восстановление прошивки средствами netinstall

Netinstall — универсальный инструмент для прошивки и предварительной настройки роутеров MikroTik.При использовании происходит ворматирование внутренней памяти и конфигурации, без изменений останутся только настройки в [System] → [RouterBOARD]

Конфликтует с некоторыми фаерволами и антивирусами (ограничения в исключении), могут быть проблемы при запуске от пользователей с ограниченными правами — запускаем «От администратора».

Порядок действий

  • Потребуются файлы прошивки. можете брать целиковый основной, либо распаковать необходимые пакеты из дополнительных обязателен только пакет system.
  • Проводное соединение с роутером. Причем ПК и роутер должны находиться в пределах одного сегмента сети, лучше соединять кабелем напрямую.
  • Рекомендуют отключить на ПК все лишние сетевые интерфейсы. На практике — проблем с этим обычно не возникает.
  • Установить на проводном интерфейсе к которому подключен роутер статический ip, например: 192.168.100.1/24.
  • Если на Mikrotik присутствует порт с надписью Boot, то подключаетесь к нему, если нет — к первому порту.
  • Запускаем Netinstall, в [Net Booting] необходимо включить Boot Server Enabled и указать ip из выбранной ранее подсети, например: 192.168.100.10.
  • Отключаем питание MikroTik, зажимаем Reset и ждем 15 секунд (пока роутер не появится в Netinstall). Если кнопка Reset отсутствует, то замыкаем контактную площадку либо перемычку.
  • В [Обзор] выбираем каталог с необходимыми файлами RouterOS, отмечаем необходимые.
  • Нажимаем [установить].

На что еще способен netinstall

  • Key — можно обновить лицензию. SoftID необходим для заказа ключа.
  • Сохранить старую конфигурацию — сохранить восстановление и восстановить ее после прошивки.
  • IP-адрес / маска сети и шлюз — настроить ip.
  • Baud rate — установть скорость Последовательный интерфейс.
  • Сценарий настройки — скрипт, который будет запущен после пошивки.
  • Применить конфигурацию по умолчанию — загрузить конфигурацию по умолчанию.Работает если предыдущие три пункта не установлены.
  • Flashfig — утилита для настройки новых девайсов.

Бекап и экспорт конфигурации в Mikrotik

Бинарный бекап

  • Включает в себя практически полную (не переносятся файлы, сертификаты и ключи ipsec) копию настроек RouterOS.
  • Шифрование только системных учетных записей.
  • Не редактируется.
  • Восстановление затирает текущую конфигурацию.
  • Желательно восстанавливать на аналогичную модель Mikrotik.
  • Возможно восстановить на отличных от оригинального моделях. Но в бинарном бекапе интерфейсы настройки интерфейсаязываются к внутреннему идентификатору и при восстановлении реальных и системных номеров портов Ethernet будут перепутаны. Если на новом девайсе не хватает физических интерфейсов — настройки восстановлены, но будут ссылаться на неизвестно.

Создания бекапа:

[Файлы] → [Резервное копирование]

Имя — имя файла.по умолчанию будет —
Пароль — пароль. По умолчанию используется пароль текущего пользователя.
Не шифровать — не шифровать бекап.

Консольный вариант:

 / сохранение резервной копии системы
# Все ключи опциональны
# name = <строка> - имя
# пароль = <строка> - пароль
# dont-encrypt =  - не шифровать 

Восстановление:

[Файлы] → [Подсветить необходимый файл] → [Восстановить]

Консольный вариант:

 / имя загрузки резервной копии системы = <имя> пароль = <пароль> 

Дополнительно:

  • www.mikrotikpasswordrecovery.net — сервис извлечения системных учетных записей из не шифрованных резервных копий.
  • github.com/BigNerd95/RouterOS-Backup-Tools — неофициальный скрипт для частичной распаковки резервного копирования.

Экспорт и импорт конфигурации

  • Не включает настройки системных пользователей.
  • Можно сохранить (экспортировать) и загрузить (импортировать) только из консоли.
  • Возможно скопировать как целиковый конфиг, так и часть.
  • Не шифруется.
  • Можно редактировать.
  • Во время загрузки (импорт) конфигурации текущей затерта не будет.
  • Можно восстанавливать на любую модель, путаницы в интерфейсах не будет, но если интерфейс не будет хватать соответствующие не восстановятся.
  • В последних обновлениях RouterOS починили восстановление Scripts и Schedulers. Теперь они восстанавливаются без ошибок с указанными пользователями, сами пользователи не будут.

Варианты экспорта:

  • compact — только отличия от дефолтной конфигурации.По умолчанию в RouterOS 6. Конфликтут с многословием.
  • verbose — наиболее полная конфигурация. По умолчанию в RouterOS 5. Конфликтует с compact.
  • hide-sensitive — не экспортировать пароли, ключи и пр.
  • terse — не разрывать строки.

экспорт не сохраняет конфигурацию в файле, если явно не указать ключ file = <имя> файла расширения rsc будет добавлено автоматически.

 # Показать текущую конфигурацию
/ экспорт
# Сохранить полную конфигурацию в файле
/ экспорт подробного файла = конфигурация
# Сохранить конфигурацию ip-адреса в файле
/ файл экспорта IP-адреса = config-ip-add
# Загрузить конфигурацию из файла
/ import file = config.rsc 

DualBoot в Mikrotik (Раздел)

Flash накопитель можно разбить на несколько разделов и установить несколько копий RouterOS (в том числе различных). В случае неудачной загрузки с основного раздела будет загружаться следующий следующий. Функция доступна на девайсах с MIPS, PowerPC и CCR серии.

Разбивка на разделы:

[Раздел] → [Повторное разделение]

 разделов переделать разделы = 2 

Необходимо указать итоговое число разделов.Есть два ограничения: максимальное число разделов — 8 и минимальный размер раздела: 32 МБ на MIPS; 40 МБ на PowerPC; 48 МБ на CCR.

Новый раздел будет пустым, скопировать на него текущую прошивку через [Скопировать в].

 копирование разделов в часть1 

В консоли лучше видны свойства разделов: Активный (A) — с которого будет произведена следующая загрузка и раздел с которого была загружена система®.

Смена активного раздела происходит в его свойствах кнопкой [Активировать].Опция Откат отвечает за выбор раздела, если загрузка не удалась.

 # Установка активного раздела
разделы активировать часть1
# Установка резервного хранилища раздела
разделы установить part1 fallback-to = part0
# При неудаче искать сервер bootp (netinstall)
разделы установить part1 fallback-to = etherboot 

[Сохранить конфигурацию в] — Сохранить конфигурацию в текущем® разделе на выбранный.
[Восстановить конфигурацию из] — Сохранить конфигурацию с выбранным разделом на текущий®.

 разделов сохранить конфигурацию в часть 1
разделы восстановить конфигурацию из части 1 

Функционал интересный, но имеет два недостатка: Не все роутеры комплектуются достаточным комплектом флэш-памяти. Сбои в RouterOS, даже при обновлении, не такое частое явление.

Поделиться ссылкой:

Похожее

.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *